Unbreak by updating to 4.0.1

PR:		232964
Submitted by:	 w.schwarzenfeld@utanet.at
This commit is contained in:
Tilman Keskinoz 2018-11-25 21:01:10 +00:00
parent 78be6b73a6
commit a7380f5967
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=485901
13 changed files with 140 additions and 139 deletions

View file

@ -3,8 +3,7 @@
# $MCom: ports/audio/terminatorx/Makefile,v 1.6 2007/08/04 03:51:28 marcus Exp $
PORTNAME= terminatorx
PORTVERSION= 3.84
PORTREVISION= 8
PORTVERSION= 4.0.1
CATEGORIES= audio
MASTER_SITES= http://terminatorx.org/dist/
DISTNAME= terminatorX-${PORTVERSION}
@ -15,23 +14,24 @@ COMMENT= Realtime audio synthesizer that allows you to "scratch" on audio data
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN= fails to build
BROKEN_powerpc64=fails to configure: checking for XOpenDisplay in -lX11... no
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:audio/ladspa \
rarian-sk-config:textproc/rarian
LIB_DEPENDS= libaudiofile.so:audio/libaudiofile \
liblrdf.so:textproc/liblrdf
liblrdf.so:textproc/liblrdf \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
BROKEN_powerpc64= fails to configure: checking for XOpenDisplay in -lX11... no
USES= tar:bzip2 gmake gnome pathfix pkgconfig
USE_GNOME= cairo gdkpixbuf2 gtk30 libxml2
USE_XORG= x11 xext xi xxf86dga ice sm
OPTIONS_DEFINE= ALSA JACK MPG123 SOX VORBIS MAD
OPTIONS_DEFAULT= JACK MPG123 SOX VORBIS MAD
SOX_DESC= sox (.au) support
MPG123_DESC= mpg123 support
USE_XORG= x11 xext xi xxf86dga ice sm
USES= tar:bzip2 gmake pathfix pkgconfig autoreconf
USE_GNOME= gtk20 libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-alsamidi \
--disable-scheduler
@ -57,6 +57,11 @@ VORBIS_CONFIGURE_OFF= --disable-vorbis
MAD_LIB_DEPENDS= libmad.so:audio/libmad
MAD_CONFIGURE_OFF= --disable-mad
INSTALL_ICONS= yes
pre-configure:
cd ${WRKSRC} && NOCONFIGURE=1 ./autogen.sh
post-patch:
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
@ -66,25 +71,25 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/terminatorX ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/terminatorX.1 ${STAGEDIR}${MANPREFIX}/man/man1
.for file in terminatorX-app.png terminatorX-mime.png
${INSTALL_DATA} ${WRKSRC}/gnome-support/${file} \
.for file in *.png
${INSTALL_DATA} ${WRKSRC}/icons/${file} \
${STAGEDIR}${PREFIX}/share/pixmaps
.endfor
${MKDIR} ${STAGEDIR}${PREFIX}/share/mime-info
.for f in terminatorX.mime terminatorX.keys
${INSTALL_DATA} ${WRKSRC}/gnome-support/${f} \
${INSTALL_DATA} ${WRKSRC}/${f} \
${STAGEDIR}${PREFIX}/share/mime-info
.endfor
${INSTALL_DATA} ${WRKSRC}/gnome-support/terminatorX.desktop \
${INSTALL_DATA} ${WRKSRC}/terminatorX.desktop \
${STAGEDIR}${PREFIX}/share/applications
@${MKDIR} ${STAGEDIR}${PREFIX}/share/gnome/help/terminatorX/C
${INSTALL_DATA} ${WRKSRC}/doc/terminatorX-manual/C/terminatorX-manual.xml \
${INSTALL_DATA} ${WRKSRC}/help/C/terminatorX-manual.xml \
${STAGEDIR}${PREFIX}/share/gnome/help/terminatorX/C/terminatorX.xml
@${MKDIR} ${STAGEDIR}${PREFIX}/share/gnome/help/terminatorX/C/figures
${INSTALL_DATA} ${WRKSRC}/doc/terminatorX-manual/C/figures/signalflow.png \
${INSTALL_DATA} ${WRKSRC}/help/C/figures/signalflow.png \
${STAGEDIR}${PREFIX}/share/gnome/help/terminatorX/C/figures
@${MKDIR} ${STAGEDIR}${PREFIX}/share/omf/terminatorX
${INSTALL_DATA} ${WRKSRC}/doc/terminatorX-manual/C/terminatorX-manual-C.omf \
${INSTALL_DATA} ${WRKSRC}/help/terminatorX-manual-C.omf \
${STAGEDIR}${PREFIX}/share/omf/terminatorX/terminatorX-C.omf
.include <bsd.port.mk>

View file

@ -1,2 +1,3 @@
SHA256 (terminatorX-3.84.tar.bz2) = f754c3fbebc28f4182b4b7e31816362ea353a450b2a4ce13834af95145cdf921
SIZE (terminatorX-3.84.tar.bz2) = 449362
TIMESTAMP = 1541608090
SHA256 (terminatorX-4.0.1.tar.bz2) = 96e2e7910d96b9bdadb315727c4127cfda579bd68d2b25d99cd9d35e9fbea56a
SIZE (terminatorX-4.0.1.tar.bz2) = 1832692

View file

@ -0,0 +1,30 @@
--- aclocal.m4.orig 2018-11-07 18:55:24 UTC
+++ aclocal.m4
@@ -1,4 +1,4 @@
-# generated automatically by aclocal 1.15 -*- Autoconf -*-
+# generated automatically by aclocal 1.16 -*- Autoconf -*-
# Copyright (C) 1996-2014 Free Software Foundation, Inc.
@@ -588,10 +588,10 @@ AS_VAR_IF([$1], [""], [$5], [$4])dnl
# generated from the m4 files accompanying Automake X.Y.
# (This private macro should not be called outside this file.)
AC_DEFUN([AM_AUTOMAKE_VERSION],
-[am__api_version='1.15'
+[am__api_version='1.16'
dnl Some users find AM_AUTOMAKE_VERSION and mistake it for a way to
dnl require some minimum version. Point them to the right macro.
-m4_if([$1], [1.15], [],
+m4_if([$1], [1.16], [],
[AC_FATAL([Do not call $0, use AM_INIT_AUTOMAKE([$1]).])])dnl
])
@@ -607,7 +607,7 @@ m4_define([_AM_AUTOCONF_VERSION], [])
# Call AM_AUTOMAKE_VERSION and AM_AUTOMAKE_VERSION so they can be traced.
# This function is AC_REQUIREd by AM_INIT_AUTOMAKE.
AC_DEFUN([AM_SET_CURRENT_AUTOMAKE_VERSION],
-[AM_AUTOMAKE_VERSION([1.15])dnl
+[AM_AUTOMAKE_VERSION([1.16])dnl
m4_ifndef([AC_AUTOCONF_VERSION],
[m4_copy([m4_PACKAGE_VERSION], [AC_AUTOCONF_VERSION])])dnl
_AM_AUTOCONF_VERSION(m4_defn([AC_AUTOCONF_VERSION]))])

View file

@ -0,0 +1,20 @@
--- configure.orig 2018-11-07 18:59:29 UTC
+++ configure
@@ -2287,7 +2287,7 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
-am__api_version='1.15'
+am__api_version='1.16'
ac_aux_dir=
for ac_dir in "$srcdir" "$srcdir/.." "$srcdir/../.."; do
@@ -5580,7 +5580,7 @@ fi
done
-for ac_header in fcntl.h limits.h malloc.h unistd.h
+for ac_header in fcntl.h limits.h stdlib.h unistd.h
do :
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"

View file

@ -0,0 +1,36 @@
--- configure.ac.orig 2018-11-07 18:12:55 UTC
+++ configure.ac
@@ -122,6 +122,33 @@ if test "$tX_threads" = "no"; then
AC_MSG_ERROR([** failed to detect pthreads implementation **])
fi
+AC_CHECK_FUNC(scandir,
+ if test "x$uname" = xSunOS -o "x$uname" = xQNX; then
+ AC_MSG_WARN(Not using $uname scandir emulation function.)
+ else
+ AC_DEFINE(HAVE_SCANDIR, 1, [Has scandir])
+ fi)
+
+dnl Do we have the POSIX compatible scandir() prototype?
+AC_CACHE_CHECK([whether we have the POSIX compatible scandir() prototype],
+ ac_cv_cxx_scandir_posix,[
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+ AC_TRY_COMPILE([
+ #include <dirent.h>
+ int func (const char *d, dirent ***list, void *sort) {
+ int n = scandir(d, list, 0, (int(*)(const dirent **, const dirent **))sort);
+ }
+ ],[
+ ], ac_cv_cxx_scandir_posix=yes, ac_cv_cxx_scandir_posix=no)
+ AC_LANG_RESTORE
+ ])
+
+if test "$ac_cv_cxx_scandir_posix" = yes; then
+ AC_DEFINE(HAVE_SCANDIR_POSIX, 1, [scandir conforms to POSIX])
+fi
+
+
AC_SEARCH_LIBS([dlclose], [dl])

View file

@ -1,53 +0,0 @@
--- configure.in.orig 2011-11-13 12:53:51 UTC
+++ configure.in
@@ -118,6 +118,32 @@ if test "$tX_threads" = "no"; then
AC_MSG_ERROR([** failed to detect pthreads implementation **])
fi
+AC_CHECK_FUNC(scandir,
+ if test "x$uname" = xSunOS -o "x$uname" = xQNX; then
+ AC_MSG_WARN(Not using $uname scandir emulation function.)
+ else
+ AC_DEFINE(HAVE_SCANDIR, 1, [Has scandir])
+ fi)
+
+dnl Do we have the POSIX compatible scandir() prototype?
+AC_CACHE_CHECK([whether we have the POSIX compatible scandir() prototype],
+ ac_cv_cxx_scandir_posix,[
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+ AC_TRY_COMPILE([
+ #include <dirent.h>
+ int func (const char *d, dirent ***list, void *sort) {
+ int n = scandir(d, list, 0, (int(*)(const dirent **, const dirent **))sort);
+ }
+ ],[
+ ], ac_cv_cxx_scandir_posix=yes, ac_cv_cxx_scandir_posix=no)
+ AC_LANG_RESTORE
+ ])
+
+if test "$ac_cv_cxx_scandir_posix" = yes; then
+ AC_DEFINE(HAVE_SCANDIR_POSIX, 1, [scandir conforms to POSIX])
+fi
+
dnl GTK+ search. Enable FileChooser for gtk+>=2.4
AM_PATH_GTK_2_0(, [
@@ -509,6 +535,8 @@ AC_MSG_CHECKING(for GNOME)
AC_MSG_RESULT([Found GNOME - installing terminatorX.desktop.])
OPTION_GNOME="yes"
else
+ GNOMEpresent_TRUE='#'
+ GNOMEpresent_FALSE=
AC_MSG_RESULT([GNOME not found.])
fi
AM_CONDITIONAL(GNOMEpresent, test "$gnomepresent" = yes)
@@ -563,7 +591,7 @@ AC_SUBST(XML_LIBS)
AC_SUBST(XML_CFLAGS)
if test "$prefix" != "NONE"; then
- xml_man="\\\"$datadir/terminatorX/doc/terminatorX-manual/C/terminatorX-manual.xml\\\""
+ xml_man="\\\"$datadir/help/terminatorX/C/terminatorX.xml\\\""
else
xml_man="\\\"/usr/local/share/terminatorX/doc/terminatorX-manual/C/terminatorX-manual.xml\\\""
fi

View file

@ -0,0 +1,11 @@
--- src/tX_audiodevice.cc.orig 2018-11-07 17:14:34 UTC
+++ src/tX_audiodevice.cc
@@ -594,7 +594,7 @@ tX_jack_client tX_jack_client::instance;
bool tX_jack_client::init()
{
if (!client_initialized) {
- if ((client=jack_client_open("terminatorX", (jack_options_t) NULL, NULL))==0) {
+ if ((client=jack_client_open("terminatorX", (jack_options_t) '\0', NULL))==0) {
tX_error("tX_jack_client() -> failed to connect to jackd.");
} else {
client_initialized = true;

View file

@ -1,11 +0,0 @@
--- src/tX_dial.c.orig 2011-01-30 21:01:30 UTC
+++ src/tX_dial.c
@@ -266,7 +266,7 @@ static void gtk_tx_dial_size_allocate (G
}
}
-inline void gtk_tx_dial_draw (GtkTxDial *tx_dial, GtkWidget *widget)
+static inline void gtk_tx_dial_draw (GtkTxDial *tx_dial, GtkWidget *widget)
{
if (GTK_WIDGET_DRAWABLE (widget)) {
gdk_pixbuf_render_to_drawable(knob_pixmaps[tx_dial->old_image],

View file

@ -1,32 +1,22 @@
--- src/tX_dialog.cc.orig 2011-01-30 21:01:30 UTC
--- src/tX_dialog.cc.orig 2018-11-07 19:20:20 UTC
+++ src/tX_dialog.cc
@@ -252,7 +252,11 @@ GList *get_alsa_device_list() {
#ifdef USE_OSS
static GList *oss_devices=NULL;
@@ -244,13 +244,18 @@ void append_alsa_device_list(GtkComboBox
}
}
#else
-void append_alsa_device_list(GtkComboBoxText *combo) {
+void append_alsa_device_list(GtkComboBoxText *combo,char *current) {
}
#endif
#ifdef USE_OSS
+#ifdef HAVE_SCANDIR_POSIX
int oss_select_dsp_only(const struct dirent *entry){
+#else
+int oss_select_dsp_only(struct dirent *entry){
+#endif
+
return (strstr(entry->d_name, "dsp")!=0);
}
@@ -562,7 +566,7 @@ void show_about(int nag)
gtk_box_pack_start(GTK_BOX(box), iwid, WID_FIX);
gtk_box_pack_start(GTK_BOX(box), box2, WID_FIX);
- label=gtk_label_new(PACKAGE" release "VERSION);
+ label=gtk_label_new(PACKAGE" release " VERSION);
gtk_box_pack_start(GTK_BOX(box2), label, WID_DYN);
gtk_misc_set_alignment(GTK_MISC(label), 0.1, 0.5);
gtk_widget_show(label);
@@ -585,7 +589,7 @@ void show_about(int nag)
sep=gtk_hseparator_new();
add_about_wid_fix(sep);
- label=gtk_label_new("This is "PACKAGE" release "VERSION" - Copyright (C) 1999-2011 by Alexander König"
+ label=gtk_label_new("This is " PACKAGE " release " VERSION " - Copyright (C) 1999-2011 by Alexander König"
"\nSend comments, patches and scratches to: alex@lisas.de\nterminatorX-homepage: http://www.terminatorX.org");
gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_CENTER);

View file

@ -1,10 +1,9 @@
--- src/tX_global.c.orig 2011-01-30 21:01:31 UTC
--- src/tX_global.c.orig 2018-11-07 17:27:45 UTC
+++ src/tX_global.c
@@ -127,7 +127,7 @@ void set_global_defaults() {
#endif
@@ -129,6 +129,7 @@ void set_global_defaults() {
globals.use_stdout_cmdline=0;
strcpy(globals.current_path, "");
- strcpy(globals.lrdf_path, "/usr/share/ladspa/rdf:/usr/local/share/ladspa/rdf");
strcpy(globals.lrdf_path, "/usr/share/ladspa/rdf:/usr/local/share/ladspa/rdf");
+ strcpy(globals.lrdf_path, "%%LOCALBASE%%/share/ladspa/rdf");
globals.fullscreen_enabled=0;
globals.confirm_events=0;

View file

@ -1,29 +0,0 @@
--- src/tX_mastergui.cc.orig 2011-11-13 12:53:51 UTC
+++ src/tX_mastergui.cc
@@ -273,7 +273,7 @@ char tx_mg_current_setname[PATH_MAX]="";
GtkSignalFunc new_tables() {
GtkWidget *dialog=gtk_message_dialog_new(GTK_WINDOW(main_window),
GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_QUESTION, GTK_BUTTONS_YES_NO,
- "Are you sure you want to loose all turntables and events?");
+ "Are you sure you want to lose all turntables and events?");
int res=gtk_dialog_run(GTK_DIALOG(dialog));
gtk_widget_destroy(dialog);
@@ -894,7 +894,7 @@ gboolean quit()
if (globals.quit_confirm) {
GtkWidget *dialog=gtk_message_dialog_new(GTK_WINDOW(main_window),
GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_QUESTION, GTK_BUTTONS_YES_NO,
- "Exit terminatorX and loose all unsaved data?");
+ "Exit terminatorX and lose all unsaved data?");
int res=gtk_dialog_run(GTK_DIALOG(dialog));
gtk_widget_destroy(dialog);
@@ -1671,7 +1671,7 @@ void create_mastergui(int x, int y)
add_sep2();
- dummy=gtk_label_new("v"VERSION);
+ dummy=gtk_label_new("v" VERSION);
gtk_misc_set_alignment(GTK_MISC(dummy), 1, 0.5);
gtk_box_pack_end(GTK_BOX(status_box), dummy, WID_FIX);
gtk_widget_show(dummy);

View file

@ -1,11 +1,13 @@
--- src/tX_mouse.cc.orig 2011-01-30 21:01:32 UTC
--- src/tX_mouse.cc.orig 2018-11-07 18:49:45 UTC
+++ src/tX_mouse.cc
@@ -47,7 +47,8 @@
@@ -37,9 +37,9 @@
#include "tX_global.h"
#include "tX_engine.h"
#include "tX_vtt.h"
-#include <stdlib.h>
+#include <cstdlib>
#include <string.h>
-#include <math.h>
+#include <cmath>
#define TX_MOUSE_SPEED_NORMAL 0.05

View file

@ -6,5 +6,5 @@ share/gnome/help/terminatorX/C/terminatorX.xml
share/mime-info/terminatorX.keys
share/mime-info/terminatorX.mime
share/omf/terminatorX/terminatorX-C.omf
share/pixmaps/terminatorX-app.png
share/pixmaps/terminatorX-mime.png
share/pixmaps/terminatorX.png