- Beta is too unstable, rollback to latest stable version
- Support staging
This commit is contained in:
parent
bd9bd71842
commit
a749fc13a6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=339600
6 changed files with 11 additions and 78 deletions
|
@ -2,8 +2,8 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= openlierox
|
||||
DISTVERSION= 0.59_beta10
|
||||
PORTREVISION= 3
|
||||
DISTVERSION= 0.58_rc3
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/OpenLieroX%20${DISTVERSION:C/_/%20/}
|
||||
DISTNAME= OpenLieroX_${DISTVERSION}.src
|
||||
|
@ -19,7 +19,7 @@ LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
|
|||
USE_BZIP2= yes
|
||||
USE_SDL= sdl image
|
||||
USE_GNOME= libxml2
|
||||
USE_GCC= yes
|
||||
USE_GCC= any # too many gcc'isms
|
||||
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
CXXFLAGS+= -I${LOCALBASE}/include
|
||||
|
@ -44,11 +44,9 @@ PLIST_FILES= bin/openlierox \
|
|||
OPTIONS_DEFINE= DEDICATED_ONLY DOCS
|
||||
DEDICATED_ONLY_DESC=Build dedicated server only
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MDEDICATED_ONLY}
|
||||
BROKEN= does not build
|
||||
CMAKE_ARGS+= -DDEDICATED_ONLY=YES
|
||||
.else
|
||||
USE_XORG+= x11
|
||||
|
@ -56,25 +54,18 @@ USE_SDL+= mixer
|
|||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|boost_signals-mt|boost_signals boost_system|; \
|
||||
s|EXEC_PROGRAM.*OLXVER)|SET(OLXVER "${DISTVERSION}")|; \
|
||||
@${REINPLACE_CMD} -e 's|EXEC_PROGRAM.*OLXVER)|SET(OLXVER "${DISTVERSION}")|; \
|
||||
s|/usr/local|${LOCALBASE}|' ${WRKSRC}/CMakeOlxCommon.cmake
|
||||
@${FIND} ${WRKSRC} \( -name "*.cpp" -o -name "*.h" -o -name "*.cc" \) -print0 | ${XARGS} -0 -n1 \
|
||||
${REINPLACE_CMD} -e '/include.*curl\/types.h/ d'
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/openlierox ${PREFIX}/bin/
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/openliero ${STAGEDIR}${PREFIX}/bin/
|
||||
${INSTALL_DATA} ${WRKSRC}/share/openlierox-openlierox.desktop \
|
||||
${PREFIX}/share/applications/
|
||||
${STAGEDIR}${PREFIX}/share/applications/
|
||||
${INSTALL_DATA} ${WRKSRC}/share/OpenLieroX.svg \
|
||||
${PREFIX}/share/pixmaps/
|
||||
.if !defined(NOPORTDATA)
|
||||
${MKDIR} ${DATADIR}
|
||||
cd ${WRKSRC}/share/gamedir && ${COPYTREE_SHARE} . ${DATADIR}/
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
${MKDIR} ${DOCSDIR}
|
||||
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}/
|
||||
.endif
|
||||
${STAGEDIR}${PREFIX}/share/pixmaps/
|
||||
cd ${WRKSRC}/share/gamedir && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
|
||||
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (OpenLieroX_0.59_beta10.src.tar.bz2) = 5f4bcc83c7f90fae716820ac9c4c6ee266c143abc55ce6b9efd0603b7c1d057c
|
||||
SIZE (OpenLieroX_0.59_beta10.src.tar.bz2) = 103956181
|
||||
SHA256 (OpenLieroX_0.58_rc3.src.tar.bz2) = 9f246887d38c325e597373d9189990c9374c241cb807b4b5777844eceeed65cc
|
||||
SIZE (OpenLieroX_0.58_rc3.src.tar.bz2) = 63845193
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- src/common/Debug_DumpCallstack.cpp.orig 2012-04-17 04:26:14.000000000 +0400
|
||||
+++ src/common/Debug_DumpCallstack.cpp 2012-12-14 23:19:15.525963503 +0400
|
||||
@@ -11,6 +11,8 @@
|
||||
#include "util/macros.h"
|
||||
#include <vector>
|
||||
#include <string>
|
||||
+#include <cstdio>
|
||||
+#include <cstdlib>
|
||||
|
||||
#ifndef HAVE_EXECINFO
|
||||
# if defined(__linux__)
|
||||
@@ -25,8 +27,6 @@
|
||||
#if HAVE_EXECINFO
|
||||
|
||||
#include <execinfo.h>
|
||||
-#include <stdio.h>
|
||||
-#include <stdlib.h>
|
||||
|
||||
#if HASBFD
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
--- ./src/common/FindFile.cpp.orig 2010-02-17 19:59:26.000000000 +0300
|
||||
+++ ./src/common/FindFile.cpp 2011-10-01 19:06:16.000000000 +0400
|
||||
@@ -456,6 +456,10 @@
|
||||
AddToFileList(&basesearchpaths, "${HOME}/OpenLieroX");
|
||||
AddToFileList(&basesearchpaths, ".");
|
||||
AddToFileList(&basesearchpaths, "${BIN}");
|
||||
+#elif defined(__FreeBSD__)
|
||||
+ AddToFileList(&basesearchpaths, "${HOME}/.OpenLieroX");
|
||||
+ AddToFileList(&basesearchpaths, ".");
|
||||
+ AddToFileList(&basesearchpaths, SYSTEM_DATA_DIR);
|
||||
#else // all other systems (Linux, *BSD, OS/2, ...)
|
||||
AddToFileList(&basesearchpaths, "${HOME}/.OpenLieroX");
|
||||
AddToFileList(&basesearchpaths, ".");
|
|
@ -1,15 +0,0 @@
|
|||
--- src/common/SystemFunctions.cpp.orig 2012-04-17 04:26:14.000000000 +0400
|
||||
+++ src/common/SystemFunctions.cpp 2012-12-14 23:18:03.318932050 +0400
|
||||
@@ -63,8 +63,10 @@
|
||||
#if defined(__APPLE__) && defined(MAC_OS_X_VERSION_10_6) && MAC_OS_X_VERSION_MIN_REQUIRED >= MAC_OS_X_VERSION_10_6
|
||||
#define HAVE_PTHREAD_NAME
|
||||
// glibc 2.12 introduced this
|
||||
-#elif __GLIBC_PREREQ(2,12)
|
||||
-#define HAVE_PTHREAD_NAME
|
||||
+#elif defined(__GLIBC_PREREQ)
|
||||
+# if __GLIBC_PREREQ(2,12)
|
||||
+# define HAVE_PTHREAD_NAME
|
||||
+# endif
|
||||
#endif
|
||||
#endif
|
||||
|
|
@ -1,10 +0,0 @@
|
|||
--- src/gusanos/objects_list.h.orig 2012-12-14 23:03:07.488932193 +0400
|
||||
+++ src/gusanos/objects_list.h 2012-12-14 23:06:22.329933269 +0400
|
||||
@@ -4,6 +4,7 @@
|
||||
//#include "game/CGameObject.h"
|
||||
#include <list>
|
||||
#include <vector>
|
||||
+#include <cstring>
|
||||
|
||||
static const int RENDER_LAYERS_AMMOUNT = 10;
|
||||
static const int COLLISION_LAYERS_AMMOUNT = 10;
|
Loading…
Reference in a new issue