Update Simgear & Flightgear ports to 2018.2.1
Also, remove js_server as it has been unmaintained for years now.
This commit is contained in:
parent
c49fa36cb9
commit
a77cd202c9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=471256
14 changed files with 134 additions and 51 deletions
|
@ -1,7 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= simgear
|
||||
PORTVERSION= 2018.1.1
|
||||
PORTVERSION= 2018.2.1
|
||||
CATEGORIES= devel games
|
||||
MASTER_SITES= SF/flightgear/release-${PORTVERSION:R}
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1523304226
|
||||
SHA256 (simgear-2018.1.1.tar.bz2) = d403cbd8688782780c50461ea233f26ea3bb8242ff681674e69ac1da05226656
|
||||
SIZE (simgear-2018.1.1.tar.bz2) = 1303653
|
||||
TIMESTAMP = 1527106569
|
||||
SHA256 (simgear-2018.2.1.tar.bz2) = 3e2788bc1ce03fc4ca69f41d1546c28fc9502756ae773831ad6e42c4db34f535
|
||||
SIZE (simgear-2018.2.1.tar.bz2) = 1315134
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= flightgear-data
|
||||
PORTVERSION= 2018.1.1
|
||||
PORTVERSION= 2018.2.1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/flightgear/release-${PORTVERSION:R}
|
||||
DISTNAME= FlightGear-${PORTVERSION}-data
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1523304831
|
||||
SHA256 (FlightGear-2018.1.1-data.tar.bz2) = dfd80e09f6bf04bd25604788c080716007969d127d46d0e10c43c2f709fb8db8
|
||||
SIZE (FlightGear-2018.1.1-data.tar.bz2) = 1576049981
|
||||
TIMESTAMP = 1527110762
|
||||
SHA256 (FlightGear-2018.2.1-data.tar.bz2) = 3d5dbf9b584b135699aadff0f51017fac37aefd1157e00adbba1d4855a1b24e9
|
||||
SIZE (FlightGear-2018.2.1-data.tar.bz2) = 1618697853
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= flightgear
|
||||
PORTVERSION= 2018.1.1
|
||||
PORTVERSION= 2018.2.1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/flightgear/release-${PORTVERSION:R}
|
||||
|
||||
|
@ -33,8 +33,7 @@ USE_XORG= ice sm x11 xext xft xi xinerama xmu xt
|
|||
USE_GL= gl glew glu glut
|
||||
|
||||
DOS2UNIX_REGEX= .*\.(c|h|cxx|cpp|hxx|hpp)
|
||||
CMAKE_ARGS+= -DENABLE_JS_SERVER:BOOL=ON \
|
||||
-DSYSTEM_SQLITE:BOOL=ON \
|
||||
CMAKE_ARGS+= -DSYSTEM_SQLITE:BOOL=ON \
|
||||
-DFG_DATA_DIR:PATH=${LOCALBASE}/share/${PORTNAME} \
|
||||
-DCMAKE_INSTALL_MANDIR:PATH=${MANPREFIX}/man \
|
||||
-DFGCOM_DATA_PATH:PATH=${DATADIR}
|
||||
|
@ -48,7 +47,7 @@ DBUS_CMAKE_ON= -DUSE_DBUS:BOOL=ON
|
|||
DBUS_CMAKE_OFF= -DUSE_DBUS:BOOL=OFF
|
||||
QT5_CMAKE_ON= -DENABLE_QT:BOOL=ON
|
||||
QT5_CMAKE_OFF= -DENABLE_QT:BOOL=OFF
|
||||
QT5_USE= QT5=core,buildtools,gui,qmake,qml,quick,widgets
|
||||
QT5_USE= QT5=core,buildtools,gui,network,qmake,qml,quick,widgets
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -67,8 +66,4 @@ USE_GCC= yes
|
|||
CXXFLAGS+= -D_GLIBCXX_USE_C99
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/utils/js_server/js_server \
|
||||
${STAGEDIR}${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1523305013
|
||||
SHA256 (flightgear-2018.1.1.tar.bz2) = ed1aa7867e89757622f3faaab996028c4be2f79006dfb89a3059c77b9831aab9
|
||||
SIZE (flightgear-2018.1.1.tar.bz2) = 8158999
|
||||
TIMESTAMP = 1527066607
|
||||
SHA256 (flightgear-2018.2.1.tar.bz2) = 592ad56ee434f004c78fcfa7caa17666841429705547ab6eb947058fc09e45a2
|
||||
SIZE (flightgear-2018.2.1.tar.bz2) = 8343870
|
||||
|
|
25
games/flightgear/files/patch-3rdparty-joystick-js.h
Normal file
25
games/flightgear/files/patch-3rdparty-joystick-js.h
Normal file
|
@ -0,0 +1,25 @@
|
|||
Add missing defines and includes from removed ul.h
|
||||
|
||||
--- 3rdparty/joystick/js.h.orig 2018-05-30 23:24:08.180090000 +0200
|
||||
+++ 3rdparty/joystick/js.h 2018-05-30 23:32:04.841896000 +0200
|
||||
@@ -25,10 +25,20 @@
|
||||
#define __INCLUDED_JS_H__ 1
|
||||
#define JS_NEW
|
||||
|
||||
+#ifndef TRUE
|
||||
+#define TRUE 1
|
||||
+#define FALSE 0
|
||||
+#endif
|
||||
+
|
||||
+#include <fcntl.h>
|
||||
+#include <sys/param.h>
|
||||
+
|
||||
#include <string>
|
||||
#include <cstring>
|
||||
#include <cstdlib>
|
||||
|
||||
+#include <simgear/props/props.hxx> /* for jsSetError and SG_WARN */
|
||||
+
|
||||
#define _JS_MAX_AXES 16
|
||||
#define _JS_MAX_BUTTONS 32
|
||||
#define _JS_MAX_HATS 4
|
15
games/flightgear/files/patch-3rdparty-joystick-jsBSD.cxx
Normal file
15
games/flightgear/files/patch-3rdparty-joystick-jsBSD.cxx
Normal file
|
@ -0,0 +1,15 @@
|
|||
jsSetError() takes only two arguments (unlike ulSetError())
|
||||
|
||||
--- 3rdparty/joystick/jsBSD.cxx.orig 2018-05-28 23:22:56.449679000 +0200
|
||||
+++ 3rdparty/joystick/jsBSD.cxx 2018-05-28 23:50:32.852422000 +0200
|
||||
@@ -326,8 +289,8 @@
|
||||
error = ( joyfile == NULL ) ;
|
||||
if ( error )
|
||||
{
|
||||
- jsSetError ( SG_WARN, "unable to open calibration file %s (%s), joystick %i disabled (you can generate the calibration file with the plib-jscal utility)",
|
||||
- joyfname, strerror ( errno ), id + 1 );
|
||||
+ jsSetError ( SG_WARN, "unable to open calibration file, you can generate "
|
||||
+ "the calibration file with the plib-jscal utility" );
|
||||
return ;
|
||||
}
|
||||
|
|
@ -0,0 +1,13 @@
|
|||
Use all linker flags from pkgconf, including library path
|
||||
|
||||
--- CMakeModules/SetupFGFSLibraries.cmake.orig 2018-05-29 23:46:55.859412000 +0200
|
||||
+++ CMakeModules/SetupFGFSLibraries.cmake 2018-05-29 23:47:59.869522000 +0200
|
||||
@@ -27,7 +27,7 @@
|
||||
endif()
|
||||
|
||||
if(USE_DBUS)
|
||||
- target_link_libraries(${target} ${DBUS_LIBRARIES})
|
||||
+ target_link_libraries(${target} ${DBUS_LDFLAGS})
|
||||
endif()
|
||||
|
||||
if(FG_HAVE_GPERFTOOLS)
|
|
@ -1,11 +0,0 @@
|
|||
--- CMakeLists.txt.orig 2016-03-04 21:42:31.724356963 +0000
|
||||
+++ CMakeLists.txt 2016-03-04 21:47:33.738336446 +0000
|
||||
@@ -310,7 +310,7 @@
|
||||
endif (ENABLE_QT)
|
||||
##############################################################################
|
||||
|
||||
-find_package(PLIB REQUIRED puaux pu js fnt)
|
||||
+find_package(PLIB REQUIRED puaux pu js fnt net)
|
||||
|
||||
# FlightGear and SimGear versions need to match
|
||||
find_package(SimGear ${FLIGHTGEAR_VERSION} REQUIRED)
|
|
@ -1,10 +0,0 @@
|
|||
--- utils/CMakeLists.txt.orig 2016-11-24 08:26:29.486200480 +0000
|
||||
+++ utils/CMakeLists.txt 2016-11-24 08:26:58.661198446 +0000
|
||||
@@ -30,3 +30,7 @@
|
||||
if(ENABLE_STGMERGE)
|
||||
add_subdirectory(stgmerge)
|
||||
endif()
|
||||
+
|
||||
+if(ENABLE_JS_SERVER)
|
||||
+ add_subdirectory(js_server)
|
||||
+endif()
|
|
@ -1,10 +0,0 @@
|
|||
--- utils/js_server/CMakeLists.txt.orig 2012-03-09 14:44:22.999701740 +0100
|
||||
+++ utils/js_server/CMakeLists.txt 2012-03-09 14:59:36.643375244 +0100
|
||||
@@ -0,0 +1,7 @@
|
||||
+add_executable(js_server js_server.cxx)
|
||||
+
|
||||
+target_link_libraries(js_server
|
||||
+ ${PLIB_LIBRARIES}
|
||||
+)
|
||||
+
|
||||
+install(TARGETS js_server RUNTIME DESTINATION bin)
|
|
@ -0,0 +1,67 @@
|
|||
Import extra patch from x11-toolkits/plib
|
||||
|
||||
--- 3rdparty/joystick/jsBSD.cxx.orig 2018-05-30 23:47:01.351096000 +0200
|
||||
+++ 3rdparty/joystick/jsBSD.cxx 2018-05-30 23:47:28.474434000 +0200
|
||||
@@ -64,6 +64,7 @@
|
||||
# else
|
||||
# define HAVE_USBHID_H 1
|
||||
# include <usbhid.h>
|
||||
+# include <dev/usb/usb_ioctl.h>
|
||||
# endif
|
||||
}
|
||||
#endif
|
||||
@@ -116,54 +117,12 @@
|
||||
static char *
|
||||
walkusbdev(int f, char *dev, char *out, int outlen)
|
||||
{
|
||||
- struct usb_device_info di;
|
||||
- int i, a;
|
||||
- char *cp;
|
||||
-
|
||||
- for (a = 1; a < USB_MAX_DEVICES; a++) {
|
||||
- di.udi_addr = a;
|
||||
- if (ioctl(f, USB_DEVICEINFO, &di) != 0)
|
||||
- return NULL;
|
||||
- for (i = 0; i < USB_MAX_DEVNAMES; i++)
|
||||
- if (di.udi_devnames[i][0] &&
|
||||
- strcmp(di.udi_devnames[i], dev) == 0) {
|
||||
- cp = new char[strlen(di.udi_vendor) + strlen(di.udi_product) + 2];
|
||||
- strcpy(cp, di.udi_vendor);
|
||||
- strcat(cp, " ");
|
||||
- strcat(cp, di.udi_product);
|
||||
- strncpy(out, cp, outlen - 1);
|
||||
- out[outlen - 1] = 0;
|
||||
- delete cp;
|
||||
- return out;
|
||||
- }
|
||||
- }
|
||||
return NULL;
|
||||
}
|
||||
|
||||
static int
|
||||
findusbdev(char *name, char *out, int outlen)
|
||||
{
|
||||
- int i, f;
|
||||
- char buf[50];
|
||||
- char *cp;
|
||||
- static int protection_warned = 0;
|
||||
-
|
||||
- for (i = 0; i < 16; i++) {
|
||||
- sprintf(buf, "%s%d", USBDEV, i);
|
||||
- f = open(buf, O_RDONLY);
|
||||
- if (f >= 0) {
|
||||
- cp = walkusbdev(f, name, out, outlen);
|
||||
- close(f);
|
||||
- if (cp)
|
||||
- return 1;
|
||||
- } else if (errno == EACCES) {
|
||||
- if (!protection_warned) {
|
||||
- fprintf(stderr, "Can't open %s for read!\n",
|
||||
- buf);
|
||||
- protection_warned = 1;
|
||||
- }
|
||||
- }
|
||||
- }
|
||||
return 0;
|
||||
}
|
||||
|
|
@ -10,7 +10,6 @@ bin/fgpanel
|
|||
bin/fgtraffic
|
||||
bin/fgviewer
|
||||
bin/js_demo
|
||||
bin/js_server
|
||||
bin/metar
|
||||
bin/yasim
|
||||
bin/yasim-proptest
|
||||
|
|
Loading…
Reference in a new issue