Update the sleuthkit to 4.1.3:
- Use libtool (instead of jumping from .11 to .12, we go back to .10) - Include a patch which allows python bindings to work correctly (obtained from Joachim Metz) Update pytsk to 2014-02-09: - Remove DOCS/EXAMPLES conditionals - Don't override DOCSDIR and EXAMPLESDIR, mva's patch will do it soon
This commit is contained in:
parent
9ef24de288
commit
a77e2439ca
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=343668
6 changed files with 27 additions and 27 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pytsk
|
||||
DISTVERSION= 2013-12-30
|
||||
DISTVERSION= 2014-02-09
|
||||
CATEGORIES= sysutils security devel python
|
||||
MASTER_SITES= https://googledrive.com/host/0B3fBvzttpiiScUxsUm54cG02RDA/ \
|
||||
LOCAL/antoine
|
||||
|
@ -23,31 +23,22 @@ SHEBANG_FILES= samples/*.py
|
|||
python_OLD_CMD= .*
|
||||
python_CMD= ${PYTHON_CMD}
|
||||
USE_PYTHON= 2
|
||||
USE_PYDISTUTILS=yes
|
||||
PYDISTUTILS_AUTOPLIST=yes
|
||||
USE_PYDISTUTILS= yes
|
||||
PYDISTUTILS_AUTOPLIST= yes
|
||||
|
||||
PORTDOCS= README
|
||||
PORTEXAMPLES= *
|
||||
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e "s|'/', 'usr', 'local'|'${LOCALBASE}'|" \
|
||||
${WRKSRC}/setup.py
|
||||
|
||||
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
|
||||
PORTDOCS= README
|
||||
|
||||
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
|
||||
PORTEXAMPLES= *
|
||||
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
post-install:
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MEXAMPLES}
|
||||
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/samples/*.py ${STAGEDIR}${EXAMPLESDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (pytsk-2013-12-30.tgz) = ea2c8c94b99543acc1e667c6ac510167fd9e51064257f521362b88f7c20e62bc
|
||||
SIZE (pytsk-2013-12-30.tgz) = 90104
|
||||
SHA256 (pytsk-2014-02-09.tgz) = 246e7adf31d4b2aa43d2ebfb351c00c8a8e7b556fd2740dc89b1441a41414db8
|
||||
SIZE (pytsk-2014-02-09.tgz) = 92637
|
||||
|
|
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= sleuthkit
|
||||
PORTVERSION= 4.1.2
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 4.1.3
|
||||
CATEGORIES= sysutils security
|
||||
MASTER_SITES= SF
|
||||
|
||||
|
@ -23,12 +22,10 @@ RUN_DEPENDS= p5-DateTime-TimeZone>=0:${PORTSDIR}/devel/p5-DateTime-TimeZone \
|
|||
exif:${PORTSDIR}/graphics/exif
|
||||
|
||||
CONFLICTS= ja-ls-[0-9]* icat-[0-9]*
|
||||
# Version 4.1.3 breaks python bindings
|
||||
PORTSCOUT= skipv:4.1.3
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= ac_cv_path_PERL="${PERL}"
|
||||
USES= perl5
|
||||
USES= libtool perl5
|
||||
USE_LDCONFIG= yes
|
||||
DATADIR= ${PREFIX}/share/tsk
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (sleuthkit-4.1.2.tar.gz) = 58253b35c016083558fb581308f4a3baf884229de89eb84ddbfb977ed56600d3
|
||||
SIZE (sleuthkit-4.1.2.tar.gz) = 7990136
|
||||
SHA256 (sleuthkit-4.1.3.tar.gz) = 67f9d2a31a8884d58698d6122fc1a1bfa9bf238582bde2b49228ec9b899f0327
|
||||
SIZE (sleuthkit-4.1.3.tar.gz) = 7952733
|
||||
|
|
11
sysutils/sleuthkit/files/patch-tsk__img__tsk_img.h
Normal file
11
sysutils/sleuthkit/files/patch-tsk__img__tsk_img.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./tsk/img/tsk_img.h.orig 2014-01-27 03:27:03.000000000 +0000
|
||||
+++ ./tsk/img/tsk_img.h 2014-02-09 16:25:08.000000000 +0000
|
||||
@@ -66,6 +66,8 @@
|
||||
|
||||
TSK_IMG_TYPE_EWF_EWF = 0x0040, ///< EWF version
|
||||
|
||||
+ TSK_IMG_TYPE_EXTERNAL = 0x1000, ///< external defined format which at least implements TSK_IMG_INFO, used by pytsk
|
||||
+
|
||||
TSK_IMG_TYPE_UNSUPP = 0xffff, ///< Unsupported disk image type
|
||||
} TSK_IMG_TYPE_ENUM;
|
||||
|
|
@ -52,7 +52,8 @@ include/tsk/vs/tsk_vs.h
|
|||
lib/libtsk.a
|
||||
lib/libtsk.la
|
||||
lib/libtsk.so
|
||||
lib/libtsk.so.11
|
||||
lib/libtsk.so.10
|
||||
lib/libtsk.so.10.2.0
|
||||
man/man1/blkcalc.1.gz
|
||||
man/man1/blkcat.1.gz
|
||||
man/man1/blkls.1.gz
|
||||
|
|
Loading…
Reference in a new issue