cad/openscad: Update to 2021.01.01-20221206 (current revision)
This is needed to update math/cgal. PR: 268478 Reported by: yuri@
This commit is contained in:
parent
7c7e3e0836
commit
a79c1b4163
4 changed files with 98 additions and 23 deletions
|
@ -1,11 +1,7 @@
|
|||
PORTNAME= openscad
|
||||
PORTVERSION= 2021.01.01
|
||||
PORTREVISION= 14
|
||||
DISTVERSION= 2021.01.01-20221206
|
||||
CATEGORIES= cad
|
||||
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
PATCHFILES+= cc49ad8dac24.patch:-p1
|
||||
|
||||
MAINTAINER= mr@FreeBSD.org
|
||||
COMMENT= Programmer's solid 3D CAD modeller #'
|
||||
WWW= https://openscad.org/
|
||||
|
@ -13,7 +9,8 @@ WWW= https://openscad.org/
|
|||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= cgal>0:math/cgal
|
||||
BUILD_DEPENDS= cgal>0:math/cgal \
|
||||
${LOCALBASE}/include/linux/input.h:devel/evdev-proto
|
||||
LIB_DEPENDS= libzip.so:archivers/libzip \
|
||||
libhidapi.so:comms/hidapi \
|
||||
libboost_regex.so:devel/boost-libs \
|
||||
|
@ -26,23 +23,23 @@ LIB_DEPENDS= libzip.so:archivers/libzip \
|
|||
libfontconfig.so:x11-fonts/fontconfig \
|
||||
libdouble-conversion.so:devel/double-conversion
|
||||
|
||||
USES= bison compiler:c++14-lang cpe desktop-file-utils eigen:3 gettext \
|
||||
gl gnome pkgconfig qmake qt:5 shared-mime-info xorg
|
||||
USE_GITHUB= yes
|
||||
USES= bison cmake compiler:c++14-lang cpe desktop-file-utils eigen:3 gettext \
|
||||
gl gnome localbase:ldflags pkgconfig qt:5 shared-mime-info xorg
|
||||
USE_GL= gl glu glew
|
||||
USE_GNOME= glib20 libxml2
|
||||
USE_QT= buildtools:build core concurrent:build dbus gui multimedia widgets
|
||||
USE_GNOME= cairo glib20 libxml2
|
||||
USE_QT= buildtools:build core concurrent:build dbus gui multimedia network svg widgets qmake:build
|
||||
USE_XORG= x11
|
||||
GH_TAGNAME= 41f58fe57c03457a3a8b4dc541ef5654ec3e8c78
|
||||
QMAKE_ARGS= CONFIG+="experimental" VERSION=${PORTVERSION}
|
||||
# Avoid overlinking: kvm, procstat, boost(thread, system), Qt5(concurrent, network, printsupport)
|
||||
LDFLAGS+= -Wl,--as-needed
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_TAGNAME= 972d184
|
||||
GH_TUPLE= openscad:MCAD:1ea4022:MCAD/libraries/MCAD \
|
||||
microsoft:mimalloc:fe61be8:mimalloc/submodules/mimalloc
|
||||
|
||||
CMAKE_ARGS= -DQT5QSCINTILLA_LIBRARY=/usr/local/lib/qt5/libqscintilla2_qt5.so
|
||||
|
||||
CONFLICTS_INSTALL= openscad-devel # bin/openscad
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} 's/-libusb//' ${WRKSRC}/features/hidapi.prf
|
||||
@${REINPLACE_CMD} -e 's,share/man,man,' \
|
||||
${WRKSRC}/openscad.pro
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,5 +1,7 @@
|
|||
TIMESTAMP = 1629893805
|
||||
SHA256 (openscad-openscad-2021.01.01-41f58fe57c03457a3a8b4dc541ef5654ec3e8c78_GH0.tar.gz) = e8f94682dc3331c86d1cdc8d8bb0088a9910f1d1694ff9310524ca2d11e37ccc
|
||||
SIZE (openscad-openscad-2021.01.01-41f58fe57c03457a3a8b4dc541ef5654ec3e8c78_GH0.tar.gz) = 15656495
|
||||
SHA256 (cc49ad8dac24.patch) = 43cebd358d152f7a6dc1fc27294c67c4938b207d6a06f26fd60117e3a3c71412
|
||||
SIZE (cc49ad8dac24.patch) = 1610
|
||||
TIMESTAMP = 1671494678
|
||||
SHA256 (openscad-openscad-2021.01.01-20221206-972d184_GH0.tar.gz) = fc6a33395cdebbe457489d0593548c19abfc53ad15aef771c31e3f84f1615b35
|
||||
SIZE (openscad-openscad-2021.01.01-20221206-972d184_GH0.tar.gz) = 23120895
|
||||
SHA256 (openscad-MCAD-1ea4022_GH0.tar.gz) = c32e9ebb29b7fff12de408d76258f109b37001740a6f76a2f65b0792e32890d1
|
||||
SIZE (openscad-MCAD-1ea4022_GH0.tar.gz) = 56897
|
||||
SHA256 (microsoft-mimalloc-fe61be8_GH0.tar.gz) = 3669f0f83e3d904cbef5625be2105cb8438428de2e152740220a7acead1b8800
|
||||
SIZE (microsoft-mimalloc-fe61be8_GH0.tar.gz) = 1127821
|
||||
|
|
13
cad/openscad/files/patch-src_handle__dep.cc
Normal file
13
cad/openscad/files/patch-src_handle__dep.cc
Normal file
|
@ -0,0 +1,13 @@
|
|||
- https://github.com/openscad/openscad/issues/4453
|
||||
|
||||
--- src/handle_dep.cc.orig 2022-12-20 00:11:57 UTC
|
||||
+++ src/handle_dep.cc
|
||||
@@ -9,6 +9,8 @@
|
||||
#include <boost/filesystem.hpp>
|
||||
namespace fs = boost::filesystem;
|
||||
|
||||
+#include <sys/wait.h>
|
||||
+
|
||||
std::unordered_set<std::string> dependencies;
|
||||
const char *make_command = nullptr;
|
||||
|
|
@ -1,14 +1,16 @@
|
|||
bin/openscad
|
||||
man/man1/openscad.1.gz
|
||||
share/applications/openscad.desktop
|
||||
share/icons/hicolor/128x128/apps/openscad.png
|
||||
share/icons/hicolor/256x256/apps/openscad.png
|
||||
share/icons/hicolor/48x48/apps/openscad.png
|
||||
share/icons/hicolor/512x512/apps/openscad.png
|
||||
share/icons/hicolor/64x64/apps/openscad.png
|
||||
share/man/man1/openscad.1.gz
|
||||
share/metainfo/org.openscad.OpenSCAD.appdata.xml
|
||||
share/mime/packages/openscad.xml
|
||||
%%DATADIR%%/color-schemes/editor/dark-background.json
|
||||
%%DATADIR%%/color-schemes/editor/high-contrast-dark.json
|
||||
%%DATADIR%%/color-schemes/editor/high-contrast-light.json
|
||||
%%DATADIR%%/color-schemes/editor/light-background.json
|
||||
%%DATADIR%%/color-schemes/editor/monokai.json
|
||||
%%DATADIR%%/color-schemes/editor/solarized-dark.json
|
||||
|
@ -16,8 +18,10 @@ share/mime/packages/openscad.xml
|
|||
%%DATADIR%%/color-schemes/editor/tomorrow-night.json
|
||||
%%DATADIR%%/color-schemes/editor/tomorrow.json
|
||||
%%DATADIR%%/color-schemes/editor/visualstudio.json
|
||||
%%DATADIR%%/color-schemes/editor/xcode.json
|
||||
%%DATADIR%%/color-schemes/readme.txt
|
||||
%%DATADIR%%/color-schemes/render/beforedawn.json
|
||||
%%DATADIR%%/color-schemes/render/clearsky.json
|
||||
%%DATADIR%%/color-schemes/render/deepocean.json
|
||||
%%DATADIR%%/color-schemes/render/metallic.json
|
||||
%%DATADIR%%/color-schemes/render/monotone.json
|
||||
|
@ -39,11 +43,13 @@ share/mime/packages/openscad.xml
|
|||
%%DATADIR%%/examples/Basics/CSG-modules.scad
|
||||
%%DATADIR%%/examples/Basics/CSG.scad
|
||||
%%DATADIR%%/examples/Basics/LetterBlock.scad
|
||||
%%DATADIR%%/examples/Basics/hull.scad
|
||||
%%DATADIR%%/examples/Basics/linear_extrude.scad
|
||||
%%DATADIR%%/examples/Basics/logo.scad
|
||||
%%DATADIR%%/examples/Basics/logo_and_text.scad
|
||||
%%DATADIR%%/examples/Basics/projection.scad
|
||||
%%DATADIR%%/examples/Basics/projection.stl
|
||||
%%DATADIR%%/examples/Basics/roof.scad
|
||||
%%DATADIR%%/examples/Basics/rotate_extrude.scad
|
||||
%%DATADIR%%/examples/Basics/text_on_cube.scad
|
||||
%%DATADIR%%/examples/COPYING-CC0.txt
|
||||
|
@ -107,6 +113,57 @@ share/mime/packages/openscad.xml
|
|||
%%DATADIR%%/fonts/Liberation-2.00.1/ttf/LiberationSerif-BoldItalic.ttf
|
||||
%%DATADIR%%/fonts/Liberation-2.00.1/ttf/LiberationSerif-Italic.ttf
|
||||
%%DATADIR%%/fonts/Liberation-2.00.1/ttf/LiberationSerif-Regular.ttf
|
||||
%%DATADIR%%/libraries/MCAD/2Dshapes.scad
|
||||
%%DATADIR%%/libraries/MCAD/3d_triangle.scad
|
||||
%%DATADIR%%/libraries/MCAD/README.markdown
|
||||
%%DATADIR%%/libraries/MCAD/TODO
|
||||
%%DATADIR%%/libraries/MCAD/__init__.py
|
||||
%%DATADIR%%/libraries/MCAD/array.scad
|
||||
%%DATADIR%%/libraries/MCAD/bearing.scad
|
||||
%%DATADIR%%/libraries/MCAD/bitmap/README
|
||||
%%DATADIR%%/libraries/MCAD/bitmap/alphabet_block.scad
|
||||
%%DATADIR%%/libraries/MCAD/bitmap/bitmap.scad
|
||||
%%DATADIR%%/libraries/MCAD/bitmap/height_map.scad
|
||||
%%DATADIR%%/libraries/MCAD/bitmap/letter_necklace.scad
|
||||
%%DATADIR%%/libraries/MCAD/bitmap/name_tag.scad
|
||||
%%DATADIR%%/libraries/MCAD/bitmap/test_name_tag.scad
|
||||
%%DATADIR%%/libraries/MCAD/boxes.scad
|
||||
%%DATADIR%%/libraries/MCAD/constants.scad
|
||||
%%DATADIR%%/libraries/MCAD/curves.scad
|
||||
%%DATADIR%%/libraries/MCAD/fonts.scad
|
||||
%%DATADIR%%/libraries/MCAD/gears.scad
|
||||
%%DATADIR%%/libraries/MCAD/gridbeam.scad
|
||||
%%DATADIR%%/libraries/MCAD/hardware.scad
|
||||
%%DATADIR%%/libraries/MCAD/involute_gears.scad
|
||||
%%DATADIR%%/libraries/MCAD/layouts.scad
|
||||
%%DATADIR%%/libraries/MCAD/lego_compatibility.scad
|
||||
%%DATADIR%%/libraries/MCAD/lgpl-2.1.txt
|
||||
%%DATADIR%%/libraries/MCAD/libtriangles.scad
|
||||
%%DATADIR%%/libraries/MCAD/linear_bearing.scad
|
||||
%%DATADIR%%/libraries/MCAD/materials.scad
|
||||
%%DATADIR%%/libraries/MCAD/math.scad
|
||||
%%DATADIR%%/libraries/MCAD/metric_fastners.scad
|
||||
%%DATADIR%%/libraries/MCAD/motors.scad
|
||||
%%DATADIR%%/libraries/MCAD/multiply.scad
|
||||
%%DATADIR%%/libraries/MCAD/nuts_and_bolts.scad
|
||||
%%DATADIR%%/libraries/MCAD/openscad_testing.py
|
||||
%%DATADIR%%/libraries/MCAD/openscad_utils.py
|
||||
%%DATADIR%%/libraries/MCAD/polyholes.scad
|
||||
%%DATADIR%%/libraries/MCAD/profiles.scad
|
||||
%%DATADIR%%/libraries/MCAD/regular_shapes.scad
|
||||
%%DATADIR%%/libraries/MCAD/screw.scad
|
||||
%%DATADIR%%/libraries/MCAD/servos.scad
|
||||
%%DATADIR%%/libraries/MCAD/shapes.scad
|
||||
%%DATADIR%%/libraries/MCAD/stepper.scad
|
||||
%%DATADIR%%/libraries/MCAD/teardrop.scad
|
||||
%%DATADIR%%/libraries/MCAD/test_docs.py
|
||||
%%DATADIR%%/libraries/MCAD/test_mcad.py
|
||||
%%DATADIR%%/libraries/MCAD/transformations.scad
|
||||
%%DATADIR%%/libraries/MCAD/triangles.scad
|
||||
%%DATADIR%%/libraries/MCAD/trochoids.scad
|
||||
%%DATADIR%%/libraries/MCAD/units.scad
|
||||
%%DATADIR%%/libraries/MCAD/unregular_shapes.scad
|
||||
%%DATADIR%%/libraries/MCAD/utilities.scad
|
||||
%%DATADIR%%/locale/cs/LC_MESSAGES/openscad.mo
|
||||
%%DATADIR%%/locale/de/LC_MESSAGES/openscad.mo
|
||||
%%DATADIR%%/locale/es/LC_MESSAGES/openscad.mo
|
||||
|
@ -114,9 +171,15 @@ share/mime/packages/openscad.xml
|
|||
%%DATADIR%%/locale/hy/LC_MESSAGES/openscad.mo
|
||||
%%DATADIR%%/locale/pl/LC_MESSAGES/openscad.mo
|
||||
%%DATADIR%%/locale/ru/LC_MESSAGES/openscad.mo
|
||||
%%DATADIR%%/locale/tr/LC_MESSAGES/openscad.mo
|
||||
%%DATADIR%%/locale/uk/LC_MESSAGES/openscad.mo
|
||||
%%DATADIR%%/locale/zh_CN/LC_MESSAGES/openscad.mo
|
||||
%%DATADIR%%/locale/zh_TW/LC_MESSAGES/openscad.mo
|
||||
%%DATADIR%%/shaders/MouseSelector.frag
|
||||
%%DATADIR%%/shaders/MouseSelector.vert
|
||||
%%DATADIR%%/shaders/Preview.frag
|
||||
%%DATADIR%%/shaders/Preview.vert
|
||||
%%DATADIR%%/templates/CC0.json
|
||||
%%DATADIR%%/templates/difference.json
|
||||
%%DATADIR%%/templates/for.json
|
||||
%%DATADIR%%/templates/function.json
|
||||
|
|
Loading…
Reference in a new issue