Update to 1.6.

See also: http://www.wesnoth.org/start/1.6/

PR:		ports/132957
Submitted by:	"Anonymous" <swell.k -at- gmail.com>
This commit is contained in:
Philip Paeps 2009-03-24 20:09:03 +00:00
parent 4317209877
commit a7fb8a41f4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=230907
10 changed files with 3291 additions and 2273 deletions

View file

@ -6,7 +6,7 @@
# #
PORTNAME= wesnoth PORTNAME= wesnoth
PORTVERSION= 1.4.7 PORTVERSION= 1.6
CATEGORIES= games CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.wesnoth.org/files/ http://www.wesnoth.org/files/
@ -18,27 +18,41 @@ COMMENT= A fantasy turn-based strategy game
LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \
freetype.9:${PORTSDIR}/print/freetype2 freetype.9:${PORTSDIR}/print/freetype2
USE_SDL= image mixer net CONFLICTS= wesnoth-1.5*
USE_GNOME= gnometarget
USE_SDL= image mixer net ttf
USE_GNOME= gnometarget pango
USE_GMAKE= yes USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
WANT_GNOME= yes WANT_GNOME= yes
USE_BZIP2= yes USE_BZIP2= yes
GNU_CONFIGURE= yes GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var \ CONFIGURE_ARGS= --localstatedir=/var \
--with-libiconv-prefix=${LOCALBASE} \ --with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE} \ --with-libintl-prefix=${LOCALBASE} \
--with-freetype-prefix=${LOCALBASE} \
--with-localedir=${PREFIX}/share/locale --with-localedir=${PREFIX}/share/locale
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CXXFLAGS="-I${LOCALBASE}/include ${CXXFLAGS} -ftemplate-depth-45" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
MAN6= wesnoth.6 MANLANG= "" cs da de en_GB es fi fr gl hu it ja
MANLANG= "" ca_ES@valencia cs da de es fr gl hu it ja MANLANG+= lt nl pl racv sk sr sr@latin sv tr zh_CN zh_TW
MANLANG+= nl pl sk sr sr@latin sv tr zh_CN zh_TW
MAN6_CS= wesnoth.6
MAN6_DE= wesnoth.6
MAN6_EN= wesnoth.6
MAN6_EN_GB= wesnoth.6
MAN6_ES= wesnoth.6
MAN6_FI= wesnoth.6
MAN6_GL= wesnoth.6
MAN6_HU= wesnoth.6
MAN6_IT= wesnoth.6
MAN6_LT= wesnoth.6
MAN6_PL= wesnoth.6
MAN6_SK= wesnoth.6
MAN6_TR= wesnoth.6
MAN6_ZH_CN= wesnoth.6
OPTIONS= CAMPAIGN "Enable campaign server" On \ OPTIONS= CAMPAIGN "Enable campaign server" On \
EDITOR "Enable map editor" On \ EDITOR "Enable map editor" On \
FRIBIDI "Enable bidirectional support" On \
NLS "Enable localization" On \ NLS "Enable localization" On \
SERVER "Enable server" On \ SERVER "Enable server" On \
TOOLS "Enable extra tools for artists and translators" On TOOLS "Enable extra tools for artists and translators" On
@ -58,12 +72,17 @@ PLIST_SUB+= CAMPAIGN=""
.if defined(WITHOUT_EDITOR) .if defined(WITHOUT_EDITOR)
PLIST_SUB+= EDITOR="@comment " PLIST_SUB+= EDITOR="@comment "
CONFIGURE_ARGS+= --disable-editor
.else .else
CONFIGURE_ARGS+= --enable-editor
MAN6+= wesnoth_editor.6
PLIST_SUB+= EDITOR="" PLIST_SUB+= EDITOR=""
.endif .endif
.if defined(WITHOUT_FRIBIDI)
CONFIGURE_ARGS+= --without-fribidi
.else
LIB_DEPENDS+= fribidi.0:${PORTSDIR}/converters/fribidi
.endif
.if defined(WITHOUT_NLS) .if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment " PLIST_SUB+= NLS="@comment "
@ -87,6 +106,10 @@ CONFIGURE_ARGS+= --enable-tools
PLIST_SUB+= TOOLS="" PLIST_SUB+= TOOLS=""
.endif .endif
.if (defined(WITH_CAMPAIGN) || defined(WITH_SERVER) || defined(WITH_TOOLS)) && defined(WITHOUT_NLS)
BROKEN= you need NLS support for `campaignd' or `wesnothd' or tools to link against gettext
.endif
post-configure: post-configure:
@${REINPLACE_CMD} -e 's|[$$][{]datarootdir[}]/icons|${LOCALBASE}/share/pixmaps|' \ @${REINPLACE_CMD} -e 's|[$$][{]datarootdir[}]/icons|${LOCALBASE}/share/pixmaps|' \
${WRKSRC}/icons/Makefile ${WRKSRC}/icons/Makefile

View file

@ -1,3 +1,3 @@
MD5 (wesnoth-1.4.7.tar.bz2) = fdd341c3d66bf1bea2113c79db852d68 MD5 (wesnoth-1.6.tar.bz2) = ac636a0f0f6e1f346a99a0495e57b1de
SHA256 (wesnoth-1.4.7.tar.bz2) = 63c85889ef8c08e6dd5ea977edd057d64ce65a4934e661e222d2b0dd89e26847 SHA256 (wesnoth-1.6.tar.bz2) = 22eb64ea4e1e84c37fc16008a568dd5ae515446531e89ad57e2218db33ea9020
SIZE (wesnoth-1.4.7.tar.bz2) = 155052245 SIZE (wesnoth-1.6.tar.bz2) = 225406601

View file

@ -0,0 +1,11 @@
--- Makefile.in.orig 2009-03-24 16:52:32.000000000 +0100
+++ Makefile.in 2009-03-24 16:52:43.000000000 +0100
@@ -279,7 +279,7 @@
bin_SCRIPTS =
# Ignore junk -- object files, editor backup files, wmllint backup files.
-findfilterflags = ! \( -name .svn -prune -o -name ".\#*" -o -name "*~" -o -name "*bak" -o -name 'Makefile' -o -name '*Makefile' -o -type d -o -wholename "data/test/*" \)
+findfilterflags = ! \( -name .svn -prune -o -name ".\#*" -o -name "*~" -o -name "*bak" -o -name 'Makefile' -o -name '*Makefile' -o -type d -o -path "data/test/*" \)
# List all datafiles, ignoring junk
finddata = (cd $(top_srcdir) && find data fonts icons images sounds $(findfilterflags) -print )

View file

@ -0,0 +1,11 @@
--- configure.orig 2009-03-16 01:47:21.000000000 +0300
+++ configure
@@ -13309,7 +13309,7 @@
-for ac_func in round socket strtoul sendfile
+for ac_func in round socket strtoul
do
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
{ $as_echo "$as_me:$LINENO: checking for $ac_func" >&5

View file

@ -0,0 +1,11 @@
--- src/multiplayer_connect.cpp.orig 2008-09-07 18:16:37.000000000 -0700
+++ src/multiplayer_connect.cpp 2008-09-07 18:17:40.000000000 -0700
@@ -642,7 +642,7 @@
res["current_player"] = id_.empty() ? current_player_ : id_;
if (id_.empty()) {
- char const *description;
+ char const *description = NULL;
switch(controller_) {
case CNTR_NETWORK:
description = N_("(Vacant slot)");

View file

@ -0,0 +1,11 @@
--- src/Makefile.in.orig 2008-11-02 19:33:40.000000000 +0100
+++ src/Makefile.in 2008-11-02 19:33:49.000000000 +0100
@@ -1783,7 +1783,7 @@
game_config.o: revision.hpp
.PRECIOUS: revision.hpp
revision.hpp: FORCE
- if [ "$(REVISION)" == "" ] || [ "$(REVISION)" == "exported" ]; then echo '' >/tmp/westemp$$$$; \
+ if [ "$(REVISION)" = "" ] || [ "$(REVISION)" = "exported" ]; then echo '' >/tmp/westemp$$$$; \
else echo '#define REVISION "$(REVISION)"' >/tmp/westemp$$$$; fi;\
if cmp -s revision.hpp /tmp/westemp$$$$ 2>/dev/null; then :; else cp /tmp/westemp$$$$ revision.hpp; fi; \
if [ -e /tmp/westemp$$$$ ]; then rm /tmp/westemp$$$$; fi

View file

@ -1,11 +0,0 @@
--- src/help.cpp.orig Tue Jun 7 19:34:15 2005
+++ src/help.cpp Tue Jun 7 19:34:22 2005
@@ -41,7 +41,7 @@
#include <algorithm>
#include <iostream>
#include <list>
-#include <locale>
+#include <locale.h>
#include <map>
#include <queue>
#include <set>

View file

@ -1,15 +0,0 @@
--- src/language.cpp.orig Mon Jul 25 13:44:10 2005
+++ src/language.cpp Mon Jul 25 13:45:47 2005
@@ -133,12 +133,10 @@
unsetenv ("LANGUAGE"); // void so no return value to check
#endif
-#ifdef __BEOS__
if(setenv ("LANG", locale, 1) == -1)
std::cerr << "setenv LANG failed: " << strerror(errno);
if(setenv ("LC_ALL", locale, 1) == -1)
std::cerr << "setenv LC_ALL failed: " << strerror(errno);
-#endif
#ifdef __APPLE__
if(setenv ("LANGUAGE", locale, 1) == -1)
std::cerr << "setenv LANGUAGE failed: " << strerror(errno);

View file

@ -0,0 +1,13 @@
--- src/gui/widgets/window_builder.cpp.orig 2008-11-02 17:31:45.000000000 +0100
+++ src/gui/widgets/window_builder.cpp 2008-11-02 17:32:43.000000000 +0100
@@ -199,6 +199,10 @@
std::cerr << cfg;
assert(false);
}
+
+ // Appease the compiler on FreeBSD
+ // Unreachable
+ return NULL;
}
} // namespace

File diff suppressed because it is too large Load diff