Upgrade from 1.1.6 to 1.1.7. The changes are listed as:
GA 1.1.7 - - Add JSON support - Allow building without server flags (Bug#21391025) - Correct relative() not seeking after changing position.(Bug#21152054) The first item is only available if the mysql-client is recent enough (version 5.7). For older client-libraries the new patch is required.
This commit is contained in:
parent
a2ba5b2b9c
commit
a80b1131fe
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=407091
4 changed files with 39 additions and 20 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= mysql-connector-c++
|
||||
PORTVERSION= 1.1.6
|
||||
PORTVERSION= 1.1.7
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= MYSQL/Connector-C++
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (mysql-connector-c++-1.1.6.tar.gz) = ad710b3900cae3be94656825aa70319cf7a96e1ad46bf93e07275f3606f69447
|
||||
SIZE (mysql-connector-c++-1.1.6.tar.gz) = 522236
|
||||
SHA256 (mysql-connector-c++-1.1.7.tar.gz) = 5b353fbcd26f607a2a0987ce78a4b811f8971813d46b0f4ae6fa07887e9fc763
|
||||
SIZE (mysql-connector-c++-1.1.7.tar.gz) = 518469
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
--- CMakeLists.txt.orig 2015-06-04 12:58:30 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -305,14 +305,6 @@ IF(RPM_LAYOUT)
|
||||
SET(DOC_DESTINATION "share/doc/${CPACK_PACKAGE_NAME}-${MYSQLCPPCONN_VERSION}")
|
||||
ENDIF()
|
||||
|
||||
-INSTALL(FILES
|
||||
- ${CPACK_RESOURCE_FILE_README}
|
||||
- ${CPACK_RESOURCE_FILE_INSTALL}
|
||||
- ${CPACK_RESOURCE_FILE_LICENSE}
|
||||
- "${CMAKE_SOURCE_DIR}/Licenses_for_Third-Party_Components.txt"
|
||||
- "${CMAKE_SOURCE_DIR}/ANNOUNCEMENT"
|
||||
- DESTINATION ${DOC_DESTINATION} OPTIONAL)
|
||||
-
|
||||
SET(COMMON_IGNORE_FILES
|
||||
"/CMakeFiles/"
|
||||
"/Testing/"
|
36
databases/mysql-connector-c++/files/patch-optional-json
Normal file
36
databases/mysql-connector-c++/files/patch-optional-json
Normal file
|
@ -0,0 +1,36 @@
|
|||
The newly-added JSON-support may not be available in the older
|
||||
version of MySQL client-library against which this connector may
|
||||
be building. Fortunately, that's easy to detect at compile time...
|
||||
|
||||
-mi
|
||||
|
||||
--- driver/mysql_resultbind.cpp 2016-01-12 13:42:38.000000000 -0500
|
||||
+++ driver/mysql_resultbind.cpp 2016-01-24 03:58:18.451886000 -0500
|
||||
@@ -87,5 +87,7 @@
|
||||
case MYSQL_TYPE_STRING:
|
||||
case MYSQL_TYPE_VAR_STRING:
|
||||
+#ifdef MYSQL_TYPE_JSON
|
||||
case MYSQL_TYPE_JSON:
|
||||
+#endif
|
||||
return st_buffer_size_type(new char[field->max_length + 1], field->max_length + 1, field->type);
|
||||
|
||||
--- driver/mysql_util.cpp 2016-01-12 13:42:38.000000000 -0500
|
||||
+++ driver/mysql_util.cpp 2016-01-24 04:01:04.499990000 -0500
|
||||
@@ -432,6 +432,8 @@
|
||||
case MYSQL_TYPE_GEOMETRY:
|
||||
return sql::DataType::GEOMETRY;
|
||||
+#ifdef MYSQL_TYPE_JSON
|
||||
case MYSQL_TYPE_JSON:
|
||||
return sql::DataType::JSON;
|
||||
+#endif
|
||||
default:
|
||||
return sql::DataType::UNKNOWN;
|
||||
@@ -646,6 +648,8 @@
|
||||
case MYSQL_TYPE_GEOMETRY:
|
||||
return "GEOMETRY";
|
||||
+#ifdef MYSQL_TYPE_JSON
|
||||
case MYSQL_TYPE_JSON:
|
||||
return "JSON";
|
||||
+#endif
|
||||
default:
|
||||
return "UNKNOWN";
|
Loading…
Reference in a new issue