multimedia/arcan: switch to upstreamable UVC fix

This commit is contained in:
Jan Beich 2020-11-28 23:48:42 +00:00
parent b1071adfe5
commit a8320e43e5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=556541
3 changed files with 4 additions and 40 deletions

View file

@ -12,6 +12,7 @@ PATCHFILES+= b519eb023e20.patch:-p2 # https://github.com/letoram/arcan/pull/205
PATCHFILES+= d6b52b1b3601.patch:-p2 # https://github.com/letoram/arcan/pull/205
PATCHFILES+= d8a262d6d19a.patch:-p2 # https://github.com/letoram/arcan/pull/205
PATCHFILES+= f724b748cc72.patch:-p2 # https://github.com/letoram/arcan/pull/205
PATCHFILES+= 06ca1fd319bf.patch:-p2 # https://github.com/letoram/arcan/pull/209
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Display Server, Multimedia Framework, Game Engine
@ -33,6 +34,7 @@ USE_LDCONFIG= yes
GH_ACCOUNT= letoram
WRKSRC_SUBDIR= src
CMAKE_ON= HYBRID_HEADLESS
CMAKE_OFF= STATIC_LIBUVC
CMAKE_ARGS= -DENGINE_BUILDTAG:STRING="${DISTVERSIONFULL}"
LDFLAGS+= -Wl,--as-needed # bzip2, ffmpeg, librt, libutil, lzma, zlib
LDFLAGS_i386= -Wl,-z,notext

View file

@ -13,3 +13,5 @@ SHA256 (d8a262d6d19a.patch) = 82b04de15212726d33fab17c87600fa0c78e44ea28ee9da764
SIZE (d8a262d6d19a.patch) = 804
SHA256 (f724b748cc72.patch) = 33c580b5638060476bfb1bf48d9fe040d15e412c494a2a52432b01f9a55758b8
SIZE (f724b748cc72.patch) = 1348
SHA256 (06ca1fd319bf.patch) = e65a854e6a51ecb68707f3b257dc3a748b72a840f398f536c455faea0d2d673a
SIZE (06ca1fd319bf.patch) = 3777

View file

@ -1,40 +0,0 @@
- Git cannot be used as poudriere disables network access during build
- ExternalProject_Add fails to build with Ninja
--- frameserver/decode/default/CMakeLists.txt.orig 2020-11-27 15:29:00 UTC
+++ frameserver/decode/default/CMakeLists.txt
@@ -52,31 +52,18 @@ if (LIBVLC_FOUND)
${DECODE_DEFS}
)
- pkg_check_modules(LIBUSB_1 REQUIRED libusb-1.0)
pkg_check_modules(FFMPEG REQUIRED libavcodec libavdevice libavfilter libavformat libavutil libswresample libswscale)
+ pkg_check_modules(LIBUVC libuvc)
- ExternalProject_Add(libuvc
- SOURCE_DIR "${CMAKE_CURRENT_BINARY_DIR}/frameserver/decode/libuvc"
- BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/libuvc_static"
- UPDATE_COMMAND ""
- GIT_REPOSITORY "${EXTERNAL_SRC_DIR}/git/libuvc"
- ${EXTERNAL_DEFS}
- ${CMAKE_EXTERNAL_DEFS}
- -DBUILD_UVC_STATIC=ON
- )
-
- set(DECODE_DEPS libuvc)
set(DECODE_INCLUDE_DIRS
${DECODE_INCLUDE_DIRS}
- ${LIBUSB_1_INCLUDE_DIRS}
${FFMPEG_INCLUDE_DIRS}
- ${CMAKE_CURRENT_BINARY_DIR}/libuvc_static/include
+ ${LIBUVC_INCLUDE_DIRS}
${CMAKE_CURRENT_BINARY_DIR}/../../../include)
set(DECODE_LIBS
${FFMPEG_LINK_LIBRARIES}
${DECODE_LIBS}
- ${LIBUSB_1_LINK_LIBRARIES}
- ${CMAKE_CURRENT_BINARY_DIR}/libuvc_static/libuvc.a
+ ${LIBUVC_LINK_LIBRARIES}
)
set(DECODE_SOURCES
${DECODE_SOURCES}