Update to 0.5.7.
PR: ports/115422 Submitted by: maintainer
This commit is contained in:
parent
898f84cedd
commit
a85b4fa4f6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=197940
5 changed files with 24 additions and 39 deletions
|
@ -1,15 +1,13 @@
|
|||
# New ports collection makefile for: kcheckgmail
|
||||
# Date created: 17 June 2007
|
||||
# Whom: Yuan Jue <yuanjue@FreeBSD.org>
|
||||
# Whom: YUAN Jue <yuanjue@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= kcheckgmail
|
||||
PORTVERSION= 0.5.6
|
||||
PORTVERSION= 0.5.7
|
||||
CATEGORIES= mail kde
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
http://www.yuanjue.net/download/
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
MASTER_SITES= http://www.yuanjue.net/download/
|
||||
|
||||
MAINTAINER= yuanjue@FreeBSD.org
|
||||
COMMENT= A Gmail Notifier for KDE
|
||||
|
@ -19,6 +17,7 @@ GNU_CONFIGURE= yes
|
|||
USE_GMAKE= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_KDELIBS_VER=3
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
.if !defined(WITHOUT_NLS)
|
||||
USE_GETTEXT= yes
|
||||
|
@ -30,10 +29,11 @@ PLIST_SUB+= NLS="@comment "
|
|||
|
||||
DOCSDIR= ${PREFIX}/share/doc/HTML/en/${PORTNAME}
|
||||
|
||||
post-patch:
|
||||
@${TOUCH} -t 200501251945 ${WRKSRC}/acinclude.m4
|
||||
@${TOUCH} -t 200704011036 ${WRKSRC}/aclocal.m4
|
||||
@${TOUCH} -t 200704011037 ${WRKSRC}/Makefile.in
|
||||
@${TOUCH} -t 200704011038 ${WRKSRC}/configure
|
||||
MAN1= kcheckgmail.1
|
||||
|
||||
post-extract:
|
||||
.if defined(NOPORTDOCS)
|
||||
@${REINPLACE_CMD} -e 's|doc||g' ${WRKSRC}/subdirs
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (kcheckgmail-0.5.6.tar.bz2) = b49cb678330b1c8299b1040ba3d18f7f
|
||||
SHA256 (kcheckgmail-0.5.6.tar.bz2) = b76126f680415ad292d18c3f818a65d08b48cc1cbd667000cd0f63bd56af44ef
|
||||
SIZE (kcheckgmail-0.5.6.tar.bz2) = 514501
|
||||
MD5 (kcheckgmail-0.5.7.tar.bz2) = 66f79a4f374a4abaa3e9aa2e2b884be8
|
||||
SHA256 (kcheckgmail-0.5.7.tar.bz2) = ba4074f6e5888d0c22fce4e6f4dc3a119337d51984eebeed90736db728b53c11
|
||||
SIZE (kcheckgmail-0.5.7.tar.bz2) = 897852
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
--- admin/detect-autoconf.sh.orig Tue Jan 25 19:44:35 2005
|
||||
+++ admin/detect-autoconf.sh Sat Jun 16 20:35:30 2007
|
||||
@@ -1,11 +1,11 @@
|
||||
#! /bin/sh
|
||||
|
||||
# Global variables...
|
||||
-AUTOCONF="autoconf"
|
||||
-AUTOHEADER="autoheader"
|
||||
-AUTOM4TE="autom4te"
|
||||
-AUTOMAKE="automake"
|
||||
-ACLOCAL="aclocal"
|
||||
+AUTOCONF="autoconf259"
|
||||
+AUTOHEADER="autoheader259"
|
||||
+AUTOM4TE="autom4te259"
|
||||
+AUTOMAKE="automake19"
|
||||
+ACLOCAL="aclocal19"
|
||||
|
||||
# Please add higher versions first. The last version number is the minimum
|
||||
# needed to compile KDE. Do not forget to include the name/version #
|
|
@ -2,15 +2,17 @@ KCheckGMail is a simple KDE systray application that notifies
|
|||
when new email is received in a GMail account.
|
||||
|
||||
Features:
|
||||
* Small
|
||||
* Small (around 230KB)
|
||||
* Available in multiple languages
|
||||
* Google Applications for Domains Support!
|
||||
* eMail snippets
|
||||
* Snooze support!
|
||||
* eMail snippets + attachments (new)
|
||||
* More functionality via DCOP (new)
|
||||
* Customizable search (new)
|
||||
* Store password safely, using the KDE Wallet
|
||||
* Customizable check interval
|
||||
* Secure login and data retrieval by using https
|
||||
|
||||
|
||||
WWW: http://kcheckgmail.sourceforge.net/
|
||||
|
||||
- YUAN Jue
|
||||
|
|
|
@ -7,15 +7,16 @@ share/apps/kcheckgmail/icons/crystalsvg/22x22/apps/kcheckgmail.png
|
|||
share/apps/kcheckgmail/icons/crystalsvg/32x32/apps/kcheckgmail.png
|
||||
share/apps/kcheckgmail/icons/crystalsvg/48x48/apps/kcheckgmail.png
|
||||
share/apps/kcheckgmail/icons/crystalsvg/64x64/apps/kcheckgmail.png
|
||||
%%DOCSDIR%%/common
|
||||
%%DOCSDIR%%/index.cache.bz2
|
||||
%%DOCSDIR%%/index.docbook
|
||||
%%PORTDOCS%%%%DOCSDIR%%/common
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.cache.bz2
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.docbook
|
||||
share/icons/crystalsvg/128x128/apps/kcheckgmail.png
|
||||
share/icons/crystalsvg/16x16/apps/kcheckgmail.png
|
||||
share/icons/crystalsvg/22x22/apps/kcheckgmail.png
|
||||
share/icons/crystalsvg/32x32/apps/kcheckgmail.png
|
||||
share/icons/crystalsvg/48x48/apps/kcheckgmail.png
|
||||
share/icons/crystalsvg/64x64/apps/kcheckgmail.png
|
||||
%%NLS%%share/locale/ar/LC_MESSAGES/kcheckgmail.mo
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/kcheckgmail.mo
|
||||
%%NLS%%share/locale/es/LC_MESSAGES/kcheckgmail.mo
|
||||
%%NLS%%share/locale/et/LC_MESSAGES/kcheckgmail.mo
|
||||
|
@ -25,6 +26,7 @@ share/icons/crystalsvg/64x64/apps/kcheckgmail.png
|
|||
%%NLS%%share/locale/ko/LC_MESSAGES/kcheckgmail.mo
|
||||
%%NLS%%share/locale/lt/LC_MESSAGES/kcheckgmail.mo
|
||||
%%NLS%%share/locale/pl/LC_MESSAGES/kcheckgmail.mo
|
||||
%%NLS%%share/locale/pt/LC_MESSAGES/kcheckgmail.mo
|
||||
%%NLS%%share/locale/pt_BR/LC_MESSAGES/kcheckgmail.mo
|
||||
%%NLS%%share/locale/ru/LC_MESSAGES/kcheckgmail.mo
|
||||
%%NLS%%share/locale/sk/LC_MESSAGES/kcheckgmail.mo
|
||||
|
@ -59,4 +61,4 @@ share/icons/crystalsvg/64x64/apps/kcheckgmail.png
|
|||
@dirrm share/apps/kcheckgmail/icons/crystalsvg
|
||||
@dirrm share/apps/kcheckgmail/icons
|
||||
@dirrm share/apps/kcheckgmail
|
||||
@dirrm %%DOCSDIR%%
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
|
Loading…
Reference in a new issue