Spot The Difference is a file integrity checker. Its goal is to detect signs of

intrusion by looking for suspicious changes in system files. Crackers, in fact,
to do their evil or just to make sure they can work their way back into the
system, often change some configuration files, executables and/or log files
(usually with rootkits); thus leaving signs of the break-in.

WWW: http://www.kernel-panic.it/software/stdiff/
This commit is contained in:
Marcelo Araujo 2010-12-11 21:09:43 +00:00
parent 64a82765d1
commit a8c1d5b9db
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=266064
6 changed files with 101 additions and 14 deletions

View file

@ -682,6 +682,7 @@
SUBDIR += py-bcfg2
SUBDIR += py-filelike
SUBDIR += py-psutil
SUBDIR += py-stdiff
SUBDIR += py-supervisor
SUBDIR += py-zdaemon
SUBDIR += py-zfs
@ -727,13 +728,6 @@
SUBDIR += rsyslog3-snmp
SUBDIR += rsyslog4
SUBDIR += rsyslog4-dbi
SUBDIR += rsyslog4-gnutls
SUBDIR += rsyslog4-gssapi
SUBDIR += rsyslog4-mysql
SUBDIR += rsyslog4-pgsql
SUBDIR += rsyslog4-relp
SUBDIR += rsyslog4-rfc3195
SUBDIR += rsyslog4-snmp
SUBDIR += rsyslog4-devel
SUBDIR += rsyslog4-devel-dbi
SUBDIR += rsyslog4-devel-gnutls
@ -743,15 +737,15 @@
SUBDIR += rsyslog4-devel-relp
SUBDIR += rsyslog4-devel-rfc3195
SUBDIR += rsyslog4-devel-snmp
SUBDIR += rsyslog4-gnutls
SUBDIR += rsyslog4-gssapi
SUBDIR += rsyslog4-mysql
SUBDIR += rsyslog4-pgsql
SUBDIR += rsyslog4-relp
SUBDIR += rsyslog4-rfc3195
SUBDIR += rsyslog4-snmp
SUBDIR += rsyslog5
SUBDIR += rsyslog5-dbi
SUBDIR += rsyslog5-gnutls
SUBDIR += rsyslog5-gssapi
SUBDIR += rsyslog5-mysql
SUBDIR += rsyslog5-pgsql
SUBDIR += rsyslog5-relp
SUBDIR += rsyslog5-rfc3195
SUBDIR += rsyslog5-snmp
SUBDIR += rsyslog5-devel
SUBDIR += rsyslog5-devel-dbi
SUBDIR += rsyslog5-devel-gnutls
@ -761,6 +755,13 @@
SUBDIR += rsyslog5-devel-relp
SUBDIR += rsyslog5-devel-rfc3195
SUBDIR += rsyslog5-devel-snmp
SUBDIR += rsyslog5-gnutls
SUBDIR += rsyslog5-gssapi
SUBDIR += rsyslog5-mysql
SUBDIR += rsyslog5-pgsql
SUBDIR += rsyslog5-relp
SUBDIR += rsyslog5-rfc3195
SUBDIR += rsyslog5-snmp
SUBDIR += rsyslog6-devel
SUBDIR += rsyslog6-devel-dbi
SUBDIR += rsyslog6-devel-gnutls

View file

@ -0,0 +1,33 @@
# New ports collection makefile for: py-stdiff
# Date created: 11 Dec 2010
# Whom: Marcelo Araujo <araujo@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= stdiff
PORTVERSION= 0.2.1
CATEGORIES= sysutils python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
MAINTAINER= araujo@FreeBSD.org
COMMENT= Spot The Difference is a file integrity checker.
USE_PYTHON= yes
USE_PYDISTUTILS= yes
.if !defined(NOPORTDOCS)
PORTDOCS= *
.endif
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
$(INSTALL_MAN) ${WRKSRC}/INSTALL.txt ${DOCSDIR}/
$(INSTALL_MAN) ${WRKSRC}/LICENSE.txt ${DOCSDIR}/
(cd ${WRKSRC}/ && ${COPYTREE_SHARE} docs ${DOCSDIR}/)
.endif
@if [ ! -f ${PREFIX}/etc/stdiff.conf ]; then \
${CP} -p ${PREFIX}/etc/stdiff.conf.sample \
${PREFIX}/etc/stdiff.conf; fi
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (stdiff-0.2.1.tar.gz) = 4c30a233395401f1f54a33eff683c8f7a5b8cbeff6ef9019db438cdffac503c0
SIZE (stdiff-0.2.1.tar.gz) = 43603

View file

@ -0,0 +1,11 @@
--- setup.py 2004-11-06 11:31:49.000000000 -0200
+++ /tmp/setup.py 2010-11-07 11:45:39.000000000 -0200
@@ -35,7 +35,7 @@
download_url="http://sourceforge.net/projects/stdiff/",
packages=["spot"],
scripts=["scripts/stdiff.py", "scripts/stdiff_install_db.py"],
- data_files=[("/etc", ["stdiff.conf.sample"])],
+ data_files=[("/usr/local/etc", ["stdiff.conf.sample"])],
classifiers=["Development status :: 0.2.1",
"Environment :: Console (Text Based)",
"Intended Audience :: System Administrators",

View file

@ -0,0 +1,7 @@
Spot The Difference is a file integrity checker. Its goal is to detect signs of
intrusion by looking for suspicious changes in system files. Crackers, in fact,
to do their evil or just to make sure they can work their way back into the
system, often change some configuration files, executables and/or log files
(usually with rootkits); thus leaving signs of the break-in.
WWW: http://www.kernel-panic.it/software/stdiff/

View file

@ -0,0 +1,33 @@
bin/stdiff.py
bin/stdiff_install_db.py
%%PYTHON_SITELIBDIR%%/spot/Parser.py
%%PYTHON_SITELIBDIR%%/spot/Parser.pyc
%%PYTHON_SITELIBDIR%%/spot/Parser.pyo
%%PYTHON_SITELIBDIR%%/spot/__init__.py
%%PYTHON_SITELIBDIR%%/spot/__init__.pyc
%%PYTHON_SITELIBDIR%%/spot/__init__.pyo
%%PYTHON_SITELIBDIR%%/spot/install_db_mysql.py
%%PYTHON_SITELIBDIR%%/spot/install_db_mysql.pyc
%%PYTHON_SITELIBDIR%%/spot/install_db_mysql.pyo
%%PYTHON_SITELIBDIR%%/spot/install_db_pgsql.py
%%PYTHON_SITELIBDIR%%/spot/install_db_pgsql.pyc
%%PYTHON_SITELIBDIR%%/spot/install_db_pgsql.pyo
%%PYTHON_SITELIBDIR%%/spot/spot.py
%%PYTHON_SITELIBDIR%%/spot/spot.pyc
%%PYTHON_SITELIBDIR%%/spot/spot.pyo
%%PYTHON_SITELIBDIR%%/spot/spot_dbm.py
%%PYTHON_SITELIBDIR%%/spot/spot_dbm.pyc
%%PYTHON_SITELIBDIR%%/spot/spot_dbm.pyo
%%PYTHON_SITELIBDIR%%/spot/spot_mysql.py
%%PYTHON_SITELIBDIR%%/spot/spot_mysql.pyc
%%PYTHON_SITELIBDIR%%/spot/spot_mysql.pyo
%%PYTHON_SITELIBDIR%%/spot/spot_pgsql.py
%%PYTHON_SITELIBDIR%%/spot/spot_pgsql.pyc
%%PYTHON_SITELIBDIR%%/spot/spot_pgsql.pyo
%%PYTHON_SITELIBDIR%%/spot/spot_sqlite.py
%%PYTHON_SITELIBDIR%%/spot/spot_sqlite.pyc
%%PYTHON_SITELIBDIR%%/spot/spot_sqlite.pyo
@dirrm %%PYTHON_SITELIBDIR%%/spot
@unexec if cmp -s %D/etc/stdiff.conf.sample %D/etc/stdiff.conf; then rm -f %D/etc/stdiff.conf ; fi
etc/stdiff.conf.sample
@exec if [ ! -f %D/etc/stdiff.conf ]; then cp -p %D/%F %B/stdiff.conf; fi