Fix build with clang
This commit is contained in:
parent
3ee931631c
commit
a8c22639ca
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=275910
3 changed files with 33 additions and 0 deletions
|
@ -25,6 +25,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
|
|||
post-patch:
|
||||
@${REINPLACE_CMD} -e "/-include/d" \
|
||||
-e "s/^CFLAGS=.*/CFLAGS=${CFLAGS} -DUNIX_HOST/" \
|
||||
-e "s/gcc/${CC}/" \
|
||||
${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
|
|
16
textproc/libsoldout/files/patch-BSDmakefile
Normal file
16
textproc/libsoldout/files/patch-BSDmakefile
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- ./BSDmakefile.orig 2011-05-22 15:52:03.000000000 +0200
|
||||
+++ ./BSDmakefile 2011-06-20 19:22:57.278509671 +0200
|
||||
@@ -16,9 +16,10 @@
|
||||
|
||||
DEPDIR=depends
|
||||
ALLDEPS=$(DEPDIR)/all
|
||||
-CFLAGS=-c -g -O3 -Wall -Werror -fPIC
|
||||
-LDFLAGS=-g -O3 -Wall -Werror
|
||||
-CC=gcc
|
||||
+CFLAGS?=-c -g -O3 -Wall -Werror
|
||||
+CFLAGS+= -c -fPIC
|
||||
+LDFLAGS?=-g -O3 -Wall -Werror
|
||||
+CC?=gcc
|
||||
|
||||
all: libupskirt.so lace kilt
|
||||
|
16
textproc/libupskirt/files/patch-BSDmakefile
Normal file
16
textproc/libupskirt/files/patch-BSDmakefile
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- ./BSDmakefile.orig 2011-05-22 15:52:03.000000000 +0200
|
||||
+++ ./BSDmakefile 2011-06-20 19:22:57.278509671 +0200
|
||||
@@ -16,9 +16,10 @@
|
||||
|
||||
DEPDIR=depends
|
||||
ALLDEPS=$(DEPDIR)/all
|
||||
-CFLAGS=-c -g -O3 -Wall -Werror -fPIC
|
||||
-LDFLAGS=-g -O3 -Wall -Werror
|
||||
-CC=gcc
|
||||
+CFLAGS?=-c -g -O3 -Wall -Werror
|
||||
+CFLAGS+= -c -fPIC
|
||||
+LDFLAGS?=-g -O3 -Wall -Werror
|
||||
+CC?=gcc
|
||||
|
||||
all: libupskirt.so lace kilt
|
||||
|
Loading…
Reference in a new issue