Fix build with gcc 3.4

This commit is contained in:
Alexander Nedotsukov 2004-08-04 04:44:31 +00:00
parent bfd65f6466
commit a8e8e15d33
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=115385
2 changed files with 15 additions and 0 deletions

View file

@ -26,4 +26,8 @@ USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
${WRKSRC}/Makefile.in
.include <bsd.port.mk>

View file

@ -0,0 +1,11 @@
--- libgnomecanvas/libgnomecanvasmm/line.h.orig Wed Aug 4 13:38:03 2004
+++ libgnomecanvas/libgnomecanvasmm/line.h Wed Aug 4 13:38:23 2004
@@ -286,7 +286,7 @@
{
template <>
-class Glib::Value<Gnome::Canvas::Points> : public Glib::Value_Boxed<Gnome::Canvas::Points>
+class Value<Gnome::Canvas::Points> : public Glib::Value_Boxed<Gnome::Canvas::Points>
{
public:
static GType value_type() G_GNUC_CONST;