New port: comms/airspy: AirSpy's usemode driver and associated tools

This commit is contained in:
Yuri Victorovich 2018-06-24 20:28:18 +00:00
parent 4dc6e0c483
commit a90d23c45e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=473274
6 changed files with 100 additions and 0 deletions

View file

@ -4,6 +4,7 @@
COMMENT = Communication utilities
SUBDIR += acfax
SUBDIR += airspy
SUBDIR += aldo
SUBDIR += amtterm
SUBDIR += anyremote

25
comms/airspy/Makefile Normal file
View file

@ -0,0 +1,25 @@
# $FreeBSD$
PORTNAME= airspy
DISTVERSIONPREFIX= v
DISTVERSION= 1.0.9-18
DISTVERSIONSUFFIX= -gbfb6670
CATEGORIES= comms hamradio
MAINTAINER= yuri@FreeBSD.org
COMMENT= AirSpy's usemode driver and associated tools
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/airspy-tools/LICENSE.md
BROKEN_FreeBSD_10= error: use of undeclared identifier '__m128'
USES= cmake:outsource pkgconfig
USE_GITHUB= yes
GH_PROJECT= airspyone_host
USE_LDCONFIG= yes
CMAKE_OFF= INSTALL_UDEV_RULES
CMAKE_ARGS= -DLIBUSB_LIBRARIES="/usr/lib/libusb.so"
.include <bsd.port.mk>

3
comms/airspy/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1529870725
SHA256 (airspy-airspyone_host-v1.0.9-18-gbfb6670_GH0.tar.gz) = 67c02690a3304eb461c1e0c2a045c24eacf114bdd7c82dbc921d6e7d13235311
SIZE (airspy-airspyone_host-v1.0.9-18-gbfb6670_GH0.tar.gz) = 238210

View file

@ -0,0 +1,50 @@
--- libairspy/src/CMakeLists.txt.orig 2018-06-24 20:11:21 UTC
+++ libairspy/src/CMakeLists.txt
@@ -58,15 +58,14 @@ set_target_properties(airspy PROPERTIES
endif( ${WIN32} )
# Static library
-add_library(airspy-static STATIC ${c_sources})
if(MSVC)
set_target_properties(airspy-static PROPERTIES OUTPUT_NAME "airspy_static")
else()
- set_target_properties(airspy-static PROPERTIES OUTPUT_NAME "airspy")
+ set_target_properties(airspy PROPERTIES OUTPUT_NAME "airspy")
endif()
set_target_properties(airspy PROPERTIES CLEAN_DIRECT_OUTPUT 1)
-set_target_properties(airspy-static PROPERTIES CLEAN_DIRECT_OUTPUT 1)
+set_target_properties(airspy PROPERTIES CLEAN_DIRECT_OUTPUT 1)
# Dependencies
target_link_libraries(airspy ${LIBUSB_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
@@ -82,10 +81,10 @@ if( ${UNIX} )
LIBRARY DESTINATION lib${LIB_SUFFIX}
COMPONENT sharedlibs
)
- install(TARGETS airspy-static
- ARCHIVE DESTINATION lib${LIB_SUFFIX}
- COMPONENT staticlibs
- )
+ #install(TARGETS airspy-static
+ # ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ # COMPONENT staticlibs
+ # )
install(FILES ${c_headers}
DESTINATION include/${PROJECT_NAME}
COMPONENT headers
@@ -97,10 +96,10 @@ if( ${WIN32} )
DESTINATION bin
COMPONENT sharedlibs
)
- install(TARGETS airspy-static
- DESTINATION bin
- COMPONENT staticlibs
- )
+ #install(TARGETS airspy-static
+ # DESTINATION bin
+ # COMPONENT staticlibs
+ # )
install(FILES ${c_headers}
DESTINATION include/${PROJECT_NAME}
COMPONENT headers

4
comms/airspy/pkg-descr Normal file
View file

@ -0,0 +1,4 @@
Host software for AirSpy, a project to produce a low cost, open source software
radio platform.
WWW: https://airspy.com/

17
comms/airspy/pkg-plist Normal file
View file

@ -0,0 +1,17 @@
bin/airspy_gpio
bin/airspy_gpiodir
bin/airspy_info
bin/airspy_lib_version
bin/airspy_r820t
bin/airspy_rx
bin/airspy_si5351c
bin/airspy_spiflash
include/libairspy/airspy.h
include/libairspy/airspy_commands.h
include/libairspy/filters.h
include/libairspy/iqconverter_float.h
include/libairspy/iqconverter_int16.h
lib/libairspy.so
lib/libairspy.so.0
lib/libairspy.so.1.0.9
libdata/pkgconfig/libairspy.pc