- Switch to options helpers

- Regenerate patches with `make makepatch`
- Fix 64 bit issue
This commit is contained in:
Dmitry Marakasov 2015-08-19 14:09:29 +00:00
parent 0ec6c58f66
commit a980bf7d70
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=394783
3 changed files with 28 additions and 15 deletions

View file

@ -31,13 +31,9 @@ DESKTOP_ENTRIES="Apricots" \
OPTIONS_DEFINE= DOCS OPENAL
OPTIONS_DEFAULT=OPENAL
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENAL}
USES+= openal:al,alut
CPPFLAGS+= -DAP_AUDIO_OPENAL
LDFLAGS+= -L${LOCALBASE}/lib -lopenal -lalut
.endif
OPENAL_USES= openal:al,alut
OPENAL_CPPFLAGS=-DAP_AUDIO_OPENAL
OPENAL_LDFLAGS= -L${LOCALBASE}/lib -lopenal -lalut
do-build:
cd ${WRKSRC}/apricots && ${CXX} ${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS} \

View file

@ -1,6 +1,24 @@
--- apricots/init.cpp.orig 2013-10-18 03:20:08.162773332 +0400
+++ apricots/init.cpp 2013-10-18 03:21:49.134378818 +0400
@@ -275,7 +275,7 @@
--- apricots/init.cpp.orig 2015-08-19 14:00:09 UTC
+++ apricots/init.cpp
@@ -218,7 +218,7 @@ void init_gameconstants(gamedata &g){
string getConfig(string config, string name, string defval)
{
// Pull out just the name line
- unsigned int ndx = config.find(name);
+ size_t ndx = config.find(name);
if (ndx == string::npos)
{
@@ -241,7 +241,7 @@ string getConfig(string config, string n
int getConfig(string config, string name, int defval, int min, int max)
{
// Pull out just the name line
- unsigned int ndx = config.find(name);
+ size_t ndx = config.find(name);
if (ndx == string::npos)
{
@@ -275,7 +275,7 @@ int getConfig(string config, string name
void init_gamedata(gamedata &g){
//--JAM: Read from config file

View file

@ -1,7 +1,6 @@
Patch to build with newer openal. Not sure whether it doesn't leak memory
--- apricots/sampleio.cpp.orig 2003-08-06 03:21:22.000000000 +0400
+++ apricots/sampleio.cpp 2010-04-07 18:32:05.000000000 +0400
@@ -74,28 +74,21 @@
--- apricots/sampleio.cpp.orig 2015-08-19 14:00:09 UTC
+++ apricots/sampleio.cpp
@@ -74,28 +74,21 @@ void sampleio :: init(int nsamples, char
alListenerfv(AL_ORIENTATION, front );
// Load in samples
@ -35,7 +34,7 @@ Patch to build with newer openal. Not sure whether it doesn't leak memory
}
// Generate Sources
@@ -107,8 +100,6 @@
@@ -107,8 +100,6 @@ void sampleio :: init(int nsamples, char
alSourcefv(sources[j], AL_ORIENTATION, back );
}