parent
a46760c2fb
commit
a9953d0862
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=13934
3 changed files with 70 additions and 110 deletions
|
@ -3,7 +3,7 @@
|
|||
# Date created: 25 Now 1995
|
||||
# Whom: Donald Burr <d_burr@ix.netcom.com>
|
||||
#
|
||||
# $Id: Makefile,v 1.7 1998/09/28 01:54:23 steve Exp $
|
||||
# $Id: Makefile,v 1.8 1998/10/11 07:31:38 jseger Exp $
|
||||
#
|
||||
|
||||
DISTNAME= WorkMan-1.3a
|
||||
|
@ -16,11 +16,6 @@ MAINTAINER= d_burr@ix.netcom.com
|
|||
|
||||
LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview-lib
|
||||
|
||||
OSVERSION!= sysctl -n kern.osreldate
|
||||
.if ${OSVERSION} >= 300000
|
||||
BROKEN= scsi.h
|
||||
.endif
|
||||
|
||||
WRKSRC= ${WRKDIR}/workman
|
||||
USE_IMAKE= yes
|
||||
MAN1= workman.1
|
||||
|
|
|
@ -157,110 +157,6 @@ diff -c --recursive ./Makefile ../workman.new/./Makefile
|
|||
cp workman.man $(MANDIR)/man$(PEXT)/workman.$(PEXT)
|
||||
chmod 644 $(MANDIR)/man$(PEXT)/workman.$(PEXT)
|
||||
cp workmandb.man $(MANDIR)/man$(DEXT)/workmandb.$(DEXT)
|
||||
diff -c --recursive ./plat_freebsd.c ../workman.new/./plat_freebsd.c
|
||||
*** ./plat_freebsd.c Mon Feb 20 09:29:55 1995
|
||||
--- ../workman.new/./plat_freebsd.c Sun Nov 26 03:29:22 1995
|
||||
***************
|
||||
*** 5,10 ****
|
||||
--- 5,13 ----
|
||||
*
|
||||
* Todd Pfaff, 3/20/94
|
||||
*
|
||||
+ * 11/26/95: Modified to work under FreeBSD 2.x
|
||||
+ * by Donald Burr <d_burr@ix.netcom.com>
|
||||
+ *
|
||||
*/
|
||||
static char *ident = "@(#)plat_freebsd.c 1.2 2/20/95";
|
||||
|
||||
***************
|
||||
*** 30,42 ****
|
||||
#include "/sys/scsi/scsi_all.h"
|
||||
#include "/sys/scsi/scsi_cd.h"
|
||||
#else
|
||||
#include <scsi/scsi_all.h>
|
||||
#include <scsi/scsi_cd.h>
|
||||
#endif
|
||||
|
||||
#include "struct.h"
|
||||
|
||||
! #define DEFAULT_CD_DEVICE "/dev/rcd0d"
|
||||
|
||||
void *malloc();
|
||||
|
||||
--- 33,49 ----
|
||||
#include "/sys/scsi/scsi_all.h"
|
||||
#include "/sys/scsi/scsi_cd.h"
|
||||
#else
|
||||
+ /*
|
||||
#include <scsi/scsi_all.h>
|
||||
#include <scsi/scsi_cd.h>
|
||||
+ */
|
||||
+ #include <scsi.h>
|
||||
+ #include <sys/scsiio.h>
|
||||
#endif
|
||||
|
||||
#include "struct.h"
|
||||
|
||||
! #define DEFAULT_CD_DEVICE "/dev/rcd0c"
|
||||
|
||||
void *malloc();
|
||||
|
||||
***************
|
||||
*** 163,169 ****
|
||||
}
|
||||
|
||||
if (ioctl(d->fd, CDIOCREADSUBCHANNEL, &sc)) {
|
||||
! #ifdef __NetBSD__
|
||||
/* we need to release the device so the kernel will notice
|
||||
reloaded media */
|
||||
(void) close(d->fd);
|
||||
--- 170,176 ----
|
||||
}
|
||||
|
||||
if (ioctl(d->fd, CDIOCREADSUBCHANNEL, &sc)) {
|
||||
! #if defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__)
|
||||
/* we need to release the device so the kernel will notice
|
||||
reloaded media */
|
||||
(void) close(d->fd);
|
||||
***************
|
||||
*** 261,266 ****
|
||||
--- 268,276 ----
|
||||
|
||||
bzero((char *)&vol, sizeof(vol));
|
||||
|
||||
+ #define LEFT_PORT 0
|
||||
+ #define RIGHT_PORT 1
|
||||
+
|
||||
vol.vol[LEFT_PORT] = left;
|
||||
vol.vol[RIGHT_PORT] = right;
|
||||
|
||||
***************
|
||||
*** 345,356 ****
|
||||
if (fstatfs(stbuf.st_rdev, &buf) == 0)
|
||||
return (-3);
|
||||
|
||||
! #ifdef __NetBSD__
|
||||
rval = ioctl(d->fd, CDIOCALLOW);
|
||||
if (rval == 0)
|
||||
#endif
|
||||
rval = ioctl(d->fd, CDIOCEJECT);
|
||||
! #ifdef __NetBSD__
|
||||
if (rval == 0)
|
||||
rval = ioctl(d->fd, CDIOCPREVENT);
|
||||
#endif
|
||||
--- 355,366 ----
|
||||
if (fstatfs(stbuf.st_rdev, &buf) == 0)
|
||||
return (-3);
|
||||
|
||||
! #if defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__)
|
||||
rval = ioctl(d->fd, CDIOCALLOW);
|
||||
if (rval == 0)
|
||||
#endif
|
||||
rval = ioctl(d->fd, CDIOCEJECT);
|
||||
! #if defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__)
|
||||
if (rval == 0)
|
||||
rval = ioctl(d->fd, CDIOCPREVENT);
|
||||
#endif
|
||||
diff -c --recursive ./workman.man ../workman.new/./workman.man
|
||||
*** ./workman.man Thu Jun 15 23:52:13 1995
|
||||
--- ../workman.new/./workman.man Sun Nov 26 03:28:54 1995
|
||||
|
|
69
audio/workman/files/patch-ac
Normal file
69
audio/workman/files/patch-ac
Normal file
|
@ -0,0 +1,69 @@
|
|||
--- plat_freebsd.c.orig Mon Feb 20 17:29:55 1995
|
||||
+++ plat_freebsd.c Tue Oct 13 03:24:22 1998
|
||||
@@ -5,6 +5,9 @@
|
||||
*
|
||||
* Todd Pfaff, 3/20/94
|
||||
*
|
||||
+ * 11/26/95: Modified to work under FreeBSD 2.x
|
||||
+ * by Donald Burr <d_burr@ix.netcom.com>
|
||||
+ *
|
||||
*/
|
||||
static char *ident = "@(#)plat_freebsd.c 1.2 2/20/95";
|
||||
|
||||
@@ -22,21 +25,17 @@
|
||||
#include <string.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/cdio.h>
|
||||
-#include <sys/scsiio.h>
|
||||
#ifdef __NetBSD__
|
||||
#define MSF_MINUTES 1
|
||||
#define MSF_SECONDS 2
|
||||
#define MSF_FRAMES 3
|
||||
#include "/sys/scsi/scsi_all.h"
|
||||
#include "/sys/scsi/scsi_cd.h"
|
||||
-#else
|
||||
-#include <scsi/scsi_all.h>
|
||||
-#include <scsi/scsi_cd.h>
|
||||
#endif
|
||||
|
||||
#include "struct.h"
|
||||
|
||||
-#define DEFAULT_CD_DEVICE "/dev/rcd0d"
|
||||
+#define DEFAULT_CD_DEVICE "/dev/rcd0c"
|
||||
|
||||
void *malloc();
|
||||
|
||||
@@ -163,7 +162,7 @@
|
||||
}
|
||||
|
||||
if (ioctl(d->fd, CDIOCREADSUBCHANNEL, &sc)) {
|
||||
-#ifdef __NetBSD__
|
||||
+#if defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__)
|
||||
/* we need to release the device so the kernel will notice
|
||||
reloaded media */
|
||||
(void) close(d->fd);
|
||||
@@ -261,6 +260,9 @@
|
||||
|
||||
bzero((char *)&vol, sizeof(vol));
|
||||
|
||||
+#define LEFT_PORT 0
|
||||
+#define RIGHT_PORT 1
|
||||
+
|
||||
vol.vol[LEFT_PORT] = left;
|
||||
vol.vol[RIGHT_PORT] = right;
|
||||
|
||||
@@ -345,12 +347,12 @@
|
||||
if (fstatfs(stbuf.st_rdev, &buf) == 0)
|
||||
return (-3);
|
||||
|
||||
-#ifdef __NetBSD__
|
||||
+#if defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__)
|
||||
rval = ioctl(d->fd, CDIOCALLOW);
|
||||
if (rval == 0)
|
||||
#endif
|
||||
rval = ioctl(d->fd, CDIOCEJECT);
|
||||
-#ifdef __NetBSD__
|
||||
+#if defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__)
|
||||
if (rval == 0)
|
||||
rval = ioctl(d->fd, CDIOCPREVENT);
|
||||
#endif
|
Loading…
Reference in a new issue