xonsh is a Python-ish, BASHwards-looking shell language and command prompt.
The language is a superset of Python 3.4+ with additional shell primitives. xonsh (pronounced conch) is meant for the daily use of experts and novices alike. WWW: http://xon.sh PR: 220596 Submitted by: roberfern@gmail.com
This commit is contained in:
parent
cdad5a196f
commit
a99b06d58b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=450378
6 changed files with 54 additions and 0 deletions
|
@ -45,6 +45,7 @@
|
|||
SUBDIR += viewglob
|
||||
SUBDIR += vshnu
|
||||
SUBDIR += wcd
|
||||
SUBDIR += xonsh
|
||||
SUBDIR += zsh
|
||||
SUBDIR += zsh-navigation-tools
|
||||
|
||||
|
|
21
shells/xonsh/Makefile
Normal file
21
shells/xonsh/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xonsh
|
||||
PORTVERSION= 0.5.12
|
||||
CATEGORIES= shells python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= roberfern@gmail.com
|
||||
COMMENT= Python-ish BASH-wards shell
|
||||
|
||||
LICENSE= BSD2CLAUSE
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}amalgamate>=0:devel/py-amalgamate
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
USES= python:3.4+
|
||||
USE_PYTHON= distutils autoplist concurrent
|
||||
|
||||
.include <bsd.port.mk>
|
3
shells/xonsh/distinfo
Normal file
3
shells/xonsh/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1506080374
|
||||
SHA256 (xonsh-0.5.12.tar.gz) = 4ca8fd5f1ce5532fba252132a7a7db26b38d80429d8d538928d1aed26149e5fb
|
||||
SIZE (xonsh-0.5.12.tar.gz) = 686495
|
11
shells/xonsh/files/patch-xonsh_platform.py
Normal file
11
shells/xonsh/files/patch-xonsh_platform.py
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- xonsh/platform.py.orig 2017-03-12 02:36:40 UTC
|
||||
+++ xonsh/platform.py
|
||||
@@ -491,7 +491,7 @@ def LIBC():
|
||||
libc = ctypes.CDLL('cygwin1.dll')
|
||||
elif ON_BSD:
|
||||
try:
|
||||
- libc = ctypes.CDLL('libc.so')
|
||||
+ libc = ctypes.CDLL(ctypes.util.find_library("c"))
|
||||
except AttributeError:
|
||||
libc = None
|
||||
except OSError:
|
11
shells/xonsh/files/patch-xonsh_xoreutils_uptime.py
Normal file
11
shells/xonsh/files/patch-xonsh_xoreutils_uptime.py
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- xonsh/xoreutils/uptime.py.orig 2017-02-11 16:24:07 UTC
|
||||
+++ xonsh/xoreutils/uptime.py
|
||||
@@ -100,7 +100,7 @@ def _uptime_bsd():
|
||||
return None
|
||||
# Determine how much space we need for the response.
|
||||
sz = ctypes.c_uint(0)
|
||||
- xp.LIBC.sysctlbyname('kern.boottime', None, ctypes.byref(sz), None, 0)
|
||||
+ xp.LIBC.sysctlbyname(b'kern.boottime', None, ctypes.byref(sz), None, 0)
|
||||
if sz.value != struct.calcsize('@LL'):
|
||||
# Unexpected, let's give up.
|
||||
return None
|
7
shells/xonsh/pkg-descr
Normal file
7
shells/xonsh/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
xonsh is a Python-ish, BASHwards-looking shell language and command prompt.
|
||||
|
||||
The language is a superset of Python 3.4+ with additional shell primitives.
|
||||
xonsh (pronounced conch) is meant for the daily use of experts and novices
|
||||
alike.
|
||||
|
||||
WWW: http://xon.sh
|
Loading…
Reference in a new issue