Update to version 0.39.0
Changelog: https://github.com/OpenMW/openmw/releases/tag/openmw-0.39.0 PR: 210729 Submitted by: Tobias Kortkamp (maintainer)
This commit is contained in:
parent
a2130a105d
commit
a9c53ef845
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=417975
17 changed files with 28 additions and 165 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= openmw
|
||||
PORTVERSION= 0.38.0
|
||||
PORTVERSION= 0.39.0
|
||||
DISTVERSIONPREFIX= openmw-
|
||||
CATEGORIES= games
|
||||
|
||||
|
@ -24,10 +24,12 @@ BROKEN_FreeBSD_9= does not build
|
|||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= OpenMW
|
||||
|
||||
USES= cmake:outsource compiler:c++11-lib ninja openal pkgconfig
|
||||
USES= cmake:outsource compiler:c++14-lang ninja openal pkgconfig
|
||||
USE_GL= gl
|
||||
USE_QT5= qmake_build buildtools_build core widgets network opengl
|
||||
USE_QT5= qmake_build buildtools_build core gui network opengl \
|
||||
printsupport widgets
|
||||
USE_SDL= sdl2
|
||||
USE_XORG= xt
|
||||
|
||||
CMAKE_ARGS= -DCMAKE_BUILD_TYPE=Release \
|
||||
-DDESIRED_QT_VERSION=5 \
|
||||
|
@ -37,7 +39,7 @@ CMAKE_ARGS= -DCMAKE_BUILD_TYPE=Release \
|
|||
-DBUILD_LAUNCHER=ON \
|
||||
-DBUILD_MWINIIMPORTER=ON \
|
||||
-DBUILD_ESSIMPORTER=ON \
|
||||
-DBUILD_OPENCS=OFF \
|
||||
-DBUILD_OPENCS=ON \
|
||||
-DBUILD_WIZARD=ON \
|
||||
-DBUILD_WITH_CODE_COVERAGE=OFF \
|
||||
-DBUILD_UNITTEST=OFF \
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (OpenMW-openmw-openmw-0.38.0_GH0.tar.gz) = c16a44ee9a787dcae61a373625d39733868d213fd6e8ccd86ab9e7ac00ecb85a
|
||||
SIZE (OpenMW-openmw-openmw-0.38.0_GH0.tar.gz) = 4137263
|
||||
SHA256 (OpenMW-openmw-openmw-0.39.0_GH0.tar.gz) = b0d294b0814099bd93326f7b86dd84fb727d38dd536bf104272112e6d70ae720
|
||||
SIZE (OpenMW-openmw-openmw-0.39.0_GH0.tar.gz) = 4764754
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- CMakeLists.txt.orig 2016-01-12 16:11:28 UTC
|
||||
--- CMakeLists.txt.orig 2016-06-30 21:09:52 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -224,7 +224,7 @@ if (USE_QT)
|
||||
set (OSG_QT osgQt)
|
||||
@@ -296,7 +296,7 @@ find_package(Boost REQUIRED COMPONENTS $
|
||||
find_package(SDL2 REQUIRED)
|
||||
find_package(OpenAL REQUIRED)
|
||||
find_package(Bullet REQUIRED)
|
||||
-if (NOT BULLET_FOUND OR BULLET_VERSION VERSION_LESS 283)
|
||||
+if (NOT BULLET_FOUND OR BULLET_VERSION VERSION_LESS 282)
|
||||
message(FATAL_ERROR "OpenMW requires Bullet version 2.83 or later")
|
||||
endif()
|
||||
|
||||
-find_package(OpenSceneGraph 3.2.0 REQUIRED osgDB osgViewer osgText osgGA osgAnimation osgParticle ${OSG_QT} osgUtil osgFX)
|
||||
+find_package(OpenSceneGraph 3.2.0 REQUIRED osgDB osgViewer osgText osgGA osgAnimation osgParticle osgUtil osgFX)
|
||||
|
||||
include_directories(${OPENSCENEGRAPH_INCLUDE_DIRS})
|
||||
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- apps/essimporter/converter.hpp.orig 2016-01-12 16:11:28 UTC
|
||||
+++ apps/essimporter/converter.hpp
|
||||
@@ -121,7 +121,7 @@ public:
|
||||
{
|
||||
mContext->mPlayer.mObject.mCreatureStats.mLevel = npc.mNpdt52.mLevel;
|
||||
mContext->mPlayerBase = npc;
|
||||
- std::map<const int, float> empty;
|
||||
+ std::map<int, float> empty;
|
||||
// FIXME: player start spells and birthsign spells aren't listed here,
|
||||
// need to fix openmw to account for this
|
||||
for (std::vector<std::string>::const_iterator it = npc.mSpells.mList.begin(); it != npc.mSpells.mList.end(); ++it)
|
|
@ -1,21 +0,0 @@
|
|||
--- apps/essimporter/convertinventory.cpp.orig 2016-01-12 16:11:28 UTC
|
||||
+++ apps/essimporter/convertinventory.cpp
|
||||
@@ -1,6 +1,7 @@
|
||||
#include "convertinventory.hpp"
|
||||
|
||||
#include <components/misc/stringops.hpp>
|
||||
+#include <cstdlib>
|
||||
|
||||
namespace ESSImport
|
||||
{
|
||||
@@ -15,8 +16,8 @@ namespace ESSImport
|
||||
objstate.blank();
|
||||
objstate.mRef = *it;
|
||||
objstate.mRef.mRefID = Misc::StringUtils::lowerCase(it->mId);
|
||||
- objstate.mCount = std::abs(it->mCount); // restocking items have negative count in the savefile
|
||||
- // openmw handles them differently, so no need to set any flags
|
||||
+ objstate.mCount = abs(it->mCount); // restocking items have negative count in the savefile
|
||||
+ // openmw handles them differently, so no need to set any flags
|
||||
state.mItems.push_back(objstate);
|
||||
if (it->mRelativeEquipmentSlot != -1)
|
||||
// Note we should really write the absolute slot here, which we do not know about
|
|
@ -1,11 +0,0 @@
|
|||
--- apps/openmw/crashcatcher.cpp.orig 2016-01-12 16:11:28 UTC
|
||||
+++ apps/openmw/crashcatcher.cpp
|
||||
@@ -24,7 +24,7 @@
|
||||
#ifndef PR_SET_PTRACER
|
||||
#define PR_SET_PTRACER 0x59616d61
|
||||
#endif
|
||||
-#elif defined (__APPLE__)
|
||||
+#elif defined (__APPLE__) || defined (__FreeBSD__)
|
||||
#include <signal.h>
|
||||
#endif
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- apps/openmw/mwmechanics/spells.cpp.orig 2016-01-19 22:26:03 UTC
|
||||
+++ apps/openmw/mwmechanics/spells.cpp
|
||||
@@ -44,7 +44,7 @@ namespace MWMechanics
|
||||
{
|
||||
if (mSpells.find (spell)==mSpells.end())
|
||||
{
|
||||
- std::map<const int, float> random;
|
||||
+ std::map<int, float> random;
|
||||
|
||||
// Determine the random magnitudes (unless this is a castable spell, in which case
|
||||
// they will be determined when the spell is cast)
|
|
@ -1,11 +0,0 @@
|
|||
--- apps/openmw/mwmechanics/spells.hpp.orig 2016-01-19 22:25:34 UTC
|
||||
+++ apps/openmw/mwmechanics/spells.hpp
|
||||
@@ -33,7 +33,7 @@ namespace MWMechanics
|
||||
|
||||
typedef const ESM::Spell* SpellKey;
|
||||
|
||||
- typedef std::map<SpellKey, std::map<const int, float> > TContainer; // ID, <effect index, normalised random magnitude>
|
||||
+ typedef std::map<SpellKey, std::map<int, float> > TContainer; // ID, <effect index, normalised random magnitude>
|
||||
typedef TContainer::const_iterator TIterator;
|
||||
|
||||
struct CorprusStats
|
|
@ -1,10 +0,0 @@
|
|||
--- apps/openmw/mwworld/projectilemanager.hpp.orig 2016-01-12 16:11:28 UTC
|
||||
+++ apps/openmw/mwworld/projectilemanager.hpp
|
||||
@@ -3,6 +3,7 @@
|
||||
|
||||
#include <string>
|
||||
|
||||
+#include <osg/observer_ptr>
|
||||
#include <osg/ref_ptr>
|
||||
#include <osg/PositionAttitudeTransform>
|
||||
|
|
@ -1,10 +0,0 @@
|
|||
--- apps/openmw/mwworld/refdata.hpp.orig 2016-01-12 16:11:28 UTC
|
||||
+++ apps/openmw/mwworld/refdata.hpp
|
||||
@@ -5,6 +5,7 @@
|
||||
|
||||
#include "../mwscript/locals.hpp"
|
||||
|
||||
+#include <string>
|
||||
#include <osg/Vec3f>
|
||||
|
||||
namespace SceneUtil
|
|
@ -1,11 +0,0 @@
|
|||
--- apps/openmw/mwworld/worldimp.cpp.orig 2016-01-12 16:11:28 UTC
|
||||
+++ apps/openmw/mwworld/worldimp.cpp
|
||||
@@ -108,7 +108,7 @@ namespace MWWorld
|
||||
}
|
||||
|
||||
private:
|
||||
- typedef std::tr1::unordered_map<std::string, ContentLoader*> LoadersContainer;
|
||||
+ typedef std::unordered_map<std::string, ContentLoader*> LoadersContainer;
|
||||
LoadersContainer mLoaders;
|
||||
};
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
--- apps/wizard/CMakeLists.txt.orig 2016-01-12 16:11:28 UTC
|
||||
--- apps/wizard/CMakeLists.txt.orig 2016-04-06 11:40:42 UTC
|
||||
+++ apps/wizard/CMakeLists.txt
|
||||
@@ -150,6 +150,7 @@ endif()
|
||||
@@ -147,6 +147,7 @@ endif()
|
||||
|
||||
# Workaround for binutil => 2.23 problem when linking, should be fixed eventually upstream
|
||||
if (UNIX AND NOT APPLE)
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
--- components/esm/spellstate.cpp.orig 2016-01-12 16:11:28 UTC
|
||||
+++ components/esm/spellstate.cpp
|
||||
@@ -12,7 +12,7 @@ namespace ESM
|
||||
{
|
||||
std::string id = esm.getHString();
|
||||
|
||||
- std::map<const int, float> random;
|
||||
+ std::map<int, float> random;
|
||||
while (esm.isNextSub("INDX"))
|
||||
{
|
||||
int index;
|
||||
@@ -73,8 +73,8 @@ namespace ESM
|
||||
{
|
||||
esm.writeHNString("SPEL", it->first);
|
||||
|
||||
- const std::map<const int, float>& random = it->second;
|
||||
- for (std::map<const int, float>::const_iterator rIt = random.begin(); rIt != random.end(); ++rIt)
|
||||
+ const std::map<int, float>& random = it->second;
|
||||
+ for (std::map<int, float>::const_iterator rIt = random.begin(); rIt != random.end(); ++rIt)
|
||||
{
|
||||
esm.writeHNT("INDX", rIt->first);
|
||||
esm.writeHNT("RAND", rIt->second);
|
|
@ -1,11 +0,0 @@
|
|||
--- components/esm/spellstate.hpp.orig 2016-01-12 16:11:28 UTC
|
||||
+++ components/esm/spellstate.hpp
|
||||
@@ -28,7 +28,7 @@ namespace ESM
|
||||
float mMagnitude;
|
||||
};
|
||||
|
||||
- typedef std::map<std::string, std::map<const int, float> > TContainer;
|
||||
+ typedef std::map<std::string, std::map<int, float> > TContainer;
|
||||
TContainer mSpells;
|
||||
|
||||
std::map<std::string, std::vector<PermanentSpellEffectInfo> > mPermanentSpellEffects;
|
|
@ -1,10 +0,0 @@
|
|||
--- components/resource/bulletshape.cpp.orig 2016-01-12 16:11:28 UTC
|
||||
+++ components/resource/bulletshape.cpp
|
||||
@@ -1,6 +1,7 @@
|
||||
#include "bulletshape.hpp"
|
||||
|
||||
#include <stdexcept>
|
||||
+#include <string>
|
||||
|
||||
#include <BulletCollision/CollisionShapes/btBoxShape.h>
|
||||
#include <BulletCollision/CollisionShapes/btTriangleMesh.h>
|
|
@ -1,10 +0,0 @@
|
|||
--- components/sceneutil/lightcontroller.cpp.orig 2016-01-12 16:11:28 UTC
|
||||
+++ components/sceneutil/lightcontroller.cpp
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
#include <cmath>
|
||||
|
||||
+#include <osg/observer_ptr>
|
||||
#include <osg/NodeVisitor>
|
||||
|
||||
#include <components/sceneutil/lightmanager.hpp>
|
|
@ -1,15 +1,18 @@
|
|||
bin/bsatool
|
||||
bin/esmtool
|
||||
bin/openmw
|
||||
bin/openmw-cs
|
||||
bin/openmw-essimporter
|
||||
bin/openmw-iniimporter
|
||||
bin/openmw-launcher
|
||||
bin/openmw-wizard
|
||||
%%ETCDIR%%/gamecontrollerdb.txt
|
||||
%%ETCDIR%%/openmw-cs.cfg
|
||||
%%ETCDIR%%/openmw.cfg
|
||||
%%ETCDIR%%/settings-default.cfg
|
||||
%%ETCDIR%%/version
|
||||
share/appdata/openmw.appdata.xml
|
||||
share/applications/openmw-cs.desktop
|
||||
share/applications/openmw.desktop
|
||||
%%DATADIR%%/resources/defaultfilters
|
||||
%%DATADIR%%/resources/mygui/DejaVuLGCSansMono.ttf
|
||||
|
@ -97,9 +100,16 @@ share/applications/openmw.desktop
|
|||
%%DATADIR%%/resources/mygui/openmw_wait_dialog_progressbar.layout
|
||||
%%DATADIR%%/resources/mygui/openmw_windows.skin.xml
|
||||
%%DATADIR%%/resources/mygui/skins.xml
|
||||
%%DATADIR%%/resources/shaders/lighting.glsl
|
||||
%%DATADIR%%/resources/shaders/objects_fragment.glsl
|
||||
%%DATADIR%%/resources/shaders/objects_vertex.glsl
|
||||
%%DATADIR%%/resources/shaders/parallax.glsl
|
||||
%%DATADIR%%/resources/shaders/terrain_fragment.glsl
|
||||
%%DATADIR%%/resources/shaders/terrain_vertex.glsl
|
||||
%%DATADIR%%/resources/shaders/water_fragment.glsl
|
||||
%%DATADIR%%/resources/shaders/water_nm.png
|
||||
%%DATADIR%%/resources/shaders/water_vertex.glsl
|
||||
%%DATADIR%%/resources/version
|
||||
share/pixmaps/openmw-cs.png
|
||||
share/pixmaps/openmw.png
|
||||
@dir %%DATADIR%%/data
|
||||
|
|
Loading…
Reference in a new issue