Committed a wrong patch. This is the correct one.
This commit is contained in:
parent
3f785ee468
commit
a9c9ccf424
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=203466
2 changed files with 21 additions and 9 deletions
|
@ -47,6 +47,9 @@ JAVA_VENDOR= freebsd bsdjava
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
.include <${FILESDIR}/Makefile.localized>
|
||||
.if ${OSVERSION} >= 700042
|
||||
BROKEN= fails to install; consider upgrading to editors/openoffice.org-2
|
||||
.endif
|
||||
|
||||
LANG_EXT?= 01
|
||||
LANG_CONFIGURE_ARG?= ENUS
|
||||
|
@ -102,8 +105,7 @@ OOOCXX= ${CXX}
|
|||
.endif
|
||||
CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib" \
|
||||
PATH="${WRKDIR}/bin:${PATH}"
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
|
||||
unzip:${PORTSDIR}/archivers/unzip \
|
||||
|
@ -168,13 +170,12 @@ post-extract:
|
|||
@cd ${WRKSRC} ; ${MV} moz moz.runtime ; ${MV} moz.old moz
|
||||
.endif
|
||||
|
||||
pre-build:
|
||||
@${RM} -rf ${WRKDIR}/bin
|
||||
@${MKDIR} ${WRKDIR}/bin
|
||||
@${LN} -s `which ${CC}` ${WRKDIR}/bin/gcc
|
||||
@${LN} -s `which ${CC}` ${WRKDIR}/bin/cc
|
||||
@${LN} -s `which ${CXX}` ${WRKDIR}/bin/g++
|
||||
@${LN} -s `which ${CXX}` ${WRKDIR}/bin/c++
|
||||
pre-configure:
|
||||
#Workaround for moz project, it uses gcc directly.
|
||||
@${LN} -sf `which ${CC}` ${WRKSRC}/solenv/bin/gcc
|
||||
@${LN} -sf `which ${CC}` ${WRKSRC}/solenv/bin/cc
|
||||
@${LN} -sf `which ${CXX}` ${WRKSRC}/solenv/bin/g++
|
||||
@${LN} -sf `which ${CXX}` ${WRKSRC}/solenv/bin/c++
|
||||
|
||||
do-build:
|
||||
@cd ${WRKSRC} ; ./bootstrap
|
||||
|
|
|
@ -10,8 +10,19 @@ it is not a good habit. in this patch we eleminate this.
|
|||
in the system. We add 100 as micro version number, so that we treat FreeBSD's version of
|
||||
java 1.4.1-p10 for example to 1.4.1_110.
|
||||
|
||||
3. Java version of 1.5.0_13-p7 will be treated as 1.5.0_13. -p part will be ignored.
|
||||
|
||||
--- jvmaccess/source/sunversion.cxx Thu Jun 16 21:45:26 2005
|
||||
+++ jvmaccess/source/sunversion.cxx Sat Oct 22 16:42:01 2005
|
||||
@@ -193,7 +193,7 @@
|
||||
pCur ++;
|
||||
// nPartPos ++;
|
||||
}
|
||||
- else if (nUpdatePart == 0 && (pCur == pEnd || isalpha(*pCur)))
|
||||
+ else if (nUpdatePart == 0 && (pCur == pEnd || isalpha(*pCur) || (*pCur)=='-' ))
|
||||
{
|
||||
int len = pCur - pLast;
|
||||
if (len >= 127)
|
||||
@@ -246,30 +247,22 @@
|
||||
m_preRelease = Rel_RC2;
|
||||
#if defined FREEBSD || defined NETBSD
|
||||
|
|
Loading…
Reference in a new issue