- Update to 0.3.0

PR:		133132
Submitted by:	Toni Gundogdu <legatvs@gmail.com> (maintainer)
This commit is contained in:
Martin Wilke 2009-03-27 22:42:59 +00:00
parent a54efbb381
commit a9ee35b344
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=231166
3 changed files with 8 additions and 64 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= cclive
PORTVERSION= 0.2.6
PORTVERSION= 0.3.0
CATEGORIES= multimedia net
MASTER_SITES= GOOGLE_CODE
@ -18,27 +18,25 @@ LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
OPTIONS= TITLE "Enable video title parsing (req. Perl)" off \
SIGWINCH "Enable SIGWINCH handling; resize progressbar" on
MAKE_ENV= V=1
MAN1= cclive.1
PLIST_FILES= bin/cclive
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_GNOME= pkgconfig
.include <bsd.port.pre.mk>
MAKE_ENV+= WITH_MAN=yes
.if defined(WITH_TITLE)
MAKE_ENV+= WITH_PERL=yes
CONFIGURE_ARGS+=--with-perl
USE_PERL5= 5.8.2+
RUN_DEPENDS+= p5-HTML-Parser>=3.59:${PORTSDIR}/www/p5-HTML-Parser
.endif
.if defined(WITH_SIGWINCH)
MAKE_ENV+= WITH_SIGWINCH=yes
CONFIGURE_ARGS+= --with-sigwinch
.endif
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (cclive-0.2.6.tar.bz2) = 2f596966021df4fd15e0616854ebbdc6
SHA256 (cclive-0.2.6.tar.bz2) = f1ad40c9b6dcfea9732a24b5db94d5820a5c4c2f7680c98cd7e992f5ddf7fc7c
SIZE (cclive-0.2.6.tar.bz2) = 41770
MD5 (cclive-0.3.0.tar.bz2) = dfa72b7f8be7116fbd83cc7a60926eb9
SHA256 (cclive-0.3.0.tar.bz2) = 886d6efffeee5318a70b11dbe8248702ac025d008f0ff16c12c63dcc80911ff7
SIZE (cclive-0.3.0.tar.bz2) = 120446

View file

@ -1,54 +0,0 @@
--- Makefile.orig 2009-03-10 01:13:54.000000000 +0200
+++ Makefile 2009-03-10 01:15:18.000000000 +0200
@@ -1,23 +1,20 @@
# GNU Makefile for cclive.
-SHELL = /bin/sh
-
.SUFFIXES:
.SUFFIXES: .c .o
-prefix = $(HOME)
+prefix = $(PREFIX)
bindir = $(prefix)/bin
exec_prefix = $(prefix)
datarootdir = $(prefix)/share
datadir = $(datarootdir)
-mandir = $(datarootdir)/man
+mandir = $(MANPREFIX)/man
man1dir = $(mandir)/man1
-CC = cc
RM = rm -f
-INSTALL = install -c
-INSTALL_D = install -d
-INSTALL_M = install
+INSTALL = $(BSD_INSTALL_PROGRAM)
+INSTALL_D = mkdir -p
+INSTALL_M = $(BSD_INSTALL_MAN)
UNAME = uname
AWK = awk
CURL_CONFIG = curl-config
@@ -25,10 +22,6 @@
POD2MAN = pod2man
PERL = perl
-WITH_MAN = yes
-WITH_SIGWINCH = yes
-WITH_PERL = no
-
ifndef V
QUIET_CC = @echo ' ' CC $@;
QUIET_LINK = @echo ' ' LINK $@;
@@ -42,11 +35,9 @@
CURL_CFLAGS := $(shell sh -c "$(CURL_CONFIG) --cflags")
CURL_LDFLAGS := $(shell sh -c "$(CURL_CONFIG) --libs")
-CFLAGS = -g -Wall
ALL_CFLAGS = -D_GNU_SOURCE -DOSNAME=\"$(OS_NAME)\" -I. $(CFLAGS)
ALL_CFLAGS += $(CURL_CFLAGS)
-LDFLAGS =
ALL_LDFLAGS = $(LDFLAGS)
ALL_LDFLAGS += $(CURL_LDFLAGS)