Update to 0.8.0
PR: 73680 Submitted by: ahze
This commit is contained in:
parent
10ae617e96
commit
a9fdc07866
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=124453
4 changed files with 10 additions and 62 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= gstreamer
|
||||
PORTVERSION= 0.7.0
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 0.8.0
|
||||
CATEGORIES= multimedia gnome
|
||||
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-editor/
|
||||
PKGNAMESUFFIX= -editor
|
||||
|
@ -16,27 +15,25 @@ DISTNAME= gst-editor-${PORTVERSION}
|
|||
MAINTAINER= lioux@FreeBSD.org
|
||||
COMMENT= Provide View and Controller counterparts to GStreamer's Model
|
||||
|
||||
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
LIB_DEPENDS= gstreamer-0.8.5:${PORTSDIR}/multimedia/gstreamer \
|
||||
popt.0:${PORTSDIR}/devel/popt
|
||||
RUN_DEPENDS= gst-visualise-0.8:${PORTSDIR}/multimedia/gstreamer-plugins
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_LIBTOOL_VER=15
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomehack \
|
||||
gnomehier \
|
||||
gnomeprefix \
|
||||
pkgconfig \
|
||||
gconf2 \
|
||||
libglade2 \
|
||||
libgnomeui
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= PKG_CONFIG=${PKG_CONFIG}
|
||||
PLIST_SUB= \
|
||||
VERSION="${PORTVERSION}"
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= gst-editor.1 gst-inspect-gui.1 gst-launch-gui.1
|
||||
|
||||
PKG_CONFIG?="${LOCALBASE}/bin/pkg-config"
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (gst-editor-0.7.0.tar.bz2) = 4a00e603b7a94a560fafee65162092ad
|
||||
SIZE (gst-editor-0.7.0.tar.bz2) = 340490
|
||||
MD5 (gst-editor-0.8.0.tar.bz2) = 6552880c22f8571438ed29852e28f273
|
||||
SIZE (gst-editor-0.8.0.tar.bz2) = 356642
|
||||
|
|
|
@ -1,51 +0,0 @@
|
|||
--- ltmain.sh.orig Tue Oct 28 09:26:50 2003
|
||||
+++ ltmain.sh Sat Feb 21 15:30:25 2004
|
||||
@@ -1280,7 +1280,7 @@
|
||||
esac
|
||||
elif test "X$arg" = "X-lc_r"; then
|
||||
case $host in
|
||||
- *-*-openbsd* | *-*-freebsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd4*)
|
||||
# Do not include libc_r directly, use -pthread flag.
|
||||
continue
|
||||
;;
|
||||
@@ -1290,8 +1290,16 @@
|
||||
continue
|
||||
;;
|
||||
|
||||
+ -pthread)
|
||||
+ compile_command="$compile_command -pthread"
|
||||
+ finalize_command="$finalize_command -pthread"
|
||||
+ compiler_flags="$compiler_flags -pthread"
|
||||
+ continue
|
||||
+ ;;
|
||||
+
|
||||
-module)
|
||||
module=yes
|
||||
+ build_old_libs=no
|
||||
continue
|
||||
;;
|
||||
|
||||
@@ -3000,6 +3008,9 @@
|
||||
# problems, so we reset it completely
|
||||
verstring=
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
verstring="0.0"
|
||||
;;
|
||||
@@ -5428,10 +5439,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
|
@ -31,22 +31,24 @@ share/gnome/applications/gst-editor.desktop
|
|||
share/gnome/applications/gst-inspect.desktop
|
||||
share/gnome/applications/gst-launch.desktop
|
||||
share/gnome/gst-editor/editor.glade2
|
||||
share/gnome/gst-editor/editorelement.glade2
|
||||
share/gnome/gst-editor/gnome/help/gst-editor/C/gst-editor-manual.xml
|
||||
share/gnome/gst-editor/gnome/help/gst-editor/C/legal.xml
|
||||
share/gnome/gst-editor/gst-debug-ui.glade2
|
||||
share/gnome/gst-editor/gst-editor.png
|
||||
share/gnome/omf/gst-editor/gst-editor-manual-C.omf
|
||||
@exec scrollkeeper-install -q %D/share/gnome/omf/gst-editor/gst-editor-manual-C.omf 2>/dev/null || /usr/bin/true
|
||||
share/gnome/pixmaps/gst-editor.png
|
||||
share/gnome/pixmaps/gst-inspect.png
|
||||
share/gnome/pixmaps/gst-launch.png
|
||||
@unexec rmdir %D/share/gnome/pixmaps 2>/dev/null || true
|
||||
@dirrm share/gnome/omf/gst-editor
|
||||
@unexec rmdir %D/share/gnome/omf 2>/dev/null || true
|
||||
@dirrm share/gnome/gst-editor/gnome/help/gst-editor/C
|
||||
@dirrm share/gnome/gst-editor/gnome/help/gst-editor
|
||||
@dirrm share/gnome/gst-editor/gnome/help
|
||||
@dirrm share/gnome/gst-editor/gnome
|
||||
@dirrm share/gnome/gst-editor
|
||||
@unexec rmdir %D/share/gnome/applications 2>/dev/null || true
|
||||
@unexec rmdir %D/share/gnome 2>/dev/null || true
|
||||
@dirrm include/gst-editor-%%VERSION%%/gst/element-ui
|
||||
@dirrm include/gst-editor-%%VERSION%%/gst/element-browser
|
||||
@dirrm include/gst-editor-%%VERSION%%/gst/editor
|
||||
|
|
Loading…
Reference in a new issue