Add libev port - fast and simple event loop library, that fixes many libevent
bugs and has many additional features.
This commit is contained in:
parent
f84cbe4fe8
commit
aa33df36e5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=203990
6 changed files with 57 additions and 0 deletions
|
@ -572,6 +572,7 @@
|
|||
SUBDIR += libedit
|
||||
SUBDIR += libelf
|
||||
SUBDIR += libepp-nicbr
|
||||
SUBDIR += libev
|
||||
SUBDIR += libevent
|
||||
SUBDIR += libevocosm
|
||||
SUBDIR += libexecinfo
|
||||
|
|
21
devel/libev/Makefile
Normal file
21
devel/libev/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# New ports collection makefile for: libev
|
||||
# Date created: 18 Dec 2007
|
||||
# Whom: vsevolod
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libev
|
||||
PORTVERSION= 1.86
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://dist.schmorp.de/libev/Attic/
|
||||
|
||||
MAINTAINER= vsevolod@FreeBSD.org
|
||||
COMMENT= A full-featured and high-performance event loop library
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
MAN3= ev.3
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/libev/distinfo
Normal file
3
devel/libev/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (libev-1.86.tar.gz) = b90a196f7cd8e9b09c2c2caa39615188
|
||||
SHA256 (libev-1.86.tar.gz) = 8db02bba92cc563399e9628f687c978b6b33530c8cae7f82e32645f3ca646d53
|
||||
SIZE (libev-1.86.tar.gz) = 389386
|
19
devel/libev/files/patch-Makefile.in
Normal file
19
devel/libev/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- Makefile.in.orig 2007-12-18 04:49:11.000000000 +0300
|
||||
+++ Makefile.in 2007-12-18 17:18:57.194279648 +0300
|
||||
@@ -142,14 +142,14 @@
|
||||
VERSION_INFO = 1:0
|
||||
|
||||
EXTRA_DIST = LICENSE libev.m4 autogen.sh \
|
||||
- ev.h ev_vars.h ev_wrap.h event_compat.h ev++.h event.h \
|
||||
+ ev.h ev_vars.h ev_wrap.h event_compat.h ev++.h \
|
||||
ev_epoll.c ev_select.c ev_poll.c ev_kqueue.c ev_port.c ev_win32.c \
|
||||
ev.3 ev.pod
|
||||
|
||||
|
||||
man_MANS = ev.3
|
||||
|
||||
-include_HEADERS = ev.h event_compat.h ev++.h event.h
|
||||
+include_HEADERS = ev.h event_compat.h ev++.h
|
||||
|
||||
lib_LTLIBRARIES = libev.la
|
||||
|
6
devel/libev/pkg-descr
Normal file
6
devel/libev/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
Libev is a high-performance event loop/event model with lots of features.
|
||||
It is modelled (very losely) after libevent and the Event perl module,
|
||||
but aims to be faster and more correct, and also more featureful. And
|
||||
also smaller.
|
||||
|
||||
WWW: http://software.schmorp.de/pkg/libev
|
7
devel/libev/pkg-plist
Normal file
7
devel/libev/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
|||
lib/libev.a
|
||||
lib/libev.la
|
||||
lib/libev.so
|
||||
lib/libev.so.1
|
||||
include/ev.h
|
||||
include/ev++.h
|
||||
include/event_compat.h
|
Loading…
Reference in a new issue