Add morebalance 0.2, a modular open source user-space load
balancing system. PR: 57868 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
This commit is contained in:
parent
3777ea8a6b
commit
aa50c50a7f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=90859
7 changed files with 95 additions and 0 deletions
|
@ -317,6 +317,7 @@
|
|||
SUBDIR += mldonkey-urlslave
|
||||
SUBDIR += mmucl
|
||||
SUBDIR += mopd
|
||||
SUBDIR += morebalance
|
||||
SUBDIR += mpd
|
||||
SUBDIR += mpich
|
||||
SUBDIR += mrt
|
||||
|
|
43
net/morebalance/Makefile
Normal file
43
net/morebalance/Makefile
Normal file
|
@ -0,0 +1,43 @@
|
|||
# New ports collection Makefile for: morebalance
|
||||
# Date created: Wed Oct 8
|
||||
# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= morebalance
|
||||
PORTVERSION= 0.2
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://mindx.dyndns.org/morebalance/
|
||||
|
||||
MAINTAINER= sheepkiller@cultdeadsheep.org
|
||||
COMMENT= A modular open source user-space load balancing system
|
||||
|
||||
USE_REINPLACE= yes
|
||||
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
|
||||
MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
|
||||
USE_GETOPT_LONG= yes
|
||||
|
||||
.if defined(WITH_PCRE)
|
||||
LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
|
||||
CFLAGS+= -DUSE_PCRE
|
||||
LDFLAGS+= -L${LOCALBASE}/lib -lpcre
|
||||
.endif
|
||||
|
||||
.if defined(WITH_TLS)
|
||||
LIB_DEPENDS+= gnutls.7:${PORTSDIR}/security/gnutls \
|
||||
ggz.1:${PORTSDIR}/games/libggz
|
||||
CFLAGS+= -DUSE_TLS
|
||||
LDFLAGS+= -lggz -lgnutls -L${LOCALBASE}/lib
|
||||
.endif
|
||||
|
||||
MAN1= morebalance.1
|
||||
MAN5= morebalance.conf.5
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
|
||||
@${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc/${PORTNAME}.conf.sample
|
||||
@${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${MANPREFIX}/man/man1
|
||||
@${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.conf.5 ${MANPREFIX}/man/man5
|
||||
|
||||
.include <bsd.port.mk>
|
1
net/morebalance/distinfo
Normal file
1
net/morebalance/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (morebalance-0.2.tar.gz) = 2b917d789dcc620abe68df295d91fec7
|
34
net/morebalance/files/patch-Makefile
Normal file
34
net/morebalance/files/patch-Makefile
Normal file
|
@ -0,0 +1,34 @@
|
|||
--- Makefile.orig Wed Oct 8 13:54:08 2003
|
||||
+++ Makefile Sat Oct 11 15:38:37 2003
|
||||
@@ -1,26 +1,21 @@
|
||||
VERSION = 0.2
|
||||
-#PCRE=-lpcre
|
||||
-#GNUTLS=-lggz -lgnutls
|
||||
-
|
||||
-CC = gcc
|
||||
-CFLAGS = -Wall -O3 -ggdb3
|
||||
|
||||
OBJECTS = main.o conf.o sys.o magic.o server.o ipban.o filter.o
|
||||
|
||||
all: morebalance
|
||||
|
||||
morebalance: $(OBJECTS)
|
||||
- $(CC) -o $@ $(OBJECTS) -lpthread $(PCRE) $(GNUTLS)
|
||||
+ $(CC) $(CFLAGS) -o $@ $(OBJECTS) $(LDFLAGS)
|
||||
|
||||
clean:
|
||||
rm -f *.o
|
||||
rm -f morebalance
|
||||
|
||||
install: morebalance
|
||||
- install -d -m755 $(DESTDIR)$(prefix)/usr/bin
|
||||
- install -d -m755 $(DESTDIR)$(prefix)/etc
|
||||
- cp morebalance $(DESTDIR)$(prefix)/usr/bin
|
||||
- cp morebalance.conf $(DESTDIR)$(prefix)/etc
|
||||
+ install -d -m755 $(DESTDIR)$(PREFIX)/bin
|
||||
+ install -d -m755 $(DESTDIR)$(PREFIX)/etc
|
||||
+ cp morebalance $(DESTDIR)$(PREFIX)/bin
|
||||
+ cp morebalance.conf $(DESTDIR)$(PREFIX)/etc
|
||||
|
||||
distclean: clean
|
||||
rm -f configure-stamp
|
10
net/morebalance/files/patch-sys.c
Normal file
10
net/morebalance/files/patch-sys.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- sys.c.orig Sat Oct 11 20:37:45 2003
|
||||
+++ sys.c Sat Oct 11 20:38:00 2003
|
||||
@@ -2,6 +2,7 @@
|
||||
#include "sys.h"
|
||||
|
||||
/* System includes */
|
||||
+#include <sys/types.h>
|
||||
#include <netdb.h>
|
||||
#include <netinet/in.h>
|
||||
#include <stdlib.h>
|
4
net/morebalance/pkg-descr
Normal file
4
net/morebalance/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
MoreBalance is a modular open source user-space load balancing system.
|
||||
It also serves as a general fun networking tool.
|
||||
|
||||
WWW: http://mindx.dyndns.org/morebalance/
|
2
net/morebalance/pkg-plist
Normal file
2
net/morebalance/pkg-plist
Normal file
|
@ -0,0 +1,2 @@
|
|||
sbin/morebalance
|
||||
etc/morebalance.conf.sample
|
Loading…
Reference in a new issue