Add the missing extra-patch-sgmlformat patch and fix a few things:
* Adding the missing patch fixes the breakage if not built without defining WITHOUT_MUTT_SGMLFORMAT. * Fix for if both WITH_MUTT_NNTP and WITH_MUTT_PGP_OUTLOOK_PATCH are defined. * Fix pkg-plist if WITH_MUTT_PGP_OUTLOOK_PATCH and WITH_MUTT_HTML are both defined. Submitted by: maintainer
This commit is contained in:
parent
f11850c2eb
commit
aa5556a4bd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=55288
4 changed files with 28 additions and 11 deletions
|
@ -46,7 +46,7 @@
|
|||
|
||||
PORTNAME= mutt-devel
|
||||
PORTVERSION= 1.3.27
|
||||
PORTREVISION?= 4
|
||||
PORTREVISION?= 5
|
||||
CATEGORIES+= mail
|
||||
.if defined(WITH_MUTT_NNTP)
|
||||
CATEGORIES+= news
|
||||
|
@ -392,7 +392,11 @@ PLIST_SUB+= SUB_ADD_G="@comment "
|
|||
post-patch::
|
||||
${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-nodoc-contrib
|
||||
.endif
|
||||
|
||||
.if defined(MUTT_WITH_PGP_OUTLOOK_PATCH)
|
||||
PLIST_SUB+= SUB_PGP=""
|
||||
.else
|
||||
PLIST_SUB+= SUB_PGP="@comment "
|
||||
.endif
|
||||
.if ${SGML_USED} == yes
|
||||
BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
|
||||
post-patch::
|
||||
|
|
|
@ -14,18 +14,12 @@
|
|||
/* XXX Default values! */
|
||||
|
||||
{ "pgp_decode_command", DT_STR, R_NONE, UL &PgpDecodeCommand, 0},
|
||||
--- mutt.h.orig Mon Feb 12 08:52:29 2001
|
||||
+++ mutt.h Sat Feb 24 18:05:56 2001
|
||||
@@ -249,7 +249,9 @@
|
||||
#ifdef HAVE_PGP
|
||||
OPT_VERIFYSIG, /* verify PGP signatures */
|
||||
--- mutt.h.orig Tue Feb 26 22:40:16 2002
|
||||
+++ mutt.h Tue Feb 26 22:44:05 2002
|
||||
@@ -263,2 +263,3 @@
|
||||
OPT_PGPTRADITIONAL, /* create old-style PGP messages */
|
||||
+ OPT_PGPOUTLOOK, /* Create even older broken outlook compatible messages */
|
||||
#endif
|
||||
+
|
||||
|
||||
OPT_PRINT,
|
||||
OPT_INCLUDE,
|
||||
--- pgp.c.orig Mon Feb 12 08:55:21 2001
|
||||
+++ pgp.c Sat Feb 24 18:11:40 2001
|
||||
@@ -1501,12 +1501,20 @@
|
||||
|
|
11
mail/mutt-devel/files/extra-patch-sgmlformat
Normal file
11
mail/mutt-devel/files/extra-patch-sgmlformat
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- doc/Makefile.in.orig2 Sat Feb 2 18:30:27 2002
|
||||
+++ doc/Makefile.in Sat Feb 2 18:32:39 2002
|
||||
@@ -60,7 +60,7 @@
|
||||
topsrcdir_DOCFILES = COPYRIGHT GPL INSTALL ChangeLog \
|
||||
README NEWS TODO README.SECURITY README.SSL
|
||||
|
||||
-all:
|
||||
+all: muttrc.man try-html try-txt try-latin1
|
||||
|
||||
try-html: ../makedoc
|
||||
rm -f *.html && $(MAKE) manual.html || cp $(srcdir)/manual*.html ./
|
|
@ -346,6 +346,7 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
|
|||
%%SUB_HTML%%share/doc/mutt/html/manual332.html
|
||||
%%SUB_HTML%%share/doc/mutt/html/manual333.html
|
||||
%%SUB_HTML%%share/doc/mutt/html/manual334.html
|
||||
%%SUB_HTML%%%%SUB_PGP%%share/doc/mutt/html/manual335.html
|
||||
%%SUB_HTML%%share/doc/mutt/html/manual34.html
|
||||
%%SUB_HTML%%share/doc/mutt/html/manual35.html
|
||||
%%SUB_HTML%%share/doc/mutt/html/manual36.html
|
||||
|
@ -420,11 +421,13 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
|
|||
%%SUB_HTML%%share/doc/mutt/html/manual99.html
|
||||
%%SUB_ADD_A%%share/doc/mutt/html/manual335.html
|
||||
%%SUB_ADD_A%%share/doc/mutt/html/manual336.html
|
||||
%%SUB_ADD_A%%%%SUB_PGP%%share/doc/mutt/html/manual337.html
|
||||
%%SUB_ADD_B%%share/doc/mutt/html/manual335.html
|
||||
%%SUB_ADD_B%%share/doc/mutt/html/manual336.html
|
||||
%%SUB_ADD_B%%share/doc/mutt/html/manual337.html
|
||||
%%SUB_ADD_B%%share/doc/mutt/html/manual338.html
|
||||
%%SUB_ADD_B%%share/doc/mutt/html/manual339.html
|
||||
%%SUB_ADD_B%%%%SUB_PGP%%share/doc/mutt/html/manual340.html
|
||||
%%SUB_ADD_C%%share/doc/mutt/html/manual335.html
|
||||
%%SUB_ADD_C%%share/doc/mutt/html/manual336.html
|
||||
%%SUB_ADD_C%%share/doc/mutt/html/manual337.html
|
||||
|
@ -432,6 +435,7 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
|
|||
%%SUB_ADD_C%%share/doc/mutt/html/manual339.html
|
||||
%%SUB_ADD_C%%share/doc/mutt/html/manual340.html
|
||||
%%SUB_ADD_C%%share/doc/mutt/html/manual341.html
|
||||
%%SUB_ADD_C%%%%SUB_PGP%%share/doc/mutt/html/manual342.html
|
||||
%%SUB_ADD_D%%share/doc/mutt/html/manual335.html
|
||||
%%SUB_ADD_D%%share/doc/mutt/html/manual336.html
|
||||
%%SUB_ADD_D%%share/doc/mutt/html/manual337.html
|
||||
|
@ -453,6 +457,7 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
|
|||
%%SUB_ADD_D%%share/doc/mutt/html/manual353.html
|
||||
%%SUB_ADD_D%%share/doc/mutt/html/manual354.html
|
||||
%%SUB_ADD_D%%share/doc/mutt/html/manual355.html
|
||||
%%SUB_ADD_D%%%%SUB_PGP%%share/doc/mutt/html/manual356.html
|
||||
%%SUB_ADD_E%%share/doc/mutt/html/manual335.html
|
||||
%%SUB_ADD_E%%share/doc/mutt/html/manual336.html
|
||||
%%SUB_ADD_E%%share/doc/mutt/html/manual337.html
|
||||
|
@ -476,6 +481,7 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
|
|||
%%SUB_ADD_E%%share/doc/mutt/html/manual355.html
|
||||
%%SUB_ADD_E%%share/doc/mutt/html/manual356.html
|
||||
%%SUB_ADD_E%%share/doc/mutt/html/manual357.html
|
||||
%%SUB_ADD_E%%%%SUB_PGP%%share/doc/mutt/html/manual358.html
|
||||
%%SUB_ADD_F%%share/doc/mutt/html/manual335.html
|
||||
%%SUB_ADD_F%%share/doc/mutt/html/manual336.html
|
||||
%%SUB_ADD_F%%share/doc/mutt/html/manual337.html
|
||||
|
@ -502,6 +508,7 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
|
|||
%%SUB_ADD_F%%share/doc/mutt/html/manual358.html
|
||||
%%SUB_ADD_F%%share/doc/mutt/html/manual359.html
|
||||
%%SUB_ADD_F%%share/doc/mutt/html/manual360.html
|
||||
%%SUB_ADD_F%%%%SUB_PGP%%share/doc/mutt/html/manual361.html
|
||||
%%SUB_ADD_G%%share/doc/mutt/html/manual335.html
|
||||
%%SUB_ADD_G%%share/doc/mutt/html/manual336.html
|
||||
%%SUB_ADD_G%%share/doc/mutt/html/manual337.html
|
||||
|
@ -530,5 +537,6 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
|
|||
%%SUB_ADD_G%%share/doc/mutt/html/manual360.html
|
||||
%%SUB_ADD_G%%share/doc/mutt/html/manual361.html
|
||||
%%SUB_ADD_G%%share/doc/mutt/html/manual362.html
|
||||
%%SUB_ADD_G%%%%SUB_PGP%%share/doc/mutt/html/manual363.html
|
||||
%%SUB_HTML%%@dirrm share/doc/mutt/html
|
||||
%%PORTDOCS%%@dirrm share/doc/mutt
|
||||
|
|
Loading…
Reference in a new issue