obsolete/no port need this
This commit is contained in:
parent
ecdd8aa8fe
commit
aa6142e85f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=131486
8 changed files with 1 additions and 113 deletions
1
MOVED
1
MOVED
|
@ -1434,3 +1434,4 @@ chinese/scim-chinese|chinese/scim-pinyin|2005-03-13|project renamed
|
|||
games/netpanzerdata|games/netpanzer-data|2005-03-13|port name changed
|
||||
databases/py-PySQLite|databases/py-PySQLite10|2005-03-14|renamed
|
||||
mail/sylpheed-gtk2|mail/sylpheed2|2005-03-16|obsoleted by official gtk2 version
|
||||
x11-toolkits/bakery_gnomeui||2005-03-17|obsolete/no port need this
|
||||
|
|
|
@ -8,7 +8,6 @@
|
|||
SUBDIR += Xaw3d
|
||||
SUBDIR += XawPlus
|
||||
SUBDIR += bakery
|
||||
SUBDIR += bakery_gnomeui
|
||||
SUBDIR += blt
|
||||
SUBDIR += bwidget
|
||||
SUBDIR += easygtk
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
# New ports collection makefile for: bakery_gnomeui
|
||||
# Date created: 28 Nov 2003
|
||||
# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= bakery_gnomeui
|
||||
PORTVERSION= 2.0.0
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= x11-toolkits gnome
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= bakery
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= A Bakery C++ Application Framework extention for GNOME
|
||||
|
||||
LIB_DEPENDS= bakery-2.3:${PORTSDIR}/x11-toolkits/bakery \
|
||||
gnomeuimm-2.0:${PORTSDIR}/x11-toolkits/libgnomeuimm
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_PERL5= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomeprefix gnomehack gnometarget
|
||||
USE_INC_LIBTOOL_VER=13
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
MD5 (bakery_gnomeui-2.0.0.tar.gz) = 6bb5eac1d7443c24b7088c56fe086960
|
||||
SIZE (bakery_gnomeui-2.0.0.tar.gz) = 354488
|
|
@ -1,11 +0,0 @@
|
|||
--- bakery_gnomeui/Makefile.in.orig Fri Nov 28 12:32:22 2003
|
||||
+++ bakery_gnomeui/Makefile.in Fri Nov 28 12:32:52 2003
|
||||
@@ -189,7 +189,7 @@
|
||||
Configuration/libbakery_gnomeui_configuration.la \
|
||||
$(BAKERY_GNOMEUI_LIBS)
|
||||
|
||||
-libbakery_gnomeui_2_0_la_LDFLAGS = -version-info $(GENERIC_LIBRARY_VERSION) -release $(GENERIC_RELEASE)
|
||||
+libbakery_gnomeui_2_0_la_LDFLAGS = -version-info $(GENERIC_LIBRARY_VERSION)
|
||||
subdir = bakery_gnomeui
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
|
@ -1,51 +0,0 @@
|
|||
--- ltmain.sh.orig Fri Sep 12 14:51:51 2003
|
||||
+++ ltmain.sh Sun Sep 21 17:49:07 2003
|
||||
@@ -1280,7 +1280,7 @@
|
||||
esac
|
||||
elif test "X$arg" = "X-lc_r"; then
|
||||
case $host in
|
||||
- *-*-openbsd* | *-*-freebsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd4*)
|
||||
# Do not include libc_r directly, use -pthread flag.
|
||||
continue
|
||||
;;
|
||||
@@ -1290,8 +1290,16 @@
|
||||
continue
|
||||
;;
|
||||
|
||||
+ -pthread)
|
||||
+ compile_command="$compile_command -pthread"
|
||||
+ finalize_command="$finalize_command -pthread"
|
||||
+ compiler_flags="$compiler_flags -pthread"
|
||||
+ continue
|
||||
+ ;;
|
||||
+
|
||||
-module)
|
||||
module=yes
|
||||
+ build_old_libs=no
|
||||
continue
|
||||
;;
|
||||
|
||||
@@ -3000,6 +3008,9 @@
|
||||
# problems, so we reset it completely
|
||||
verstring=
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
verstring="0.0"
|
||||
;;
|
||||
@@ -5428,10 +5439,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
|
@ -1,4 +0,0 @@
|
|||
This is a Bakery C++ Application Framework extension for creating
|
||||
GNOME applications. A set of libgnomeuimm based implementations.
|
||||
|
||||
WWW: http://bakery.sourceforge.net/
|
|
@ -1,14 +0,0 @@
|
|||
include/bakery_gnomeui-2.0/bakery_gnomeui/App/App_GnomeUI.h
|
||||
include/bakery_gnomeui-2.0/bakery_gnomeui/App/App_WithDoc_GnomeUI.h
|
||||
include/bakery_gnomeui-2.0/bakery_gnomeui/Configuration/Client.h
|
||||
include/bakery_gnomeui-2.0/bakery_gnomeui/Configuration/Dialog_Preferences.h
|
||||
include/bakery_gnomeui-2.0/bakery_gnomeui/bakery_gnomeui.h
|
||||
lib/libbakery_gnomeui-2.0.a
|
||||
lib/libbakery_gnomeui-2.0.so
|
||||
lib/libbakery_gnomeui-2.0.so.1
|
||||
libdata/pkgconfig/bakery_gnomeui-2.0.pc
|
||||
share/locale/de/LC_MESSAGES/bakery_gnomeui.mo
|
||||
@dirrm include/bakery_gnomeui-2.0/bakery_gnomeui/Configuration
|
||||
@dirrm include/bakery_gnomeui-2.0/bakery_gnomeui/App
|
||||
@dirrm include/bakery_gnomeui-2.0/bakery_gnomeui
|
||||
@dirrm include/bakery_gnomeui-2.0
|
Loading…
Reference in a new issue