- Update gimp-devel to 2.3.15
- Split gimp-devel into a meta-port Repocopyed by: marcus
This commit is contained in:
parent
b09c2714ca
commit
aa9978bef1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=189193
17 changed files with 443 additions and 2992 deletions
|
@ -3,103 +3,79 @@
|
|||
# Whom: erich@FreeBSD.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/graphics/gimp-devel/Makefile,v 1.24 2006/10/13 23:42:43 marcus Exp $
|
||||
# $MCom: ports/graphics/gimp-app-devel/Makefile,v 1.12 2007/04/03 17:41:42 ahze Exp $
|
||||
#
|
||||
|
||||
PORTNAME= gimp
|
||||
PORTVERSION= 2.3.9
|
||||
PORTREVISION= 2
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= graphics gnome
|
||||
PORTVERSION= 2.3.15
|
||||
PORTEPOCH?= 1
|
||||
CATEGORIES?= graphics gnome
|
||||
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
|
||||
http://gimp.mirrors.hoobly.com/%SUBDIR%/ \
|
||||
http://ftp.gwdg.de/pub/misc/grafik/gimp/%SUBDIR%/ \
|
||||
ftp://ftp.fh-heilbronn.de/mirrors/ftp.gimp.org/%SUBDIR%/ \
|
||||
ftp://ftp.insync.net/pub/mirrors/ftp.gimp.org/%SUBDIR%/ \
|
||||
http://www.mirrorservice.org/sites/ftp.gimp.org/pub/%SUBDIR%/ \
|
||||
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/%SUBDIR%,} \
|
||||
${MASTER_SITE_LOCAL:S|$|ahze/|:S|$|:gut|}
|
||||
MASTER_SITE_SUBDIR= gimp/v${PORTVERSION:R} \
|
||||
ahze:gut
|
||||
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${EXTRA_DISTFILES}
|
||||
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/%SUBDIR%,}
|
||||
MASTER_SITE_SUBDIR= gimp/v${PORTVERSION:R}
|
||||
PKGNAMESUFFIX?= -app-devel
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= A GNU Image Manipulation Program development version
|
||||
|
||||
LIB_DEPENDS= wmf.2:${PORTSDIR}/graphics/libwmf \
|
||||
LIB_DEPENDS= exif.12:${PORTSDIR}/graphics/libexif \
|
||||
wmf.2:${PORTSDIR}/graphics/libwmf \
|
||||
poppler-glib.1:${PORTSDIR}/graphics/poppler-gtk \
|
||||
aa.1:${PORTSDIR}/graphics/aalib \
|
||||
mng.1:${PORTSDIR}/graphics/libmng \
|
||||
png.5:${PORTSDIR}/graphics/png \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
tiff.4:${PORTSDIR}/graphics/tiff
|
||||
|
||||
CONFLICTS= gimp-1.* gimp-2.2.*
|
||||
NO_LATEST_LINK= yes
|
||||
|
||||
SHLIBVER?= 0
|
||||
tiff.4:${PORTSDIR}/graphics/tiff \
|
||||
lcms.1:${PORTSDIR}/graphics/lcms
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GETTEXT= yes
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_GNOME= gnomehack intltool intlhack gtk20 libartlgpl2 ltverhack
|
||||
USE_GNOME= gnomehack intltool intlhack gtk20 libartlgpl2 ltverhack desktopfileutils
|
||||
WANT_GNOME= yes
|
||||
USE_GCC= 3.4+
|
||||
USE_LDCONFIG= yes
|
||||
INSTALLS_ICONS= yes
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
PLIST_SUB= SHLIBVER="${SHLIBVER}"
|
||||
CONFIGURE_ARGS= --disable-perl \
|
||||
CONFIGURE_ARGS?=--disable-perl \
|
||||
--with-html-dir=${DOCSDIR} \
|
||||
--disable-gtk-doc \
|
||||
--enable-static \
|
||||
--with-gimpprint
|
||||
--without-print \
|
||||
--disable-python \
|
||||
--with-desktop-dir=${PREFIX}/share
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
|
||||
|
||||
GIMP_DISTFILE= ${DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
|
||||
|
||||
MAN1= gimp-2.3.1 gimp-remote-2.3.1 gimptool-2.0.1
|
||||
MAN5= gimprc-2.3.5
|
||||
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
|
||||
GIMP_THREAD_LIBS=${PTHREAD_LIBS}
|
||||
|
||||
.if !defined(GIMP_SLAVE)
|
||||
OPTIONS= DEBUG "debugging" off \
|
||||
PYTHON "Python-Fu support" off \
|
||||
RSVG "SVG format support" on \
|
||||
PRINT "Gutenprint plugin" on \
|
||||
GNOMEPRINT "GNOME printing plugin" on \
|
||||
MP "multiple processor support" off
|
||||
MP "multiple processor support" off \
|
||||
RSVG "SVG format support" on
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
IGNORE= does not build on 4.X
|
||||
.endif
|
||||
.if defined(GIMP_SLAVE)
|
||||
PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
|
||||
GIMP_LIBS= `${PKG_CONFIG} --libs gimp-2.0`
|
||||
GIMP_THUMB_LIBS=`${PKG_CONFIG} --libs gimpthumb-2.0`
|
||||
GIMP_UI_LIBS= `${PKG_CONFIG} --libs gimpui-2.0`
|
||||
|
||||
#.if defined(WITHOUT_EXIF)
|
||||
CONFIGURE_ARGS+= --without-libexif
|
||||
#.else
|
||||
#LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
|
||||
#.endif
|
||||
LIB_DEPENDS+= gimp-2.0.0:${PORTSDIR}/graphics/gimp-app
|
||||
|
||||
.if defined(WITH_DEBUG)
|
||||
CONFIGURE_ARGS+= --enable-debug
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PYTHON)
|
||||
USE_PYTHON= yes
|
||||
# we need to manually include this, because USE_PYTHON is defined
|
||||
# # after including bsd.port.pre.mk
|
||||
.include "${PORTSDIR}/Mk/bsd.python.mk"
|
||||
USE_GNOME+= pygtk2
|
||||
CONFIGURE_ARGS+= --enable-python
|
||||
PLIST_SUB+= PYTHON:=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-python
|
||||
PLIST_SUB+= PYTHON:="@comment "
|
||||
.endif
|
||||
|
||||
CONFLICTS= gimp-1.* gimp-app-[0-9]*
|
||||
|
||||
MAN1+= gimp-2.3.1 gimp-remote-2.3.1 gimptool-2.0.1
|
||||
MAN5+= gimprc-2.3.5
|
||||
|
||||
.if defined(WITHOUT_RSVG)
|
||||
CONFIGURE_ARGS+= --without-librsvg
|
||||
|
@ -109,69 +85,41 @@ USE_GNOME+= librsvg2
|
|||
PLIST_SUB+= SVG=""
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
LIB_DEPENDS+= gutenprintui2.1:${PORTSDIR}/print/gutenprint
|
||||
EXTRA_DISTFILES+= gimp2-gutenprint-2${EXTRACT_SUFX}:gut
|
||||
GUT_WRKSRC= ${WRKDIR}/gimp2-gutenprint
|
||||
PKGCONFIG?= ${LOCALBASE}/bin/pkg-config
|
||||
GUTENPRINT_CFLAGS= `${PKGCONFIG} --cflags gutenprintui2`
|
||||
GUTENPRINT_LIBS= `${PKGCONFIG} --libs gutenprintui2`
|
||||
GUT_MAKE_ENV= GUTENPRINT_CFLAGS="${GUTENPRINT_CFLAGS}" \
|
||||
GUTENPRINT_LIBS="${GUTENPRINT_LIBS}"
|
||||
PLIST_SUB+= GPRINT=""
|
||||
.else
|
||||
PLIST_SUB+= GPRINT="@comment "
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_GNOMEPRINT)
|
||||
USE_GNOME+= libgnomeprintui
|
||||
PLIST_SUB+= PRINT=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-gnomeprint
|
||||
PLIST_SUB+= PRINT="@comment "
|
||||
.if defined(WITH_DEBUG)
|
||||
CONFIGURE_ARGS+= --enable-debug
|
||||
.endif
|
||||
|
||||
.if defined(WITH_MP)
|
||||
CONFIGURE_ARGS+= --enable-mp
|
||||
.endif
|
||||
|
||||
.if ${HAVE_GNOME:Mgnomepanel}!=""
|
||||
USE_GNOME+= gnomepanel desktopfileutils gnomehier
|
||||
CONFIGURE_ARGS+= --with-desktop-dir=${LOCALBASE}/share/gnome
|
||||
CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
|
||||
PKGNAMESUFFIX:= -gnome
|
||||
PLIST_SUB+= GTK="gnome/" GNOMEPANEL:=""
|
||||
GNOME_ENABLED= yes
|
||||
.else
|
||||
PLIST_SUB+= GTK="" GNOMEPANEL:="@comment "
|
||||
CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
|
||||
CONFIGURE_ARGS+= --without-desktop-dir
|
||||
CONFIGURE_ARGS+= --disable-mp
|
||||
.endif
|
||||
|
||||
.if ${HAVE_GNOME:Mgnomehier}!="" || defined(WITH_GNOME)
|
||||
USE_GNOME+= desktopfileutils gnomehier
|
||||
PLIST_SUB+= GNOME=""
|
||||
.else
|
||||
PLIST_SUB+= GNOME="@comment "
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
${RM} -rf ${WRKSRC}/plug-ins/print
|
||||
${MKDIR} ${WRKSRC}/plug-ins/print
|
||||
${CP} -f ${GUT_WRKSRC}/* ${WRKSRC}/plug-ins/print
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%GIMP_LIBS%%|${GIMP_LIBS}|; \
|
||||
s|%%GIMP_THUMB_LIBS%%|${GIMP_THUMB_LIBS}|; \
|
||||
s|%%GIMP_UI_LIBS%%|${GIMP_UI_LIBS}|' \
|
||||
${WRKSRC}/plug-ins/pygimp/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|"libpng"|"libpng12"|' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|@mandir@|${PREFIX}/man|' \
|
||||
${WRKSRC}/docs/Makefile.in
|
||||
|
||||
post-build:
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
@(cd ${WRKSRC}/plug-ins/print; ${SETENV} ${GUT_MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
@(cd ${WRKSRC}/plug-ins/print; ${SETENV} ${GUT_MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
|
||||
.if ${HAVE_GNOME:Mgnomehier}!="" || defined(WITH_GNOME)
|
||||
${MKDIR} ${PREFIX}/share/gnome/mime-info ${PREFIX}/share/gnome/application-registry
|
||||
${INSTALL_DATA} ${WRKSRC}/desktop/gimp.applications ${PREFIX}/share/gnome/application-registry
|
||||
${INSTALL_DATA} ${WRKSRC}/desktop/gimp.keys ${PREFIX}/share/gnome/mime-info
|
||||
.endif
|
||||
.if defined(GNOME_ENABLED)
|
||||
@-update-desktop-database
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,6 +1,3 @@
|
|||
MD5 (gimp-2.3.9.tar.bz2) = 4299e81e1824e08a90b50dc8beb46151
|
||||
SHA256 (gimp-2.3.9.tar.bz2) = 64c334f99cc4e5204a1925299b7a1da3d027f0b1c6900e6309f5b8da40aa9f10
|
||||
SIZE (gimp-2.3.9.tar.bz2) = 15183977
|
||||
MD5 (gimp2-gutenprint-2.tar.bz2) = d24f0e7bd1f2e62984395293b5f1a43d
|
||||
SHA256 (gimp2-gutenprint-2.tar.bz2) = 3226cf58210fd796e5748817256d29de425e21b093fb84997b787df050344164
|
||||
SIZE (gimp2-gutenprint-2.tar.bz2) = 15155
|
||||
MD5 (gimp-2.3.15.tar.bz2) = ca1ac6c338866020b9ebe98d134bd749
|
||||
SHA256 (gimp-2.3.15.tar.bz2) = 419f42a6e9b305a6b7870771ef072e64265f9332f8dcfa341ba14f5216aa0ac7
|
||||
SIZE (gimp-2.3.15.tar.bz2) = 16080133
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- app/main.c.orig Fri Jun 9 12:02:54 2006
|
||||
+++ app/main.c Fri Jun 9 12:03:28 2006
|
||||
@@ -18,7 +18,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
-#define _POSIX_SOURCE /* all the sigaction stuff is POSIX */
|
||||
+#define __XSI_VISIBLE
|
||||
#define _SVID_SOURCE /* except for SA_RESTART, it seems */
|
||||
|
||||
#include <stdio.h>
|
|
@ -1,6 +1,6 @@
|
|||
--- configure.orig Sun Mar 6 15:30:12 2005
|
||||
+++ configure Sun Mar 6 15:33:57 2005
|
||||
@@ -25925,6 +25925,7 @@
|
||||
--- configure.orig Thu Nov 23 15:16:53 2006
|
||||
+++ configure Sun Dec 31 19:29:32 2006
|
||||
@@ -29404,6 +29404,7 @@
|
||||
if test "x$enable_gtktest" = "xyes" ; then
|
||||
ac_save_CFLAGS="$CFLAGS"
|
||||
ac_save_LIBS="$LIBS"
|
||||
|
@ -8,9 +8,18 @@
|
|||
CFLAGS="$CFLAGS $GTK_CFLAGS"
|
||||
LIBS="$GTK_LIBS $LIBS"
|
||||
rm -f conf.gtktest
|
||||
@@ -33865,9 +33866,9 @@
|
||||
@@ -35211,7 +35212,7 @@
|
||||
fi
|
||||
{ echo "$as_me:$LINENO: result: $have_exif_0_6" >&5
|
||||
echo "${ECHO_T}$have_exif_0_6" >&6; }
|
||||
- if test x$have_exif_0_6 == xyes; then
|
||||
+ if test x$have_exif_0_6 = xyes; then
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_EXIF_0_6 1
|
||||
@@ -38514,9 +38515,9 @@
|
||||
fi
|
||||
fi;
|
||||
|
||||
|
||||
-gimpdatadir="$datadir/$PACKAGE/2.0"
|
||||
-gimpplugindir="$libdir/$PACKAGE/2.0"
|
||||
|
@ -19,5 +28,5 @@
|
|||
+gimpplugindir="$libexecdir/$PACKAGE/2.2"
|
||||
+gimpsysconfdir="$sysconfdir/$PACKAGE/2.2"
|
||||
|
||||
localedir='${prefix}/${DATADIRNAME}/locale'
|
||||
|
||||
|
||||
|
|
33
graphics/gimp-app-devel/files/patch-desktop_Makefile.in
Normal file
33
graphics/gimp-app-devel/files/patch-desktop_Makefile.in
Normal file
|
@ -0,0 +1,33 @@
|
|||
--- desktop/Makefile.in.orig Mon Jan 1 02:31:10 2007
|
||||
+++ desktop/Makefile.in Mon Jan 1 02:33:44 2007
|
||||
@@ -65,8 +65,7 @@
|
||||
"$(DESTDIR)$(icons16dir)" "$(DESTDIR)$(icons22dir)" \
|
||||
"$(DESTDIR)$(icons24dir)" "$(DESTDIR)$(icons32dir)" \
|
||||
"$(DESTDIR)$(icons48dir)" "$(DESTDIR)$(icons64dir)" \
|
||||
- "$(DESTDIR)$(iconsscalabledir)" "$(DESTDIR)$(mimeinfodir)" \
|
||||
- "$(DESTDIR)$(registrydir)"
|
||||
+ "$(DESTDIR)$(iconsscalabledir)"
|
||||
applicationsDATA_INSTALL = $(INSTALL_DATA)
|
||||
icons16DATA_INSTALL = $(INSTALL_DATA)
|
||||
icons22DATA_INSTALL = $(INSTALL_DATA)
|
||||
@@ -79,8 +78,7 @@
|
||||
registryDATA_INSTALL = $(INSTALL_DATA)
|
||||
DATA = $(applications_DATA) $(icons16_DATA) $(icons22_DATA) \
|
||||
$(icons24_DATA) $(icons32_DATA) $(icons48_DATA) \
|
||||
- $(icons64_DATA) $(iconsscalable_DATA) $(mimeinfo_DATA) \
|
||||
- $(registry_DATA)
|
||||
+ $(icons64_DATA) $(iconsscalable_DATA)
|
||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||
AA = @AA@
|
||||
ACLOCAL = @ACLOCAL@
|
||||
@@ -445,10 +443,6 @@
|
||||
desktop_files = $(desktop_in_files:.desktop.in.in=.desktop)
|
||||
@DESKTOP_DATADIR_TRUE@applicationsdir = $(DESKTOP_DATADIR)/applications
|
||||
@DESKTOP_DATADIR_TRUE@applications_DATA = $(desktop_files)
|
||||
-@DESKTOP_DATADIR_TRUE@mimeinfodir = $(DESKTOP_DATADIR)/mime-info
|
||||
-@DESKTOP_DATADIR_TRUE@mimeinfo_DATA = gimp.keys
|
||||
-@DESKTOP_DATADIR_TRUE@registrydir = $(DESKTOP_DATADIR)/application-registry
|
||||
-@DESKTOP_DATADIR_TRUE@registry_DATA = gimp.applications
|
||||
@DESKTOP_DATADIR_TRUE@icons16dir = $(DESKTOP_DATADIR)/icons/hicolor/16x16/apps
|
||||
@DESKTOP_DATADIR_TRUE@icons16_DATA = 16x16/gimp.png
|
||||
@DESKTOP_DATADIR_TRUE@icons22dir = $(DESKTOP_DATADIR)/icons/hicolor/22x22/apps
|
|
@ -1,7 +1,3 @@
|
|||
|
||||
$FreeBSD$
|
||||
$MCom: ports/graphics/gimp-devel/files/patch-gimptool-2.0.in,v 1.3 2005/06/28 05:40:04 adamw Exp $
|
||||
|
||||
--- gimptool-2.0.in.orig Tue Jan 15 12:21:05 2002
|
||||
+++ gimptool-2.0.in Fri May 17 20:46:18 2002
|
||||
@@ -215,19 +215,19 @@
|
||||
|
|
|
@ -1,15 +1,6 @@
|
|||
--- libgimp/gimp.c.orig Fri Jun 2 08:04:39 2006
|
||||
+++ libgimp/gimp.c Fri Jun 9 11:24:56 2006
|
||||
@@ -21,7 +21,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
-#define _POSIX_SOURCE /* all the sigaction stuff is POSIX */
|
||||
+#define __XSI_VISIBLE /* all the sigaction stuff is POSIX */
|
||||
#define _SVID_SOURCE /* except for SA_RESTART, it seems */
|
||||
|
||||
#include <errno.h>
|
||||
@@ -30,6 +30,7 @@
|
||||
--- libgimp/gimp.c.orig Fri Sep 1 06:14:32 2006
|
||||
+++ libgimp/gimp.c Sun Dec 31 15:56:37 2006
|
||||
@@ -29,6 +29,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <sys/types.h>
|
||||
|
@ -17,7 +8,7 @@
|
|||
|
||||
#ifdef HAVE_SYS_TIME_H
|
||||
#include <sys/time.h>
|
||||
@@ -292,6 +293,9 @@
|
||||
@@ -291,6 +292,9 @@
|
||||
gimp_env_init (TRUE);
|
||||
|
||||
progname = argv[0];
|
||||
|
|
|
@ -0,0 +1,97 @@
|
|||
--- plug-ins/pygimp/Makefile.in.orig Sun Dec 31 22:19:08 2006
|
||||
+++ plug-ins/pygimp/Makefile.in Sun Dec 31 22:22:17 2006
|
||||
@@ -64,10 +64,9 @@
|
||||
"$(DESTDIR)$(pygimpdir)"
|
||||
pygimpLTLIBRARIES_INSTALL = $(INSTALL)
|
||||
LTLIBRARIES = $(pygimp_LTLIBRARIES)
|
||||
-am__DEPENDENCIES_1 = \
|
||||
- $(top_builddir)/libgimp/libgimp-$(GIMP_API_VERSION).la
|
||||
-am__DEPENDENCIES_2 = $(top_builddir)/libgimpcolor/libgimpcolor-$(GIMP_API_VERSION).la
|
||||
-am__DEPENDENCIES_3 = $(top_builddir)/libgimpbase/libgimpbase-$(GIMP_API_VERSION).la
|
||||
+am__DEPENDENCIES_1 =
|
||||
+am__DEPENDENCIES_2 =
|
||||
+am__DEPENDENCIES_3 =
|
||||
am__DEPENDENCIES_4 =
|
||||
_gimpenums_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
|
||||
$(am__DEPENDENCIES_2) $(am__DEPENDENCIES_3) \
|
||||
@@ -75,11 +74,10 @@
|
||||
$(am__DEPENDENCIES_4)
|
||||
am__gimpenums_la_OBJECTS = gimpenumsmodule.lo
|
||||
_gimpenums_la_OBJECTS = $(am__gimpenums_la_OBJECTS)
|
||||
-am__DEPENDENCIES_5 = \
|
||||
- $(top_builddir)/libgimp/libgimpui-$(GIMP_API_VERSION).la
|
||||
-am__DEPENDENCIES_6 = $(top_builddir)/libgimpwidgets/libgimpwidgets-$(GIMP_API_VERSION).la
|
||||
-am__DEPENDENCIES_7 = $(top_builddir)/libgimpconfig/libgimpconfig-$(GIMP_API_VERSION).la
|
||||
-am__DEPENDENCIES_8 = $(top_builddir)/libgimpmath/libgimpmath-$(GIMP_API_VERSION).la
|
||||
+am__DEPENDENCIES_5 =
|
||||
+am__DEPENDENCIES_6 =
|
||||
+am__DEPENDENCIES_7 =
|
||||
+am__DEPENDENCIES_8 =
|
||||
_gimpui_la_DEPENDENCIES = $(am__DEPENDENCIES_5) $(am__DEPENDENCIES_6) \
|
||||
$(am__DEPENDENCIES_7) $(am__DEPENDENCIES_8) \
|
||||
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_2) \
|
||||
@@ -99,7 +97,7 @@
|
||||
$(am__DEPENDENCIES_4) $(am__DEPENDENCIES_4)
|
||||
am_gimpcolor_la_OBJECTS = gimpcolormodule.lo pygimp-colors.lo
|
||||
gimpcolor_la_OBJECTS = $(am_gimpcolor_la_OBJECTS)
|
||||
-am__DEPENDENCIES_9 = $(top_builddir)/libgimpthumb/libgimpthumb-$(GIMP_API_VERSION).la
|
||||
+am__DEPENDENCIES_9 =
|
||||
gimpthumb_la_DEPENDENCIES = $(am__DEPENDENCIES_9) \
|
||||
$(am__DEPENDENCIES_4) $(am__DEPENDENCIES_4)
|
||||
am_gimpthumb_la_OBJECTS = gimpthumbmodule.lo gimpthumb.lo
|
||||
@@ -531,9 +529,7 @@
|
||||
-export-symbols-regex initgimp
|
||||
|
||||
gimp_la_LIBADD = \
|
||||
- $(libgimp) \
|
||||
- $(libgimpcolor) \
|
||||
- $(libgimpbase) \
|
||||
+ %%GIMP_LIBS%% \
|
||||
$(GLIB_LIBS) \
|
||||
$(PYLINK_LIBS) \
|
||||
$(RT_LIBS)
|
||||
@@ -545,9 +541,7 @@
|
||||
-export-symbols-regex init_gimpenums
|
||||
|
||||
_gimpenums_la_LIBADD = \
|
||||
- $(libgimp) \
|
||||
- $(libgimpcolor) \
|
||||
- $(libgimpbase) \
|
||||
+ %%GIMP_LIBS%% \
|
||||
$(GLIB_LIBS) \
|
||||
$(PYLINK_LIBS) \
|
||||
$(RT_LIBS)
|
||||
@@ -562,7 +556,7 @@
|
||||
-export-symbols-regex initgimpcolor
|
||||
|
||||
gimpcolor_la_LIBADD = \
|
||||
- $(libgimpcolor) \
|
||||
+ %%GIMP_LIBS%% \
|
||||
$(GLIB_LIBS) \
|
||||
$(PYLINK_LIBS)
|
||||
|
||||
@@ -574,13 +568,8 @@
|
||||
-export-symbols-regex init_gimpui
|
||||
|
||||
_gimpui_la_LIBADD = \
|
||||
- $(libgimpui) \
|
||||
- $(libgimpwidgets) \
|
||||
- $(libgimpconfig) \
|
||||
- $(libgimpmath) \
|
||||
- $(libgimp) \
|
||||
- $(libgimpcolor) \
|
||||
- $(libgimpbase) \
|
||||
+ %%GIMP_LIBS%% \
|
||||
+ %%GIMP_UI_LIBS%% \
|
||||
$(GTK_LIBS) \
|
||||
$(PYLINK_LIBS) \
|
||||
$(RT_LIBS) \
|
||||
@@ -594,7 +583,7 @@
|
||||
-export-symbols-regex initgimpthumb
|
||||
|
||||
gimpthumb_la_LIBADD = \
|
||||
- $(libgimpthumb) \
|
||||
+ %%GIMP_THUMB_LIBS%% \
|
||||
$(GDK_PIXBUF_LIBS) \
|
||||
$(PYLINK_LIBS)
|
||||
|
File diff suppressed because it is too large
Load diff
|
@ -3,175 +3,49 @@
|
|||
# Whom: erich@FreeBSD.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/graphics/gimp-devel/Makefile,v 1.24 2006/10/13 23:42:43 marcus Exp $
|
||||
# $MCom: ports/graphics/gimp-devel/Makefile,v 1.30 2007/04/03 17:42:21 ahze Exp $
|
||||
#
|
||||
|
||||
PORTNAME= gimp
|
||||
PORTVERSION= 2.3.9
|
||||
PORTREVISION= 2
|
||||
PORTEPOCH= 1
|
||||
PORTVERSION?= 2.3
|
||||
PORTEPOCH?= 2
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
|
||||
http://gimp.mirrors.hoobly.com/%SUBDIR%/ \
|
||||
http://ftp.gwdg.de/pub/misc/grafik/gimp/%SUBDIR%/ \
|
||||
ftp://ftp.fh-heilbronn.de/mirrors/ftp.gimp.org/%SUBDIR%/ \
|
||||
ftp://ftp.insync.net/pub/mirrors/ftp.gimp.org/%SUBDIR%/ \
|
||||
http://www.mirrorservice.org/sites/ftp.gimp.org/pub/%SUBDIR%/ \
|
||||
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/%SUBDIR%,} \
|
||||
${MASTER_SITE_LOCAL:S|$|ahze/|:S|$|:gut|}
|
||||
MASTER_SITE_SUBDIR= gimp/v${PORTVERSION:R} \
|
||||
ahze:gut
|
||||
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${EXTRA_DISTFILES}
|
||||
MASTER_SITES?= # empty
|
||||
PKGNAMESUFFIX= -devel
|
||||
DISTFILES?= # empty
|
||||
EXTRACT_ONLY?= # empty
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= A GNU Image Manipulation Program development version
|
||||
COMMENT= The "meta-port" for The Gimp
|
||||
|
||||
LIB_DEPENDS= wmf.2:${PORTSDIR}/graphics/libwmf \
|
||||
poppler-glib.1:${PORTSDIR}/graphics/poppler-gtk \
|
||||
aa.1:${PORTSDIR}/graphics/aalib \
|
||||
mng.1:${PORTSDIR}/graphics/libmng \
|
||||
png.5:${PORTSDIR}/graphics/png \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
tiff.4:${PORTSDIR}/graphics/tiff
|
||||
RUN_DEPENDS= gimp-2.3:${PORTSDIR}/graphics/gimp-app-devel
|
||||
|
||||
CONFLICTS= gimp-1.* gimp-2.2.*
|
||||
NO_LATEST_LINK= yes
|
||||
OPTIONS= PYTHON "Python-fu support" Off \
|
||||
PRINT "Gutenprint (gimp-print) plugin" On
|
||||
# HELP "Install Gimp-Help (50+MB distfile)" Off
|
||||
|
||||
SHLIBVER?= 0
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GETTEXT= yes
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_GNOME= gnomehack intltool intlhack gtk20 libartlgpl2 ltverhack
|
||||
WANT_GNOME= yes
|
||||
USE_GCC= 3.4+
|
||||
USE_LDCONFIG= yes
|
||||
INSTALLS_ICONS= yes
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
PLIST_SUB= SHLIBVER="${SHLIBVER}"
|
||||
CONFIGURE_ARGS= --disable-perl \
|
||||
--with-html-dir=${DOCSDIR} \
|
||||
--disable-gtk-doc \
|
||||
--enable-static \
|
||||
--with-gimpprint
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
|
||||
|
||||
GIMP_DISTFILE= ${DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
|
||||
|
||||
MAN1= gimp-2.3.1 gimp-remote-2.3.1 gimptool-2.0.1
|
||||
MAN5= gimprc-2.3.5
|
||||
|
||||
OPTIONS= DEBUG "debugging" off \
|
||||
PYTHON "Python-Fu support" off \
|
||||
RSVG "SVG format support" on \
|
||||
PRINT "Gutenprint plugin" on \
|
||||
GNOMEPRINT "GNOME printing plugin" on \
|
||||
MP "multiple processor support" off
|
||||
NO_BUILD= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
IGNORE= does not build on 4.X
|
||||
.endif
|
||||
pre-everything::
|
||||
@if [ -n "`${PKG_INFO} -xI '^gimp-devel-[0-9].[0-9].[0-9]*' 2>/dev/null`" ]; then \
|
||||
${ECHO_CMD} "${PKGNAME}: Old version of gimp detected! Please see ${PORTSDIR}/UPDATING for information on upgrading ${PKGNAME}" ; \
|
||||
${FALSE}; \
|
||||
fi
|
||||
|
||||
#.if defined(WITHOUT_EXIF)
|
||||
CONFIGURE_ARGS+= --without-libexif
|
||||
#.else
|
||||
#LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
|
||||
#.if defined(WITH_HELP)
|
||||
#RUN_DEPENDS+= gimp-help>0:${PORTSDIR}/graphics/gimp-help
|
||||
#.endif
|
||||
|
||||
.if defined(WITH_DEBUG)
|
||||
CONFIGURE_ARGS+= --enable-debug
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PYTHON)
|
||||
USE_PYTHON= yes
|
||||
# we need to manually include this, because USE_PYTHON is defined
|
||||
# # after including bsd.port.pre.mk
|
||||
.include "${PORTSDIR}/Mk/bsd.python.mk"
|
||||
USE_GNOME+= pygtk2
|
||||
CONFIGURE_ARGS+= --enable-python
|
||||
PLIST_SUB+= PYTHON:=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-python
|
||||
PLIST_SUB+= PYTHON:="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_RSVG)
|
||||
CONFIGURE_ARGS+= --without-librsvg
|
||||
PLIST_SUB+= SVG="@comment "
|
||||
.else
|
||||
USE_GNOME+= librsvg2
|
||||
PLIST_SUB+= SVG=""
|
||||
RUN_DEPENDS+= ${LOCALBASE}/libexec/gimp/2.2/environ/pygimp.env:${PORTSDIR}/graphics/py-gimp
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
LIB_DEPENDS+= gutenprintui2.1:${PORTSDIR}/print/gutenprint
|
||||
EXTRA_DISTFILES+= gimp2-gutenprint-2${EXTRACT_SUFX}:gut
|
||||
GUT_WRKSRC= ${WRKDIR}/gimp2-gutenprint
|
||||
PKGCONFIG?= ${LOCALBASE}/bin/pkg-config
|
||||
GUTENPRINT_CFLAGS= `${PKGCONFIG} --cflags gutenprintui2`
|
||||
GUTENPRINT_LIBS= `${PKGCONFIG} --libs gutenprintui2`
|
||||
GUT_MAKE_ENV= GUTENPRINT_CFLAGS="${GUTENPRINT_CFLAGS}" \
|
||||
GUTENPRINT_LIBS="${GUTENPRINT_LIBS}"
|
||||
PLIST_SUB+= GPRINT=""
|
||||
.else
|
||||
PLIST_SUB+= GPRINT="@comment "
|
||||
RUN_DEPENDS+= ${LOCALBASE}/libexec/gimp/2.2/plug-ins/print:${PORTSDIR}/print/gimp-gutenprint
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_GNOMEPRINT)
|
||||
USE_GNOME+= libgnomeprintui
|
||||
PLIST_SUB+= PRINT=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-gnomeprint
|
||||
PLIST_SUB+= PRINT="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_MP)
|
||||
CONFIGURE_ARGS+= --enable-mp
|
||||
.endif
|
||||
|
||||
.if ${HAVE_GNOME:Mgnomepanel}!=""
|
||||
USE_GNOME+= gnomepanel desktopfileutils gnomehier
|
||||
CONFIGURE_ARGS+= --with-desktop-dir=${LOCALBASE}/share/gnome
|
||||
CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
|
||||
PKGNAMESUFFIX:= -gnome
|
||||
PLIST_SUB+= GTK="gnome/" GNOMEPANEL:=""
|
||||
GNOME_ENABLED= yes
|
||||
.else
|
||||
PLIST_SUB+= GTK="" GNOMEPANEL:="@comment "
|
||||
CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
|
||||
CONFIGURE_ARGS+= --without-desktop-dir
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
${RM} -rf ${WRKSRC}/plug-ins/print
|
||||
${MKDIR} ${WRKSRC}/plug-ins/print
|
||||
${CP} -f ${GUT_WRKSRC}/* ${WRKSRC}/plug-ins/print
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|"libpng"|"libpng12"|' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|@mandir@|${PREFIX}/man|' \
|
||||
${WRKSRC}/docs/Makefile.in
|
||||
|
||||
post-build:
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
@(cd ${WRKSRC}/plug-ins/print; ${SETENV} ${GUT_MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
@(cd ${WRKSRC}/plug-ins/print; ${SETENV} ${GUT_MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
|
||||
.endif
|
||||
.if defined(GNOME_ENABLED)
|
||||
@-update-desktop-database
|
||||
.endif
|
||||
do-install: # empty
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,6 +0,0 @@
|
|||
MD5 (gimp-2.3.9.tar.bz2) = 4299e81e1824e08a90b50dc8beb46151
|
||||
SHA256 (gimp-2.3.9.tar.bz2) = 64c334f99cc4e5204a1925299b7a1da3d027f0b1c6900e6309f5b8da40aa9f10
|
||||
SIZE (gimp-2.3.9.tar.bz2) = 15183977
|
||||
MD5 (gimp2-gutenprint-2.tar.bz2) = d24f0e7bd1f2e62984395293b5f1a43d
|
||||
SHA256 (gimp2-gutenprint-2.tar.bz2) = 3226cf58210fd796e5748817256d29de425e21b093fb84997b787df050344164
|
||||
SIZE (gimp2-gutenprint-2.tar.bz2) = 15155
|
|
@ -1,11 +0,0 @@
|
|||
--- app/main.c.orig Fri Jun 9 12:02:54 2006
|
||||
+++ app/main.c Fri Jun 9 12:03:28 2006
|
||||
@@ -18,7 +18,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
-#define _POSIX_SOURCE /* all the sigaction stuff is POSIX */
|
||||
+#define __XSI_VISIBLE
|
||||
#define _SVID_SOURCE /* except for SA_RESTART, it seems */
|
||||
|
||||
#include <stdio.h>
|
|
@ -1,23 +0,0 @@
|
|||
--- configure.orig Sun Mar 6 15:30:12 2005
|
||||
+++ configure Sun Mar 6 15:33:57 2005
|
||||
@@ -25925,6 +25925,7 @@
|
||||
if test "x$enable_gtktest" = "xyes" ; then
|
||||
ac_save_CFLAGS="$CFLAGS"
|
||||
ac_save_LIBS="$LIBS"
|
||||
+ GTK_LIBS="$GIMP_THREAD_LIBS $GTK_LIBS"
|
||||
CFLAGS="$CFLAGS $GTK_CFLAGS"
|
||||
LIBS="$GTK_LIBS $LIBS"
|
||||
rm -f conf.gtktest
|
||||
@@ -33865,9 +33866,9 @@
|
||||
fi
|
||||
fi;
|
||||
|
||||
-gimpdatadir="$datadir/$PACKAGE/2.0"
|
||||
-gimpplugindir="$libdir/$PACKAGE/2.0"
|
||||
-gimpsysconfdir="$sysconfdir/$PACKAGE/2.0"
|
||||
+gimpdatadir="$datadir/$PACKAGE"
|
||||
+gimpplugindir="$libexecdir/$PACKAGE/2.2"
|
||||
+gimpsysconfdir="$sysconfdir/$PACKAGE/2.2"
|
||||
|
||||
localedir='${prefix}/${DATADIRNAME}/locale'
|
||||
|
|
@ -1,30 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
$MCom: ports/graphics/gimp-devel/files/patch-gimptool-2.0.in,v 1.3 2005/06/28 05:40:04 adamw Exp $
|
||||
|
||||
--- gimptool-2.0.in.orig Tue Jan 15 12:21:05 2002
|
||||
+++ gimptool-2.0.in Fri May 17 20:46:18 2002
|
||||
@@ -215,19 +215,19 @@
|
||||
| --uninstall-script | --uninstall-admin-script )
|
||||
case $1 in
|
||||
--*install-bin)
|
||||
- install_cmd="@INSTALL_PROGRAM@"
|
||||
+ install_cmd="@INSTALL_SCRIPT@"
|
||||
install_dir="$HOME/@gimpdir@/plug-ins"
|
||||
;;
|
||||
--install-bin-strip)
|
||||
- install_cmd="@INSTALL_PROGRAM@ -s"
|
||||
+ install_cmd="@INSTALL_SCRIPT@ -s"
|
||||
install_dir="$HOME/@gimpdir@/plug-ins"
|
||||
;;
|
||||
--*install-admin-bin)
|
||||
- install_cmd="@INSTALL_PROGRAM@"
|
||||
+ install_cmd="@INSTALL_SCRIPT@"
|
||||
install_dir="$gimpplugindir/plug-ins"
|
||||
;;
|
||||
--install-admin-bin-strip)
|
||||
- install_cmd="@INSTALL_PROGRAM@ -s"
|
||||
+ install_cmd="@INSTALL_SCRIPT@ -s"
|
||||
install_dir="$gimpplugindir/plug-ins"
|
||||
;;
|
||||
--*install-script)
|
|
@ -1,29 +0,0 @@
|
|||
--- libgimp/gimp.c.orig Fri Jun 2 08:04:39 2006
|
||||
+++ libgimp/gimp.c Fri Jun 9 11:24:56 2006
|
||||
@@ -21,7 +21,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
-#define _POSIX_SOURCE /* all the sigaction stuff is POSIX */
|
||||
+#define __XSI_VISIBLE /* all the sigaction stuff is POSIX */
|
||||
#define _SVID_SOURCE /* except for SA_RESTART, it seems */
|
||||
|
||||
#include <errno.h>
|
||||
@@ -30,6 +30,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <sys/types.h>
|
||||
+#include <floatingpoint.h>
|
||||
|
||||
#ifdef HAVE_SYS_TIME_H
|
||||
#include <sys/time.h>
|
||||
@@ -292,6 +293,9 @@
|
||||
gimp_env_init (TRUE);
|
||||
|
||||
progname = argv[0];
|
||||
+
|
||||
+ /* Ignore floating point exceptions */
|
||||
+ fpsetmask(0);
|
||||
|
||||
basename = g_path_get_basename (progname);
|
||||
|
|
@ -16,4 +16,6 @@ major features:
|
|||
new effect filters.
|
||||
* Multiple undo/redo.
|
||||
|
||||
This is "The Gimp" meta-port, see ports/graphics/gimp-app for more details
|
||||
|
||||
WWW: http://www.gimp.org/
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue