Update py-sip to 4.19.2, py-qt4 to 4.12 and py-qt5 to 5.7.1
* This is mostly based on the work by Adriaan de Groot <groot@kde.org> in our development repo. PR: 217305 PR: 218539 Submitted by: Adriaan de Groot <groot@kde.org> Reviewed by: rakuco, mat Approved by: rakuco (mentor) Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D9771
This commit is contained in:
parent
f1cbd3af4b
commit
aa9ba55255
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=439794
15 changed files with 1290 additions and 1142 deletions
|
@ -61,16 +61,16 @@ MASTER_SITES_PYQT5= SF/pyqt/PyQt5/PyQt-${PORTVERSION} \
|
|||
MASTER_SITES_QSCI2= SF/pyqt/QScintilla2/QScintilla-${PORTVERSION} \
|
||||
GENTOO
|
||||
|
||||
SIP_VERSION= 4.18
|
||||
SIP_VERSION= 4.19.2
|
||||
QSCI2_VERSION= 2.9.1
|
||||
PYQT4_VERSION= 4.11.4
|
||||
PYQT5_VERSION= 5.6
|
||||
PYQT4_VERSION= 4.12
|
||||
PYQT5_VERSION= 5.7.1
|
||||
|
||||
SIP_DISTNAME= sip-${SIP_VERSION}
|
||||
PYQT4_DISTNAME= PyQt-x11-gpl-${PYQT4_VERSION}
|
||||
PYQT4_DISTINFO_FILE= ${.CURDIR}/../../devel/${PYQT_RELNAME}/distinfo
|
||||
PYQT4_DISTNAME= PyQt4_gpl_x11-${PYQT4_VERSION}
|
||||
PYQT4_DISTINFO_FILE= ${.CURDIR:H:H}/devel/${PYQT_RELNAME}/distinfo
|
||||
PYQT5_DISTNAME= PyQt5_gpl-${PYQT5_VERSION}
|
||||
PYQT5_DISTINFO_FILE= ${.CURDIR}/../../devel/py-qt5/distinfo
|
||||
PYQT5_DISTINFO_FILE= ${.CURDIR:H:H}/devel/${PYQT_RELNAME}/distinfo
|
||||
QSCI2_DISTNAME= QScintilla-gpl-${QSCI2_VERSION}
|
||||
|
||||
# PyQt components split up into pyqt4/pyqt5/...
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (PyQt-x11-gpl-4.11.4.tar.gz) = fc1fe77495432ba3b0d74ff5cb164d375a97f5dddb728256330f615a7cdcf407
|
||||
SIZE (PyQt-x11-gpl-4.11.4.tar.gz) = 11317088
|
||||
TIMESTAMP = 1487867323
|
||||
SHA256 (PyQt4_gpl_x11-4.12.tar.gz) = 3c1d4b55314adb3e1132de8fc2a92eed216d37e58aceed41294dbca210ca88db
|
||||
SIZE (PyQt4_gpl_x11-4.12.tar.gz) = 11325395
|
||||
|
|
|
@ -7,82 +7,97 @@ depends on different modules with module-specific .api files.
|
|||
Also fixes a bug where dbus support drops multiple -I flags produced
|
||||
by pkg-config --cflags dbus-1 .
|
||||
|
||||
--- configure.py.orig 2016-04-24 10:55:08.000000000 +0000
|
||||
+++ configure.py 2016-10-30 22:16:19.159104000 +0000
|
||||
@@ -1482,13 +1482,13 @@
|
||||
|
||||
generate_sip_module_code(target_config, verbose, no_timestamp, parts,
|
||||
tracing, 'Qt', sip_flags)
|
||||
- subdirs.append('Qt')
|
||||
|
||||
--- configure.py.orig 2016-07-25 13:55:28.000000000 +0000
|
||||
+++ configure.py 2016-09-14 18:42:40.977955000 +0000
|
||||
@@ -1460,8 +1460,9 @@
|
||||
|
||||
# Add the internal modules if they are required.
|
||||
if not target_config.no_tools:
|
||||
- # Generate pylupdate5 and pyrcc5.
|
||||
- for tool in ('pylupdate', 'pyrcc'):
|
||||
- generate_application_makefile(target_config, verbose, tool)
|
||||
- subdirs.append(tool)
|
||||
- pyqt_modules.append('pylupdate')
|
||||
- pyqt_modules.append('pyrcc')
|
||||
+ if "QtXml" in target_config.pyqt_modules:
|
||||
+ # Generate pylupdate5 and pyrcc5.
|
||||
+ pyqt_modules.append('pylupdate')
|
||||
+ pyqt_modules.append('pyrcc')
|
||||
|
||||
for mname in pyqt_modules:
|
||||
metadata = MODULE_METADATA[mname]
|
||||
@@ -1504,18 +1505,19 @@
|
||||
|
||||
generate_sip_module_code(target_config, verbose, parts, tracing, 'Qt',
|
||||
sip_flags, False)
|
||||
- subdirs.append('Qt')
|
||||
|
||||
wrappers = []
|
||||
if not target_config.no_tools:
|
||||
- # Generate the pylupdate5 and pyrcc5 wrappers.
|
||||
- for tool in ('pylupdate', 'pyrcc'):
|
||||
- wrappers.append((tool,
|
||||
- generate_tool_wrapper(target_config, tool + '5',
|
||||
- 'PyQt5.%s_main' % tool)))
|
||||
-
|
||||
- # Generate the pyuic5 wrapper.
|
||||
- wrappers.append(('pyuic',
|
||||
+ if "QtXml" in target_config.pyqt_modules:
|
||||
+ # Generate the pylupdate5 and pyrcc5 wrappers.
|
||||
+ for tool in ('pylupdate', 'pyrcc'):
|
||||
+ generate_application_makefile(target_config, verbose, tool)
|
||||
+ subdirs.append(tool)
|
||||
|
||||
# Generate the pyuic5 wrapper.
|
||||
pyuic_wrapper = generate_pyuic5_wrapper(target_config)
|
||||
@@ -1507,22 +1507,6 @@
|
||||
+ wrappers.append((tool,
|
||||
+ generate_tool_wrapper(target_config, tool + '5',
|
||||
+ 'PyQt5.%s_main' % tool)))
|
||||
+
|
||||
+ if "QtCore" in target_config.pyqt_modules:
|
||||
+ # Generate the pyuic5 wrapper.
|
||||
+ wrappers.append(('pyuic',
|
||||
generate_tool_wrapper(target_config, 'pyuic5',
|
||||
'PyQt5.uic.pyuic')))
|
||||
|
||||
@@ -1533,23 +1535,6 @@
|
||||
source_path('examples', 'quick', 'tutorials', 'extending',
|
||||
'chapter6-plugins'))
|
||||
|
||||
|
||||
- # Generate the QScintilla API file.
|
||||
- if target_config.qsci_api:
|
||||
- inform("Generating the QScintilla API file...")
|
||||
- f = open_for_writing('PyQt5.api')
|
||||
-
|
||||
- for mname in target_config.pyqt_modules:
|
||||
- api = open(mname + '.api')
|
||||
- if MODULE_METADATA[mname].public:
|
||||
- api = open(mname + '.api')
|
||||
-
|
||||
- for l in api:
|
||||
- f.write('PyQt5.' + l)
|
||||
- for l in api:
|
||||
- f.write('PyQt5.' + l)
|
||||
-
|
||||
- api.close()
|
||||
- os.remove(mname + '.api')
|
||||
- api.close()
|
||||
- os.remove(mname + '.api')
|
||||
-
|
||||
- f.close()
|
||||
-
|
||||
# Generate the Python dbus module.
|
||||
if target_config.pydbus_module_dir != '':
|
||||
mname = 'dbus'
|
||||
@@ -1548,21 +1532,24 @@
|
||||
@@ -1577,14 +1562,18 @@
|
||||
out_f.write('''TEMPLATE = subdirs
|
||||
CONFIG += ordered nostrip
|
||||
SUBDIRS = %s
|
||||
+''' % ' '.join(subdirs))
|
||||
|
||||
+''' % (' '.join(subdirs)))
|
||||
|
||||
+ if "QtCore" in target_config.pyqt_modules:
|
||||
+ out_f.write('''
|
||||
init_py.files = %s
|
||||
init_py.path = %s
|
||||
INSTALLS += init_py
|
||||
-''' % (' '.join(subdirs), source_path('__init__.py'), qmake_quote(target_config.pyqt_module_dir + '/PyQt5')))
|
||||
+''' % (source_path('__init__.py'), qmake_quote(target_config.pyqt_module_dir + '/PyQt5')))
|
||||
|
||||
- # Install the uic module and the pyuic5 wrapper.
|
||||
-''' % (' '.join(subdirs), source_path('__init__.py'), root_dir))
|
||||
+''' % (source_path('__init__.py'), root_dir))
|
||||
|
||||
- # Install the uic module.
|
||||
- out_f.write('''
|
||||
+ # Install the uic module and the pyuic5 wrapper.
|
||||
+ out_f.write('''
|
||||
+ if not target_config.no_tools:
|
||||
+ # Install the uic module.
|
||||
+ out_f.write('''
|
||||
uic_package.files = %s
|
||||
uic_package.path = %s
|
||||
INSTALLS += uic_package
|
||||
''' % (source_path('pyuic', 'uic'), qmake_quote(target_config.pyqt_module_dir + '/PyQt5')))
|
||||
|
||||
- if not target_config.no_tools:
|
||||
- out_f.write('''
|
||||
+ if not target_config.no_tools:
|
||||
+ out_f.write('''
|
||||
pyuic5.files = %s
|
||||
pyuic5.path = %s
|
||||
INSTALLS += pyuic5
|
||||
@@ -1579,11 +1566,12 @@
|
||||
|
||||
@@ -1620,11 +1609,12 @@
|
||||
|
||||
# Install the QScintilla .api file.
|
||||
if target_config.qsci_api:
|
||||
+ api_list = ' '.join(['%s.api' % m for m in target_config.pyqt_modules])
|
||||
|
@ -93,17 +108,6 @@ by pkg-config --cflags dbus-1 .
|
|||
INSTALLS += qscintilla_api
|
||||
-''' % qmake_quote(target_config.qsci_api_dir + '/api/python'))
|
||||
+''' % (api_list, qmake_quote(target_config.qsci_api_dir + '/api/python')))
|
||||
|
||||
|
||||
out_f.close()
|
||||
|
||||
@@ -2140,7 +2128,9 @@
|
||||
else:
|
||||
dlist = target_config.dbus_inc_dirs
|
||||
|
||||
- target_config.dbus_inc_dirs = []
|
||||
+ # Don't reset dbus_inc_dirs, because it will forget the flags
|
||||
+ # found for dbus, above (which might require multiple -I flags).
|
||||
+ # target_config.dbus_inc_dirs = []
|
||||
|
||||
for d in dlist:
|
||||
if os.access(os.path.join(d, 'dbus', 'dbus-python.h'), os.F_OK):
|
||||
|
||||
|
|
|
@ -1,101 +1,101 @@
|
|||
bin/pyuic5
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/Qt.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/Qt.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/Qt.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/Qt.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/QtCore.so
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/__init__.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/__init__.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/__init__.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/__init__.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/__init__.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/__init__.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/compiler.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/compiler.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/compiler.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/compiler.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/indenter.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/indenter.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/indenter.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/indenter.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/misc.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/misc.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/misc.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/misc.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/proxy_metaclass.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/proxy_metaclass.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/proxy_metaclass.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/proxy_metaclass.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/qobjectcreator.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/qobjectcreator.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/qobjectcreator.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/qobjectcreator.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/qtproxies.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/qtproxies.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/qtproxies.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Compiler/qtproxies.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Loader/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Loader/__init__.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Loader/__init__.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Loader/__init__.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Loader/loader.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Loader/loader.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Loader/loader.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Loader/loader.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Loader/qobjectcreator.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Loader/qobjectcreator.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Loader/qobjectcreator.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/Loader/qobjectcreator.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/__init__.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/__init__.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/__init__.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/driver.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/driver.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/driver.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/driver.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/exceptions.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/exceptions.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/exceptions.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/exceptions.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/icon_cache.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/icon_cache.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/icon_cache.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/icon_cache.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/objcreator.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/objcreator.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/objcreator.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/objcreator.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/__init__.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/__init__.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/__init__.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/as_string.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/as_string.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/as_string.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/as_string.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/ascii_upper.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/ascii_upper.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/ascii_upper.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/invoke.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/invoke.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/invoke.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/load_plugin.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/load_plugin.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/load_plugin.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/ascii_upper.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/proxy_base.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/proxy_base.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/proxy_base.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/proxy_base.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/string_io.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/string_io.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/string_io.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/port_v%%PYTHON_MAJOR_VER%%/string_io.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/properties.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/properties.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/properties.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/properties.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/pyuic.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/pyuic.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/pyuic.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/pyuic.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/uiparser.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/uiparser.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/uiparser.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/uiparser.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qaxcontainer.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qaxcontainer.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qaxcontainer.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qaxcontainer.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qscintilla.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qscintilla.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qscintilla.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qscintilla.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtcharts.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtcharts.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtcharts.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtprintsupport.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtprintsupport.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtprintsupport.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtprintsupport.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtquickwidgets.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtquickwidgets.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtquickwidgets.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtquickwidgets.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtwebenginewidgets.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtwebenginewidgets.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtwebenginewidgets.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtwebkit.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtwebkit.pyc
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtwebkit.pyo
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/uic/widget-plugins/qtwebkit.%%PYTHON_PYOEXTENSION%%
|
||||
%%PYQT_SIPDIR%%/QtCore/QtCoremod.sip
|
||||
%%PYQT_SIPDIR%%/QtCore/qabstractanimation.sip
|
||||
%%PYQT_SIPDIR%%/QtCore/qabstracteventdispatcher.sip
|
||||
|
|
|
@ -1,3 +1,4 @@
|
|||
TIMESTAMP = 1477759251
|
||||
SHA256 (PyQt5_gpl-5.6.tar.gz) = 2e481a6c4c41b96ed3b33449e5f9599987c63a5c8db93313bd57a6acbf20f0e1
|
||||
SIZE (PyQt5_gpl-5.6.tar.gz) = 3720782
|
||||
TIMESTAMP = 1487865147
|
||||
SHA256 (PyQt5_gpl-5.7.1.tar.gz) = be849f212a074049b9ebc10b6c07dddefb86e6d30e8df8a5c715cbb2cf7fad14
|
||||
SIZE (PyQt5_gpl-5.7.1.tar.gz) = 3733746
|
||||
|
||||
|
|
|
@ -39,5 +39,7 @@ post-install:
|
|||
${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
|
||||
-f -d ${PYTHONPREFIX_SITELIBDIR} \
|
||||
${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
|
||||
${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/sip
|
||||
${STRIP_CMD} ${STAGEDIR}/${PYTHON_SITELIBDIR}/sip.so
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1473848835
|
||||
SHA256 (sip-4.18.tar.gz) = f1dc5c81c07a9ad97edcd4a0af964a41e420024ba7ca165afd2b351efd249cb6
|
||||
SIZE (sip-4.18.tar.gz) = 991980
|
||||
TIMESTAMP = 1491828562
|
||||
SHA256 (sip-4.19.2.tar.gz) = 432b4aad25254e6997913e33b1ca3cf5fd21d5729a50a3ce2edccbea82c80533
|
||||
SIZE (sip-4.19.2.tar.gz) = 1000746
|
||||
|
|
20
devel/py-sip/files/patch-hg_6b09a6d578e8
Normal file
20
devel/py-sip/files/patch-hg_6b09a6d578e8
Normal file
|
@ -0,0 +1,20 @@
|
|||
Fix a regression so that a shadow class is not generated if there is a private
|
||||
dtor.
|
||||
|
||||
https://www.riverbankcomputing.com/hg/sip/rev/6b09a6d578e8
|
||||
|
||||
diff -r 6209a625ac87 -r 6b09a6d578e8 sipgen/transform.c
|
||||
--- sipgen/transform.c Thu Mar 30 09:43:04 2017 +0100
|
||||
+++ sipgen/transform.c Sun Apr 02 11:49:58 2017 +0100
|
||||
@@ -273,7 +273,7 @@
|
||||
for (cd = pt->classes; cd != NULL; cd = cd->next)
|
||||
if (cd->iff->type == class_iface)
|
||||
{
|
||||
- if (needsShadow(cd) && !isIncomplete(cd) && canCreate(cd))
|
||||
+ if (needsShadow(cd) && !isIncomplete(cd) && !isPrivateDtor(cd) && canCreate(cd))
|
||||
setHasShadow(cd);
|
||||
|
||||
/* Get the list of visible Python member functions. */
|
||||
|
||||
|
||||
|
|
@ -48,10 +48,10 @@
|
|||
%%QT_INCDIR%%/Qsci/qsciscintillabase.h
|
||||
%%QT_INCDIR%%/Qsci/qscistyle.h
|
||||
%%QT_INCDIR%%/Qsci/qscistyledtext.h
|
||||
lib/qt4/libqscintilla2.so
|
||||
lib/qt4/libqscintilla2.so.12
|
||||
lib/qt4/libqscintilla2.so.12.0
|
||||
lib/qt4/libqscintilla2.so.12.0.1
|
||||
%%QT_LIBDIR%%/libqscintilla2.so
|
||||
%%QT_LIBDIR%%/libqscintilla2.so.12
|
||||
%%QT_LIBDIR%%/libqscintilla2.so.12.0
|
||||
%%QT_LIBDIR%%/libqscintilla2.so.12.0.1
|
||||
%%QT_MKSPECDIR%%/features/qscintilla2.prf
|
||||
share/qt4/qsci/api/python/Python-2.4.api
|
||||
share/qt4/qsci/api/python/Python-2.5.api
|
||||
|
|
|
@ -0,0 +1,44 @@
|
|||
Obtained from: https://gitweb.gentoo.org/repo/gentoo.git/tree/sci-geosciences/qgis
|
||||
|
||||
From 85a0db24f32351f6096cd8282f03ad5c2f4e6ef5 Mon Sep 17 00:00:00 2001
|
||||
From: Sandro Mani <manisandro@gmail.com>
|
||||
Date: Wed, 1 Mar 2017 16:12:38 +0100
|
||||
Subject: [PATCH] Fix build against recent sip/PyQt4:
|
||||
|
||||
qgsfiledownloader.sip:33:0:
|
||||
src/gui/qgsfiledownloader.h:94:5: error: overriding non-deleted function 'virtual QgsFileDownloader::~QgsFileDownloader()'
|
||||
|
||||
RuntimeError: qgis._core cannot import type 'QList<QVariant>' from PyQt4.QtCore
|
||||
---
|
||||
python/core/core.sip | 1 +
|
||||
src/gui/qgsfiledownloader.h | 4 +++-
|
||||
2 files changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/python/core/core.sip b/python/core/core.sip
|
||||
index 8f0b6af..41f5450 100644
|
||||
--- python/core/core.sip
|
||||
+++ python/core/core.sip
|
||||
@@ -3,6 +3,7 @@
|
||||
|
||||
%Feature QT5_SUPPORT
|
||||
|
||||
+%Import QtCore/QtCoremod.sip
|
||||
%Import QtXml/QtXmlmod.sip
|
||||
%Import QtNetwork/QtNetworkmod.sip
|
||||
%Import QtSql/QtSqlmod.sip
|
||||
diff --git a/src/gui/qgsfiledownloader.h b/src/gui/qgsfiledownloader.h
|
||||
index c9276f7..841e4b6 100644
|
||||
--- src/gui/qgsfiledownloader.h
|
||||
+++ src/gui/qgsfiledownloader.h
|
||||
@@ -90,8 +90,10 @@ class GUI_EXPORT QgsFileDownloader : public QObject
|
||||
void onSslErrors( QNetworkReply *reply, const QList<QSslError> &errors );
|
||||
#endif
|
||||
|
||||
- private:
|
||||
+ protected:
|
||||
~QgsFileDownloader();
|
||||
+
|
||||
+ private:
|
||||
/**
|
||||
* Abort current request and show an error if the instance has GUI
|
||||
* notifications enabled.
|
|
@ -0,0 +1,46 @@
|
|||
Obtained from: https://gitweb.gentoo.org/repo/gentoo.git/tree/sci-visualization/qtiplot
|
||||
|
||||
sci-visualization/qtiplot: Fix build with >=sip-4.19
|
||||
Thanks-to: Fabio Rossi <rossi.f@inwind.it>
|
||||
Gentoo-bug: 609280
|
||||
|
||||
Package-Manager: Portage-2.3.3, Repoman-2.3.1
|
||||
|
||||
--- qtiplot/src/scripting/qti.sip 2017-02-13 17:01:03.123828499 +0100
|
||||
+++ qtiplot/src/scripting/qti.sip 2017-02-13 17:02:12.628828234 +0100
|
||||
@@ -148,14 +148,14 @@
|
||||
}
|
||||
break;
|
||||
case Table::Date:
|
||||
- if (sipCanConvertToType(item, sipType_QDateTime, 0)) {
|
||||
+ if (sipCanConvertToType(item, sipFindType("QDateTime"), 0)) {
|
||||
int isErr = 0;
|
||||
- QDateTime* dateTime = reinterpret_cast<QDateTime*>(sipConvertToType(item, sipType_QDateTime,
|
||||
+ QDateTime* dateTime = reinterpret_cast<QDateTime*>(sipConvertToType(item, sipFindType("QDateTime"),
|
||||
0/*sipTransferObj*/, 0/*flags*/, 0/*state*/, &isErr));
|
||||
if (isErr)
|
||||
return 1;
|
||||
table->setText(row, col, dateTime->toString(table->columnFormat(col)));
|
||||
- delete dateTime;
|
||||
+ //delete dateTime;
|
||||
}
|
||||
else {
|
||||
if (PyType_Ready(item_type) == 0)
|
||||
@@ -164,14 +164,14 @@
|
||||
}
|
||||
break;
|
||||
case Table::Time:
|
||||
- if (sipCanConvertToType(item, sipType_QTime, 0)) {
|
||||
+ if (sipCanConvertToType(item, sipFindType("QTime"), 0)) {
|
||||
int isErr = 0;
|
||||
- QTime* time = reinterpret_cast<QTime*>(sipConvertToType(item, sipType_QTime,
|
||||
+ QTime* time = reinterpret_cast<QTime*>(sipConvertToType(item, sipFindType("QTime"),
|
||||
0/*sipTransferObj*/, 0/*flags*/, 0/*state*/, &isErr));
|
||||
if (isErr)
|
||||
return 1;
|
||||
table->setText(row, col, time->toString(table->columnFormat(col)));
|
||||
- delete time;
|
||||
+ //delete time;
|
||||
}
|
||||
else {
|
||||
if (PyType_Ready(item_type) == 0)
|
|
@ -2,31 +2,32 @@
|
|||
%%DOCSDIR%%/NEWS
|
||||
%%DOCSDIR%%/README
|
||||
%%DOCSDIR%%/THANKS
|
||||
%%DOCSDIR%%/html/_sources/buffer_interface.txt
|
||||
%%DOCSDIR%%/html/_sources/build_system.txt
|
||||
%%DOCSDIR%%/html/_sources/dbus.txt
|
||||
%%DOCSDIR%%/html/_sources/deploy_commercial.txt
|
||||
%%DOCSDIR%%/html/_sources/designer.txt
|
||||
%%DOCSDIR%%/html/_sources/gotchas.txt
|
||||
%%DOCSDIR%%/html/_sources/i18n.txt
|
||||
%%DOCSDIR%%/html/_sources/incompatibilities.txt
|
||||
%%DOCSDIR%%/html/_sources/incompatible_apis.txt
|
||||
%%DOCSDIR%%/html/_sources/index.txt
|
||||
%%DOCSDIR%%/html/_sources/installation.txt
|
||||
%%DOCSDIR%%/html/_sources/introduction.txt
|
||||
%%DOCSDIR%%/html/_sources/keyword_arguments.txt
|
||||
%%DOCSDIR%%/html/_sources/new_style_signals_slots.txt
|
||||
%%DOCSDIR%%/html/_sources/old_style_signals_slots.txt
|
||||
%%DOCSDIR%%/html/_sources/pickle.txt
|
||||
%%DOCSDIR%%/html/_sources/pyqt_qsettings.txt
|
||||
%%DOCSDIR%%/html/_sources/pyqt_qvariant.txt
|
||||
%%DOCSDIR%%/html/_sources/python_shell.txt
|
||||
%%DOCSDIR%%/html/_sources/python_v3.txt
|
||||
%%DOCSDIR%%/html/_sources/qml.txt
|
||||
%%DOCSDIR%%/html/_sources/qt_properties.txt
|
||||
%%DOCSDIR%%/html/_sources/qt_v5.txt
|
||||
%%DOCSDIR%%/html/_sources/resources.txt
|
||||
%%DOCSDIR%%/html/_sources/webkit.txt
|
||||
%%DOCSDIR%%/html/_sources/buffer_interface.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/build_system.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/dbus.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/deploy_commercial.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/designer.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/extension_api.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/gotchas.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/i18n.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/incompatibilities.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/incompatible_apis.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/index.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/installation.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/introduction.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/keyword_arguments.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/new_style_signals_slots.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/old_style_signals_slots.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/pickle.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/pyqt_qsettings.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/pyqt_qvariant.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/python_shell.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/python_v3.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/qml.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/qt_properties.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/qt_v5.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/resources.rst.txt
|
||||
%%DOCSDIR%%/html/_sources/webkit.rst.txt
|
||||
%%DOCSDIR%%/html/_static/ajax-loader.gif
|
||||
%%DOCSDIR%%/html/_static/basic.css
|
||||
%%DOCSDIR%%/html/_static/classic.css
|
||||
|
@ -37,8 +38,8 @@
|
|||
%%DOCSDIR%%/html/_static/down-pressed.png
|
||||
%%DOCSDIR%%/html/_static/down.png
|
||||
%%DOCSDIR%%/html/_static/file.png
|
||||
%%DOCSDIR%%/html/_static/jquery-3.1.0.js
|
||||
%%DOCSDIR%%/html/_static/jquery.js
|
||||
%%DOCSDIR%%/html/_static/jquery-1.11.1.js
|
||||
%%DOCSDIR%%/html/_static/logo.png
|
||||
%%DOCSDIR%%/html/_static/logo_tn.ico
|
||||
%%DOCSDIR%%/html/_static/minus.png
|
||||
|
@ -46,8 +47,8 @@
|
|||
%%DOCSDIR%%/html/_static/pygments.css
|
||||
%%DOCSDIR%%/html/_static/searchtools.js
|
||||
%%DOCSDIR%%/html/_static/sidebar.js
|
||||
%%DOCSDIR%%/html/_static/underscore.js
|
||||
%%DOCSDIR%%/html/_static/underscore-1.3.1.js
|
||||
%%DOCSDIR%%/html/_static/underscore.js
|
||||
%%DOCSDIR%%/html/_static/up-pressed.png
|
||||
%%DOCSDIR%%/html/_static/up.png
|
||||
%%DOCSDIR%%/html/_static/websupport.js
|
||||
|
@ -58,6 +59,7 @@
|
|||
%%DOCSDIR%%/html/dbus.html
|
||||
%%DOCSDIR%%/html/deploy_commercial.html
|
||||
%%DOCSDIR%%/html/designer.html
|
||||
%%DOCSDIR%%/html/extension_api.html
|
||||
%%DOCSDIR%%/html/genindex.html
|
||||
%%DOCSDIR%%/html/gotchas.html
|
||||
%%DOCSDIR%%/html/i18n.html
|
||||
|
|
|
@ -11,13 +11,9 @@ MAINTAINER= kde@FreeBSD.org
|
|||
COMMENT= Python bindings for the Qt5 toolkit, Qt demo and examples
|
||||
|
||||
DISTINFO_FILE= ${PYQT_DISTINFO_FILE}
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
USES= python pyqt:5
|
||||
USE_PYQT= #
|
||||
|
||||
EXAMPLESDIR= ${PREFIX}/share/examples/py-qt5
|
||||
|
||||
USE_PYQT= core_run dbus_run designer_run \
|
||||
designerplugin_run doc_run gui_run multimedia_run \
|
||||
multimediawidgets_run network_run opengl_run qscintilla2_run \
|
||||
|
@ -25,6 +21,8 @@ USE_PYQT= core_run dbus_run designer_run \
|
|||
xmlpatterns_run sip_run qscintilla2_run \
|
||||
printsupport_run serialport_run webkitwidgets_run widgets_run
|
||||
|
||||
EXAMPLESDIR= ${PREFIX}/share/examples/py-qt5
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,7 +1,13 @@
|
|||
bin/pylupdate5
|
||||
bin/pyrcc5
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/QtXml.so
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/pylupdate.so
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/pylupdate_main.py
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/pyrcc.so
|
||||
%%PYTHON_SITELIBDIR%%/PyQt5/pyrcc_main.py
|
||||
%%PYQT_SIPDIR%%/QtXml/QtXmlmod.sip
|
||||
%%PYQT_SIPDIR%%/QtXml/qdom.sip
|
||||
%%PYQT_SIPDIR%%/QtXml/qxml.sip
|
||||
%%PYQT_SIPDIR%%/pylupdate/pylupdatemod.sip
|
||||
%%PYQT_SIPDIR%%/pyrcc/pyrccmod.sip
|
||||
%%API%%share/qt5/qsci/api/python/QtXml.api
|
||||
|
|
Loading…
Reference in a new issue