lang/ruby*: remove obsolete patches
Remove no longer needed patches for ftp. While here, fix the test target for ruby21 PR: 192998 Submitted by: Robert Grimm <rfgrimm@gmail.com>
This commit is contained in:
parent
68669fc03d
commit
aafb928748
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=366970
5 changed files with 4 additions and 65 deletions
|
@ -177,7 +177,7 @@ RUBY?= ${LOCALBASE}/bin/${RUBY_NAME}
|
|||
# Ruby 1.9
|
||||
#
|
||||
RUBY_RELVERSION= 1.9.3
|
||||
RUBY_PORTREVISION= 1
|
||||
RUBY_PORTREVISION= 2
|
||||
RUBY_PORTEPOCH= 1
|
||||
RUBY_PATCHLEVEL= 547
|
||||
|
||||
|
@ -193,7 +193,7 @@ RUBY21= "@comment "
|
|||
# Ruby 2.0
|
||||
#
|
||||
RUBY_RELVERSION= 2.0.0
|
||||
RUBY_PORTREVISION= 1
|
||||
RUBY_PORTREVISION= 2
|
||||
RUBY_PORTEPOCH= 1
|
||||
RUBY_PATCHLEVEL= 481
|
||||
|
||||
|
@ -209,7 +209,7 @@ RUBY21= "@comment "
|
|||
# Ruby 2.1
|
||||
#
|
||||
RUBY_RELVERSION= 2.1.2
|
||||
RUBY_PORTREVISION= 1
|
||||
RUBY_PORTREVISION= 2
|
||||
RUBY_PORTEPOCH= 1
|
||||
RUBY_PATCHLEVEL= 0
|
||||
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
--- lib/uri/generic.rb.orig 2009-06-18 16:47:45.000000000 +0400
|
||||
+++ lib/uri/generic.rb 2009-06-18 16:48:54.000000000 +0400
|
||||
@@ -1032,7 +1032,15 @@
|
||||
end
|
||||
end
|
||||
|
||||
- str << path_query
|
||||
+ path = path_query
|
||||
+
|
||||
+ #
|
||||
+ # Add URI delimiter if the path misses it (like as in FTP)
|
||||
+ #
|
||||
+ if not path.empty? and not str.empty? and path[0, 1] != '/'
|
||||
+ path = '/' + path
|
||||
+ end
|
||||
+ str << path
|
||||
end
|
||||
|
||||
if @fragment
|
|
@ -1,21 +0,0 @@
|
|||
--- lib/uri/generic.rb.orig 2013-11-27 04:27:22.851503866 +0000
|
||||
+++ lib/uri/generic.rb 2013-11-27 04:27:58.130502926 +0000
|
||||
@@ -1481,7 +1481,17 @@
|
||||
end
|
||||
end
|
||||
|
||||
- str << path_query
|
||||
+ path = path_query
|
||||
+
|
||||
+ #
|
||||
+ # Add URI delimiter if the path misses it (like as in FTP)
|
||||
+ #
|
||||
+ if not path.empty? and not str.empty? and path[0, 1] != '/'
|
||||
+ path = '/' + path
|
||||
+ end
|
||||
+ str << path
|
||||
+ end
|
||||
+ if @fragment
|
||||
end
|
||||
|
||||
if @fragment
|
|
@ -229,6 +229,6 @@ validate:
|
|||
rm -rf ${WRKSRC}/rubyspec/*
|
||||
(cd ${WRKSRC}/rubyspec && git clone git://github.com/rubyspec/rubyspec.git)
|
||||
(cd ${WRKSRC}/rubyspec && git clone git://github.com/rubyspec/mspec.git)
|
||||
(cd ${WRKSRC}/rubyspec/rubyspec && env PATH=${WRKSRC}/rubyspec/mspec/bin:${PATH} mspec -t ${STAGEDIR}${PREFIX}/bin/ruby${RUBY_SUFFIX})
|
||||
(cd ${WRKSRC}/rubyspec/rubyspec && env PATH=${WRKSRC}/rubyspec/mspec/bin:${PATH} mspec -t ${PREFIX}/bin/ruby${RUBY_SUFFIX} .)
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
--- lib/uri/generic.rb.orig 2013-11-27 04:27:22.851503866 +0000
|
||||
+++ lib/uri/generic.rb 2013-11-27 04:27:58.130502926 +0000
|
||||
@@ -1481,7 +1481,17 @@
|
||||
end
|
||||
end
|
||||
|
||||
- str << path_query
|
||||
+ path = path_query
|
||||
+
|
||||
+ #
|
||||
+ # Add URI delimiter if the path misses it (like as in FTP)
|
||||
+ #
|
||||
+ if not path.empty? and not str.empty? and path[0, 1] != '/'
|
||||
+ path = '/' + path
|
||||
+ end
|
||||
+ str << path
|
||||
+ end
|
||||
+ if @fragment
|
||||
end
|
||||
|
||||
if @fragment
|
Loading…
Reference in a new issue