. Add an explicit -lm when linking hdiff, required by gcc 3.4. This should

fix the build on 5.x.

Reported by:	mich, lofi
This commit is contained in:
Greg Lewis 2005-03-19 22:10:16 +00:00
parent 709f2b29d9
commit ab01e5a9a1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=131668

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- mfhdf/hdiff/Makefile.in.orig Sat Mar 19 15:02:26 2005
+++ mfhdf/hdiff/Makefile.in Sat Mar 19 15:03:32 2005
@@ -250,7 +250,7 @@
-test -z "$(noinst_PROGRAMS)" || rm -f $(noinst_PROGRAMS)
hdiff$(EXEEXT): $(hdiff_OBJECTS) $(hdiff_DEPENDENCIES)
@rm -f hdiff$(EXEEXT)
- $(LINK) $(hdiff_LDFLAGS) $(hdiff_OBJECTS) $(hdiff_LDADD) $(LIBS)
+ $(LINK) $(hdiff_LDFLAGS) $(hdiff_OBJECTS) $(hdiff_LDADD) $(LIBS) -lm
hdifftst$(EXEEXT): $(hdifftst_OBJECTS) $(hdifftst_DEPENDENCIES)
@rm -f hdifftst$(EXEEXT)
$(LINK) $(hdifftst_LDFLAGS) $(hdifftst_OBJECTS) $(hdifftst_LDADD) $(LIBS)