- Add OPTIONS to the port.
- Add the LICENSE information to the port. - Fix building of port on 6.x/9.x with DBUS option enabled, provided by swell.k@gmail.com. - Remove unneeded dependencies on gettext and dbus-glib. - Remove ALSA detection logic from configure script. PR: ports/147546 Approved by: tabthorpe (mentor)
This commit is contained in:
parent
ff5b20110c
commit
ab1642fb0a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=258369
6 changed files with 985 additions and 241 deletions
|
@ -6,114 +6,231 @@
|
|||
#
|
||||
|
||||
PORTNAME= emacs
|
||||
PORTVERSION= ${EMACS_VER}
|
||||
PORTREVISION= 6
|
||||
PORTVERSION= ${EMACS_VER}.${EMACS_REV}
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= editors ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_GNU_ALPHA}
|
||||
MASTER_SITE_SUBDIR= emacs/pretest
|
||||
MASTER_SITES= http://wahjava.users.sourceforge.net/%SUBDIR%/ \
|
||||
${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= ashish
|
||||
|
||||
MAINTAINER= ashish@FreeBSD.org
|
||||
COMMENT= GNU editing macros
|
||||
|
||||
.if !defined(WITHOUT_X11)
|
||||
USE_XORG= x11
|
||||
.if defined(WITHOUT_GTK)
|
||||
USE_XORG+= xaw xft xpm
|
||||
.else
|
||||
USE_GNOME= gtk20
|
||||
.endif
|
||||
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
|
||||
tiff.4:${PORTSDIR}/graphics/tiff \
|
||||
ungif.5:${PORTSDIR}/graphics/libungif \
|
||||
png.6:${PORTSDIR}/graphics/png
|
||||
.endif
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
CONFLICTS= emacs-19.* emacs-21.* emacs-22.* \
|
||||
CONFLICTS= emacs-19.* emacs-21.* emacs-22.* emacs-23.* \
|
||||
xemacs-[0-9]* xemacs-devel-[0-9]* \
|
||||
xemacs-mule-[0-9]* xemacs-devel-mule-[0-9]*
|
||||
xemacs-mule-[0-9]* xemacs-devel-mule-[0-9]* \
|
||||
emacs-nox11-[0-9]*
|
||||
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
EMACS_VER= 23.0.95
|
||||
EMACS_VER= 24.0.50
|
||||
EMACS_REV= 100884
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
ALL_TARGET= bootstrap
|
||||
USE_XZ= yes
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
CONFIGURE_ARGS= --localstatedir=/var
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
MAN1= b2m.1 ctags.1 ebrowse.1 emacs.1 emacsclient.1 etags.1 \
|
||||
grep-changelog.1 rcs-checkin.1
|
||||
MANCOMPRESSED= yes
|
||||
PLIST_SUB= EMACS_VER=${EMACS_VER} EMACS_ARCH=${CONFIGURE_TARGET}
|
||||
|
||||
MAKE_ENV= LC_ALL=C
|
||||
|
||||
INFO= ada-mode auth autotype calc ccmode cl dbus dired-x \
|
||||
ebrowse ede ediff edt efaq eieio eintr elisp emacs-mime emacs epa \
|
||||
erc eshell eudc flymake forms gnus idlwave info \
|
||||
mairix-el message mh-e newsticker nxml-mode \
|
||||
org pcl-cvs pgg rcirc reftex remember sasl sc semantic ses sieve \
|
||||
smtpmail speedbar tramp url vip viper widget woman
|
||||
|
||||
LATEST_LINK= emacs-devel
|
||||
OPTIONS= DBUS "DBus support" ON \
|
||||
GCONF "GConf support" ON \
|
||||
GIF "GIF Images support" ON \
|
||||
JPEG "JPEG images support" ON \
|
||||
M17N "M17N support for text-shaping" ON \
|
||||
MOTIF "Use Motif widgets" OFF \
|
||||
OTF "Opentype Font Support" ON \
|
||||
PNG "PNG images support" ON \
|
||||
SOUND "Sound support" ON \
|
||||
SOURCES "Install source code" ON \
|
||||
SVG "SVG images support" ON \
|
||||
TIFF "TIFF images support" ON \
|
||||
XAW "Use Athena widgets" OFF \
|
||||
XAW3D "Use Athena3D widgets" OFF \
|
||||
SYNC_INPUT "Synchronously process asynchronous input" ON \
|
||||
SCROLLBARS "Without toolkit scroll-bars" ON \
|
||||
XFT "Freetype fonts support" ON \
|
||||
XIM "X Input Method support" ON \
|
||||
XPM "XPM images support" ON
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
DBUS_PTHREAD_LIBS= ${CC} -dumpspecs | ${GREP} -m 1 pthread: | ${SED} -e 's|^.*%{\!pg: %{pthread:||' -e 's|}.*$$||' || ${TRUE}
|
||||
|
||||
CONFIGURE_TARGET= ${MACHINE_ARCH}-freebsd
|
||||
.if defined(WITHOUT_X11)
|
||||
CONFIGURE_ARGS= --with-x=no
|
||||
CONFIGURE_ARGS+= --without-x
|
||||
.else
|
||||
.if !defined(WITHOUT_GTK)
|
||||
CONFIGURE_ARGS= --with-x-toolkit=gtk
|
||||
.else
|
||||
CONFIGURE_ARGS= --with-x-toolkit=athena
|
||||
.endif
|
||||
CONFIGURE_ARGS+= --enable-font-backend
|
||||
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2 \
|
||||
m17n.4:${PORTSDIR}/devel/m17n-lib
|
||||
# also libotf, which is pulled in by m17n
|
||||
USE_XORG= x11
|
||||
USE_GNOME=
|
||||
|
||||
# m17n depends on libintl.so too
|
||||
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -lintl"
|
||||
USE_GETTEXT= yes
|
||||
.if defined(WITHOUT_SVG)
|
||||
CONFIGURE_ARGS+= --without-rsvg
|
||||
.else
|
||||
USE_GNOME+= librsvg2
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_GTK2)
|
||||
.if defined(WITH_XAW)
|
||||
.if defined(WITH_XAW3D) || defined(WITH_MOTIF)
|
||||
IGNORE= please choose only one toolkit: GTK+/Motif/Xaw/Xaw3d
|
||||
.endif
|
||||
USE_XORG= xaw
|
||||
CONFIGURE_ARGS+= --with-x-toolkit=athena --without-xaw3d
|
||||
.elif defined(WITH_XAW3D)
|
||||
.if defined(WITH_MOTIF)
|
||||
IGNORE= please choose only one toolkit: GTK+/Motif/Xaw/Xaw3d
|
||||
.endif
|
||||
LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
|
||||
CONFIGURE_ARGS+= --with-x-toolkit=athena
|
||||
.elif defined(WITH_MOTIF)
|
||||
USE_MOTIF= yes
|
||||
CONFIGURE_ARGS+= --with-x-toolkit=motif
|
||||
.else
|
||||
IGNORE= please choose a toolkit: GTK+/Motif/Xaw/Xaw3d, or build without X11 support
|
||||
.endif
|
||||
.else
|
||||
.if defined(WITH_XAW) || defined(WITH_XAW3D) || defined(WITH_MOTIF)
|
||||
IGNORE= please choose only one toolkit: GTK+/Motif/Xaw/Xaw3d
|
||||
.endif
|
||||
USE_GNOME+= gtk20
|
||||
CONFIGURE_ARGS+= --with-x-toolkit=gtk
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_SCROLLBARS)
|
||||
CONFIGURE_ARGS+= --without-toolkit-scroll-bars
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_SYNC_INPUT)
|
||||
CONFIGURE_ARGS+= --without-sync-input
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_JPEG)
|
||||
CONFIGURE_ARGS+= --without-jpeg
|
||||
.else
|
||||
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_TIFF)
|
||||
CONFIGURE_ARGS+= --without-tiff
|
||||
.else
|
||||
LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_GIF)
|
||||
CONFIGURE_ARGS+= --without-gif
|
||||
.else
|
||||
LIB_DEPENDS+= ungif.5:${PORTSDIR}/graphics/libungif
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_PNG)
|
||||
CONFIGURE_ARGS+= --without-png
|
||||
.else
|
||||
LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_XPM)
|
||||
CONFIGURE_ARGS+= --without-xpm
|
||||
.else
|
||||
USE_XORG+= xpm
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_XFT)
|
||||
.if defined(WITH_M17N)
|
||||
IGNORE= m17n support requires Xft. Please run 'make config'
|
||||
.elif defined(WITH_OTF)
|
||||
IGNORE= otf support requires Xft. Please run 'make config'
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-xft
|
||||
.endif
|
||||
.else
|
||||
USE_XORG+= xft
|
||||
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_M17N)
|
||||
CONFIGURE_ARGS+= --without-m17n-flt
|
||||
.else
|
||||
.if !defined(WITHOUT_XFT)
|
||||
LIB_DEPENDS+= m17n.4:${PORTSDIR}/devel/m17n-lib
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_OTF)
|
||||
CONFIGURE_ARGS+= --without-libotf
|
||||
.else
|
||||
.if !defined(WITHOUT_XFT)
|
||||
LIB_DEPENDS+= otf.0:${PORTSDIR}/print/libotf
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_GCONF)
|
||||
CONFIGURE_ARGS+= --without-gconf
|
||||
.else
|
||||
USE_GNOME+= gconf2
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_XIM)
|
||||
CONFIGURE_ARGS+= --without-xim
|
||||
.endif
|
||||
|
||||
MAN1= b2m.1 ctags.1 ebrowse.1 emacs.1 emacsclient.1 etags.1 \
|
||||
grep-changelog.1 rcs-checkin.1
|
||||
PLIST_SUB= EMACS_VER=${EMACS_VER} EMACS_ARCH=${CONFIGURE_TARGET}
|
||||
.endif
|
||||
|
||||
MAKE_ENV= LC_ALL=C
|
||||
.if defined(WITHOUT_SOUND)
|
||||
CONFIGURE_ARGS+= --without-sound
|
||||
.endif
|
||||
|
||||
INFO= ada-mode auth autotype calc ccmode cl dbus dired-x \
|
||||
ebrowse ediff efaq eintr elisp emacs-mime emacs epa \
|
||||
erc eshell eudc flymake forms gnus idlwave info \
|
||||
mairix-el message mh-e newsticker nxml-mode \
|
||||
org pcl-cvs pgg rcirc reftex remember sasl sc ses sieve \
|
||||
smtpmail speedbar tramp url vip viper widget woman
|
||||
|
||||
LATEST_LINK= emacs-devel
|
||||
|
||||
OPTIONS= SOURCES "Install source code" ON
|
||||
.if defined(WITHOUT_DBUS)
|
||||
CONFIGURE_ARGS+= --without-dbus
|
||||
.else
|
||||
LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} > 900007
|
||||
BROKEN= fails to build with new utmpx
|
||||
.endif
|
||||
|
||||
.if defined(WITH_SOURCES)
|
||||
PLIST_SUB+= SOURCES=""
|
||||
.else
|
||||
.if defined(WITHOUT_SOURCES)
|
||||
PLIST_SUB+= SOURCES="@comment "
|
||||
.else
|
||||
PLIST_SUB+= SOURCES=""
|
||||
.endif
|
||||
|
||||
.if ${ARCH} == "ia64"
|
||||
BROKEN= Emacs 22.X and later does not currently build on ia64
|
||||
BROKEN= Emacs 24.X does not currently build on ia64
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
.if !defined(WITHOUT_X11) && !defined(WITHOUT_GTK)
|
||||
@${ECHO_MSG} "====>"
|
||||
@${ECHO_MSG} "====> To disable GTK+ interface support, define WITHOUT_X11 or WITHOUT_GTK"
|
||||
@${ECHO_MSG} "====>"
|
||||
.endif
|
||||
.if !defined(WITHOUT_X11) && !defined(WITHOUT_XIM)
|
||||
@${ECHO_MSG} "====>"
|
||||
@${ECHO_MSG} "====> To disable X11 Input Method support, define WITHOUT_XIM"
|
||||
@${ECHO_MSG} "====>"
|
||||
.if ${OSVERSION} > 900000
|
||||
PLIST_SUB+= 9X=""
|
||||
.else
|
||||
PLIST_SUB+= 9X="@comment "
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${RM} -f ${WRKSRC}/info/*
|
||||
@${REINPLACE_CMD} -e "s/%%EMACS_VER%%/${EMACS_VER}/g" -e "s/%%DATADIR%%/${DATADIR:C/\//\\\//g}/g" ${WRKSRC}/sources.el
|
||||
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} -e "s/^\(DBUS_LIBS.*\)-pthread\(.*\)$$/\1$$(${DBUS_PTHREAD_LIBS})\2/" ${WRKSRC}/src/Makefile
|
||||
|
||||
.if defined(WITH_SOURCES)
|
||||
post-install:
|
||||
@${MKDIR} ${DATADIR}/${EMACS_VER}/src
|
||||
|
@ -121,4 +238,11 @@ post-install:
|
|||
@${INSTALL_DATA} ${WRKSRC}/sources.el ${DATADIR}/${EMACS_VER}/site-lisp/site-start.el
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_X11)
|
||||
pre-everything::
|
||||
@${ECHO_MSG}
|
||||
@${ECHO_MSG} "====> To disable X11 support, define: WITHOUT_X11."
|
||||
@${ECHO_MSG}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (emacs-23.0.95.tar.gz) = 82dabe28e28872f0b577f9d292866505
|
||||
SHA256 (emacs-23.0.95.tar.gz) = 703001e949b426f99dcdb65eb563118a3214bd8e057bf930925984dc4d8434cf
|
||||
SIZE (emacs-23.0.95.tar.gz) = 42792970
|
||||
MD5 (emacs-24.0.50.100884.tar.xz) = d23fb8b788123816c0f04458b323a4ba
|
||||
SHA256 (emacs-24.0.50.100884.tar.xz) = cbe80cab540746cca0ce72f63536a1ea25291ab4960409bd4c5923c4cf25651e
|
||||
SIZE (emacs-24.0.50.100884.tar.xz) = 22607296
|
||||
|
|
|
@ -1,6 +1,9 @@
|
|||
--- Makefile.in.orig Tue Jun 23 07:41:36 2009 +0300
|
||||
+++ Makefile.in Tue Jun 23 07:39:33 2009 +0300
|
||||
@@ -461,14 +461,6 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.in.orig
|
||||
+++ Makefile.in
|
||||
@@ -472,14 +472,6 @@
|
||||
|
||||
install-arch-indep: mkdir info install-etc
|
||||
-set ${COPYDESTS} ; \
|
||||
|
@ -15,20 +18,20 @@
|
|||
mkdir ${COPYDESTS} ; \
|
||||
chmod ugo+rx ${COPYDESTS} ; \
|
||||
unset CDPATH; \
|
||||
@@ -570,9 +562,9 @@
|
||||
@@ -579,9 +571,9 @@
|
||||
cd ${srcdir}/info ; \
|
||||
for elt in $(INFO_FILES); do \
|
||||
test "$(MAKEINFO)" = "off" && ! test -e $$elt && continue; \
|
||||
- for f in `ls $$elt $$elt-[1-9] $$elt-[1-9][0-9] 2>/dev/null`; do \
|
||||
- ${INSTALL_DATA} $$f $(DESTDIR)${infodir}/$$f; \
|
||||
- chmod a+r $(DESTDIR)${infodir}/$$f; \
|
||||
+ for f in `ls $$elt 2>/dev/null`; do \
|
||||
+ ${INSTALL_DATA} $$f $(DESTDIR)${infodir}/$$f.info; \
|
||||
+ chmod a+r $(DESTDIR)${infodir}/$$f.info; \
|
||||
done; \
|
||||
done); \
|
||||
else true; fi
|
||||
@@ -583,7 +575,7 @@
|
||||
+ for f in `ls $$elt 2>/dev/null`; do \
|
||||
+ ${INSTALL_DATA} $$f $(DESTDIR)${infodir}/$$f.info; \
|
||||
+ chmod a+r $(DESTDIR)${infodir}/$$f.info; \
|
||||
if [ -n "${GZIP_INFO}" ] && [ -n "${GZIP_PROG}" ]; then \
|
||||
rm -f $(DESTDIR)${infodir}/$$f.gz; \
|
||||
${GZIP_PROG} -9n $(DESTDIR)${infodir}/$$f; \
|
||||
@@ -596,7 +588,7 @@
|
||||
for elt in $(INFO_FILES); do \
|
||||
test "$(MAKEINFO)" = "off" && ! test -e $$elt && continue; \
|
||||
(cd $${thisdir}; \
|
||||
|
@ -36,4 +39,4 @@
|
|||
+ ${INSTALL_INFO} --info-dir=$(DESTDIR)${infodir} $(DESTDIR)${infodir}/$$elt.info); \
|
||||
done; \
|
||||
else true; fi
|
||||
-chmod -R a+r $(DESTDIR)${datadir}/emacs/${version} $(DESTDIR)${datadir}/emacs/site-lisp ${COPYDESTS} $(DESTDIR)${infodir}
|
||||
-chmod -R a+r $(DESTDIR)${datadir}/emacs/${version} ${COPYDESTS}
|
||||
|
|
167
editors/emacs-devel/files/patch-configure
Normal file
167
editors/emacs-devel/files/patch-configure
Normal file
|
@ -0,0 +1,167 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.orig
|
||||
+++ configure
|
||||
@@ -5981,160 +5981,10 @@
|
||||
|
||||
|
||||
|
||||
- ALSA_REQUIRED=1.0.0
|
||||
- ALSA_MODULES="alsa >= $ALSA_REQUIRED"
|
||||
-
|
||||
- succeeded=no
|
||||
-
|
||||
- # Extract the first word of "pkg-config", so it can be a program name with args.
|
||||
-set dummy pkg-config; ac_word=$2
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||
-$as_echo_n "checking for $ac_word... " >&6; }
|
||||
-if test "${ac_cv_path_PKG_CONFIG+set}" = set; then :
|
||||
- $as_echo_n "(cached) " >&6
|
||||
-else
|
||||
- case $PKG_CONFIG in
|
||||
- [\\/]* | ?:[\\/]*)
|
||||
- ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a path.
|
||||
- ;;
|
||||
- *)
|
||||
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
||||
-for as_dir in $PATH
|
||||
-do
|
||||
- IFS=$as_save_IFS
|
||||
- test -z "$as_dir" && as_dir=.
|
||||
- for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
|
||||
- ac_cv_path_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||
- break 2
|
||||
- fi
|
||||
-done
|
||||
- done
|
||||
-IFS=$as_save_IFS
|
||||
-
|
||||
- test -z "$ac_cv_path_PKG_CONFIG" && ac_cv_path_PKG_CONFIG="no"
|
||||
- ;;
|
||||
-esac
|
||||
-fi
|
||||
-PKG_CONFIG=$ac_cv_path_PKG_CONFIG
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PKG_CONFIG" >&5
|
||||
-$as_echo "$PKG_CONFIG" >&6; }
|
||||
-else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
- if test "$PKG_CONFIG" = "no" ; then
|
||||
- HAVE_ALSA=no
|
||||
- else
|
||||
- PKG_CONFIG_MIN_VERSION=0.9.0
|
||||
- if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ALSA_MODULES" >&5
|
||||
-$as_echo_n "checking for $ALSA_MODULES... " >&6; }
|
||||
-
|
||||
- if $PKG_CONFIG --exists "$ALSA_MODULES" 2>&5; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
- succeeded=yes
|
||||
-
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking ALSA_CFLAGS" >&5
|
||||
-$as_echo_n "checking ALSA_CFLAGS... " >&6; }
|
||||
- ALSA_CFLAGS=`$PKG_CONFIG --cflags "$ALSA_MODULES"|sed -e 's,///*,/,g'`
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ALSA_CFLAGS" >&5
|
||||
-$as_echo "$ALSA_CFLAGS" >&6; }
|
||||
-
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking ALSA_LIBS" >&5
|
||||
-$as_echo_n "checking ALSA_LIBS... " >&6; }
|
||||
- ALSA_LIBS=`$PKG_CONFIG --libs "$ALSA_MODULES"|sed -e 's,///*,/,g'`
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ALSA_LIBS" >&5
|
||||
-$as_echo "$ALSA_LIBS" >&6; }
|
||||
- else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- ALSA_CFLAGS=""
|
||||
- ALSA_LIBS=""
|
||||
- ## If we have a custom action on failure, don't print errors, but
|
||||
- ## do set a variable so people can do so.
|
||||
- ALSA_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$ALSA_MODULES"`
|
||||
-
|
||||
- fi
|
||||
-
|
||||
-
|
||||
-
|
||||
- else
|
||||
- echo "*** Your version of pkg-config is too old. You need version $PKG_CONFIG_MIN_VERSION or newer."
|
||||
- echo "*** See http://www.freedesktop.org/software/pkgconfig"
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
- if test $succeeded = yes; then
|
||||
- HAVE_ALSA=yes
|
||||
- else
|
||||
- HAVE_ALSA=no
|
||||
- fi
|
||||
-
|
||||
- if test $HAVE_ALSA = yes; then
|
||||
- SAVE_CFLAGS="$CFLAGS"
|
||||
- SAVE_LDFLAGS="$LDFLAGS"
|
||||
- CFLAGS="$ALSA_CFLAGS $CFLAGS"
|
||||
- LDFLAGS="$ALSA_LIBS $LDFLAGS"
|
||||
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
-/* end confdefs.h. */
|
||||
-#include <asoundlib.h>
|
||||
-int
|
||||
-main ()
|
||||
-{
|
||||
-snd_lib_error_set_handler (0);
|
||||
- ;
|
||||
- return 0;
|
||||
-}
|
||||
-_ACEOF
|
||||
-if ac_fn_c_try_compile "$LINENO"; then :
|
||||
- emacs_alsa_normal=yes
|
||||
-else
|
||||
- emacs_alsa_normal=no
|
||||
-fi
|
||||
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
- if test "$emacs_alsa_normal" != yes; then
|
||||
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
-/* end confdefs.h. */
|
||||
-#include <alsa/asoundlib.h>
|
||||
-int
|
||||
-main ()
|
||||
-{
|
||||
-snd_lib_error_set_handler (0);
|
||||
- ;
|
||||
- return 0;
|
||||
-}
|
||||
-_ACEOF
|
||||
-if ac_fn_c_try_compile "$LINENO"; then :
|
||||
- emacs_alsa_subdir=yes
|
||||
-else
|
||||
- emacs_alsa_subdir=no
|
||||
-fi
|
||||
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
- if test "$emacs_alsa_subdir" != yes; then
|
||||
- as_fn_error $? "pkg-config found alsa, but it does not compile. See config.log for error messages." "$LINENO" 5
|
||||
- fi
|
||||
- ALSA_CFLAGS="$ALSA_CFLAGS -DALSA_SUBDIR_INCLUDE"
|
||||
- fi
|
||||
-
|
||||
- CFLAGS="$SAVE_CFLAGS"
|
||||
- LDFLAGS="$SAVE_LDFLAGS"
|
||||
- LIBSOUND="$LIBSOUND $ALSA_LIBS"
|
||||
- CFLAGS_SOUND="$CFLAGS_SOUND $ALSA_CFLAGS"
|
||||
-
|
||||
-$as_echo "#define HAVE_ALSA 1" >>confdefs.h
|
||||
-
|
||||
- fi
|
||||
|
||||
if test x$have_sound_header = xyes || test $HAVE_ALSA = yes; then
|
||||
case "$opsys" in
|
||||
- gnu-linux|freebsd|netbsd)
|
||||
+ gnu-linux|freebsd*|netbsd)
|
||||
|
||||
$as_echo "#define HAVE_SOUND 1" >>confdefs.h
|
||||
|
|
@ -1,47 +0,0 @@
|
|||
--- src/image.c.orig 2010-03-29 08:46:39.902587060 +0200
|
||||
+++ src/image.c 2010-03-29 08:51:40.907908128 +0200
|
||||
@@ -5793,7 +5793,7 @@
|
||||
/* PNG library details. */
|
||||
|
||||
DEF_IMGLIB_FN (png_get_io_ptr);
|
||||
-DEF_IMGLIB_FN (png_check_sig);
|
||||
+DEF_IMGLIB_FN (png_sig_cmp);
|
||||
DEF_IMGLIB_FN (png_create_read_struct);
|
||||
DEF_IMGLIB_FN (png_create_info_struct);
|
||||
DEF_IMGLIB_FN (png_destroy_read_struct);
|
||||
@@ -5824,7 +5824,7 @@
|
||||
return 0;
|
||||
|
||||
LOAD_IMGLIB_FN (library, png_get_io_ptr);
|
||||
- LOAD_IMGLIB_FN (library, png_check_sig);
|
||||
+ LOAD_IMGLIB_FN (library, png_sig_cmp);
|
||||
LOAD_IMGLIB_FN (library, png_create_read_struct);
|
||||
LOAD_IMGLIB_FN (library, png_create_info_struct);
|
||||
LOAD_IMGLIB_FN (library, png_destroy_read_struct);
|
||||
@@ -5849,7 +5849,7 @@
|
||||
#else
|
||||
|
||||
#define fn_png_get_io_ptr png_get_io_ptr
|
||||
-#define fn_png_check_sig png_check_sig
|
||||
+#define fn_png_sig_cmp png_sig_cmp
|
||||
#define fn_png_create_read_struct png_create_read_struct
|
||||
#define fn_png_create_info_struct png_create_info_struct
|
||||
#define fn_png_destroy_read_struct png_destroy_read_struct
|
||||
@@ -5996,7 +5996,7 @@
|
||||
|
||||
/* Check PNG signature. */
|
||||
if (fread (sig, 1, sizeof sig, fp) != sizeof sig
|
||||
- || !fn_png_check_sig (sig, sizeof sig))
|
||||
+ || fn_png_sig_cmp (sig, 0, sizeof sig))
|
||||
{
|
||||
image_error ("Not a PNG file: `%s'", file, Qnil);
|
||||
UNGCPRO;
|
||||
@@ -6013,7 +6013,7 @@
|
||||
|
||||
/* Check PNG signature. */
|
||||
if (tbr.len < sizeof sig
|
||||
- || !fn_png_check_sig (tbr.bytes, sizeof sig))
|
||||
+ || fn_png_sig_cmp (tbr.bytes, 0, sizeof sig))
|
||||
{
|
||||
image_error ("Not a PNG image: `%s'", img->spec, Qnil);
|
||||
UNGCPRO;
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue