Update to upstream version 0.9.2.7
PR: 206329 Submitted by: daniel@morante.net (maintainer)
This commit is contained in:
parent
f66fade054
commit
ab18d9e94d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=407171
4 changed files with 67 additions and 22 deletions
|
@ -2,7 +2,8 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= zetacoin
|
||||
PORTVERSION= 0.9.2.4
|
||||
PORTVERSION= 0.9.2.7
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= net-p2p finance
|
||||
|
||||
MAINTAINER= daniel@morante.net
|
||||
|
@ -10,40 +11,45 @@ COMMENT= Peer-to-Peer crypto currency with quick transactions
|
|||
|
||||
LICENSE= MIT
|
||||
|
||||
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconf
|
||||
LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs
|
||||
|
||||
USES+= autoreconf compiler:c++0x gmake libtool pkgconfig:build
|
||||
|
||||
BROKEN_armv6= AtomicPointer not implemented
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_TAGNAME= 22ddb9b
|
||||
|
||||
OPTIONS_DEFINE= X11 UPNP WALLET CLI TEST
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
WALLET_DESC= Build wallet or P2P server node only
|
||||
QRCODES_DESC= Enable QR code display when building graphical interface
|
||||
CLI_DESC= Build command line RPC client
|
||||
CLI_DESC= Build command line RPC client
|
||||
|
||||
OPTIONS_DEFAULT= X11 WALLET QRCODES
|
||||
OPTIONS_GROUP= X11
|
||||
OPTIONS_GROUP= X11
|
||||
OPTIONS_GROUP_X11= QRCODES
|
||||
|
||||
UPNP_CONFIGURE_WITH= miniupnpc
|
||||
UPNP_LIB_DEPENDS= libminiupnpc.so:${PORTSDIR}/net/miniupnpc
|
||||
UPNP_LIB_DEPENDS= libminiupnpc.so:${PORTSDIR}/net/miniupnpc
|
||||
UPNP_CPPFLAGS= -I${LOCALBASE}/include
|
||||
UPNP_LIBS= -L${LOCALBASE}/lib
|
||||
|
||||
X11_CONFIGURE_WITH= gui
|
||||
X11_CONFIGURE_ON= --without-daemon
|
||||
X11_CONFIGURE_OFF= --with-daemon
|
||||
X11_BUILD_DEPENDS= protoc:${PORTSDIR}/devel/protobuf
|
||||
X11_LIB_DEPENDS= libprotobuf.so:${PORTSDIR}/devel/protobuf
|
||||
X11_USE= qt4=corelib,network,gui,qmake_build,linguisttools_build \
|
||||
qt4=uic_build,moc_build,rcc_build,qtestlib_build
|
||||
qt4=uic_build,moc_build,rcc_build,qtestlib_build
|
||||
X11_USES= desktop-file-utils
|
||||
|
||||
WALLET_CONFIGURE_ENABLE= wallet
|
||||
WALLET_CXXFLAGS= -I${BDB_INCLUDE_DIR} -L${BDB_LIB_DIR}
|
||||
WALLET_USE= bdb=yes
|
||||
WALLET_CXXFLAGS= -I${BDB_INCLUDE_DIR}
|
||||
WALLET_LIBS= -L${BDB_LIB_DIR}
|
||||
WALLET_USE= bdb=48
|
||||
|
||||
QRCODES_IMPLIES= X11
|
||||
QRCODES_LIB_DEPENDS= libqrencode.so:${PORTSDIR}/graphics/libqrencode
|
||||
QRCODES_CONFIGURE_WITH= qrencode
|
||||
|
||||
|
@ -53,15 +59,9 @@ TEST_CONFIGURE_ENABLE= tests
|
|||
TEST_ALL_TARGET= check
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= SSL_LIBS="-lssl" CRYPTO_LIBS="-lcrypto" SSL_CFLAGS="-I/usr/include" CRYPTO_CFLAGS="-I/usr/include"
|
||||
|
||||
USES= autoreconf gmake
|
||||
CONFIGURE_ENV= CRYPTO_CFLAGS="-I${OPENSSLINC}" CRYPTO_LIBS="-L${OPENSSLLIB} -lcrypto" \
|
||||
SSL_CFLAGS="-I${OPENSSLINC}" SSL_LIBS="-L${OPENSSLLIB} -lssl"
|
||||
USE_OPENSSL= yes
|
||||
WANT_BDB_VER= 48
|
||||
|
||||
CXXFLAGS+= -I${LOCALBASE}/include
|
||||
CXXFLAGS+= -L${LOCALBASE}/lib
|
||||
CXXFLAGS+= -Wno-invalid-offsetof
|
||||
|
||||
QT_BINARY= ${PORTNAME}-qt
|
||||
CLI_BINARY= ${PORTNAME}-cli
|
||||
|
@ -74,8 +74,8 @@ PLIST_SUB+= EXECUTABLE_QT=bin/${QT_BINARY} \
|
|||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if empty(PORT_OPTIONS:MX11) && !empty(PORT_OPTIONS:MQRCODES)
|
||||
BROKEN= QRCODES requires X11 support. Run 'make config' again!
|
||||
.if ${PORT_OPTIONS:MX11}
|
||||
QT_NONSTANDARD= yes
|
||||
.endif
|
||||
|
||||
# tests will currently fail
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (zetacoin-zetacoin-0.9.2.4-22ddb9b_GH0.tar.gz) = daa9138be4d893ec10bdc429928d4fa6c2f935c0489fdd855cc1e4aaaf65a6f8
|
||||
SIZE (zetacoin-zetacoin-0.9.2.4-22ddb9b_GH0.tar.gz) = 4265754
|
||||
SHA256 (zetacoin-zetacoin-v0.9.2.7_GH0.tar.gz) = e24bdcc9c576d6af268b790118e294f8ce1e18695a4234a58f84abb9856233f1
|
||||
SIZE (zetacoin-zetacoin-v0.9.2.7_GH0.tar.gz) = 4266219
|
||||
|
|
31
net-p2p/zetacoin/files/patch-src_net.cpp
Normal file
31
net-p2p/zetacoin/files/patch-src_net.cpp
Normal file
|
@ -0,0 +1,31 @@
|
|||
commit 9f3e48e5219a09b5ddfd6883d1f0498910eff4b6
|
||||
Author: Pavel Vasin <pavel@vasin.nl>
|
||||
Date: Sun, 23 Aug 2015 23:53:49 +0300
|
||||
|
||||
add support for miniupnpc api version 14
|
||||
|
||||
The value of new arg ttl is set to 2 as it's recommended default.
|
||||
---
|
||||
src/net.cpp | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/net.cpp b/src/net.cpp
|
||||
index fb5726a..4c6331f 100644
|
||||
--- src/net.cpp.orig 2015-07-10 17:23:55 UTC
|
||||
+++ src/net.cpp
|
||||
@@ -1120,10 +1120,14 @@ void ThreadMapPort()
|
||||
#ifndef UPNPDISCOVER_SUCCESS
|
||||
/* miniupnpc 1.5 */
|
||||
devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0);
|
||||
-#else
|
||||
+#elif MINIUPNPC_API_VERSION < 14
|
||||
/* miniupnpc 1.6 */
|
||||
int error = 0;
|
||||
devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, &error);
|
||||
+#else
|
||||
+ /* miniupnpc 1.9.20150730 */
|
||||
+ int error = 0;
|
||||
+ devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, 2, &error);
|
||||
#endif
|
||||
|
||||
struct UPNPUrls urls;
|
|
@ -27,6 +27,8 @@
|
|||
name=%%PORTNAME%%
|
||||
rcvar=%%PORTNAME%%_enable
|
||||
|
||||
load_rc_config $name
|
||||
|
||||
: ${%%PORTNAME%%_enable:=NO}
|
||||
: ${%%PORTNAME%%_config=%%PREFIX%%/etc/%%PORTNAME%%.conf}
|
||||
: ${%%PORTNAME%%_datadir=/var/db/%%PORTNAME%%}
|
||||
|
@ -40,6 +42,8 @@ pidfile="${%%PORTNAME%%_datadir}/%%PORTNAME%%d.pid"
|
|||
stop_cmd=%%PORTNAME%%_stop
|
||||
command_args="-conf=${%%PORTNAME%%_config} -datadir=${%%PORTNAME%%_datadir} -noupnp -daemon -pid=${pidfile}"
|
||||
start_precmd="${name}_prestart"
|
||||
reindex_cmd=%%PORTNAME%%_reindex
|
||||
extra_commands="reindex"
|
||||
|
||||
%%PORTNAME%%_create_datadir()
|
||||
{
|
||||
|
@ -72,5 +76,15 @@ start_precmd="${name}_prestart"
|
|||
wait_for_pids ${rc_pid}
|
||||
}
|
||||
|
||||
load_rc_config $name
|
||||
%%PORTNAME%%_reindex()
|
||||
{
|
||||
if [ -z "$rc_fast" -a -n "$rc_pid" ]; then
|
||||
%%PORTNAME%%_stop
|
||||
fi
|
||||
|
||||
echo "Reindexing ${name} blockchain."
|
||||
command_args="${command_args} -reindex"
|
||||
eval ${command} ${command_args}
|
||||
}
|
||||
|
||||
run_rc_command "$1"
|
||||
|
|
Loading…
Reference in a new issue