add gprolog

A free Prolog compiler developed by Daniel Diaz

PR:		28651
Submitted by:	Douglas Anestad <yotta@dougdidit.com>
This commit is contained in:
Ying-Chieh Liao 2001-07-08 07:57:56 +00:00
parent 827ac39580
commit ab23c9993d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44911
7 changed files with 223 additions and 0 deletions

View file

@ -52,6 +52,7 @@
SUBDIR += gnustep-guile
SUBDIR += gnustep-objc
SUBDIR += gpc
SUBDIR += gprolog
SUBDIR += guile
SUBDIR += guileobjc
SUBDIR += hugs

23
lang/gprolog/Makefile Normal file
View file

@ -0,0 +1,23 @@
# New ports collection makefile for: gprolog
# Date created: 30 June 2001
# Whom: Douglas Anestad <yotta@dougdidit.com>
#
# $FreeBSD$
#
PORTNAME= gprolog
PORTVERSION= 1.2.1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= yotta@dougdidit.com
.include <bsd.port.pre.mk>
CONFIGURE_ARGS= --disable-linedit
USE_AUTOCONF= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_GMAKE= yes
.include <bsd.port.post.mk>

1
lang/gprolog/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (gprolog-1.2.1.tar.gz) = 8858c7b3dcf297cc9c7233c085e844c5

View file

@ -0,0 +1,11 @@
--- Ma2Asm/ix86_any.c.orig Sat Jun 30 12:19:37 2001
+++ Ma2Asm/ix86_any.c Sat Jun 30 12:20:04 2001
@@ -39,7 +39,7 @@
#define MAX_C_ARGS_IN_C_CODE 32
-#if defined(M_ix86_cygwin) || defined(M_ix86_bsd)
+#if defined(M_ix86_cygwin) || (defined(M_ix86_bsd) && !defined(__FreeBSD__))
#define UN "_"

1
lang/gprolog/pkg-comment Normal file
View file

@ -0,0 +1 @@
A free Prolog compiler developed by Daniel Diaz

23
lang/gprolog/pkg-descr Normal file
View file

@ -0,0 +1,23 @@
GNU Prolog is a free Prolog compiler with constraint solving over finite
domains developed by Daniel Diaz.
GNU Prolog accepts Prolog+constraint programs and produces native binaries
(like gcc does from a C source). The obtained executable is then stand-alone.
The size of this executable can be quite small since GNU Prolog can avoid to
link the code of most unused built-in predicates. The performances of GNU
Prolog are very encouraging (comparable to commercial systems).
Beside the native-code compilation, GNU Prolog offers a classical interactive
interpreter (top-level) with a debugger.
The Prolog part conforms to the ISO standard for Prolog with many extensions
very useful in practice (global variables, OS interface, sockets,...).
GNU Prolog also includes an efficient constraint solver over Finite Domains
(FD). This opens contraint logic pogramming to the user combining the power
of constraint programming to the declarativity of logic programming.
WWW: http://gnu-prolog.inria.fr/
Douglas Anestad
yotta@dougdidit.com

163
lang/gprolog/pkg-plist Normal file
View file

@ -0,0 +1,163 @@
bin/fd2c
bin/gplc
bin/gprolog
bin/hexgplc
bin/ma2asm
bin/pl2wam
bin/wam2ma
gprolog-1.2.1/bin/gplc
gprolog-1.2.1/bin/hexgplc
gprolog-1.2.1/bin/gprolog
gprolog-1.2.1/bin/pl2wam
gprolog-1.2.1/bin/wam2ma
gprolog-1.2.1/bin/ma2asm
gprolog-1.2.1/bin/fd2c
gprolog-1.2.1/include/gprolog.h
gprolog-1.2.1/lib/obj_begin.o
gprolog-1.2.1/lib/obj_end.o
gprolog-1.2.1/lib/top_level.o
gprolog-1.2.1/lib/all_pl_bips.o
gprolog-1.2.1/lib/debugger.o
gprolog-1.2.1/lib/all_fd_bips.o
gprolog-1.2.1/lib/libengine_pl.a
gprolog-1.2.1/lib/libbips_pl.a
gprolog-1.2.1/lib/libengine_fd.a
gprolog-1.2.1/lib/libbips_fd.a
gprolog-1.2.1/doc/manual.dvi
gprolog-1.2.1/doc/manual.ps
gprolog-1.2.1/doc/compil-scheme.pdf
gprolog-1.2.1/doc/debug-box.pdf
gprolog-1.2.1/doc/manual.pdf
gprolog-1.2.1/doc/Html/index.html
gprolog-1.2.1/doc/Html/manual-idx.html
gprolog-1.2.1/doc/Html/manual001.html
gprolog-1.2.1/doc/Html/manual002.html
gprolog-1.2.1/doc/Html/manual003.html
gprolog-1.2.1/doc/Html/manual004.html
gprolog-1.2.1/doc/Html/manual005.html
gprolog-1.2.1/doc/Html/manual006.html
gprolog-1.2.1/doc/Html/manual007.html
gprolog-1.2.1/doc/Html/manual008.html
gprolog-1.2.1/doc/Html/manual009.html
gprolog-1.2.1/doc/Html/manual010.html
gprolog-1.2.1/doc/Html/manual011.html
gprolog-1.2.1/doc/Html/manual012.html
gprolog-1.2.1/doc/Html/manual013.html
gprolog-1.2.1/doc/Html/manual014.html
gprolog-1.2.1/doc/Html/manual015.html
gprolog-1.2.1/doc/Html/manual016.html
gprolog-1.2.1/doc/Html/manual017.html
gprolog-1.2.1/doc/Html/manual018.html
gprolog-1.2.1/doc/Html/manual019.html
gprolog-1.2.1/doc/Html/manual020.html
gprolog-1.2.1/doc/Html/manual021.html
gprolog-1.2.1/doc/Html/manual022.html
gprolog-1.2.1/doc/Html/manual023.html
gprolog-1.2.1/doc/Html/manual024.html
gprolog-1.2.1/doc/Html/manual025.html
gprolog-1.2.1/doc/Html/manual026.html
gprolog-1.2.1/doc/Html/manual027.html
gprolog-1.2.1/doc/Html/manual028.html
gprolog-1.2.1/doc/Html/manual029.html
gprolog-1.2.1/doc/Html/manual030.html
gprolog-1.2.1/doc/Html/manual031.html
gprolog-1.2.1/doc/Html/manual032.html
gprolog-1.2.1/doc/Html/manual033.html
gprolog-1.2.1/doc/Html/manual034.html
gprolog-1.2.1/doc/Html/manual035.html
gprolog-1.2.1/doc/Html/manual036.html
gprolog-1.2.1/doc/Html/manual037.html
gprolog-1.2.1/doc/Html/manual038.html
gprolog-1.2.1/doc/Html/manual039.html
gprolog-1.2.1/doc/Html/manual040.html
gprolog-1.2.1/doc/Html/manual041.html
gprolog-1.2.1/doc/Html/manual042.html
gprolog-1.2.1/doc/Html/manual043.html
gprolog-1.2.1/doc/Html/manual044.html
gprolog-1.2.1/doc/Html/manual045.html
gprolog-1.2.1/doc/Html/manual046.html
gprolog-1.2.1/doc/Html/manual047.html
gprolog-1.2.1/doc/Html/manual048.html
gprolog-1.2.1/doc/Html/manual049.html
gprolog-1.2.1/doc/Html/manual050.html
gprolog-1.2.1/doc/Html/manual051.html
gprolog-1.2.1/doc/Html/manual052.html
gprolog-1.2.1/doc/Html/manual053.html
gprolog-1.2.1/doc/Html/manual054.html
gprolog-1.2.1/doc/Html/manual055.html
gprolog-1.2.1/doc/Html/manual056.html
gprolog-1.2.1/doc/Html/manual057.html
gprolog-1.2.1/doc/Html/manual058.html
gprolog-1.2.1/doc/Html/manual059.html
gprolog-1.2.1/doc/Html/manual060.html
gprolog-1.2.1/doc/Html/manual061.html
gprolog-1.2.1/doc/Html/manual062.html
gprolog-1.2.1/doc/Html/manual063.html
gprolog-1.2.1/doc/Html/manual064.html
gprolog-1.2.1/doc/Html/manual065.html
gprolog-1.2.1/doc/Html/manual066.html
gprolog-1.2.1/doc/Html/manual067.html
gprolog-1.2.1/doc/Html/manual068.html
gprolog-1.2.1/doc/Html/manual069.html
gprolog-1.2.1/doc/Html/compil-scheme.gif
gprolog-1.2.1/doc/Html/contents_motif.gif
gprolog-1.2.1/doc/Html/debug-box.gif
gprolog-1.2.1/doc/Html/next_motif.gif
gprolog-1.2.1/doc/Html/previous_motif.gif
gprolog-1.2.1/ExamplesPl/Makefile
gprolog-1.2.1/ExamplesPl/boyer.pl
gprolog-1.2.1/ExamplesPl/browse.pl
gprolog-1.2.1/ExamplesPl/cal.pl
gprolog-1.2.1/ExamplesPl/chat_parser.pl
gprolog-1.2.1/ExamplesPl/crypt.pl
gprolog-1.2.1/ExamplesPl/ham.pl
gprolog-1.2.1/ExamplesPl/meta_qsort.pl
gprolog-1.2.1/ExamplesPl/nand.pl
gprolog-1.2.1/ExamplesPl/nrev.pl
gprolog-1.2.1/ExamplesPl/poly_10.pl
gprolog-1.2.1/ExamplesPl/queens.pl
gprolog-1.2.1/ExamplesPl/queens8.pl
gprolog-1.2.1/ExamplesPl/reducer.pl
gprolog-1.2.1/ExamplesPl/sdda.pl
gprolog-1.2.1/ExamplesPl/sendmore.pl
gprolog-1.2.1/ExamplesPl/tak.pl
gprolog-1.2.1/ExamplesPl/tak_gvar.pl
gprolog-1.2.1/ExamplesPl/zebra.pl
gprolog-1.2.1/ExamplesFD/Makefile
gprolog-1.2.1/ExamplesFD/alpha.pl
gprolog-1.2.1/ExamplesFD/array.pl
gprolog-1.2.1/ExamplesFD/bdiag.pl
gprolog-1.2.1/ExamplesFD/bdonald.pl
gprolog-1.2.1/ExamplesFD/bpigeon.pl
gprolog-1.2.1/ExamplesFD/bqueens.pl
gprolog-1.2.1/ExamplesFD/bramsey.pl
gprolog-1.2.1/ExamplesFD/bridge.pl
gprolog-1.2.1/ExamplesFD/bridge1.pl
gprolog-1.2.1/ExamplesFD/bschur.pl
gprolog-1.2.1/ExamplesFD/bsend.pl
gprolog-1.2.1/ExamplesFD/cars.pl
gprolog-1.2.1/ExamplesFD/crypta.pl
gprolog-1.2.1/ExamplesFD/digit8.pl
gprolog-1.2.1/ExamplesFD/donald.pl
gprolog-1.2.1/ExamplesFD/eq10.pl
gprolog-1.2.1/ExamplesFD/eq20.pl
gprolog-1.2.1/ExamplesFD/five.pl
gprolog-1.2.1/ExamplesFD/gardner.pl
gprolog-1.2.1/ExamplesFD/magic.pl
gprolog-1.2.1/ExamplesFD/magsq.pl
gprolog-1.2.1/ExamplesFD/multipl.pl
gprolog-1.2.1/ExamplesFD/partit.pl
gprolog-1.2.1/ExamplesFD/qg5.pl
gprolog-1.2.1/ExamplesFD/queens.pl
gprolog-1.2.1/ExamplesFD/send.pl
gprolog-1.2.1/ExamplesFD/square.pl
gprolog-1.2.1/ExamplesFD/srq.pl
gprolog-1.2.1/ExamplesFD/queens_fd.fd
@dirrm gprolog-1.2.1/ExamplesFD
@dirrm gprolog-1.2.1/ExamplesPl
@dirrm gprolog-1.2.1/doc/Html
@dirrm gprolog-1.2.1/doc
@dirrm gprolog-1.2.1/lib
@dirrm gprolog-1.2.1/include
@dirrm gprolog-1.2.1/bin
@dirrm gprolog-1.2.1