Import of swarm version 1.3.1.

The Swarm Simulation System

PR:		9726
Submitted by:	Horance C.H Chou <horance@freedom.ie.cycu.edu.tw>
This commit is contained in:
Steve Price 1999-04-03 02:02:29 +00:00
parent 7b31014788
commit ab382141da
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=17606
6 changed files with 315 additions and 0 deletions

32
devel/swarm/Makefile Normal file
View file

@ -0,0 +1,32 @@
# New ports collection makefile for: swarm
# Version required: 1.3.1
# Date created: 26 June 1998
# Whom: Horance C.H Chou <horance@freedom.ie.cycu.edu.tw>
#
# $Id: Makefile,v 1.28 1999/01/23 07:05:23 vanilla Exp $
#
DISTNAME= swarm-1.3.1
#PKGNAME= swarm-1.3.1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.santafe.edu/pub/swarm/
MAINTAINER= horance@freedom.ie.cycu.edu.tw
LIB_DEPENDS= ffi.2:${PORTSDIR}/devel/libffi \
png.3:${PORTSDIR}/graphics/png \
Xpm.4:${PORTSDIR}/graphics/xpm \
tcl80.1:${PORTSDIR}/lang/tcl80 \
tk80.1:${PORTSDIR}/x11-toolkits/tk80 \
BLT.2:${PORTSDIR}/x11-toolkits/blt
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-defaultdir=${PREFIX} \
--with-tclincludedir=${PREFIX}/include/tcl8.0/generic \
--with-tkincludedir=${PREFIX}/include/tk8.0/generic \
post-install:
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>

1
devel/swarm/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (swarm-1.3.1.tar.gz) = 2d315c7f3bdb492ac8ea56d79b7db84f

View file

@ -0,0 +1,13 @@
--- Makefile.in.orig Wed Jan 27 22:34:30 1999
+++ Makefile.in Wed Jan 27 22:49:33 1999
@@ -370,8 +370,8 @@
install-data-local:
$(INSTALL_DATA) swarmconfig.h $(includedir)
$(mkinstalldirs) $(bindir) $(datadir)/swarm
- $(INSTALL_PROGRAM) $(top_builddir)/libtool $(bindir)/libtool-swarm
- if test $(SWARM_INSTALL) = install-sh; then $(INSTALL_PROGRAM) $(srcdir)/install-sh $(bindir); fi
+ $(INSTALL_SCRIPT) $(top_builddir)/libtool $(bindir)/libtool-swarm
+ if test $(SWARM_INSTALL) = install-sh; then $(INSTALL_SCRIPT) $(srcdir)/install-sh $(bindir); fi
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.

1
devel/swarm/pkg-comment Normal file
View file

@ -0,0 +1 @@
The Swarm Simulation System

9
devel/swarm/pkg-descr Normal file
View file

@ -0,0 +1,9 @@
Swarm is a software package for multi-agent simulation of complex
systems being developed at The Santa Fe Institute. Swarm is intended
to be a useful tool for researchers in a variety of disciplines,
especially artificial life. The basic architecture of Swarm is the
simulation of collections of concurrently interacting agents: with
this architecture, we can implement a large variety of agent based
models. Our initial target is Unix machines running GNU Objective C
and X windows: the source code is freely available under GNU Licensing
terms.

259
devel/swarm/pkg-plist Normal file
View file

@ -0,0 +1,259 @@
bin/libtool-swarm
bin/m2h
bin/make-h2x
etc/swarm/Makefile.appl
etc/swarm/Makefile.common
etc/swarm/Makefile.lib
etc/swarm/config.swarm
include/activity.h
include/activity/Action.h
include/activity/ActionGroup.h
include/activity/CompoundAction.h
include/activity/Schedule.h
include/activity/SwarmProcess.h
include/activity/XActivity.h
include/activity/classes.h
include/activity/types.h
include/analysis.h
include/analysis/ActiveGraph.h
include/analysis/ActiveOutFile.h
include/analysis/Averager.h
include/analysis/EZBin.h
include/analysis/EZDistribution.h
include/analysis/EZGraph.h
include/analysis/Entropy.h
include/analysis/FunctionGraph.h
include/collections.h
include/collections/Array.h
include/collections/Collection.h
include/collections/InputStream.h
include/collections/List.h
include/collections/List_GEN.h
include/collections/List_linked.h
include/collections/List_mlinks.h
include/collections/Map.h
include/collections/OrderedSet.h
include/collections/OutputStream.h
include/collections/Set.h
include/collections/StringObject.h
include/collections/classes.h
include/collections/collections.h
include/collections/predicates.h
include/collections/types.h
include/defobj.h
include/defobj/Create.h
include/defobj/Customize.h
include/defobj/DefClass.h
include/defobj/DefObject.h
include/defobj/Program.h
include/defobj/Symbol.h
include/defobj/Zone.h
include/defobj/classes.h
include/defobj/defalloc.h
include/defobj/deftype.h
include/defobj/types.h
include/gui.h
include/misc.h
include/misc/argp.h
include/misc/getopt.h
include/objectbase.h
include/objectbase/ActivityControl.h
include/objectbase/Arguments.h
include/objectbase/CompleteProbeMap.h
include/objectbase/CompleteVarMap.h
include/objectbase/CustomProbeMap.h
include/objectbase/DefaultProbeMap.h
include/objectbase/EmptyProbeMap.h
include/objectbase/MessageProbe.h
include/objectbase/Probe.h
include/objectbase/ProbeLibrary.h
include/objectbase/ProbeMap.h
include/objectbase/Swarm.h
include/objectbase/SwarmObject.h
include/objectbase/VarProbe.h
include/objectbase/probing.h
include/objectbase/swarm_rts_routines.h
include/objectbase/version.h
include/random.h
include/random/ACGgen.h
include/random/BernoulliDist.h
include/random/C2LCGXgen.h
include/random/C2MRG3gen.h
include/random/C2TAUSgen.h
include/random/C3MWCgen.h
include/random/C4LCGXgen.h
include/random/ExponentialDist.h
include/random/GammaDist.h
include/random/LCGgen.h
include/random/LogNormalDist.h
include/random/MRGgen.h
include/random/MT19937gen.h
include/random/MWCAgen.h
include/random/MWCBgen.h
include/random/NormalDist.h
include/random/PMMLCGgen.h
include/random/PSWBgen.h
include/random/RWC2gen.h
include/random/RWC8gen.h
include/random/RandomBitDist.h
include/random/RandomDefs.h
include/random/RandomVars.h
include/random/SCGgen.h
include/random/SWBgen.h
include/random/TGFSRgen.h
include/random/UniformDoubleDist.h
include/random/UniformIntegerDist.h
include/random/UniformUnsignedDist.h
include/random/distributions.h
include/random/generators.h
include/simtools.h
include/simtools/AppendFile.h
include/simtools/Archiver.h
include/simtools/InFile.h
include/simtools/ListShuffler.h
include/simtools/NSelect.h
include/simtools/ObjectLoader.h
include/simtools/ObjectSaver.h
include/simtools/OutFile.h
include/simtools/QSort.h
include/simtools/UName.h
include/simtoolsgui.h
include/simtoolsgui/ActionCache.h
include/simtoolsgui/ActionHolder.h
include/simtoolsgui/ClassDisplayWidget.h
include/simtoolsgui/CommonProbeDisplay.h
include/simtoolsgui/CompleteProbeDisplay.h
include/simtoolsgui/ControlPanel.h
include/simtoolsgui/GUIComposite.h
include/simtoolsgui/GUISwarm.h
include/simtoolsgui/MessageProbeWidget.h
include/simtoolsgui/MultiVarProbeDisplay.h
include/simtoolsgui/MultiVarProbeWidget.h
include/simtoolsgui/ProbeDisplay.h
include/simtoolsgui/ProbeDisplayManager.h
include/simtoolsgui/SimpleProbeDisplay.h
include/simtoolsgui/SingleProbeDisplay.h
include/simtoolsgui/VarProbeWidget.h
include/simtoolsgui/global.h
include/space.h
include/space/Ca2d.h
include/space/ConwayLife2d.h
include/space/DblBuffer2d.h
include/space/Diffuse2d.h
include/space/Discrete2d.h
include/space/Grid2d.h
include/space/Int2dFiler.h
include/space/Object2dDisplay.h
include/space/Value2dDisplay.h
include/swarmconfig.h
include/tclobjc/TclInterp.h
include/tclobjc/TkInterp.h
include/tclobjc/tclObjc.h
include/tkobjc.h
include/tkobjc/ArchivedGeometryWidget.h
include/tkobjc/Button.h
include/tkobjc/ButtonPanel.h
include/tkobjc/Canvas.h
include/tkobjc/CanvasAbstractItem.h
include/tkobjc/CanvasItem.h
include/tkobjc/CheckButton.h
include/tkobjc/Circle.h
include/tkobjc/ClassDisplayHideButton.h
include/tkobjc/ClassDisplayLabel.h
include/tkobjc/Colormap.h
include/tkobjc/CompleteProbeDisplayLabel.h
include/tkobjc/CompositeItem.h
include/tkobjc/Entry.h
include/tkobjc/Form.h
include/tkobjc/Frame.h
include/tkobjc/Graph.h
include/tkobjc/Histogram.h
include/tkobjc/InputWidget.h
include/tkobjc/Label.h
include/tkobjc/Line.h
include/tkobjc/LinkItem.h
include/tkobjc/MessageProbeEntry.h
include/tkobjc/NodeItem.h
include/tkobjc/OvalNodeItem.h
include/tkobjc/Pixmap.h
include/tkobjc/ProbeCanvas.h
include/tkobjc/Raster.h
include/tkobjc/Rectangle.h
include/tkobjc/RectangleNodeItem.h
include/tkobjc/ScheduleItem.h
include/tkobjc/SimpleProbeDisplayHideButton.h
include/tkobjc/SuperButton.h
include/tkobjc/TextItem.h
include/tkobjc/TkExtra.h
include/tkobjc/VarProbeEntry.h
include/tkobjc/VarProbeLabel.h
include/tkobjc/Widget.h
include/tkobjc/WindowGeometryRecord.h
include/tkobjc/ZoomRaster.h
include/tkobjc/common.h
include/tkobjc/global.h
include/tkobjc/internal.h
include/tkobjc/win32dib.h
lib/libactivity.a
lib/libactivity.la
lib/libactivity.so
lib/libactivity.so.1
lib/libanalysis.a
lib/libanalysis.la
lib/libanalysis.so
lib/libanalysis.so.2
lib/libcollections.a
lib/libcollections.la
lib/libcollections.so
lib/libcollections.so.1
lib/libdefobj.a
lib/libdefobj.la
lib/libdefobj.so
lib/libdefobj.so.0
lib/libmisc.a
lib/libmisc.la
lib/libmisc.so
lib/libmisc.so.2
lib/libobjectbase.a
lib/libobjectbase.la
lib/libobjectbase.so
lib/libobjectbase.so.2
lib/librandom.a
lib/librandom.la
lib/librandom.so
lib/librandom.so.0
lib/libsimtools.a
lib/libsimtools.la
lib/libsimtools.so
lib/libsimtools.so.2
lib/libsimtoolsgui.a
lib/libsimtoolsgui.la
lib/libsimtoolsgui.so
lib/libsimtoolsgui.so.2
lib/libspace.a
lib/libspace.la
lib/libspace.so
lib/libspace.so.2
lib/libtclobjc.a
lib/libtclobjc.la
lib/libtclobjc.so
lib/libtclobjc.so.0
lib/libtkobjc.a
lib/libtkobjc.la
lib/libtkobjc.so
lib/libtkobjc.so.2
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
@dirrm etc/swarm
@dirrm include/activity
@dirrm include/analysis
@dirrm include/collections
@dirrm include/defobj
@dirrm include/misc
@dirrm include/objectbase
@dirrm include/random
@dirrm include/simtools
@dirrm include/simtoolsgui
@dirrm include/space
@dirrm include/tclobjc
@dirrm include/tkobjc