math/ambit: Update 0.6 → 0.7
Reported by: portscout
This commit is contained in:
parent
dad941db26
commit
ab88b4e243
5 changed files with 9 additions and 60 deletions
|
@ -1,7 +1,6 @@
|
|||
PORTNAME= ambit
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.6
|
||||
PORTREVISION= 3
|
||||
DISTVERSION= 0.7
|
||||
CATEGORIES= math
|
||||
PKGNAMESUFFIX= -tensor # avoid clash with shells/ambit
|
||||
|
||||
|
@ -16,7 +15,7 @@ LIB_DEPENDS= libhdf5.so:science/hdf5 \
|
|||
libopenblas.so:math/openblas \
|
||||
libsz.so:science/libaec
|
||||
|
||||
USES= cmake:testing compiler:c++11-lang python:build
|
||||
USES= cmake:testing compiler:c++17-lang python:build
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
USE_GITHUB= yes
|
||||
|
@ -24,7 +23,8 @@ GH_ACCOUNT= jturney
|
|||
|
||||
# some declared cmake options do nothing: see https://github.com/jturney/ambit/issues/25 and the patch
|
||||
CMAKE_ON= SHARED_ONLY ENABLE_OPENMP
|
||||
CMAKE_OFF= ENABLE_TESTS # https://github.com/jturney/ambit/issues/24
|
||||
CMAKE_OFF= ambit_ENABLE_PYTHON \
|
||||
ENABLE_TESTS # https://github.com/jturney/ambit/issues/24
|
||||
CMAKE_TESTING_ON= ENABLE_TESTS
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1650421128
|
||||
SHA256 (jturney-ambit-v0.6_GH0.tar.gz) = ede894402ef719e74e9d03a9458139543fa66d38d0cf91632362ba8a0e478aa6
|
||||
SIZE (jturney-ambit-v0.6_GH0.tar.gz) = 332730
|
||||
TIMESTAMP = 1684643393
|
||||
SHA256 (jturney-ambit-v0.7_GH0.tar.gz) = 97a4360db5cad6c9d2bc0932fc8641a3feb34a809c192c99886880073e87f8c2
|
||||
SIZE (jturney-ambit-v0.7_GH0.tar.gz) = 336129
|
||||
|
|
|
@ -1,39 +0,0 @@
|
|||
--- CMakeLists.txt.orig 2022-03-26 22:14:15 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -99,7 +99,7 @@ find_package (TargetLAPACK REQUIRED)
|
||||
|
||||
# Python Detection
|
||||
set(Python_ADDITIONAL_VERSIONS 3.10 3.9 3.8 3.7) # adjust with CMake minimum FindPythonInterp
|
||||
-find_package(Python 3.7 COMPONENTS Interpreter Development NumPy REQUIRED)
|
||||
+find_package(Python 3.7 COMPONENTS Interpreter Development REQUIRED)
|
||||
message(STATUS "Found Python ${Python_VERSION_MAJOR}.${Python_VERSION_MINOR}: ${Python_EXECUTABLE} (found version ${Python_VERSION})")
|
||||
|
||||
#if (NOT ENABLE_STATIC AND NOT ENABLE_PSI4)
|
||||
@@ -149,7 +149,9 @@ endif()
|
||||
#endif()
|
||||
|
||||
# library directory
|
||||
+if (FREEBSD_BUILD_PYTHON_BINDING)
|
||||
add_subdirectory(lib)
|
||||
+endif()
|
||||
|
||||
# include directory (for installation)
|
||||
add_subdirectory(include)
|
||||
@@ -157,7 +159,7 @@ add_subdirectory(include)
|
||||
# recursively add source directories
|
||||
add_subdirectory(src)
|
||||
|
||||
-#if (NOT ENABLE_PSI4)
|
||||
+if (ENABLE_TESTS)
|
||||
# test suite
|
||||
enable_testing()
|
||||
include(CTest)
|
||||
@@ -165,7 +167,7 @@ add_subdirectory(src)
|
||||
|
||||
# sample suite
|
||||
add_subdirectory(samples)
|
||||
-#endif()
|
||||
+endif()
|
||||
|
||||
# Add all targets to the build-tree export set
|
||||
|
|
@ -1,14 +0,0 @@
|
|||
- python bindinf isn't installed into the right location, see https://github.com/jturney/ambit/issues/54
|
||||
|
||||
--- src/CMakeLists.txt.orig 2022-04-20 02:23:19 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -128,7 +128,9 @@ else()
|
||||
add_library(ambit-lib ALIAS ambit-shared)
|
||||
endif()
|
||||
|
||||
+if (FREEBSD_BUILD_PYTHON_BINDING)
|
||||
add_subdirectory(python)
|
||||
+endif()
|
||||
|
||||
# <<< Install >>>
|
||||
|
|
@ -20,9 +20,11 @@ include/ambit/print.h
|
|||
include/ambit/settings.h
|
||||
include/ambit/sym_blocked_tensor.h
|
||||
include/ambit/tensor.h
|
||||
include/ambit/tensor/indices.h
|
||||
include/ambit/timer.h
|
||||
lib/libambit.so
|
||||
share/cmake/ambit/FindTargetHDF5.cmake
|
||||
share/cmake/ambit/FindTargetLAPACK.cmake
|
||||
share/cmake/ambit/ambitConfig.cmake
|
||||
share/cmake/ambit/ambitConfigVersion.cmake
|
||||
share/cmake/ambit/ambitTargets-shared-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
|
|
Loading…
Reference in a new issue