Update to 1.3.12

PR:		147001
Submitted by:	Peter Thoenen
This commit is contained in:
Tilman Keskinoz 2010-05-30 13:52:56 +00:00
parent d4bc278df0
commit abb12f5fd6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=255319
5 changed files with 12 additions and 32 deletions

View file

@ -5,9 +5,9 @@
# $FreeBSD$
PORTNAME= ccid
PORTVERSION= 1.3.11
PORTVERSION= 1.3.12
CATEGORIES= devel
MASTER_SITES= http://alioth.debian.org/frs/download.php/3080/
MASTER_SITES= http://alioth.debian.org/frs/download.php/3281/
MAINTAINER= arved@FreeBSD.org
COMMENT= Generic USB CCID (Chip/Smart Card Interface Devices) driver
@ -19,15 +19,17 @@ GNU_CONFIGURE= yes
USE_PERL5_BUILD=yes
CONFIGURE_ARGS= --enable-usbdropdir=${PREFIX}/lib/pcsc/drivers \
--enable-ccidtwindir=${PREFIX}/lib/pcsc/drivers/serial \
--enable-udev
--enable-udev
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}" \
LIBUSB_CFLAGS="-I${LOCALBASE}/include" \
LIBUSB_LIBS="-L${LOCALBASE}/lib -lusb"
PLIST_SUB= VER=${PORTVERSION}
.if !defined(NOPORTDOCS)
MAN1= RSA_SecurID_getpasswd.1
MAN8= Kobil_mIDentity_switch.8
.endif
.include <bsd.port.pre.mk>

View file

@ -1,3 +1,3 @@
MD5 (ccid-1.3.11.tar.bz2) = 727dc7eb4d560f81fe70a766a96de970
SHA256 (ccid-1.3.11.tar.bz2) = f7bf5a82b02aff7d709a45dcc6109105508625caf92e34da4140b7c84d498906
SIZE (ccid-1.3.11.tar.bz2) = 418017
MD5 (ccid-1.3.12.tar.bz2) = 7fcdbacacd955659286f988fa9b6e0be
SHA256 (ccid-1.3.12.tar.bz2) = caa1badbb530e109aa767c51d304659a510d427aaa26bd329bed693751b1e38b
SIZE (ccid-1.3.12.tar.bz2) = 425496

View file

@ -1,11 +0,0 @@
--- src/ccid_usb.c.orig 2009-03-07 20:05:04.000000000 +0300
+++ src/ccid_usb.c 2009-03-07 20:09:14.000000000 +0300
@@ -56,6 +56,8 @@
#define BUS_DEVICE_STRSIZE 32
+EXTERNAL struct usb_interface * get_ccid_usb_interface(struct usb_device *dev, int *num);
+
typedef struct
{
usb_dev_handle *handle;

View file

@ -1,10 +0,0 @@
--- src/parse.c.orig 2009-04-02 17:52:07.000000000 +0200
+++ src/parse.c 2009-10-17 13:17:25.000000000 +0200
@@ -46,6 +46,7 @@
static int ccid_parse_interface_descriptor(usb_dev_handle *handle,
struct usb_device *dev, int num);
+struct usb_interface * get_ccid_usb_interface(struct usb_device *dev, int *num);
/*****************************************************************************

View file

@ -1,11 +1,10 @@
bin/RSA_SecurID_getpasswd
sbin/Kobil_mIDentity_switch
lib/pcsc/drivers/ifd-ccid.bundle/Contents/FreeBSD/libccid.so.%%VER%%
lib/pcsc/drivers/ifd-ccid.bundle/Contents/FreeBSD/libccid.so
lib/pcsc/drivers/ifd-ccid.bundle/Contents/FreeBSD/libccid.so.%%VER%%
lib/pcsc/drivers/ifd-ccid.bundle/Contents/Info.plist
share/doc/ccid/README_Kobil_mIDentity_switch.txt
@dirrm share/doc/ccid
sbin/Kobil_mIDentity_switch
%%PORTDOCS%%%%DOCSDIR%%/README_Kobil_mIDentity_switch.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/pcsc/drivers/ifd-ccid.bundle/Contents/FreeBSD
@dirrm lib/pcsc/drivers/ifd-ccid.bundle/Contents
@dirrm lib/pcsc/drivers/ifd-ccid.bundle
@dirrmtry lib/pcsc/drivers