New port: devel/blitz: Blitz++ Multi-Dimensional Array Library for C++
Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13222
This commit is contained in:
parent
742ed9faab
commit
abdbad66be
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=454833
6 changed files with 184 additions and 0 deletions
|
@ -201,6 +201,7 @@
|
|||
SUBDIR += bison
|
||||
SUBDIR += bisoncpp
|
||||
SUBDIR += blame
|
||||
SUBDIR += blitz
|
||||
SUBDIR += bmake
|
||||
SUBDIR += bmkdep
|
||||
SUBDIR += bnf
|
||||
|
|
42
devel/blitz/Makefile
Normal file
42
devel/blitz/Makefile
Normal file
|
@ -0,0 +1,42 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= blitz
|
||||
DISTVERSION= 1.0.1
|
||||
CATEGORIES= devel science
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Blitz++ Multi-Dimensional Array Library for C++
|
||||
|
||||
LICENSE= ART20
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
USES= gmake libtool localbase python:build
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= blitzpp
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
TEST_TARGET= check-testsuite
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
CONFIGURE_ARGS= --enable-shared
|
||||
MAKE_ARGS= CXXFLAGS="${CXXFLAGS}" FREEBSD_PYTHON_CMD=${PYTHON_CMD}
|
||||
|
||||
OPTIONS_DEFINE= APAD FORTRAN SERIALIZATION TBB THREADSAFE
|
||||
APAD_DESC= Pad all lowest-rank lengths to nearest larger SIMD width
|
||||
SERIALIZATION_DESC= Enable serialization support using Boost::Serialization
|
||||
TBB_DESC= Use Intel Threading Building Blocks atomic types
|
||||
THREADSAFE_DESC= Enable thread-safety features
|
||||
|
||||
APAD_CONFIGURE_ENABLE= array-length-padding
|
||||
FORTRAN_CONFIGURE_ENABLE= fortran
|
||||
FORTRAN_USES= fortran
|
||||
SERIALIZATION_CONFIGURE_ENABLE= serialization
|
||||
SERIALIZATION_BUILD_DEPENDS= ${LOCALBASE}/include/boost/mpi.hpp:devel/boost-libs
|
||||
TBB_CONFIGURE_ON= --with-tbb # TBB_CONFIGURE_WITH=tbb doesn't work: https://github.com/blitzpp/blitz/issues/20
|
||||
TBB_BUILD_DEPENDS= ${LOCALBASE}/include/tbb/atomic.h:devel/tbb
|
||||
THREADSAFE_CONFIGURE_ENABLE= threadsafe
|
||||
|
||||
post-install:
|
||||
@${RM} -r ${STAGEDIR}${DOCSDIR}* # https://github.com/blitzpp/blitz/issues/21
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/blitz/distinfo
Normal file
3
devel/blitz/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1511509658
|
||||
SHA256 (blitzpp-blitz-1.0.1_GH0.tar.gz) = b62fc3f07b64b264307b01fec5e4f2793e09a68dcb5378984aedbc2e4b3adcef
|
||||
SIZE (blitzpp-blitz-1.0.1_GH0.tar.gz) = 4645082
|
11
devel/blitz/files/patch-blitz_generate_Makefile.in
Normal file
11
devel/blitz/files/patch-blitz_generate_Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- blitz/generate/Makefile.in.orig 2017-10-02 16:04:43 UTC
|
||||
+++ blitz/generate/Makefile.in
|
||||
@@ -619,7 +619,7 @@ uninstall-am:
|
||||
|
||||
|
||||
$(top_srcdir)/blitz/array/stencil-classes.cc: genstencils.py
|
||||
- python $< $@
|
||||
+ $(FREEBSD_PYTHON_CMD) $< $@
|
||||
|
||||
generate-headers: $(top_srcdir)/blitz/array/stencil-classes.cc
|
||||
|
4
devel/blitz/pkg-descr
Normal file
4
devel/blitz/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
Blitz++ is a C++ template class library that provides array objects for
|
||||
scientific computing. It is not a linear algebra or fft library.
|
||||
|
||||
WWW: https://github.com/blitzpp/blitz
|
123
devel/blitz/pkg-plist
Normal file
123
devel/blitz/pkg-plist
Normal file
|
@ -0,0 +1,123 @@
|
|||
include/blitz/array-impl.h
|
||||
include/blitz/array.cc
|
||||
include/blitz/array.h
|
||||
include/blitz/array/asexpr.cc
|
||||
include/blitz/array/asexpr.h
|
||||
include/blitz/array/cartesian.h
|
||||
include/blitz/array/cgsolve.h
|
||||
include/blitz/array/complex.cc
|
||||
include/blitz/array/convolve.cc
|
||||
include/blitz/array/convolve.h
|
||||
include/blitz/array/cycle.cc
|
||||
include/blitz/array/domain.h
|
||||
include/blitz/array/et.h
|
||||
include/blitz/array/expr.cc
|
||||
include/blitz/array/expr.h
|
||||
include/blitz/array/fastiter.h
|
||||
include/blitz/array/funcs.h
|
||||
include/blitz/array/functorExpr.h
|
||||
include/blitz/array/geometry.h
|
||||
include/blitz/array/indirect.h
|
||||
include/blitz/array/interlace.cc
|
||||
include/blitz/array/io.cc
|
||||
include/blitz/array/iter.h
|
||||
include/blitz/array/map.h
|
||||
include/blitz/array/methods.cc
|
||||
include/blitz/array/misc.cc
|
||||
include/blitz/array/multi.h
|
||||
include/blitz/array/newet-macros.h
|
||||
include/blitz/array/newet.h
|
||||
include/blitz/array/ops.cc
|
||||
include/blitz/array/ops.h
|
||||
include/blitz/array/reduce.cc
|
||||
include/blitz/array/reduce.h
|
||||
include/blitz/array/resize.cc
|
||||
include/blitz/array/shape.h
|
||||
include/blitz/array/slice.h
|
||||
include/blitz/array/slicing.cc
|
||||
include/blitz/array/stencil-classes.cc
|
||||
include/blitz/array/stencil-et-macros.h
|
||||
include/blitz/array/stencil-et.h
|
||||
include/blitz/array/stencilops.h
|
||||
include/blitz/array/stencils.cc
|
||||
include/blitz/array/stencils.h
|
||||
include/blitz/array/storage.h
|
||||
include/blitz/array/where.h
|
||||
include/blitz/array/zip.h
|
||||
include/blitz/bench.cc
|
||||
include/blitz/bench.h
|
||||
include/blitz/benchext.cc
|
||||
include/blitz/benchext.h
|
||||
include/blitz/blitz.h
|
||||
include/blitz/bounds.h
|
||||
include/blitz/bzconfig.h
|
||||
include/blitz/bzdebug.h
|
||||
include/blitz/compiler.h
|
||||
include/blitz/constpointerstack.h
|
||||
include/blitz/et-forward.h
|
||||
include/blitz/etbase.h
|
||||
include/blitz/funcs.h
|
||||
include/blitz/globeval.cc
|
||||
include/blitz/gnu/bzconfig.h
|
||||
include/blitz/indexexpr.h
|
||||
include/blitz/indexmap-forward.h
|
||||
include/blitz/levicivita.h
|
||||
include/blitz/limits-hack.h
|
||||
include/blitz/listinit.h
|
||||
include/blitz/memblock.cc
|
||||
include/blitz/memblock.h
|
||||
include/blitz/meta/dot.h
|
||||
include/blitz/meta/matassign.h
|
||||
include/blitz/meta/matmat.h
|
||||
include/blitz/meta/matvec.h
|
||||
include/blitz/meta/metaprog.h
|
||||
include/blitz/meta/product.h
|
||||
include/blitz/meta/sum.h
|
||||
include/blitz/meta/vecassign.h
|
||||
include/blitz/minmax.h
|
||||
include/blitz/numinquire.h
|
||||
include/blitz/numtrait.h
|
||||
include/blitz/ops.h
|
||||
include/blitz/prettyprint.h
|
||||
include/blitz/promote.h
|
||||
include/blitz/range.cc
|
||||
include/blitz/range.h
|
||||
include/blitz/ranks.h
|
||||
include/blitz/reduce.h
|
||||
include/blitz/shapecheck.h
|
||||
include/blitz/simdtypes.h
|
||||
include/blitz/tau.h
|
||||
include/blitz/timer.h
|
||||
include/blitz/tinymat2.cc
|
||||
include/blitz/tinymat2.h
|
||||
include/blitz/tinymat2io.cc
|
||||
include/blitz/tinyvec2.cc
|
||||
include/blitz/tinyvec2.h
|
||||
include/blitz/tinyvec2io.cc
|
||||
include/blitz/tm2fastiter.h
|
||||
include/blitz/tmevaluate.h
|
||||
include/blitz/traversal.cc
|
||||
include/blitz/traversal.h
|
||||
include/blitz/tuning.h
|
||||
include/blitz/tv2fastiter.h
|
||||
include/blitz/tvcross.h
|
||||
include/blitz/tvecglobs.h
|
||||
include/blitz/tvevaluate.h
|
||||
include/blitz/update.h
|
||||
include/blitz/wrap-climits.h
|
||||
include/random/F.h
|
||||
include/random/beta.h
|
||||
include/random/chisquare.h
|
||||
include/random/default.h
|
||||
include/random/discrete-uniform.h
|
||||
include/random/exponential.h
|
||||
include/random/gamma.h
|
||||
include/random/mt.h
|
||||
include/random/mtparam.cc
|
||||
include/random/normal.h
|
||||
include/random/uniform.h
|
||||
lib/libblitz.a
|
||||
lib/libblitz.so
|
||||
lib/libblitz.so.0
|
||||
lib/libblitz.so.0.0.0
|
||||
libdata/pkgconfig/blitz.pc
|
Loading…
Reference in a new issue