- Respect ${LOCALBASE} [1]
- Respect ${CXX} and ${CXXFLAGS} - Discard vendor optimization flags - Remove useless USE_GMAKE [1]: PR: ports/87563 Submitted by: maintainer
This commit is contained in:
parent
26bb7b1afa
commit
abe6c92c24
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=145647
2 changed files with 5 additions and 16 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= png2ico
|
||||
PORTVERSION= 2002.12.08
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.winterdrache.de/freeware/png2ico/data/
|
||||
DISTNAME= ${PORTNAME}-src-${PORTVERSION:S/./-/g}
|
||||
|
@ -21,11 +21,6 @@ MAN1= png2ico.1
|
|||
PLIST_FILES= bin/png2ico
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|-O2|${CFLAGS}|' ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
|
|
|
@ -1,17 +1,11 @@
|
|||
--- Makefile.orig Sat Dec 7 23:49:52 2002
|
||||
+++ Makefile Mon Mar 1 13:24:57 2004
|
||||
@@ -1,11 +1,11 @@
|
||||
-CPPFLAGS=-W -Wall -O2 -finline-functions
|
||||
+CPPFLAGS=-W -Wall -g -O -pipe -finline-functions -I/usr/local/include -L/usr/local/lib
|
||||
#CPPFLAGS=-O0 -W -Wall
|
||||
-DEBUG=-g
|
||||
+#DEBUG=-g
|
||||
|
||||
--- Makefile.orig Mon Oct 17 13:19:41 2005
|
||||
+++ Makefile Mon Oct 17 13:21:09 2005
|
||||
@@ -5,7 +5,7 @@
|
||||
all: png2ico
|
||||
|
||||
png2ico: png2ico.cpp
|
||||
- g++ $(CPPFLAGS) $(DEBUG) -o $@ $< -lpng -lz -lm
|
||||
+ ${CXX} $(CPPFLAGS) $(DEBUG) -o $@ $< -lpng -lz -lm
|
||||
+ $(CXX) $(CXXFLAGS) -I$(LOCALBASE)/include -L$(LOCALBASE)/lib -o $@ $< -lpng -lz -lm
|
||||
|
||||
doc/png2ico.txt: doc/png2ico.1
|
||||
man $< |sed -e $$'s/.\b\\(.\\)/\\1/g' -e 's/\(.*\)/\1'$$'\r/' >$@
|
||||
|
|
Loading…
Reference in a new issue