- Update to 5.5.6 RC release [1]
- Add support for DTrace [2] PR: ports/150915 [1], ports/150488 [2] Submitted by: Oleg Sidorkin <osidorkin@gmail.com> [1], rpaulo [2]
This commit is contained in:
parent
fc3108be7e
commit
ac053c9ed0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=262019
12 changed files with 90 additions and 90 deletions
|
@ -6,13 +6,13 @@
|
|||
#
|
||||
|
||||
PORTNAME?= mysql
|
||||
PORTVERSION= 5.5.5
|
||||
PORTREVISION?= 1
|
||||
PORTVERSION= 5.5.6
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES= databases ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_MYSQL}
|
||||
MASTER_SITE_SUBDIR= MySQL-5.5
|
||||
PKGNAMESUFFIX?= -server
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-m3
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-rc
|
||||
|
||||
MAINTAINER= ale@FreeBSD.org
|
||||
COMMENT?= Multithreaded SQL database (server)
|
||||
|
@ -27,10 +27,9 @@ CONFIGURE_ARGS= --localstatedir=/var/db/mysql \
|
|||
--without-libedit \
|
||||
--with-libwrap \
|
||||
--with-low-memory \
|
||||
--with-plugins=max \
|
||||
--with-plugins=max-no-ndb \
|
||||
--with-comment='FreeBSD port: ${PKGNAME}' \
|
||||
--enable-thread-safe-client \
|
||||
--disable-dtrace
|
||||
--enable-thread-safe-client
|
||||
|
||||
.ifdef USE_MYSQL
|
||||
.error You have `USE_MYSQL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
|
||||
|
@ -45,6 +44,12 @@ CONFIGURE_ARGS+=--with-charset=${WITH_CHARSET}
|
|||
.if defined(WITH_XCHARSET) && ${WITH_XCHARSET} != ""
|
||||
CONFIGURE_ARGS+=--with-extra-charsets=${WITH_XCHARSET}
|
||||
.endif
|
||||
.if defined(WITH_DTRACE)
|
||||
CONFIGURE_ARGS+=--enable-dtrace
|
||||
CONFIGURE_ENV+= LDFLAGS=-lelf
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-dtrace
|
||||
.endif
|
||||
.if defined(WITH_OPENSSL)
|
||||
.if !defined(WITHOUT_YASSL)
|
||||
CONFIGURE_ARGS+=--with-ssl=bundled
|
||||
|
@ -123,6 +128,7 @@ pre-fetch:
|
|||
@${ECHO} " WITH_CHARSET=charset Define the primary built-in charset (latin1)."
|
||||
@${ECHO} " WITH_XCHARSET=list Define other built-in charsets (may be 'all')."
|
||||
@${ECHO} " WITH_COLLATION=collate Define default collation (latin1_swedish_ci)."
|
||||
@${ECHO} " WITH_DTRACE=yes Enable DTrace."
|
||||
@${ECHO} " WITH_OPENSSL=yes Enable secure connections"
|
||||
@${ECHO} " (define WITHOUT_YASSL for backward compatibility)."
|
||||
@${ECHO} " WITH_LINUXTHREADS=yes Use the linuxthreads pthread library."
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (mysql-5.5.5-m3.tar.gz) = ad27f6561d6010c9346ffeca6de403fa
|
||||
SHA256 (mysql-5.5.5-m3.tar.gz) = 38e9fab063c193ba5fcefd31e6678477a7a45579da73150cac41a848399bff24
|
||||
SIZE (mysql-5.5.5-m3.tar.gz) = 22806816
|
||||
MD5 (mysql-5.5.6-rc.tar.gz) = 25cbd495e3aa87b4eb741b213b6dd990
|
||||
SHA256 (mysql-5.5.6-rc.tar.gz) = 1f96667a6a81b472ba3ee96a7dfaa99aec8cbd7a2f799be352235b24f7f309b8
|
||||
SIZE (mysql-5.5.6-rc.tar.gz) = 25596239
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- Makefile.in.orig 2010-03-24 21:30:45.000000000 +0100
|
||||
+++ Makefile.in 2010-04-13 16:21:29.000000000 +0200
|
||||
@@ -416,15 +416,7 @@
|
||||
--- Makefile.in.orig 2010-09-17 22:48:47.000000000 +0200
|
||||
+++ Makefile.in 2010-09-27 14:55:30.000000000 +0200
|
||||
@@ -419,16 +419,7 @@
|
||||
README COPYING EXCEPTIONS-CLIENT \
|
||||
CMakeLists.txt configure.cmake config.h.cmake BUILD-CMAKE
|
||||
|
||||
|
@ -9,9 +9,10 @@
|
|||
- @pstack_dir@ libservices \
|
||||
- @sql_union_dirs@ unittest \
|
||||
- @sql_server@ @man_dirs@ tests \
|
||||
- netware @libmysqld_dirs@ \
|
||||
- @libmysqld_dirs@ \
|
||||
- mysql-test support-files sql-bench \
|
||||
- win \
|
||||
- packaging \
|
||||
- cmake
|
||||
+SUBDIRS =
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- configure.am.orig 2010-07-06 20:37:18.000000000 +0200
|
||||
+++ configure.am 2010-07-16 11:11:48.000000000 +0200
|
||||
@@ -990,6 +990,8 @@
|
||||
--- configure.am.orig 2010-09-17 22:48:48.000000000 +0200
|
||||
+++ configure.am 2010-09-27 16:39:47.000000000 +0200
|
||||
@@ -1011,6 +1011,8 @@
|
||||
MYSQL_BASE_VERSION
|
||||
MYSQL_NO_DASH_VERSION
|
||||
MYSQL_U_SCORE_VERSION
|
||||
|
@ -9,7 +9,16 @@
|
|||
TEST_NDBCLUSTER
|
||||
MAKEINDEX
|
||||
PDFLATEX
|
||||
@@ -12684,6 +12686,8 @@
|
||||
@@ -12717,7 +12719,7 @@
|
||||
_ACEOF
|
||||
|
||||
case "$target_os" in
|
||||
- *solaris*)
|
||||
+ *solaris*|*freebsd*)
|
||||
HAVE_DTRACE_DASH_G="yes"
|
||||
;;
|
||||
*)
|
||||
@@ -12750,6 +12752,8 @@
|
||||
NDB_VERSION_MINOR=`echo $MYSQL_NUMERIC_VERSION | cut -d. -f2`
|
||||
NDB_VERSION_BUILD=`echo $MYSQL_NUMERIC_VERSION | cut -d. -f3`
|
||||
NDB_VERSION_STATUS=`echo $VERSION | sed 's/^[-.0-9]*//'`
|
||||
|
@ -18,7 +27,7 @@
|
|||
TEST_NDBCLUSTER=""
|
||||
|
||||
|
||||
@@ -25849,8 +25853,8 @@
|
||||
@@ -25752,8 +25756,8 @@
|
||||
# Some system specific hacks
|
||||
#
|
||||
|
||||
|
|
|
@ -1,21 +1,5 @@
|
|||
--- include/Makefile.in.orig 2010-07-27 16:46:08.000000000 +0200
|
||||
+++ include/Makefile.in 2010-07-27 16:48:45.000000000 +0200
|
||||
@@ -480,12 +480,11 @@
|
||||
-rm -rf .libs _libs
|
||||
install-pkgincludeHEADERS: $(pkginclude_HEADERS)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgincludedir)" || $(MKDIR_P) "$(DESTDIR)$(pkgincludedir)"
|
||||
+ test -z "$(pkgincludedir)" || $(MKDIR_P) "$(DESTDIR)$(pkgincludedir)/mysql/psi"
|
||||
@list='$(pkginclude_HEADERS)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
- f=$(am__strip_dir) \
|
||||
- echo " $(pkgincludeHEADERS_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgincludedir)/$$f'"; \
|
||||
- $(pkgincludeHEADERS_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgincludedir)/$$f"; \
|
||||
+ echo " $(pkgincludeHEADERS_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgincludedir)/$$p'"; \
|
||||
+ $(pkgincludeHEADERS_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgincludedir)/$$p"; \
|
||||
done
|
||||
|
||||
uninstall-pkgincludeHEADERS:
|
||||
@@ -708,8 +707,6 @@
|
||||
@HAVE_DTRACE_TRUE@probes_mysql_dtrace.h: $(DTRACEPROVIDER)
|
||||
@HAVE_DTRACE_TRUE@ $(DTRACE) $(DTRACEFLAGS) -h -s $(DTRACEPROVIDER) -o $@
|
||||
|
|
|
@ -17,6 +17,7 @@ include/mysql/m_ctype.h
|
|||
include/mysql/m_string.h
|
||||
include/mysql/my_alloc.h
|
||||
include/mysql/my_attribute.h
|
||||
include/mysql/my_compiler.h
|
||||
include/mysql/my_config.h
|
||||
include/mysql/my_dbug.h
|
||||
include/mysql/my_dir.h
|
||||
|
@ -28,15 +29,6 @@ include/mysql/my_no_pthread.h
|
|||
include/mysql/my_pthread.h
|
||||
include/mysql/my_sys.h
|
||||
include/mysql/my_xml.h
|
||||
include/mysql/mysql/plugin_audit.h
|
||||
include/mysql/mysql/plugin_ftparser.h
|
||||
include/mysql/mysql/plugin.h
|
||||
include/mysql/mysql/psi/mysql_file.h
|
||||
include/mysql/mysql/psi/mysql_thread.h
|
||||
include/mysql/mysql/psi/psi.h
|
||||
include/mysql/mysql/services.h
|
||||
include/mysql/mysql/service_my_snprintf.h
|
||||
include/mysql/mysql/service_thd_alloc.h
|
||||
include/mysql/mysql.h
|
||||
include/mysql/mysql_com.h
|
||||
include/mysql/mysql_embed.h
|
||||
|
@ -44,8 +36,17 @@ include/mysql/mysql_time.h
|
|||
include/mysql/mysql_version.h
|
||||
include/mysql/mysqld_ername.h
|
||||
include/mysql/mysqld_error.h
|
||||
include/mysql/plugin_audit.h
|
||||
include/mysql/plugin_ftparser.h
|
||||
include/mysql/plugin.h
|
||||
include/mysql/probes_mysql.h
|
||||
include/mysql/probes_mysql_nodtrace.h
|
||||
include/mysql/psi/mysql_file.h
|
||||
include/mysql/psi/mysql_thread.h
|
||||
include/mysql/psi/psi.h
|
||||
include/mysql/services.h
|
||||
include/mysql/service_my_snprintf.h
|
||||
include/mysql/service_thd_alloc.h
|
||||
include/mysql/sql_common.h
|
||||
include/mysql/sql_state.h
|
||||
include/mysql/sslopt-case.h
|
||||
|
@ -61,8 +62,7 @@ lib/mysql/libmysqlclient_r.la
|
|||
lib/mysql/libmysqlclient_r.so
|
||||
lib/mysql/libmysqlclient_r.so.16
|
||||
share/aclocal/mysql.m4
|
||||
@dirrm include/mysql/mysql/psi
|
||||
@dirrm include/mysql/mysql
|
||||
@dirrm include/mysql/psi
|
||||
@dirrm include/mysql
|
||||
@dirrm lib/mysql
|
||||
@dirrmtry %%DATADIR%%
|
||||
|
|
|
@ -6,13 +6,13 @@
|
|||
#
|
||||
|
||||
PORTNAME?= mysql
|
||||
PORTVERSION= 5.5.5
|
||||
PORTREVISION?= 1
|
||||
PORTVERSION= 5.5.6
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES= databases ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_MYSQL}
|
||||
MASTER_SITE_SUBDIR= MySQL-5.5
|
||||
PKGNAMESUFFIX?= -server
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-m3
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-rc
|
||||
|
||||
MAINTAINER= ale@FreeBSD.org
|
||||
COMMENT?= Multithreaded SQL database (server)
|
||||
|
@ -27,10 +27,9 @@ CONFIGURE_ARGS= --localstatedir=/var/db/mysql \
|
|||
--without-libedit \
|
||||
--with-libwrap \
|
||||
--with-low-memory \
|
||||
--with-plugins=max \
|
||||
--with-plugins=max-no-ndb \
|
||||
--with-comment='FreeBSD port: ${PKGNAME}' \
|
||||
--enable-thread-safe-client \
|
||||
--disable-dtrace
|
||||
--enable-thread-safe-client
|
||||
|
||||
.ifdef USE_MYSQL
|
||||
.error You have `USE_MYSQL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
|
||||
|
@ -45,6 +44,12 @@ CONFIGURE_ARGS+=--with-charset=${WITH_CHARSET}
|
|||
.if defined(WITH_XCHARSET) && ${WITH_XCHARSET} != ""
|
||||
CONFIGURE_ARGS+=--with-extra-charsets=${WITH_XCHARSET}
|
||||
.endif
|
||||
.if defined(WITH_DTRACE)
|
||||
CONFIGURE_ARGS+=--enable-dtrace
|
||||
CONFIGURE_ENV+= LDFLAGS=-lelf
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-dtrace
|
||||
.endif
|
||||
.if defined(WITH_OPENSSL)
|
||||
.if !defined(WITHOUT_YASSL)
|
||||
CONFIGURE_ARGS+=--with-ssl=bundled
|
||||
|
@ -123,6 +128,7 @@ pre-fetch:
|
|||
@${ECHO} " WITH_CHARSET=charset Define the primary built-in charset (latin1)."
|
||||
@${ECHO} " WITH_XCHARSET=list Define other built-in charsets (may be 'all')."
|
||||
@${ECHO} " WITH_COLLATION=collate Define default collation (latin1_swedish_ci)."
|
||||
@${ECHO} " WITH_DTRACE=yes Enable DTrace."
|
||||
@${ECHO} " WITH_OPENSSL=yes Enable secure connections"
|
||||
@${ECHO} " (define WITHOUT_YASSL for backward compatibility)."
|
||||
@${ECHO} " WITH_LINUXTHREADS=yes Use the linuxthreads pthread library."
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (mysql-5.5.5-m3.tar.gz) = ad27f6561d6010c9346ffeca6de403fa
|
||||
SHA256 (mysql-5.5.5-m3.tar.gz) = 38e9fab063c193ba5fcefd31e6678477a7a45579da73150cac41a848399bff24
|
||||
SIZE (mysql-5.5.5-m3.tar.gz) = 22806816
|
||||
MD5 (mysql-5.5.6-rc.tar.gz) = 25cbd495e3aa87b4eb741b213b6dd990
|
||||
SHA256 (mysql-5.5.6-rc.tar.gz) = 1f96667a6a81b472ba3ee96a7dfaa99aec8cbd7a2f799be352235b24f7f309b8
|
||||
SIZE (mysql-5.5.6-rc.tar.gz) = 25596239
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- Makefile.in.orig 2010-03-24 21:30:45.000000000 +0100
|
||||
+++ Makefile.in 2010-04-13 16:21:29.000000000 +0200
|
||||
@@ -416,15 +416,7 @@
|
||||
--- Makefile.in.orig 2010-09-17 22:48:47.000000000 +0200
|
||||
+++ Makefile.in 2010-09-27 14:55:30.000000000 +0200
|
||||
@@ -419,16 +419,7 @@
|
||||
README COPYING EXCEPTIONS-CLIENT \
|
||||
CMakeLists.txt configure.cmake config.h.cmake BUILD-CMAKE
|
||||
|
||||
|
@ -9,9 +9,10 @@
|
|||
- @pstack_dir@ libservices \
|
||||
- @sql_union_dirs@ unittest \
|
||||
- @sql_server@ @man_dirs@ tests \
|
||||
- netware @libmysqld_dirs@ \
|
||||
- @libmysqld_dirs@ \
|
||||
- mysql-test support-files sql-bench \
|
||||
- win \
|
||||
- packaging \
|
||||
- cmake
|
||||
+SUBDIRS =
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- configure.am.orig 2010-07-06 20:37:18.000000000 +0200
|
||||
+++ configure.am 2010-07-16 11:11:48.000000000 +0200
|
||||
@@ -990,6 +990,8 @@
|
||||
--- configure.am.orig 2010-09-17 22:48:48.000000000 +0200
|
||||
+++ configure.am 2010-09-27 16:39:47.000000000 +0200
|
||||
@@ -1011,6 +1011,8 @@
|
||||
MYSQL_BASE_VERSION
|
||||
MYSQL_NO_DASH_VERSION
|
||||
MYSQL_U_SCORE_VERSION
|
||||
|
@ -9,7 +9,16 @@
|
|||
TEST_NDBCLUSTER
|
||||
MAKEINDEX
|
||||
PDFLATEX
|
||||
@@ -12684,6 +12686,8 @@
|
||||
@@ -12717,7 +12719,7 @@
|
||||
_ACEOF
|
||||
|
||||
case "$target_os" in
|
||||
- *solaris*)
|
||||
+ *solaris*|*freebsd*)
|
||||
HAVE_DTRACE_DASH_G="yes"
|
||||
;;
|
||||
*)
|
||||
@@ -12750,6 +12752,8 @@
|
||||
NDB_VERSION_MINOR=`echo $MYSQL_NUMERIC_VERSION | cut -d. -f2`
|
||||
NDB_VERSION_BUILD=`echo $MYSQL_NUMERIC_VERSION | cut -d. -f3`
|
||||
NDB_VERSION_STATUS=`echo $VERSION | sed 's/^[-.0-9]*//'`
|
||||
|
@ -18,7 +27,7 @@
|
|||
TEST_NDBCLUSTER=""
|
||||
|
||||
|
||||
@@ -25849,8 +25853,8 @@
|
||||
@@ -25752,8 +25756,8 @@
|
||||
# Some system specific hacks
|
||||
#
|
||||
|
||||
|
|
|
@ -1,21 +1,5 @@
|
|||
--- include/Makefile.in.orig 2010-07-27 16:46:08.000000000 +0200
|
||||
+++ include/Makefile.in 2010-07-27 16:48:45.000000000 +0200
|
||||
@@ -480,12 +480,11 @@
|
||||
-rm -rf .libs _libs
|
||||
install-pkgincludeHEADERS: $(pkginclude_HEADERS)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgincludedir)" || $(MKDIR_P) "$(DESTDIR)$(pkgincludedir)"
|
||||
+ test -z "$(pkgincludedir)" || $(MKDIR_P) "$(DESTDIR)$(pkgincludedir)/mysql/psi"
|
||||
@list='$(pkginclude_HEADERS)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
- f=$(am__strip_dir) \
|
||||
- echo " $(pkgincludeHEADERS_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgincludedir)/$$f'"; \
|
||||
- $(pkgincludeHEADERS_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgincludedir)/$$f"; \
|
||||
+ echo " $(pkgincludeHEADERS_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgincludedir)/$$p'"; \
|
||||
+ $(pkgincludeHEADERS_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgincludedir)/$$p"; \
|
||||
done
|
||||
|
||||
uninstall-pkgincludeHEADERS:
|
||||
@@ -708,8 +707,6 @@
|
||||
@HAVE_DTRACE_TRUE@probes_mysql_dtrace.h: $(DTRACEPROVIDER)
|
||||
@HAVE_DTRACE_TRUE@ $(DTRACE) $(DTRACEFLAGS) -h -s $(DTRACEPROVIDER) -o $@
|
||||
|
|
|
@ -17,6 +17,7 @@ include/mysql/m_ctype.h
|
|||
include/mysql/m_string.h
|
||||
include/mysql/my_alloc.h
|
||||
include/mysql/my_attribute.h
|
||||
include/mysql/my_compiler.h
|
||||
include/mysql/my_config.h
|
||||
include/mysql/my_dbug.h
|
||||
include/mysql/my_dir.h
|
||||
|
@ -28,15 +29,6 @@ include/mysql/my_no_pthread.h
|
|||
include/mysql/my_pthread.h
|
||||
include/mysql/my_sys.h
|
||||
include/mysql/my_xml.h
|
||||
include/mysql/mysql/plugin_audit.h
|
||||
include/mysql/mysql/plugin_ftparser.h
|
||||
include/mysql/mysql/plugin.h
|
||||
include/mysql/mysql/psi/mysql_file.h
|
||||
include/mysql/mysql/psi/mysql_thread.h
|
||||
include/mysql/mysql/psi/psi.h
|
||||
include/mysql/mysql/services.h
|
||||
include/mysql/mysql/service_my_snprintf.h
|
||||
include/mysql/mysql/service_thd_alloc.h
|
||||
include/mysql/mysql.h
|
||||
include/mysql/mysql_com.h
|
||||
include/mysql/mysql_embed.h
|
||||
|
@ -44,8 +36,17 @@ include/mysql/mysql_time.h
|
|||
include/mysql/mysql_version.h
|
||||
include/mysql/mysqld_ername.h
|
||||
include/mysql/mysqld_error.h
|
||||
include/mysql/plugin_audit.h
|
||||
include/mysql/plugin_ftparser.h
|
||||
include/mysql/plugin.h
|
||||
include/mysql/probes_mysql.h
|
||||
include/mysql/probes_mysql_nodtrace.h
|
||||
include/mysql/psi/mysql_file.h
|
||||
include/mysql/psi/mysql_thread.h
|
||||
include/mysql/psi/psi.h
|
||||
include/mysql/services.h
|
||||
include/mysql/service_my_snprintf.h
|
||||
include/mysql/service_thd_alloc.h
|
||||
include/mysql/sql_common.h
|
||||
include/mysql/sql_state.h
|
||||
include/mysql/sslopt-case.h
|
||||
|
@ -61,8 +62,7 @@ lib/mysql/libmysqlclient_r.la
|
|||
lib/mysql/libmysqlclient_r.so
|
||||
lib/mysql/libmysqlclient_r.so.16
|
||||
share/aclocal/mysql.m4
|
||||
@dirrm include/mysql/mysql/psi
|
||||
@dirrm include/mysql/mysql
|
||||
@dirrm include/mysql/psi
|
||||
@dirrm include/mysql
|
||||
@dirrm lib/mysql
|
||||
@dirrmtry %%DATADIR%%
|
||||
|
|
Loading…
Reference in a new issue