Upgrade to 0.99.8, and a patch from Alex D. Chen
PR: ports/10058 Submitted by: Alex D. Chen <dhchen@Canvas.dorm7.nccu.edu.tw>
This commit is contained in:
parent
12aed04cc8
commit
ac25449d8c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=16770
8 changed files with 96 additions and 100 deletions
|
@ -1,15 +1,14 @@
|
|||
# New ports collection makefile for: libgtop
|
||||
# Version required: 0.99.2
|
||||
# Version required: 0.99.8
|
||||
# Date Created: 26 Sep 1998
|
||||
# Whom: Vanilla I. Shu <vanilla@FreeBSD.ORG>
|
||||
#
|
||||
# $Id: Makefile,v 1.13 1999/01/27 08:31:50 fenner Exp $
|
||||
# $Id: Makefile,v 1.14 1999/01/31 19:03:49 vanilla Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libgtop-0.99.2
|
||||
DISTNAME= libgtop-0.99.8
|
||||
CATEGORIES= devel gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME} \
|
||||
ftp://ftp.home-of-linux.org/pub/libgtop/0.99.2/
|
||||
MASTER_SITE_SUBDIR= libgtop
|
||||
|
||||
MAINTAINER= nacai@iname.com
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (libgtop-0.99.2.tar.gz) = 5c854b828a20ba966ed429dd6773cea6
|
||||
MD5 (libgtop-0.99.8.tar.gz) = 3cae59e8e94912483373561abf4937c4
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- lib/Makefile.in.orig Wed Jan 6 03:54:31 1999
|
||||
-- lib/Makefile.in.orig Wed Jan 6 03:54:31 1999
|
||||
+++ lib/Makefile.in Thu Jan 7 21:47:02 1999
|
||||
@@ -129,7 +129,7 @@
|
||||
LT_CURRENT = @LT_CURRENT@
|
||||
|
@ -72,45 +72,6 @@
|
|||
LT_VERSION_INFO = @LT_VERSION_INFO@
|
||||
MAKEINFO = @MAKEINFO@
|
||||
MKINSTALLDIRS = @MKINSTALLDIRS@
|
||||
--- Makefile.in.orig Tue Jan 5 21:53:28 1999
|
||||
+++ Makefile.in Wed Jan 20 00:33:09 1999
|
||||
@@ -172,8 +172,7 @@
|
||||
|
||||
@BUILD_GNOME_SUPPORT_TRUE@support = support
|
||||
|
||||
-SUBDIRS = po intl $(support) macros misc include sysdeps lib src \
|
||||
- $(examples_SUBDIRS)
|
||||
+SUBDIRS = po intl macros misc include sysdeps lib src
|
||||
|
||||
include_HEADERS = glibtop.h
|
||||
|
||||
@@ -182,7 +181,7 @@
|
||||
libgtop-sysdeps.m4 ANNOUNCE ANNOUNCE-0.25 README.LATEST \
|
||||
libgtop-mirror.sh
|
||||
|
||||
-confexecdir = $(libdir)
|
||||
+confexecdir = $(sysconfdir)
|
||||
confexec_DATA = $(top_builddir)/libgtopConf.sh \
|
||||
$(top_builddir)/libgtop-features.def
|
||||
|
||||
@@ -511,7 +510,7 @@
|
||||
$(top_srcdir)/aclocal.m4: libgtop-sysdeps.m4
|
||||
|
||||
libgtopConf.sh: libgtopConf.sh.in Makefile
|
||||
- sed -e 's#\@LIBGTOP_LIBDIR\@#$(libdir)#g' \
|
||||
+ sed -e 's#\@LIBGTOP_LIBDIR\@#$(confexecdir)#g' \
|
||||
-e 's#\@LIBGTOP_INCLUDEDIR\@#$(includedir)#g' \
|
||||
-e 's#\@LIBGTOP_EXTRA_LIBS\@#$(LIBGTOP_EXTRA_LIBS)#g' \
|
||||
-e 's#\@LIBGTOP_LIBS\@#$(LIBGTOP_LIBS)#g' \
|
||||
@@ -539,7 +538,7 @@
|
||||
&& mv libgtopConf.tmp libgtopConf.sh
|
||||
|
||||
libgtop-config: libgtop-config.in Makefile
|
||||
- sed -e 's#\@LIBGTOP_LIBDIR\@#$(libdir)#g' \
|
||||
+ sed -e 's#\@LIBGTOP_LIBDIR\@#$(confexecdir)#g' \
|
||||
< $(srcdir)/libgtop-config.in > libgtop-config.tmp \
|
||||
&& mv libgtop-config.tmp libgtop-config && \
|
||||
chmod 755 libgtop-config
|
||||
--- po/Makefile.in.in.orig Wed Jan 6 03:50:44 1999
|
||||
+++ po/Makefile.in.in Thu Jan 7 21:47:02 1999
|
||||
@@ -18,7 +18,7 @@
|
||||
|
@ -122,3 +83,41 @@
|
|||
localedir = $(datadir)/locale
|
||||
gnulocaledir = $(prefix)/share/locale
|
||||
gettextsrcdir = $(prefix)/share/gettext/po
|
||||
--- Makefile.in.orig Wed Feb 17 18:34:29 1999
|
||||
+++ Makefile.in Fri Feb 19 01:58:32 1999
|
||||
@@ -174,7 +174,7 @@
|
||||
|
||||
@BUILD_GNOME_SUPPORT_TRUE@support = support
|
||||
|
||||
-SUBDIRS = po intl $(support) macros misc include sysdeps lib src $(examples_SUBDIRS)
|
||||
+SUBDIRS = po intl macros misc include sysdeps lib src
|
||||
|
||||
|
||||
include_HEADERS = glibtop.h
|
||||
@@ -182,7 +182,7 @@
|
||||
EXTRA_DIST = autogen.sh libgtop.spec.in copyright.txt libgtopConf.sh.in LIBGTOP-VERSION features.def libgtop-config.in RELNOTES-0.25 RELNOTES-1.0 libgtop-sysdeps.m4 ANNOUNCE-0.25 ANNOUNCE-1.0 README NEWS.old libgtop-mirror.sh
|
||||
|
||||
|
||||
-confexecdir = $(libdir)
|
||||
+confexecdir = $(sysconfdir)
|
||||
confexec_DATA = $(top_builddir)/libgtopConf.sh $(top_builddir)/libgtop-features.def
|
||||
|
||||
|
||||
@@ -550,7 +550,7 @@
|
||||
$(top_srcdir)/aclocal.m4: libgtop-sysdeps.m4
|
||||
|
||||
libgtopConf.sh: libgtopConf.sh.in Makefile
|
||||
- sed -e 's#\@LIBGTOP_LIBDIR\@#$(libdir)#g' \
|
||||
+ sed -e 's#\@LIBGTOP_LIBDIR\@#$(confexecdir)#g' \
|
||||
-e 's#\@LIBGTOP_INCLUDEDIR\@#$(includedir)#g' \
|
||||
-e 's#\@LIBGTOP_DATADIR\@#$(datadir)#g' \
|
||||
-e 's#\@LIBGTOP_EXTRA_LIBS\@#$(LIBGTOP_EXTRA_LIBS)#g' \
|
||||
@@ -579,7 +579,7 @@
|
||||
&& mv libgtopConf.tmp libgtopConf.sh
|
||||
|
||||
libgtop-config: libgtop-config.in Makefile
|
||||
- sed -e 's#\@LIBGTOP_LIBDIR\@#$(libdir)#g' \
|
||||
+ sed -e 's#\@LIBGTOP_LIBDIR\@#$(confexecdir)#g' \
|
||||
< $(srcdir)/libgtop-config.in > libgtop-config.tmp \
|
||||
&& mv libgtop-config.tmp libgtop-config && \
|
||||
chmod 755 libgtop-config
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
--- configure.orig Wed Jan 6 03:51:05 1999
|
||||
+++ configure Thu Jan 7 21:25:13 1999
|
||||
@@ -2385,13 +2385,13 @@
|
||||
--- configure.orig Tue Feb 16 22:50:48 1999
|
||||
+++ configure Fri Feb 19 02:02:47 1999
|
||||
@@ -2982,13 +2982,13 @@
|
||||
fi
|
||||
|
||||
if test "$no_gnome_config" = "yes"; then
|
||||
- echo $ac_n "checking for gnomeConf.sh file in $gnome_prefix""... $ac_c" 1>&6
|
||||
-echo "configure:2390: checking for gnomeConf.sh file in $gnome_prefix" >&5
|
||||
-echo "configure:2987: checking for gnomeConf.sh file in $gnome_prefix" >&5
|
||||
- if test -f $gnome_prefix/gnomeConf.sh; then
|
||||
+ echo $ac_n "checking for gnomeConf.sh file in $prefix/share/gnome""... $ac_c" 1>&6
|
||||
+echo "configure:2390: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
|
||||
+echo "configure:2987: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
|
||||
+ if test -f $prefix/share/gnome/gnomeConf.sh; then
|
||||
echo "$ac_t""found" 1>&6
|
||||
echo "loading gnome configuration from" \
|
||||
|
|
|
@ -1,15 +1,14 @@
|
|||
# New ports collection makefile for: libgtop
|
||||
# Version required: 0.99.2
|
||||
# Version required: 0.99.8
|
||||
# Date Created: 26 Sep 1998
|
||||
# Whom: Vanilla I. Shu <vanilla@FreeBSD.ORG>
|
||||
#
|
||||
# $Id: Makefile,v 1.13 1999/01/27 08:31:50 fenner Exp $
|
||||
# $Id: Makefile,v 1.14 1999/01/31 19:03:49 vanilla Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libgtop-0.99.2
|
||||
DISTNAME= libgtop-0.99.8
|
||||
CATEGORIES= devel gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME} \
|
||||
ftp://ftp.home-of-linux.org/pub/libgtop/0.99.2/
|
||||
MASTER_SITE_SUBDIR= libgtop
|
||||
|
||||
MAINTAINER= nacai@iname.com
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (libgtop-0.99.2.tar.gz) = 5c854b828a20ba966ed429dd6773cea6
|
||||
MD5 (libgtop-0.99.8.tar.gz) = 3cae59e8e94912483373561abf4937c4
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- lib/Makefile.in.orig Wed Jan 6 03:54:31 1999
|
||||
-- lib/Makefile.in.orig Wed Jan 6 03:54:31 1999
|
||||
+++ lib/Makefile.in Thu Jan 7 21:47:02 1999
|
||||
@@ -129,7 +129,7 @@
|
||||
LT_CURRENT = @LT_CURRENT@
|
||||
|
@ -72,45 +72,6 @@
|
|||
LT_VERSION_INFO = @LT_VERSION_INFO@
|
||||
MAKEINFO = @MAKEINFO@
|
||||
MKINSTALLDIRS = @MKINSTALLDIRS@
|
||||
--- Makefile.in.orig Tue Jan 5 21:53:28 1999
|
||||
+++ Makefile.in Wed Jan 20 00:33:09 1999
|
||||
@@ -172,8 +172,7 @@
|
||||
|
||||
@BUILD_GNOME_SUPPORT_TRUE@support = support
|
||||
|
||||
-SUBDIRS = po intl $(support) macros misc include sysdeps lib src \
|
||||
- $(examples_SUBDIRS)
|
||||
+SUBDIRS = po intl macros misc include sysdeps lib src
|
||||
|
||||
include_HEADERS = glibtop.h
|
||||
|
||||
@@ -182,7 +181,7 @@
|
||||
libgtop-sysdeps.m4 ANNOUNCE ANNOUNCE-0.25 README.LATEST \
|
||||
libgtop-mirror.sh
|
||||
|
||||
-confexecdir = $(libdir)
|
||||
+confexecdir = $(sysconfdir)
|
||||
confexec_DATA = $(top_builddir)/libgtopConf.sh \
|
||||
$(top_builddir)/libgtop-features.def
|
||||
|
||||
@@ -511,7 +510,7 @@
|
||||
$(top_srcdir)/aclocal.m4: libgtop-sysdeps.m4
|
||||
|
||||
libgtopConf.sh: libgtopConf.sh.in Makefile
|
||||
- sed -e 's#\@LIBGTOP_LIBDIR\@#$(libdir)#g' \
|
||||
+ sed -e 's#\@LIBGTOP_LIBDIR\@#$(confexecdir)#g' \
|
||||
-e 's#\@LIBGTOP_INCLUDEDIR\@#$(includedir)#g' \
|
||||
-e 's#\@LIBGTOP_EXTRA_LIBS\@#$(LIBGTOP_EXTRA_LIBS)#g' \
|
||||
-e 's#\@LIBGTOP_LIBS\@#$(LIBGTOP_LIBS)#g' \
|
||||
@@ -539,7 +538,7 @@
|
||||
&& mv libgtopConf.tmp libgtopConf.sh
|
||||
|
||||
libgtop-config: libgtop-config.in Makefile
|
||||
- sed -e 's#\@LIBGTOP_LIBDIR\@#$(libdir)#g' \
|
||||
+ sed -e 's#\@LIBGTOP_LIBDIR\@#$(confexecdir)#g' \
|
||||
< $(srcdir)/libgtop-config.in > libgtop-config.tmp \
|
||||
&& mv libgtop-config.tmp libgtop-config && \
|
||||
chmod 755 libgtop-config
|
||||
--- po/Makefile.in.in.orig Wed Jan 6 03:50:44 1999
|
||||
+++ po/Makefile.in.in Thu Jan 7 21:47:02 1999
|
||||
@@ -18,7 +18,7 @@
|
||||
|
@ -122,3 +83,41 @@
|
|||
localedir = $(datadir)/locale
|
||||
gnulocaledir = $(prefix)/share/locale
|
||||
gettextsrcdir = $(prefix)/share/gettext/po
|
||||
--- Makefile.in.orig Wed Feb 17 18:34:29 1999
|
||||
+++ Makefile.in Fri Feb 19 01:58:32 1999
|
||||
@@ -174,7 +174,7 @@
|
||||
|
||||
@BUILD_GNOME_SUPPORT_TRUE@support = support
|
||||
|
||||
-SUBDIRS = po intl $(support) macros misc include sysdeps lib src $(examples_SUBDIRS)
|
||||
+SUBDIRS = po intl macros misc include sysdeps lib src
|
||||
|
||||
|
||||
include_HEADERS = glibtop.h
|
||||
@@ -182,7 +182,7 @@
|
||||
EXTRA_DIST = autogen.sh libgtop.spec.in copyright.txt libgtopConf.sh.in LIBGTOP-VERSION features.def libgtop-config.in RELNOTES-0.25 RELNOTES-1.0 libgtop-sysdeps.m4 ANNOUNCE-0.25 ANNOUNCE-1.0 README NEWS.old libgtop-mirror.sh
|
||||
|
||||
|
||||
-confexecdir = $(libdir)
|
||||
+confexecdir = $(sysconfdir)
|
||||
confexec_DATA = $(top_builddir)/libgtopConf.sh $(top_builddir)/libgtop-features.def
|
||||
|
||||
|
||||
@@ -550,7 +550,7 @@
|
||||
$(top_srcdir)/aclocal.m4: libgtop-sysdeps.m4
|
||||
|
||||
libgtopConf.sh: libgtopConf.sh.in Makefile
|
||||
- sed -e 's#\@LIBGTOP_LIBDIR\@#$(libdir)#g' \
|
||||
+ sed -e 's#\@LIBGTOP_LIBDIR\@#$(confexecdir)#g' \
|
||||
-e 's#\@LIBGTOP_INCLUDEDIR\@#$(includedir)#g' \
|
||||
-e 's#\@LIBGTOP_DATADIR\@#$(datadir)#g' \
|
||||
-e 's#\@LIBGTOP_EXTRA_LIBS\@#$(LIBGTOP_EXTRA_LIBS)#g' \
|
||||
@@ -579,7 +579,7 @@
|
||||
&& mv libgtopConf.tmp libgtopConf.sh
|
||||
|
||||
libgtop-config: libgtop-config.in Makefile
|
||||
- sed -e 's#\@LIBGTOP_LIBDIR\@#$(libdir)#g' \
|
||||
+ sed -e 's#\@LIBGTOP_LIBDIR\@#$(confexecdir)#g' \
|
||||
< $(srcdir)/libgtop-config.in > libgtop-config.tmp \
|
||||
&& mv libgtop-config.tmp libgtop-config && \
|
||||
chmod 755 libgtop-config
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
--- configure.orig Wed Jan 6 03:51:05 1999
|
||||
+++ configure Thu Jan 7 21:25:13 1999
|
||||
@@ -2385,13 +2385,13 @@
|
||||
--- configure.orig Tue Feb 16 22:50:48 1999
|
||||
+++ configure Fri Feb 19 02:02:47 1999
|
||||
@@ -2982,13 +2982,13 @@
|
||||
fi
|
||||
|
||||
if test "$no_gnome_config" = "yes"; then
|
||||
- echo $ac_n "checking for gnomeConf.sh file in $gnome_prefix""... $ac_c" 1>&6
|
||||
-echo "configure:2390: checking for gnomeConf.sh file in $gnome_prefix" >&5
|
||||
-echo "configure:2987: checking for gnomeConf.sh file in $gnome_prefix" >&5
|
||||
- if test -f $gnome_prefix/gnomeConf.sh; then
|
||||
+ echo $ac_n "checking for gnomeConf.sh file in $prefix/share/gnome""... $ac_c" 1>&6
|
||||
+echo "configure:2390: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
|
||||
+echo "configure:2987: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
|
||||
+ if test -f $prefix/share/gnome/gnomeConf.sh; then
|
||||
echo "$ac_t""found" 1>&6
|
||||
echo "loading gnome configuration from" \
|
||||
|
|
Loading…
Reference in a new issue