- Fix build with new taglib

Submitted by:	Jason E. Hale <bsdkaffee@gmail.com>
This commit is contained in:
Pav Lucistnik 2011-03-19 10:04:01 +00:00
parent 215eae00b7
commit ac6dffe43e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=271301
3 changed files with 33 additions and 1 deletions

View file

@ -1,3 +1,2 @@
MD5 (taglookup-0.2.tgz) = a77d0ea7714c338be53485db94269640
SHA256 (taglookup-0.2.tgz) = 78463a754a85c438ffdffda4326ac83723616ba5f941a44dcd2d6b2dcfbfb0be
SIZE (taglookup-0.2.tgz) = 16869

View file

@ -0,0 +1,11 @@
--- ./Makefile.orig 2007-10-29 08:02:54.000000000 -0400
+++ ./Makefile 2011-03-18 18:59:23.000000000 -0400
@@ -4,7 +4,7 @@
TAGLIB_INCLUDE = `taglib-config --cflags`
TAGLIB_LIBRARY = `taglib-config --libs`
-CPP = g++
+CPP = $(CXX)
CPPFLAGS = -Wall $(TAGLIB_INCLUDE) $(LIBCDDB_INCLUDE) -c
LDFLAGS = $(TAGLIB_LIBRARY) $(LIBCDDB_LIBRARY)

View file

@ -0,0 +1,22 @@
--- ./tag.cpp.orig 2007-10-28 18:42:56.000000000 -0400
+++ ./tag.cpp 2011-03-18 18:59:23.000000000 -0400
@@ -27,6 +27,7 @@
#include <utility>
#include <ostream>
+#include <iostream>
// LibC TODO Replace with STL
// POSIX
@@ -49,9 +50,9 @@
namespace TagLookup
{
// Utility functions:
- const TagLib::String::String toUTF8String(const std::string& s)
+ const TagLib::String toUTF8String(const std::string& s)
{
- const TagLib::String::String new_string(s, TagLib::String::UTF8);
+ const TagLib::String new_string(s, TagLib::String::UTF8);
return new_string;
} // toUTF8String