add fastdep 0.13

Fast dependency generator for C/C++ files
This commit is contained in:
Ying-Chieh Liao 2002-10-30 12:52:39 +00:00
parent a76838b770
commit aca8006da4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=69149
8 changed files with 68 additions and 0 deletions

View file

@ -165,6 +165,7 @@
SUBDIR += fam SUBDIR += fam
SUBDIR += fampp SUBDIR += fampp
SUBDIR += fastcrc SUBDIR += fastcrc
SUBDIR += fastdep
SUBDIR += fc++ SUBDIR += fc++
SUBDIR += ffcall SUBDIR += ffcall
SUBDIR += fhist SUBDIR += fhist

34
devel/fastdep/Makefile Normal file
View file

@ -0,0 +1,34 @@
# ex:ts=8
# Ports collection makefile for: fastdep
# Date created: Oct 30, 2002
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= fastdep
PORTVERSION= 0.13
CATEGORIES= devel
MASTER_SITES= http://www.irule.be/bvh/c++/fastdep/
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
USE_REINPLACE= yes
USE_GMAKE= yes
ALL_TARGET= boot
CFLAGS+= -I${LOCALBASE}/include
post-patch:
@${REINPLACE_CMD} -e "s|make|gmake|" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s|CXXFLAGS=|CXXFLAGS+=|" ${WRKSRC}/Makefile.common
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fastdep ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
.include <bsd.port.mk>

1
devel/fastdep/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (fastdep-0.13.tar.gz) = 0c1f0a3af6629e4ddba654ff7da9762a

View file

@ -0,0 +1,12 @@
--- Makefile.options.orig Wed Oct 30 20:44:36 2002
+++ Makefile.options Wed Oct 30 20:44:45 2002
@@ -1,8 +1,7 @@
-PREFIX=/opt
CATEGORY=devel/c
NAME=fastdep
BINARY=fastdep
# Possible values for CONFIGURATION
# release : optimized code with no debug symbols
# debug : non-optimized code with debug symbols
-CONFIGURATION=debug
+CONFIGURATION=release

View file

@ -0,0 +1,11 @@
--- Makefile.real.orig Wed Oct 30 20:46:26 2002
+++ Makefile.real Wed Oct 30 20:46:46 2002
@@ -8,7 +8,7 @@
g++ $(CXXFLAGS) -o $(BINARY) @linkfiles
-rm -f linkfiles
else
- g++ $(CXXFLAGS) -o $(BINARY) $(OBJECTS)
+ g++ $(CXXFLAGS) -o $(BINARY) $(OBJECTS) -L${LOCALBASE}/lib -lgnugetopt
endif
.cc.o: $(ALLMAKEFILES)

View file

@ -0,0 +1 @@
Fast dependency generator for C/C++ files

5
devel/fastdep/pkg-descr Normal file
View file

@ -0,0 +1,5 @@
fastdep is a preprocessor which generates dependency information suitable for
Makefile inclusion from C or C++ source files. Meant to run on slower hardware,
it is several orders of magnitude faster than gcc.
WWW: http://www.irule.be/bvh/c++/fastdep/

3
devel/fastdep/pkg-plist Normal file
View file

@ -0,0 +1,3 @@
bin/fastdep
%%PORTDOCS%%share/doc/fastdep/Using fastdep.txt
%%PORTDOCS%%@dirrm share/doc/fastdep