Update libgpod and gtkpod to most recent verions, 0.4.0 and 0.99.8,
respectively. Also rename a knob, commit to UPDATING will follow.
This commit is contained in:
parent
117195712a
commit
acc3d5bcf9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=175190
7 changed files with 48 additions and 44 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= gtkpod
|
||||
PORTVERSION= 0.99.4
|
||||
PORTVERSION= 0.99.8
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -15,7 +15,7 @@ MAINTAINER= danfe@FreeBSD.org
|
|||
COMMENT= GUI for Apple iPods using GTK2
|
||||
|
||||
LIB_DEPENDS= id3tag.0:${PORTSDIR}/audio/libid3tag \
|
||||
gpod.302:${PORTSDIR}/audio/libgpod
|
||||
gpod.400:${PORTSDIR}/audio/libgpod
|
||||
RUN_DEPENDS= mp3gain:${PORTSDIR}/audio/mp3gain \
|
||||
iconv:${PORTSDIR}/converters/libiconv
|
||||
|
||||
|
@ -26,15 +26,15 @@ USE_GMAKE= yes
|
|||
USE_GNOME= gtk20 libglade2
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
OPTIONS= AAC "Enable AAC support with MPEG4IP" off
|
||||
OPTIONS= MPEG4IP "Enable AAC and H.264 support with MPEG4IP" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libmp4v2.so)
|
||||
WITH_AAC= YES
|
||||
WITH_MPEG4IP= YES
|
||||
.endif
|
||||
|
||||
.if defined(WITH_AAC)
|
||||
.if defined(WITH_MPEG4IP)
|
||||
LIB_DEPENDS+= mp4v2.0:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
|
||||
.endif
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (gtkpod-0.99.4.tar.gz) = 5d153249b2586ffefc47e0f4a58ef58e
|
||||
SHA256 (gtkpod-0.99.4.tar.gz) = 50bef292a5c50e1205ef9dccac15d077207b775fb95d0e434ec27b3f503b13a3
|
||||
SIZE (gtkpod-0.99.4.tar.gz) = 975599
|
||||
MD5 (gtkpod-0.99.8.tar.gz) = f04b67605204d9076d30d83b72b78463
|
||||
SHA256 (gtkpod-0.99.8.tar.gz) = f74afefe31deb11dc235b1d361df6732966fe2ba3eaddfb960c69bf0d161e16d
|
||||
SIZE (gtkpod-0.99.8.tar.gz) = 1074007
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
--- src/display_playlists.c.orig Tue Oct 18 22:20:51 2005
|
||||
+++ src/display_playlists.c Tue Oct 18 22:22:11 2005
|
||||
@@ -1142,6 +1142,11 @@
|
||||
(useful when quitting program) */
|
||||
void pm_remove_playlist (Playlist *playlist, gboolean select)
|
||||
{
|
||||
+ GtkTreeModel *model;
|
||||
+ gboolean have_iter = FALSE;
|
||||
+ GtkTreeIter i;
|
||||
+ GtkTreeSelection *ts = NULL;
|
||||
+
|
||||
gboolean pm_delete_playlist_fe (GtkTreeModel *model,
|
||||
GtkTreePath *path,
|
||||
GtkTreeIter *iter,
|
||||
@@ -1156,10 +1161,6 @@
|
||||
}
|
||||
return FALSE;
|
||||
}
|
||||
- GtkTreeModel *model;
|
||||
- gboolean have_iter = FALSE;
|
||||
- GtkTreeIter i;
|
||||
- GtkTreeSelection *ts = NULL;
|
||||
|
||||
g_return_if_fail (playlist);
|
||||
model = gtk_tree_view_get_model (playlist_treeview);
|
|
@ -31,8 +31,11 @@ bin/gtkpod
|
|||
%%DATADIR%%/scripts/sync-notes.sh
|
||||
%%DATADIR%%/scripts/sync-palm-jppy.py
|
||||
%%DATADIR%%/scripts/sync-thunderbird.sh
|
||||
%%DATADIR%%/scripts/sync-thunderbird-nano.sh
|
||||
%%DATADIR%%/scripts/sync-tomboy.sh
|
||||
%%DATADIR%%/scripts/sync-webcalendar.sh
|
||||
share/locale/de/LC_MESSAGES/gtkpod.mo
|
||||
share/locale/es/LC_MESSAGES/gtkpod.mo
|
||||
share/locale/fr/LC_MESSAGES/gtkpod.mo
|
||||
share/locale/he/LC_MESSAGES/gtkpod.mo
|
||||
share/locale/it/LC_MESSAGES/gtkpod.mo
|
||||
|
|
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libgpod
|
||||
PORTVERSION= 0.3.2
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.4.0
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= gtkpod
|
||||
|
@ -17,10 +16,17 @@ COMMENT= A library for direct access of iPod's contents
|
|||
|
||||
USE_GNOME= gtk20
|
||||
USE_GETTEXT= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
# Disable python bindings for now, something does not work there
|
||||
CONFIGURE_ARGS= --without-python
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
CONFIGURE_ARGS+= --with-html-dir="${TARGETDIR}/share/doc"
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -28,9 +34,10 @@ post-extract: .SILENT
|
|||
${REINPLACE_CMD} -e \
|
||||
's,libdir)/pkgconfig,prefix)/libdata/pkgconfig,' \
|
||||
${WRKSRC}/Makefile.in
|
||||
${REINPLACE_CMD} '19323,19345d' ${WRKSRC}/configure
|
||||
${REINPLACE_CMD} -e '25s,^,#include <sys/types.h>,' \
|
||||
${WRKSRC}/src/db-parse-context.c
|
||||
.if defined(NOPORTDOCS)
|
||||
${REINPLACE_CMD} -e 's, docs$$,,' ${WRKSRC}/Makefile.in
|
||||
.endif
|
||||
${REINPLACE_CMD} '19987,20009d' ${WRKSRC}/configure
|
||||
.if defined(GCCVERSION)
|
||||
. if ${GCCVERSION} < 030000
|
||||
${REINPLACE_CMD} -e 's,\[\],[0],' ${WRKSRC}/src/db-itunes-parser.h
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (libgpod-0.3.2.tar.gz) = c9c41625347a33efd9441c4e71fdd04e
|
||||
SHA256 (libgpod-0.3.2.tar.gz) = b9bea0402371091b77ce537288dda66406a94bc200e6ea69ad20654b4a7f12f2
|
||||
SIZE (libgpod-0.3.2.tar.gz) = 461207
|
||||
MD5 (libgpod-0.4.0.tar.gz) = e427e0409b0cb2d7e76b17915b1396fa
|
||||
SHA256 (libgpod-0.4.0.tar.gz) = 50cb3dcf283f0b6c76da493cf070eb03c05c8a34f64bddb3ca19188a5d861cc4
|
||||
SIZE (libgpod-0.4.0.tar.gz) = 596066
|
||||
|
|
|
@ -1,8 +1,7 @@
|
|||
include/gpod-1.0/gpod/itdb.h
|
||||
include/gpod-1.0/gpod/ipod-device.h
|
||||
@dirrm include/gpod-1.0/gpod
|
||||
@dirrm include/gpod-1.0
|
||||
lib/libgpod.so.302
|
||||
lib/libgpod.so.400
|
||||
lib/libgpod.so
|
||||
lib/libgpod.la
|
||||
lib/libgpod.a
|
||||
|
@ -14,3 +13,23 @@ share/locale/he/LC_MESSAGES/libgpod.mo
|
|||
share/locale/it/LC_MESSAGES/libgpod.mo
|
||||
share/locale/ja/LC_MESSAGES/libgpod.mo
|
||||
share/locale/sv/LC_MESSAGES/libgpod.mo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ch01.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ch02.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/home.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.sgml
|
||||
%%PORTDOCS%%%%DOCSDIR%%/left.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libgpod-Artwork.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libgpod-Device.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libgpod-File-handling-functions.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libgpod-Low-level-functions.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libgpod-Playlists.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libgpod-The-Itdb-iTunesDB-structure.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libgpod-Time-handling.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libgpod-Tracks.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libgpod.devhelp
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libgpod.devhelp2
|
||||
%%PORTDOCS%%%%DOCSDIR%%/up.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/right.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/style.css
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
|
Loading…
Reference in a new issue