Add root 4.00.03, an Object-Oriented Data Analysis Framework.

PR:		65453
Submitted by:	Simon Lang <slang@freebsd.org>
Approved by:	mat (mentor).
This commit is contained in:
Thierry Thomas 2004-04-18 13:52:23 +00:00
parent 4048ba5aed
commit acc84a6ae8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=107420
8 changed files with 2111 additions and 0 deletions

View file

@ -1073,6 +1073,7 @@
SUBDIR += rinfo
SUBDIR += rlwrap
SUBDIR += robodoc
SUBDIR += root
SUBDIR += rpc2
SUBDIR += rtplib
SUBDIR += ruby-amstd

122
devel/root/Makefile Normal file
View file

@ -0,0 +1,122 @@
# New ports collection makefile for: root
# Date created: 7 April 2004
# Whom: Simon Lang <slang@freebsd.org>
#
# $FreeBSD$
#
PORTNAME= root
PORTVERSION= 4.00.03
CATEGORIES= devel science math
MASTER_SITES= ftp://root.cern.ch/root/
DISTNAME= ${PORTNAME}_v${PORTVERSION}.source
MAINTAINER= simon@lang-clan.de
COMMENT= An Object-Oriented Data Analysis Framework
HAS_CONFIGURE= yes
CONFIGURE_TARGET= freebsd4
ALL_TARGET= showbuild skip all
USE_GMAKE= yes
USE_OPENLDAP= yes
USE_QT_VER= 3
QT_NONSTANDARD= yes
USE_XLIB= yes
USE_XPM= yes
USE_GL= yes
USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
WRKSRC= ${WRKDIR}/${PORTNAME}
F77?= f77
# If the related ports are installed you may enable ROOT's support
# for them, too. It *seams* that
# --enable-asimage (After Image: ports/graphics/libafterimage)
# --enable-mysql (MySQL: ports/databases/mysql50-client)
# --enable-pgsql (PostgreSQL: ports/databases/postgresql73)
# are working. A know but yet unsolved problem: The support of
# Kerberos 5 needs some patches to ROOT.
# For this port my intention was to use only features that are
# available out of the box on a FreeBSD system running X11/QT.
# A lot of the features are related to software used in high
# energy physics projects. Have a look to the ROOT web page for
# more informations.
CONFIGURE_ARGS= \
${CONFIGURE_TARGET} \
--prefix=${PREFIX} \
--etcdir=${PREFIX}/etc \
--mandir=${PREFIX}/man/man1 \
--disable-afs \
--disable-alien \
--disable-asimage \
--disable-cern \
--disable-chirp \
--disable-dcache \
--enable-exceptions \
--enable-explicitlink \
--disable-globus \
--disable-krb5 \
--enable-ldap \
--disable-mysql \
--enable-opengl \
--disable-openiv \
--disable-pgsql \
--disable-pythia \
--disable-pythia6 \
--with-qt-incdir=${QT_PREFIX}/include \
--with-qt-libdir=${QT_PREFIX}/lib \
--disable-rfio \
--disable-rpath \
--disable-sapdb \
--disable-shadowpw \
--enable-shared \
--enable-soversion \
--disable-srp \
--disable-table \
--disable-venus
INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/root %%PREFIX%%/lib/root/cint
MAN1= cint.1 g2root.1 h2root.1 hadd.1 makecint.1 memprobe.1
MAN1+= proofd.1 proofserv.1 rmkdepend.1 root-config.1 root.1
MAN1+= root.exe.1 rootcint.1 rootd.1 rootn.exe.1
MODTESTS= Event hsimple minexam tcollex tstring
MAKE_TENV= ${MAKE_ENV} CXX="${CXX}" LDFLAGS="${LDFLAGS}"
.include <bsd.port.pre.mk>
# The thread sub-system was not working for ROOT versions 3.x on FreeBSD 4.x
# systems. Meanwhile maybe it's working with some patches - but I have no
# FreeBSD 4.x system still running for testing ;-)
.if ${OSVERSION} < 500016
CONFIGURE_ARGS+= --disable-thread
PLIST_SUB+= THREADS="@comment "
.else
CONFIGURE_ARGS+= --enable-thread
CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
PLIST_SUB+= THREADS=""
.endif
post-patch:
@${RM} ${WRKSRC}/test/Makefile.arch.orig
@${REINPLACE_CMD} -e 's|auxcflags=\"-pthread|auxcflags=\"${PTHREAD_CFLAGS}| ; \
s|auxlibs=\"-pthread|auxlibs=\"${PTHREAD_LIBS}|' \
${WRKSRC}/config/root-config.in
.if defined(MAINTAINER_MODE)
test: install
(cd ${DOCSDIR}/test ; \
${SETENV} ${MAKE_TENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS})
. for module in ${MODTESTS}
(cd ${DOCSDIR}/test ; \
${SETENV} LD_LIBRARY_PATH=.:${LD_LIBRARY_PATH} ./${module})
. endfor
.endif
.include <bsd.port.post.mk>

2
devel/root/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (root_v4.00.03.source.tar.gz) = e99a141b0d0717b6a2377ad66c7d3b2d
SIZE (root_v4.00.03.source.tar.gz) = 10689865

View file

@ -0,0 +1,55 @@
--- config/Makefile.freebsd4.orig Mon Feb 16 11:12:43 2004
+++ config/Makefile.freebsd4 Sat Apr 17 00:35:00 2004
@@ -5,7 +5,7 @@
PLATFORM = fbsd
DEBUGFLAGS = -g
-OPTFLAGS = -O
+#OPTFLAGS = -O
ifeq (debug,$(findstring debug,$(ROOTBUILD)))
OPT = $(DEBUGFLAGS)
NOOPT =
@@ -15,10 +15,10 @@
endif
# Compiler:
-CXX = g++
-CC = gcc
-CXXFLAGS = -pipe -W -Wall -fPIC -I/usr/X11R6/include $(EXTRA_CXXFLAGS)
-CFLAGS = -pipe -W -Wall -fPIC -I/usr/X11R6/include $(EXTRA_CFLAGS)
+#CXX = g++
+#CC = gcc
+CXXFLAGS += -W -Wall -fPIC -I$(X11BASE)/include $(EXTRA_CXXFLAGS)
+CFLAGS += -W -Wall -fPIC -I$(X11BASE)/include $(EXTRA_CFLAGS)
CINTCXXFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP $(EXTRA_CXXFLAGS) \
-DG__UNIX -DG__SHAREDLIB -DG__ROOT -DG__REDIRECTIO -DG__OSFDLL
CINTCFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP -DG__UNIX -DG__SHAREDLIB \
@@ -26,13 +26,13 @@
COMPILER = gnu
ifeq ($(ENABLETHREAD),yes)
-CXXFLAGS += -pthread
-CINTCXXFLAGS += -pthread
+CXXFLAGS += $(PTHREAD_CFLAGS)
+CINTCXXFLAGS += $(PTHREAD_CFLAGS)
endif
# Linker:
-LD = g++
-LDFLAGS = $(OPT) $(EXTRA_LDFLAGS)
+LD = $(CXX)
+LDFLAGS += $(OPT) $(EXTRA_LDFLAGS)
SOFLAGS = -shared -Wl,-x -Wl,-soname,
SOEXT = so
@@ -43,8 +43,8 @@
CRYPTLIBS = -lcrypt
# Fortran:
-F77 = f77
-F77FLAGS = $(OPT)
+#F77 = f77
+F77FLAGS += $(OPT)
F77LIBS = -lg2c
# Extras

View file

@ -0,0 +1,11 @@
--- configure.orig Thu Feb 19 01:11:18 2004
+++ configure Sat Apr 17 13:54:24 2004
@@ -901,7 +901,7 @@
;;
freebsd*)
if test "x$enable_thread" = "xyes"; then
- threadlib="-pthread"
+ threadlib="$PTHREAD_LIBS"
threadlibdir=
fi
;;

View file

@ -0,0 +1,25 @@
--- test/Makefile.arch.orig Sat Apr 17 10:25:16 2004
+++ test/Makefile.arch Sat Apr 17 10:41:58 2004
@@ -9,7 +9,6 @@
ARCH := $(shell root-config --arch)
PLATFORM = $(ARCH)
-CXX =
ObjSuf = o
SrcSuf = cxx
ExeSuf =
@@ -426,10 +425,10 @@
ifeq ($(ARCH),freebsd4)
# FreeBSD with glibc
-CXX = g++
-CXXFLAGS = -O -pipe -W -Wall -fPIC
-LD = g++
-LDFLAGS = -O
+#CXX = g++
+CXXFLAGS += -W -Wall -fPIC
+LD = $(CXX)
+#LDFLAGS = -O
SOFLAGS = -shared -Wl,-x
endif

23
devel/root/pkg-descr Normal file
View file

@ -0,0 +1,23 @@
ROOT stand for "<R>OOTs <O>bject-<O>riented <T>echnologies" - it is an object
oriented data anlaysis framework written in C++. ROOT has its origin at the
Centre Europeenne pour la Recherche Nucleaire (CERN) and is a cross platform
tool well-known to high energy physicists, but it's also used in a wide range
of other data analysis applications. The system consists of the C/C++
interpreter CINT (for interactive development and rapid prototyping) and
hundreds of classes, which provides functionalities u.a. for:
- Data Histogram and Minimization Operations
- Linear Algebra, Matrix and Vector Operations
- Tree, Ntuple and other Data Containers/Stuctures
- 2D Graphics, 3D Graphics and Detector Geometry Modeling
- Graphical User Interface
- Operating System and Networking Interface
- Inline Documentation and PostScript Interface
- PROOF Server (parallel computing)
For more information, user manuals, tutorials, how-to's, examples,
discussion groups and so on look at the ROOT web site:
WWW: http://root.cern.ch/
Ported to FreeBSD by Simon Lang, <simon@lang-clan.de>

1872
devel/root/pkg-plist Normal file

File diff suppressed because it is too large Load diff