net/libgnetwork: remove ancient gnome2 library unused

This commit is contained in:
Baptiste Daroussin 2022-06-08 15:29:40 +02:00
parent eed8fd052a
commit acd236ae99
9 changed files with 1 additions and 164 deletions

1
MOVED
View file

@ -17195,3 +17195,4 @@ sysutils/uefi-edk2-qemu|sysutils/edk2@qemu|2022-06-05|No more need for this port
graphics/gltt||2022-06-08|Abdonware, depends on freetype1
print/ttftot42||2022-06-08|Abdonware, depends on freetype1
print/freetype|print/freetype2|2022-06-08|Has been replaced long ago by freetype2
net/libgnetwork||2022-06-98|Gnome2 library unused anymore

View file

@ -361,7 +361,6 @@
SUBDIR += libfabric
SUBDIR += libfb
SUBDIR += libfixbuf
SUBDIR += libgnetwork
SUBDIR += libgravatar
SUBDIR += libgrss
SUBDIR += libgweather

View file

@ -1,34 +0,0 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
PORTNAME= libgnetwork
PORTVERSION= 0.0.9
PORTREVISION= 13
CATEGORIES= net gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GLib-based networking wrapper
USES= gettext gmake gnome libtool:keepla pathfix pkgconfig tar:bzip2
USE_GNOME= gnomeprefix intlhack gconf2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
#.if !defined(WITHOUT_SSL)
#LIB_DEPENDS+= gnutls.13:security/gnutls
#CONFIGURE_ARGS+=--enable-ssl=gnutls
#.else
CONFIGURE_ARGS+=--enable-ssl=no
#.endif
#pre-everything::
# @${ECHO_MSG} ""
# @${ECHO_MSG} "libgnetwork has the following configurable option(s):"
# @${ECHO_MSG} " WITHOUT_SSL Disable GnuTLS SSL support"
# @${ECHO_MSG} ""
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (gnome2/libgnetwork-0.0.9.tar.bz2) = 292c310ea2732a7ebf9711cbbe51c9afda9be376894e1ac88949b096e17dac94
SIZE (gnome2/libgnetwork-0.0.9.tar.bz2) = 527025

View file

@ -1,11 +0,0 @@
--- Makefile.in.orig Fri Dec 12 01:51:23 2003
+++ Makefile.in Fri Dec 12 01:51:29 2003
@@ -197,7 +197,7 @@
AUTOMAKE_OPTIONS = 1.7
-SUBDIRS = libgnetwork tests data doc po
+SUBDIRS = libgnetwork data doc po
EXTRA_DIST = \
intltool-merge.in \

View file

@ -1,10 +0,0 @@
--- data/Makefile.in.orig Fri Dec 12 02:11:14 2003
+++ data/Makefile.in Fri Dec 12 02:11:34 2003
@@ -419,7 +419,6 @@
if test -z "$(DESTDIR)" ; then \
for p in $(schema_DATA) ; do \
if test -f $(srcdir)/$$p ; then \
- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p ; \
fi \
done \
fi

View file

@ -1,20 +0,0 @@
--- libgnetwork/gnetwork-tcp-connection.c.orig Mon May 3 01:29:58 2004
+++ libgnetwork/gnetwork-tcp-connection.c Mon May 3 01:32:55 2004
@@ -450,6 +450,7 @@
static void
open_ssl_connection (GNetworkTcpConnection * connection)
{
+#ifdef _USE_SSL
GIOChannel *channel;
GNetworkSslAuth *auth;
GError *error;
@@ -517,6 +518,9 @@
g_object_notify (G_OBJECT (connection), "tcp-status");
g_object_notify (G_OBJECT (connection), "status");
g_object_thaw_notify (G_OBJECT (connection));
+#else
+ g_warning ("SSL support not enabled.");
+#endif
}

View file

@ -1,11 +0,0 @@
GNetwork is a networking wrapper written in pure C against the Glib/GObject
object framework.
The intention here is to provide a useful and easy-to-develop-against sockets
wrapper for GNOME2 & GTK+ 2.0 programs which require TCP/IP connection
capabilities. It can be used by programs which do not use GNOME or GTK+
anyways,however. It is NOT recommended or intended for high-load server
situations, just user applications which need TCP/IP networking. Proxies are
supported completely transparently, using the same settings as gnome-vfs.
-- The libgnetwork README

View file

@ -1,75 +0,0 @@
etc/gconf/schemas/libgnetwork.schemas
include/libgnetwork-1.0/libgnetwork/gnetwork-connection.h
include/libgnetwork-1.0/libgnetwork/gnetwork-datagram.h
include/libgnetwork-1.0/libgnetwork/gnetwork-dns.h
include/libgnetwork-1.0/libgnetwork/gnetwork-errors.h
include/libgnetwork-1.0/libgnetwork/gnetwork-interfaces.h
include/libgnetwork-1.0/libgnetwork/gnetwork-ip-address.h
include/libgnetwork-1.0/libgnetwork/gnetwork-ip-multicast.h
include/libgnetwork-1.0/libgnetwork/gnetwork-macros.h
include/libgnetwork-1.0/libgnetwork/gnetwork-server.h
include/libgnetwork-1.0/libgnetwork/gnetwork-ssl.h
include/libgnetwork-1.0/libgnetwork/gnetwork-tcp-connection.h
include/libgnetwork-1.0/libgnetwork/gnetwork-tcp-proxy.h
include/libgnetwork-1.0/libgnetwork/gnetwork-tcp-server.h
include/libgnetwork-1.0/libgnetwork/gnetwork-threads.h
include/libgnetwork-1.0/libgnetwork/gnetwork-type-builtins.h
include/libgnetwork-1.0/libgnetwork/gnetwork-udp-datagram.h
include/libgnetwork-1.0/libgnetwork/gnetwork-unix-connection.h
include/libgnetwork-1.0/libgnetwork/gnetwork-unix-server.h
include/libgnetwork-1.0/libgnetwork/gnetwork.h
lib/libgnetwork-1.0.a
lib/libgnetwork-1.0.la
lib/libgnetwork-1.0.so
lib/libgnetwork-1.0.so.0
lib/libgnetwork-1.0.so.0.0.9
libdata/pkgconfig/libgnetwork-1.0.pc
%%DOCSDIR%%/GNetworkConnection.html
%%DOCSDIR%%/GNetworkDatagram.html
%%DOCSDIR%%/GNetworkIpMulticast.html
%%DOCSDIR%%/GNetworkServer.html
%%DOCSDIR%%/GNetworkTcpConnection.html
%%DOCSDIR%%/GNetworkTcpServer.html
%%DOCSDIR%%/GNetworkUdpDatagram.html
%%DOCSDIR%%/GNetworkUnixConnection.html
%%DOCSDIR%%/GNetworkUnixServer.html
%%DOCSDIR%%/api-reference.html
%%DOCSDIR%%/compiling.html
%%DOCSDIR%%/home.png
%%DOCSDIR%%/index.html
%%DOCSDIR%%/index.sgml
%%DOCSDIR%%/introduction.html
%%DOCSDIR%%/left.png
%%DOCSDIR%%/libgnetwork-DNS-Lookups.html
%%DOCSDIR%%/libgnetwork-Error-Reporting.html
%%DOCSDIR%%/libgnetwork-IP-Addresses.html
%%DOCSDIR%%/libgnetwork-Local-Interfaces.html
%%DOCSDIR%%/libgnetwork-Proxy-Support.html
%%DOCSDIR%%/libgnetwork-SSL-Certificates.html
%%DOCSDIR%%/libgnetwork-Thread-Support.html
%%DOCSDIR%%/libgnetwork.devhelp
%%DOCSDIR%%/low-level-api.html
%%DOCSDIR%%/right.png
%%DOCSDIR%%/style.css
%%DOCSDIR%%/tutorials.html
%%DOCSDIR%%/up.png
share/locale/am/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/az/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/ca/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/cs/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/de/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/es/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/fr/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/hr/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/ja/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/ml/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/ms/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/nl/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/no/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/pl/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/pt/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/pt_BR/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/sr/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/sr@Latn/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/sv/LC_MESSAGES/libgnetwork-1.0.mo
share/locale/zh_CN/LC_MESSAGES/libgnetwork-1.0.mo