Update to 4.0.0rc1 for Qt4/KDE4

PR:		based on ports/138712
Submitted by:	Chris Petrik (maintainer)
This commit is contained in:
Max Brazhnikov 2009-09-14 18:45:11 +00:00
parent 5ca1541d6b
commit acea927405
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=241419
8 changed files with 2229 additions and 2298 deletions

View file

@ -6,72 +6,68 @@
#
PORTNAME= kvirc
PORTVERSION= 3.2.6
PORTREVISION= 3
DISTVERSION= 4.0rc1
CATEGORIES= irc kde
MASTER_SITES= ftp://ftp.kvirc.ru/pub/source/dev/
MASTER_SITES= ftp://ftp.kvirc.de/pub/kvirc/snapshots/source/ \
http://distfiles.officialunix.com/
PKGNAMESUFFIX= -devel
MAINTAINER= chris@officialunix.com
COMMENT= IRC client for QT and KDE
COMMENT= IRC client for QT4 and KDE4
USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
USE_GETTEXT= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_KDELIBS_VER=3
USE_GMAKE= yes
CONFIGURE_ENV= QTDIR="${LOCALBASE}"
PLIST_SUB= VER=${PORTVERSION}
CONFLICTS= kvirc-3.2.0*
USE_GETTEXT= yes
USE_PERL5= yes
USE_QT_VER= 4
QT_COMPONENTS= moc_build qmake_build rcc_build uic_build \
dbus webkit gui network sql xml
USE_CMAKE= yes
CMAKE_ARGS= -DWITHOUT_ESD=yes -DWITHOUT_DOXYGEN=yes
INSTALLS_ICONS= yes
CONFLICTS= kvirc-3.4.*
MAN1= kvirc.1
MANLANG= "" de.ISO8859-1 de.UTF-8 it.ISO8859-1 it.UTF-8
BUILD_DEPENDS+= recode:${PORTSDIR}/converters/recode
OPTIONS= ARTS "Compile with arts support" on \
AUDIOFILE "Compile with libaudiofile support" on \
ESOUND "Compile with esound support" off \
GSM "Compile with gsm support" off
OPTIONS= AUDIOFILE "Compile with libaudiofile dependency" on \
DEBUG "Compile with debug support" off \
GSM "Compile with gsm support" off \
KDE4 "Compile with KDE4 support (broken)" off \
PHONON "Compile with phonon support" on
.include <bsd.port.pre.mk>
.if defined(WITH_ARTS)
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
.else
CONFIGURE_ARGS+= --without-arts-support
.endif
.if defined(WITH_AUDIOFILE)
LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
.else
CONFIGURE_ARGS+= --without-af-support
CMAKE_ARGS+= -DWITHOUT_AUDIOFILE=yes
.endif
.if defined(WITH_ESOUND)
LIB_DEPENDS+= esd.2:${PORTSDIR}/audio/esound
.else
CONFIGURE_ARGS+= --without-esd-support
.if defined(WITH_DEBUG)
CMAKE_ARGS+= -DDEBUG=yes -DVERBOSE=yes
.endif
.if defined(WITH_GSM)
LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
.else
CONFIGURE_ARGS+= --without-gsm
CMAKE_ARGS+= -DWITHOUT_GSM=yes
.endif
.if defined(WITH_KDE4)
USE_KDE4+= kdelibs kdeprefix
CMAKE_ARGS+= -DWITH_KDE4=yes
.endif
.if defined(WITH_PHONON)
QT_COMPONENTS+= phonon
CMAKE_ARGS+= -DKDE4_LIB_INSTALL_DIR=${KDE4_PREFIX}/lib \
-DKDE4_INCLUDE_INSTALL_DIR=${KDE4_PREFIX}/include
.else
CMAKE_ARGS+= -DWITHOUT_PHONON=yes
.endif
post-patch:
${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" \
-e "s,.SS_KDE_GENERAL_DIR/share/icons,${PREFIX}/share/icons," \
-e "s,.SS_KDE_GENERAL_DIR/share/applnk,${PREFIX}/share/applnk," \
-e "s,.SS_KDE_GENERAL_DIR/share/mimelnk,${PREFIX}/share/mimelnk," \
-e "s,kdeservicesdir=\".SS_KDE_SERVICESDIR\",kdeservicesdir=\"${PREFIX}/share/services\"," \
-e "s,%%LTMAIN%%,${LTMAIN}," \
${WRKSRC}/configure
post-configure:
@${MV} ${WRKSRC}/data/protocols/irc.protocol ${WRKSRC}/data/protocols/kvirc.protocol
@${MV} ${WRKSRC}/data/protocols/irc6.protocol ${WRKSRC}/data/protocols/kvirc6.protocol
${LOCALBASE}/bin/recode -f ibmpc..latin1 `find ${WRKSRC} -name "*.cpp" -print`
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (kvirc-3.2.6.tar.bz2) = 7f1b4ba47e7e9c05d2d0373166e60c98
SHA256 (kvirc-3.2.6.tar.bz2) = 40c49f70b827e2efee032cd96bf08467117fb3010f2f04c702743dd765f13499
SIZE (kvirc-3.2.6.tar.bz2) = 4749304
MD5 (kvirc-4.0rc1.tar.bz2) = fbf84c24864b7a89922574bcfa68f292
SHA256 (kvirc-4.0rc1.tar.bz2) = cb59c65d759d67d883eb9387de9413e15de9d7aa4f06c8b5b0fe0bdcfdcb483e
SIZE (kvirc-4.0rc1.tar.bz2) = 4873356

View file

@ -1,10 +0,0 @@
--- data/protocols/Makefile.am.bak Wed Feb 15 10:30:27 2006
+++ data/protocols/Makefile.am Sun Aug 3 21:33:44 2003
@@ -4,6 +4,6 @@
tmpdir = $(kdeservicesdir)
+tmp_DATA = kvirc.protocol kvirc6.protocol
-tmp_DATA = irc.protocol irc6.protocol
EXTRA_DIST = $(tmp_DATA)

View file

@ -1,11 +0,0 @@
--- data/protocols/Makefile.in.orig Sun Jan 7 10:39:57 2007
+++ data/protocols/Makefile.in Sat Jan 27 18:22:24 2007
@@ -210,7 +210,7 @@
top_srcdir = @top_srcdir@
topdir = @topdir@
tmpdir = $(kdeservicesdir)
-tmp_DATA = irc.protocol irc6.protocol
+tmp_DATA = kvirc.protocol kvirc6.protocol
EXTRA_DIST = $(tmp_DATA)
all: all-am

View file

@ -1,38 +0,0 @@
--- configure.orig Sun Jan 7 10:39:57 2007
+++ configure Sat Jan 27 19:23:03 2007
@@ -20313,7 +20313,7 @@
# This can be used to rebuild libtool when needed
-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+LIBTOOL_DEPS="--disable-ltlibs %%LTMAIN%%"
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -25997,7 +25997,7 @@
else
{ echo "$as_me:$LINENO: result: no..using lpthread" >&5
echo "${ECHO_T}no..using lpthread" >&6; }
- SS_THREAD_LIBLINK="-lpthread"
+ SS_THREAD_LIBLINK="-pthread"
cat >>confdefs.h <<\_ACEOF
#define COMPILE_THREADS_USE_POSIX 1
@@ -27491,7 +27491,7 @@
# Set the X include and lib dir
SS_X_INCDIR="$x_includes"
SS_X_LIBDIR="$x_libraries"
- SS_X_LIBLINK="-lX11 -lXext"
+ SS_X_LIBLINK="-lX11 -lXext -pthread"
if test -z "$SS_X_INCDIR"; then
# Ops... X headers not found ?
@@ -30709,7 +30709,7 @@
fi
done
- SS_DIRTAG=`echo $VERSION | cut -d . -f 1,2`
+ SS_DIRTAG=`echo $VERSION | cut -d . -f 1,2,3`
cat >>confdefs.h <<_ACEOF

View file

@ -0,0 +1,14 @@
--- data/man/CMakeLists.txt.bak 2009-09-09 13:50:57.000000000 -0500
+++ data/man/CMakeLists.txt 2009-09-09 13:51:29.000000000 -0500
@@ -16,9 +16,9 @@
# If the man is in English, it uses the root directory
STRING(COMPARE EQUAL ${LANGCODE} "en" STREQUAL)
IF(${STREQUAL})
- INSTALL(FILES ${MAN} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man1/ RENAME "kvirc.1")
+ INSTALL(FILES ${MAN} DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1/ RENAME "kvirc.1")
ELSE()
- INSTALL(FILES ${MAN} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/${LANGCODE}/man1/ RENAME "kvirc.1")
+ INSTALL(FILES ${MAN} DESTINATION ${CMAKE_INSTALL_PREFIX}/man/${LANGCODE}/man1/ RENAME "kvirc.1")
ENDIF()
ENDFOREACH()
ENDIF()

View file

@ -1,11 +0,0 @@
--- src/modules/notifier/notifierwindowtabs.cpp.orig Sun Jan 7 10:39:57 2007
+++ src/modules/notifier/notifierwindowtabs.cpp Sat Jan 27 18:24:16 2007
@@ -237,7 +237,7 @@
void KviNotifierWindowTabs::addMessage(KviWindow * pWnd, KviNotifierMessage * message)
{
- QString sender = pWnd ? pWnd->windowName() : "----";
+ QString sender = pWnd ? pWnd->windowName() : (QString)"----";
// Qui servirebbe anche una lista... perche' quando si inserisce
// un tab lui lo piazza dove gli pare nell'ordine

File diff suppressed because it is too large Load diff