Update to 1.5.0 release.

This commit is contained in:
Alex Dupre 2007-02-09 09:03:20 +00:00
parent f62bed4a43
commit ad101e3a9c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=184698
5 changed files with 51 additions and 49 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= pear
PORTVERSION= 1.4.11
PORTVERSION= 1.5.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= ale
@ -27,7 +27,5 @@ post-patch:
do-install:
@${LOCALBASE}/bin/php -q ${WRKSRC}/go-pear
@${PATCH} -p0 -s -b .orig -d ${PEARDIR} < ${PATCHDIR}/PEAR_Installer.php.patch
@${RM} -f ${PEARDIR}/PEAR/Installer.php.orig
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (pear-1.4.11.tar.bz2) = fe0953c0443ed7de1c1c4d6bdeda4c70
SHA256 (pear-1.4.11.tar.bz2) = e68429c7fd5da250c472d8f78cf8605b6207d7b4a5465a6f597bf24332d47ac6
SIZE (pear-1.4.11.tar.bz2) = 279164
MD5 (pear-1.5.0.tar.bz2) = b0b026789911b75464bc5e83e1b8f5f7
SHA256 (pear-1.5.0.tar.bz2) = 7ce4229e606af74c7027c305022372eafe50db99d2f99570ac647c7da44fe416
SIZE (pear-1.5.0.tar.bz2) = 291923

View file

@ -1,20 +0,0 @@
--- PEAR/Installer.php.orig Mon Aug 21 10:20:13 2006
+++ PEAR/Installer.php Mon Aug 21 10:20:53 2006
@@ -1464,7 +1464,8 @@
$this->log(0, $e[0]);
}
}
- // {{{ Delete the files
+ // {{{ Delete the files, if not set 'register-only' option
+ if (!isset($options['register-only'])) {
$this->startFileTransaction();
PEAR::pushErrorHandling(PEAR_ERROR_RETURN);
if (PEAR::isError($err = $this->_deletePackageFiles($package, $channel))) {
@@ -1505,6 +1506,7 @@
}
}
// }}}
+ }
$this->configSet('default_channel', $savechannel);
// Register that the package is no longer installed

View file

@ -1,5 +1,5 @@
--- go-pear.orig Fri Aug 18 21:14:19 2006
+++ go-pear Mon Aug 21 09:31:30 2006
--- go-pear.orig Tue Feb 6 18:30:15 2007
+++ go-pear Wed Feb 7 16:00:44 2007
@@ -308,6 +308,7 @@
$install_pfc = $_SESSION['go-pear']['install_pfc'];
}
@ -64,7 +64,27 @@
if ($install_pfc) {
$to_install = array_merge($installer_packages, $pfc_packages);
@@ -765,7 +773,7 @@
@@ -710,19 +718,6 @@
}
print "ok\n";
-print 'Bootstrapping: Console_Getopt.........';
-$r = 'RELEASE_' . ereg_replace('[^A-Za-z0-9]', '_', substr(substr($tarball['Console_Getopt'], 15), 0, -4));
-$url = "http://cvs.php.net/viewcvs.cgi/pear-core/Console/Getopt.php?view=co&pathrev=PEAR_1_4";
-mkdir('Console', 0700);
-if (in_array('Getopt.php', $local_dir)) {
- copy(dirname(__FILE__).'/go-pear-bundle/Getopt.php', 'Console/Getopt.php');
- echo "(local) ";
-} else {
- download_url($url, 'Console/Getopt.php', $http_proxy);
- echo "(remote) ";
-}
-print "ok\n";
-
if ($install_pfc) {
foreach ($pfc_packages as $pkg) {
foreach($local_dir as $file) {
@@ -788,7 +783,7 @@
if (WEBINSTALLER || isset($_SERVER['argv'][1]) && $_SERVER['argv'][1] == 'local') {
$config = &PEAR_Config::singleton($prefix."/pear.conf", '');
} else {
@ -73,7 +93,7 @@
}
@@ -801,6 +809,7 @@
@@ -824,6 +819,7 @@
// Base installation finished
@ -81,7 +101,7 @@
ini_restore("include_path");
if (!WEBINSTALLER) {
@@ -958,6 +967,7 @@
@@ -981,6 +977,7 @@
if (WINDOWS && !WEBINSTALLER) {
win32CreateRegEnv();
}
@ -89,7 +109,7 @@
// Set of functions following
// {{{ download_url()
@@ -1354,17 +1364,17 @@
@@ -1377,17 +1374,17 @@
}
} else {
if ($_prefix === null) {
@ -111,7 +131,7 @@
// check if the user has installed PHP with PHP or GNU layout
if (@is_dir("$prefix/lib/php/.registry")) {
$php_dir = '$prefix/lib/php';
@@ -1376,6 +1386,7 @@
@@ -1399,6 +1396,7 @@
} elseif (@is_dir("$prefix/share/php/.registry")) {
$php_dir = '$prefix/share/php';
}
@ -119,7 +139,7 @@
}
}
@@ -2481,3 +2492,4 @@
@@ -2504,3 +2502,4 @@
}
return true;
}

View file

@ -18,7 +18,7 @@ etc/pear.conf
%%DATADIR%%/.registry/archive_tar.reg
%%DATADIR%%/.registry/console_getopt.reg
%%DATADIR%%/.registry/pear.reg
%%DATADIR%%/.registry/xml_rpc.reg
%%DATADIR%%/.registry/structures_graph.reg
%%DATADIR%%/Archive/Tar.php
%%DATADIR%%/Console/Getopt.php
%%DATADIR%%/OS/Guess.php
@ -107,21 +107,22 @@ etc/pear.conf
%%DATADIR%%/PEAR/Validator/PECL.php
%%DATADIR%%/PEAR/XMLParser.php
%%DATADIR%%/PEAR.php
%%DATADIR%%/Structures/Graph/Manipulator/AcyclicTest.php
%%DATADIR%%/Structures/Graph/Manipulator/TopologicalSorter.php
%%DATADIR%%/Structures/Graph/Node.php
%%DATADIR%%/Structures/Graph.php
%%DATADIR%%/System.php
%%DATADIR%%/XML/RPC/Dump.php
%%DATADIR%%/XML/RPC/Server.php
%%DATADIR%%/XML/RPC.php
%%DATADIR%%/data/PEAR/package.dtd
%%DATADIR%%/data/PEAR/template.spec
%%DATADIR%%/data/Structures_Graph/LICENSE
%%DATADIR%%/data/Structures_Graph/genpackage.xml.pl
%%DATADIR%%/data/Structures_Graph/package.sh
%%DATADIR%%/data/Structures_Graph/publish.sh
%%DATADIR%%/pearcmd.php
%%DATADIR%%/peclcmd.php
%%DATADIR%%/tests/XML_RPC/tests/allgot.inc
%%DATADIR%%/tests/XML_RPC/tests/empty-value-struct.php
%%DATADIR%%/tests/XML_RPC/tests/empty-value.php
%%DATADIR%%/tests/XML_RPC/tests/extra-lines.php
%%DATADIR%%/tests/XML_RPC/tests/protoport.php
%%DATADIR%%/tests/XML_RPC/tests/test_Dump.php
%%DATADIR%%/tests/XML_RPC/tests/types.php
%%DATADIR%%/tests/Structures_Graph/tests/README
%%DATADIR%%/tests/Structures_Graph/tests/all-tests.php
%%DATADIR%%/tests/Structures_Graph/tests/testCase/BasicGraph.php
@dirrm %%DOCSDIR%%/Archive_Tar/docs
@dirrm %%DOCSDIR%%/Archive_Tar
@dirrmtry share/doc/pear
@ -160,11 +161,14 @@ etc/pear.conf
@dirrm %%DATADIR%%/PEAR/Task
@dirrm %%DATADIR%%/PEAR/Validator
@dirrm %%DATADIR%%/PEAR
@dirrm %%DATADIR%%/XML/RPC
@dirrmtry share/pear/XML
@dirrm %%DATADIR%%/Structures/Graph/Manipulator
@dirrm %%DATADIR%%/Structures/Graph
@dirrmtry share/pear/Structures
@dirrm %%DATADIR%%/data/PEAR
@dirrm %%DATADIR%%/data/Structures_Graph
@dirrmtry share/pear/data
@dirrm %%DATADIR%%/tests/XML_RPC/tests
@dirrm %%DATADIR%%/tests/XML_RPC
@dirrm %%DATADIR%%/tests/Structures_Graph/tests/testCase
@dirrm %%DATADIR%%/tests/Structures_Graph/tests
@dirrm %%DATADIR%%/tests/Structures_Graph
@dirrmtry share/pear/tests
@dirrmtry share/pear