Update to version 1.3.3

PR:		ports/72523
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2004-10-12 12:34:39 +00:00
parent ae96fcaeaa
commit ad54e7379b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=118988
3 changed files with 34 additions and 5 deletions

View file

@ -7,7 +7,7 @@
#
PORTNAME= mhwaveedit
PORTVERSION= 1.3.0
PORTVERSION= 1.3.3
CATEGORIES= audio
MASTER_SITES= http://www.mtek.chalmers.se/~hjormagn/
@ -19,14 +19,18 @@ LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
portaudio.0:${PORTSDIR}/audio/portaudio
USE_GNOME= gnomehack gnometarget gtk20
WANT_GNOME= yes
WANT_SDL= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-optimization --without-alsalib --without-sdl
CONFIGURE_ARGS= --disable-optimization --without-alsalib
PLIST_FILES= bin/mhwaveedit
.include <bsd.port.pre.mk>
.if defined(WITH_DOUBLE_SAMPLES)
CONFIGURE_ARGS+= --with-double-samples
.endif
@ -37,6 +41,18 @@ LIB_DPENDS+= jack:${PORTSDIR}/audio/jack
CONFIGURE_ARGS+= --without-jack
.endif
.if ${HAVE_SDL:Msdl}!=""
USE_SDL+= sdl
.else
CONFIGURE_ARGS+= --without-sdl
.endif
.if ${HAVE_GNOME:Mesound}!=""
USE_GNOME+= esound
.else
CONFIGURE_ARGS+= --without-esound
.endif
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "mhWaveEdit has the following tunable option:"
@ -49,8 +65,11 @@ pre-everything::
@${ECHO_MSG} " WITH_JACK=yes"
@${ECHO_MSG} " Support JACK driver"
@${ECHO_MSG} ""
@${ECHO_MSG} " WITH_GNOME=esound"
@${ECHO_MSG} " Support EsounD driver"
@${ECHO_MSG} ""
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||g' ${WRKSRC}/configure
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
MD5 (mhwaveedit-1.3.0.tar.gz) = ea17d4639af5983d2a2b33e343c41fb3
SIZE (mhwaveedit-1.3.0.tar.gz) = 292965
MD5 (mhwaveedit-1.3.3.tar.gz) = 6fa2198e0cebdf863beeafba6fcfa29f
SIZE (mhwaveedit-1.3.3.tar.gz) = 307576

View file

@ -0,0 +1,10 @@
--- src/gtkfiles.h.orig Wed Sep 15 23:25:47 2004
+++ src/gtkfiles.h Fri Oct 8 21:39:16 2004
@@ -26,6 +26,7 @@
#include <stdio.h>
#include <stdlib.h>
+#include <unistd.h>
#include <gtk/gtk.h>