- Update to version 0.9.0
PR: 135034 Submitted by: Ports Fury
This commit is contained in:
parent
2c3b1de4d4
commit
ad5af0448c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=234736
11 changed files with 127 additions and 136 deletions
|
@ -6,11 +6,9 @@
|
|||
#
|
||||
|
||||
PORTNAME= reallyslick
|
||||
PORTVERSION= 0.8.1
|
||||
PORTREVISION= 5
|
||||
PORTVERSION= 0.9.0
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= rss-glx
|
||||
MASTER_SITES= SF/rss-glx
|
||||
DISTNAME= rss-glx_${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
@ -18,32 +16,37 @@ COMMENT= OpenGL screensaver collection
|
|||
|
||||
LIB_DEPENDS= MagickWand.2:${PORTSDIR}/graphics/ImageMagick
|
||||
|
||||
OPTIONS= FREEALUT "Enable freealut support" off \
|
||||
GLEW "Enable GLEW support" off
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GL= yes
|
||||
USE_GL= glu
|
||||
USE_GNOME= gnomehack
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_AUTOTOOLS= libtool:15:env
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include `Magick-config --cflags`
|
||||
LDFLAGS+= -L${LOCALBASE}/lib `Magick-config --libs`
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
|
||||
LDFLAGS="${LDFLAGS}"
|
||||
MAN1= biof.1 busyspheres.1 colorfire.1 cyclone.1 drempels.1 \
|
||||
euphoria.1 feedback.1 fieldlines.1 flocks.1 flux.1 \
|
||||
helios.1 hufo_smoke.1 hufo_tunnel.1 hyperspace.1 lattice.1 \
|
||||
lorenz.1 matrixview.1 plasma.1 skyrocket.1 solarwinds.1 \
|
||||
spirographx.1 sundancer2.1
|
||||
|
||||
MAN1= biof.1 busyspheres.1 colorfire.1 cyclone.1 euphoria.1 fieldlines.1 flocks.1 \
|
||||
flux.1 helios.1 hufo_smoke.1 hufo_tunnel.1 lattice.1 matrixview.1 \
|
||||
plasma.1 skyrocket.1 solarwinds.1 spirographx.1 sundancer2.1
|
||||
CPPFLAGS= -I${LOCALBASE}/include
|
||||
LDFLAGS= -L${LOCALBASE}/lib
|
||||
|
||||
post-patch:
|
||||
.for file in config.guess config.sub ltmain.sh
|
||||
${RM} ${WRKSRC}/${file}
|
||||
${LN} -s ${LOCALBASE}/share/libtool/${file} ${WRKSRC}
|
||||
.endfor
|
||||
.for file in oglc_src/Makefile.in other_src/Makefile.in \
|
||||
reallyslick/c_src/Makefile.in reallyslick/cpp_src/Makefile.in
|
||||
@${REINPLACE_CMD} -E -e 's|(@LIBS@)|\1 -lXext|' ${WRKSRC}/${file}
|
||||
.endfor
|
||||
# fix lib detection
|
||||
@${REINPLACE_CMD} -E -e 's@^(LIBS.*-l(GL|MesaGL|GLU))@\1 -lXext@' \
|
||||
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.if defined(WITH_FREEALUT)
|
||||
LIB_DEPENDS+= alut.1:${PORTSDIR}/audio/freealut
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-sound
|
||||
.endif
|
||||
|
||||
.if defined(WITH_GLEW)
|
||||
LIB_DEPENDS+= GLEW.1:${PORTSDIR}/graphics/glew
|
||||
.else
|
||||
CONFIGURE_ENV+= ac_cv_header_GL_glew_h=no
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (rss-glx_0.8.1.tar.bz2) = a2bdf0e10ee4e89c8975f313c5c0ba6f
|
||||
SHA256 (rss-glx_0.8.1.tar.bz2) = cf03409ed82f167b39a37b25d21a2de065bb728afeda561bdb2626e7b7ea42bb
|
||||
SIZE (rss-glx_0.8.1.tar.bz2) = 5248755
|
||||
MD5 (rss-glx_0.9.0.tar.bz2) = a8dad80cd33b11443e9d06b33a85fb32
|
||||
SHA256 (rss-glx_0.9.0.tar.bz2) = 04383a49f3c57d27708c314ece750dbe7f873aecff6a83a6803635dbeaf720f6
|
||||
SIZE (rss-glx_0.9.0.tar.bz2) = 5379720
|
||||
|
|
56
graphics/reallyslick/files/patch-configure
Normal file
56
graphics/reallyslick/files/patch-configure
Normal file
|
@ -0,0 +1,56 @@
|
|||
--- configure.bak 2009-05-22 00:53:12.000000000 +0900
|
||||
+++ configure 2009-05-22 00:55:34.000000000 +0900
|
||||
@@ -3357,7 +3357,7 @@
|
||||
fi
|
||||
else
|
||||
if test "$GCC" = yes; then
|
||||
- CFLAGS="-O2"
|
||||
+ CFLAGS="$CFLAGS"
|
||||
else
|
||||
CFLAGS=
|
||||
fi
|
||||
@@ -5047,7 +5047,7 @@
|
||||
|
||||
|
||||
if test "x$GCC" = xyes; then
|
||||
- CFLAGS="-O2"
|
||||
+ CFLAGS="$CFLAGS"
|
||||
fi
|
||||
# Check whether --enable-debug was given.
|
||||
if test "${enable_debug+set}" = set; then
|
||||
@@ -5411,7 +5411,7 @@
|
||||
fi
|
||||
else
|
||||
if test "$GXX" = yes; then
|
||||
- CXXFLAGS="-O2"
|
||||
+ CXXFLAGS="$CXXFLAGS"
|
||||
else
|
||||
CXXFLAGS=
|
||||
fi
|
||||
@@ -5532,7 +5532,7 @@
|
||||
|
||||
|
||||
if test "x$GXX" = xyes; then
|
||||
- CXXFLAGS="-O2"
|
||||
+ CXXFLAGS="$CXXFLAGS"
|
||||
fi
|
||||
# Check whether --enable-debug was given.
|
||||
if test "${enable_debug+set}" = set; then
|
||||
@@ -7080,7 +7080,7 @@
|
||||
fi
|
||||
else
|
||||
if test "x$ac_cv_f77_compiler_gnu" = xyes; then
|
||||
- FFLAGS="-O2"
|
||||
+ FFLAGS="$FFLAGS"
|
||||
else
|
||||
FFLAGS=
|
||||
fi
|
||||
@@ -22414,7 +22414,7 @@
|
||||
fi
|
||||
|
||||
|
||||
-if test "x${ac_cv_have_x:0:10}" != "xhave_x=yes"; then
|
||||
+if test "x${ac_cv_have_x+set}" = set; then
|
||||
{ { echo "$as_me:$LINENO: error: X11 is missing but required." >&5
|
||||
echo "$as_me: error: X11 is missing but required." >&2;}
|
||||
{ (exit 1); exit 1; }; }
|
|
@ -1,27 +0,0 @@
|
|||
--- other_src/driver.c.orig Sun Feb 26 07:16:15 2006
|
||||
+++ other_src/driver.c Fri Apr 28 09:27:01 2006
|
||||
@@ -152,10 +152,14 @@
|
||||
{
|
||||
int bFPS = False;
|
||||
XEvent event;
|
||||
- Atom XA_WM_PROTOCOLS = XInternAtom (XStuff->display, "WM_PROTOCOLS", False);
|
||||
- Atom XA_WM_DELETE_WINDOW = XInternAtom (XStuff->display, "WM_DELETE_WINDOW", False);
|
||||
+ Atom XA_WM_PROTOCOLS;
|
||||
+ Atom XA_WM_DELETE_WINDOW;
|
||||
struct timeval then, now, fps_time;
|
||||
int fps = 0;
|
||||
+ int frameTimeSoFar = 0;
|
||||
+
|
||||
+ XA_WM_PROTOCOLS = XInternAtom (XStuff->display, "WM_PROTOCOLS", False);
|
||||
+ XA_WM_DELETE_WINDOW = XInternAtom (XStuff->display, "WM_DELETE_WINDOW", False);
|
||||
|
||||
if (!rootWindow) {
|
||||
XSetWMProtocols (XStuff->display, XStuff->window, &XA_WM_DELETE_WINDOW, 1);
|
||||
@@ -164,7 +168,6 @@
|
||||
clearBuffers();
|
||||
|
||||
gettimeofday (&now, NULL);
|
||||
- int frameTimeSoFar = 0;
|
||||
while (!signalled) {
|
||||
hack_draw (XStuff, (double)now.tv_sec + now.tv_usec / 1000000.0f, frameTimeSoFar / 1000000.0f);
|
||||
|
|
@ -1,20 +0,0 @@
|
|||
--- other_src/matrixview.c.orig Sun Feb 26 08:55:26 2006
|
||||
+++ other_src/matrixview.c Fri Apr 28 09:33:18 2006
|
||||
@@ -94,13 +94,15 @@
|
||||
|
||||
// Directory scanning + image loading code in a separate function callable either from loadNextImage or another thread if pthreads is available.
|
||||
void loadNextImageFromDisk() {
|
||||
- MagickWand *magick_wand = NewMagickWand();
|
||||
+ MagickWand *magick_wand;
|
||||
ExceptionInfo exception;
|
||||
int dirLoop = 0;
|
||||
+ int imageLoaded = 0;
|
||||
+
|
||||
+ magick_wand = NewMagickWand();
|
||||
|
||||
GetExceptionInfo (&exception);
|
||||
|
||||
- int imageLoaded = 0;
|
||||
do {
|
||||
struct dirent *file;
|
||||
|
|
@ -1,27 +0,0 @@
|
|||
--- reallyslick/c_src/driver.c.orig Sun Feb 26 07:16:15 2006
|
||||
+++ reallyslick/c_src/driver.c Fri Apr 28 09:39:38 2006
|
||||
@@ -152,10 +152,14 @@
|
||||
{
|
||||
int bFPS = False;
|
||||
XEvent event;
|
||||
- Atom XA_WM_PROTOCOLS = XInternAtom (XStuff->display, "WM_PROTOCOLS", False);
|
||||
- Atom XA_WM_DELETE_WINDOW = XInternAtom (XStuff->display, "WM_DELETE_WINDOW", False);
|
||||
+ Atom XA_WM_PROTOCOLS;
|
||||
+ Atom XA_WM_DELETE_WINDOW;
|
||||
struct timeval then, now, fps_time;
|
||||
int fps = 0;
|
||||
+ int frameTimeSoFar = 0;
|
||||
+
|
||||
+ XA_WM_PROTOCOLS = XInternAtom (XStuff->display, "WM_PROTOCOLS", False);
|
||||
+ XA_WM_DELETE_WINDOW = XInternAtom (XStuff->display, "WM_DELETE_WINDOW", False);
|
||||
|
||||
if (!rootWindow) {
|
||||
XSetWMProtocols (XStuff->display, XStuff->window, &XA_WM_DELETE_WINDOW, 1);
|
||||
@@ -164,7 +168,6 @@
|
||||
clearBuffers();
|
||||
|
||||
gettimeofday (&now, NULL);
|
||||
- int frameTimeSoFar = 0;
|
||||
while (!signalled) {
|
||||
hack_draw (XStuff, (double)now.tv_sec + now.tv_usec / 1000000.0f, frameTimeSoFar / 1000000.0f);
|
||||
|
|
@ -1,28 +0,0 @@
|
|||
--- reallyslick/c_src/lattice.c.orig Sun Feb 26 07:47:35 2006
|
||||
+++ reallyslick/c_src/lattice.c Fri Apr 28 09:43:41 2006
|
||||
@@ -714,6 +714,7 @@
|
||||
static float rollVel = 0.0f, rollAcc = 0.0f;
|
||||
int drawDepth = dDrawdepth + 2;
|
||||
static float rollChange = 0; /* rsRandf (10.0f) + 2.0f; */
|
||||
+ float dot, maxSpin, rotationInertia;
|
||||
|
||||
where += (float)dSpeed * 0.05f * elapsedTime;
|
||||
if (where >= 1.0f) {
|
||||
@@ -741,14 +742,14 @@
|
||||
rsVec_cross ((float *)&angvel, dir, oldDir); /* Desired axis of rotation */
|
||||
|
||||
/* Protect against mild "overflow" */
|
||||
- float dot = MAX(MIN(rsVec_dot (oldDir, dir), -1.0), 1.0);
|
||||
- float maxSpin = 0.25f * (float)dSpeed * elapsedTime;
|
||||
+ dot = MAX(MIN(rsVec_dot (oldDir, dir), -1.0), 1.0);
|
||||
+ maxSpin = 0.25f * (float)dSpeed * elapsedTime;
|
||||
angle = MAX(MIN(acos(dot), -maxSpin), maxSpin);
|
||||
|
||||
rsVec_scale ((float *)&angvel, angle); /* Desired angular velocity */
|
||||
rsVec_subtract (angvel, oldAngvel, (float *)&tempVec); /* Change in angular velocity */
|
||||
distance = rsVec_length (tempVec); /* Don't let angular velocity change too much */
|
||||
- float rotationInertia = 0.007f * (float)dSpeed * elapsedTime;
|
||||
+ rotationInertia = 0.007f * (float)dSpeed * elapsedTime;
|
||||
if (distance > rotationInertia * elapsedTime) {
|
||||
rsVec_scale ((float *)&tempVec, ((rotationInertia * elapsedTime) / distance));
|
||||
rsVec_add (oldAngvel, tempVec, (float *)&angvel);
|
17
graphics/reallyslick/files/patch-src__hyperspace.cpp
Normal file
17
graphics/reallyslick/files/patch-src__hyperspace.cpp
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- src/hyperspace.cpp.orig 2009-05-17 07:41:52.000000000 +0900
|
||||
+++ src/hyperspace.cpp 2009-05-21 18:05:29.000000000 +0900
|
||||
@@ -144,6 +144,14 @@
|
||||
first = 0;
|
||||
}
|
||||
|
||||
+ aspectRatio = float(XStuff->windowWidth) / float(XStuff->windowHeight);
|
||||
+ glViewport(0, 0, XStuff->windowWidth, XStuff->windowHeight);
|
||||
+
|
||||
+ // setup projection matrix
|
||||
+ glMatrixMode(GL_PROJECTION);
|
||||
+ glLoadIdentity();
|
||||
+ gluPerspective(float(dFov), aspectRatio, 0.001f, 200.0f);
|
||||
+ glGetDoublev(GL_PROJECTION_MATRIX, projMat);
|
||||
glMatrixMode(GL_MODELVIEW);
|
||||
|
||||
// Camera movements
|
10
graphics/reallyslick/files/patch-src__skyrocket_sound.cpp
Normal file
10
graphics/reallyslick/files/patch-src__skyrocket_sound.cpp
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/skyrocket_sound.cpp.orig 2009-04-22 09:41:23.000000000 +0900
|
||||
+++ src/skyrocket_sound.cpp 2009-05-21 18:07:02.000000000 +0900
|
||||
@@ -25,6 +25,7 @@
|
||||
#include <AL/al.h>
|
||||
#include <AL/alut.h>
|
||||
|
||||
+#include <cstdlib>
|
||||
#include <list>
|
||||
|
||||
#include "loadTexture.h"
|
|
@ -1,4 +1,8 @@
|
|||
This is a port of the Really Slick Screensavers collection
|
||||
This is a GLX port of the Really Slick Screensavers collection
|
||||
(http://www.reallyslick.com/). Also included are several other OpenGL
|
||||
screensavers ported from other platforms.
|
||||
|
||||
http://rss-glx.sourceforge.net/
|
||||
WWW: http://www.reallyslick.com/
|
||||
The screensavers can either be run as stand-alone applications or get
|
||||
integrated into XScreenSaver's list of active screensavers.
|
||||
|
||||
WWW: http://rss-glx.sourceforge.net/
|
||||
|
|
|
@ -2,7 +2,9 @@ bin/biof
|
|||
bin/busyspheres
|
||||
bin/colorfire
|
||||
bin/cyclone
|
||||
bin/drempels
|
||||
bin/euphoria
|
||||
bin/feedback
|
||||
bin/fieldlines
|
||||
bin/flocks
|
||||
bin/flux
|
||||
|
@ -11,6 +13,7 @@ bin/hufo_smoke
|
|||
bin/hufo_tunnel
|
||||
bin/hyperspace
|
||||
bin/lattice
|
||||
bin/lorenz
|
||||
bin/matrixview
|
||||
bin/plasma
|
||||
bin/rss-glx_install.pl
|
||||
|
@ -18,7 +21,7 @@ bin/skyrocket
|
|||
bin/solarwinds
|
||||
bin/spirographx
|
||||
bin/sundancer2
|
||||
lib/libImplicit.la
|
||||
lib/libImplicit.a
|
||||
lib/librsMath.la
|
||||
lib/libImplicit.la
|
||||
lib/librsMath.a
|
||||
lib/librsMath.la
|
||||
|
|
Loading…
Reference in a new issue