add vis5d+ 1.2.1
An OpenGL-based volumetric visualization program for scientific datasets
This commit is contained in:
parent
45267e30c2
commit
ad987f58f2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=52815
7 changed files with 109 additions and 0 deletions
|
@ -5,6 +5,7 @@
|
|||
SUBDIR += clhep
|
||||
SUBDIR += libsvm
|
||||
SUBDIR += mpqc
|
||||
SUBDIR += vis5d+
|
||||
SUBDIR += xmakemol
|
||||
|
||||
.include <bsd.port.subdir.mk>
|
||||
|
|
44
science/vis5d+/Makefile
Normal file
44
science/vis5d+/Makefile
Normal file
|
@ -0,0 +1,44 @@
|
|||
# ex:ts=8
|
||||
# Ports collection Makefile for: vis5d+
|
||||
# Date created: Jan 9, 2002
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= vis5d+
|
||||
PORTVERSION= 1.2.1
|
||||
CATEGORIES= science
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= vis5d
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libmix.a:${PORTSDIR}/graphics/qslim \
|
||||
convert:${PORTSDIR}/graphics/ImageMagick
|
||||
LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv \
|
||||
netcdf.1:${PORTSDIR}/math/netcdf
|
||||
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
|
||||
|
||||
USE_BISON= yes
|
||||
USE_MESA= yes
|
||||
USE_XLIB= yes
|
||||
USE_GTK= yes
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= \
|
||||
CPPFLAGS="${CXXFLAGS} ${PTHREAD_FLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
|
||||
LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -lgiconv -lintl -L${X11BASE}/lib"
|
||||
CONFIGURE_ARGS= --enable-gtk --enable-threads --with-mesa --with-netcdf \
|
||||
--with-mixkit=${LOCALBASE}/lib/libmix.a --with-x
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
post-patch:
|
||||
.for file in configure intl/gettextP.h
|
||||
@${PERL} -pi -e "s,iconv.h,giconv.h,g" ${WRKSRC}/${file}
|
||||
.endfor
|
||||
|
||||
pre-build:
|
||||
@${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
|
||||
|
||||
.include <bsd.port.mk>
|
1
science/vis5d+/distinfo
Normal file
1
science/vis5d+/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (vis5d+-1.2.1.tar.gz) = 0521694c2210c0aedcf2fde521a2c578
|
25
science/vis5d+/files/patch-gtk::main.c
Normal file
25
science/vis5d+/files/patch-gtk::main.c
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- gtk/main.c.orig Wed Jan 9 13:08:24 2002
|
||||
+++ gtk/main.c Wed Jan 9 13:08:34 2002
|
||||
@@ -8,7 +8,6 @@
|
||||
#endif
|
||||
#include <gtk/gtk.h>
|
||||
|
||||
-#include <mcheck.h>
|
||||
#include <signal.h>
|
||||
|
||||
#include "window3D.h"
|
||||
@@ -18,14 +17,12 @@
|
||||
static void
|
||||
enable (int sig)
|
||||
{
|
||||
- mtrace ();
|
||||
signal (SIGUSR1, enable);
|
||||
}
|
||||
|
||||
static void
|
||||
disable (int sig)
|
||||
{
|
||||
- muntrace ();
|
||||
signal (SIGUSR2, disable);
|
||||
}
|
||||
|
1
science/vis5d+/pkg-comment
Normal file
1
science/vis5d+/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
An OpenGL-based volumetric visualization program for scientific datasets
|
5
science/vis5d+/pkg-descr
Normal file
5
science/vis5d+/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
Vis5d+ is intended as a central repository for enhanced versions and
|
||||
development work on Vis5d, a free OpenGL-based volumetric visualization
|
||||
program for scientific datasets in 3+ dimensions.
|
||||
|
||||
WWW: http://vis5d.sourceforge.net/
|
32
science/vis5d+/pkg-plist
Normal file
32
science/vis5d+/pkg-plist
Normal file
|
@ -0,0 +1,32 @@
|
|||
bin/comp_to_v5d
|
||||
bin/gg3d
|
||||
bin/gr3d_to_v5d
|
||||
bin/igg3d
|
||||
bin/igu3d
|
||||
bin/topoinfo
|
||||
bin/v5dappend
|
||||
bin/v5dedit
|
||||
bin/v5dimport
|
||||
bin/v5dinfo
|
||||
bin/v5dstats
|
||||
bin/vis5d
|
||||
include/vis5d+/api-config.h
|
||||
include/vis5d+/api.h
|
||||
include/vis5d+/binio.h
|
||||
include/vis5d+/v5d.h
|
||||
include/vis5d+/v5df.h
|
||||
lib/libv5d.a
|
||||
lib/libv5d.la
|
||||
lib/libv5d.so
|
||||
lib/libv5d.so.2
|
||||
lib/libvis5d.a
|
||||
lib/libvis5d.la
|
||||
lib/libvis5d.so
|
||||
lib/libvis5d.so.2
|
||||
share/locale/es/LC_MESSAGES/vis5d+.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/vis5d+.mo
|
||||
share/vis5d+/EARTH.TOPO
|
||||
share/vis5d+/OUTLSUPW
|
||||
share/vis5d+/OUTLUSAM
|
||||
@dirrm include/vis5d+
|
||||
@dirrm share/vis5d+
|
Loading…
Reference in a new issue