textproc/google-ctemplate: update to 2.4.
This commit is contained in:
parent
4c7ae0897f
commit
ad9a6e6c14
6 changed files with 7 additions and 80 deletions
|
@ -1,7 +1,7 @@
|
|||
# Created by: ijliao
|
||||
|
||||
PORTNAME= ctemplate
|
||||
PORTVERSION= 2.3
|
||||
PORTVERSION= 2.4
|
||||
DISTVERSIONPREFIX= ${PORTNAME}-
|
||||
CATEGORIES= textproc
|
||||
PKGNAMEPREFIX= google-
|
||||
|
@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
|||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
USES= libtool pathfix pkgconfig python:build shebangfix
|
||||
USES= autoreconf gmake libtool pathfix pkgconfig python:build shebangfix
|
||||
GNU_CONFIGURE= yes
|
||||
SHEBANG_FILES= src/template-converter src/htmlparser/generate_fsm.py src/htmlparser/fsm_config.py
|
||||
USE_LDCONFIG= yes
|
||||
|
@ -24,16 +24,13 @@ INSTALL_TARGET= install-strip
|
|||
TEST_TARGET= check
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|$$(prefix)/share/doc/$$(PACKAGE)-$$(VERSION)|${DOCSDIR}|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
# XXX: undefining BSWAP32 breaks builds on big-endian systems for some reason
|
||||
@${REINPLACE_CMD} -e 's|# undef BSWAP32|//&|' \
|
||||
${WRKSRC}/src/base/macros.h
|
||||
|
||||
post-patch-DOCS-off:
|
||||
@${REINPLACE_CMD} -e \
|
||||
'/install-data-am/ s|install-dist_docDATA||' \
|
||||
${WRKSRC}/Makefile.in
|
||||
's|dist_doc_DATA|noinst_DOCDATA|' \
|
||||
${WRKSRC}/Makefile.am
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1464784826
|
||||
SHA256 (OlafvdSpek-ctemplate-ctemplate-2.3_GH0.tar.gz) = 99e5cb6d3f8407d5b1ffef96b1d59ce3981cda3492814e5ef820684ebb782556
|
||||
SIZE (OlafvdSpek-ctemplate-ctemplate-2.3_GH0.tar.gz) = 720717
|
||||
TIMESTAMP = 1627287136
|
||||
SHA256 (OlafvdSpek-ctemplate-ctemplate-2.4_GH0.tar.gz) = ccc4105b3dc51c82b0f194499979be22d5a14504f741115be155bd991ee93cfa
|
||||
SIZE (OlafvdSpek-ctemplate-ctemplate-2.4_GH0.tar.gz) = 391923
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- src/base/small_map.h.orig 2014-03-19 19:34:51 UTC
|
||||
+++ src/base/small_map.h
|
||||
@@ -52,6 +52,8 @@
|
||||
#include <assert.h>
|
||||
#include <utility> // for make_pair()
|
||||
#include "base/manual_constructor.h"
|
||||
+using std::make_pair;
|
||||
+
|
||||
_START_GOOGLE_NAMESPACE_
|
||||
|
||||
template <bool> struct CompileAssert { };
|
|
@ -1,15 +0,0 @@
|
|||
--- src/htmlparser/fsm_config.py.orig 2020-09-26 14:52:15 UTC
|
||||
+++ src/htmlparser/fsm_config.py
|
||||
@@ -210,7 +210,11 @@ class FSMConfig(object):
|
||||
|
||||
self.sm['state'] = self.AddState
|
||||
self.sm['condition'] = self.AddCondition
|
||||
- execfile(filename, self.sm)
|
||||
+
|
||||
+ with open(filename) as f:
|
||||
+ code = compile(f.read(), filename, 'exec')
|
||||
+ exec(code, self.sm)
|
||||
+
|
||||
self.name = self.sm['name']
|
||||
if not self.name.isalnum():
|
||||
raise Exception("State machine name must consist of only alphanumeric"
|
|
@ -1,41 +0,0 @@
|
|||
--- src/htmlparser/generate_fsm.py.orig 2020-09-26 14:51:40 UTC
|
||||
+++ src/htmlparser/generate_fsm.py
|
||||
@@ -264,7 +264,7 @@ class FSMGenerateC(FSMGenerateAbstract):
|
||||
state_table = {}
|
||||
|
||||
for state in self._config.states:
|
||||
- state_table[state] = [default_state for col in xrange(255)]
|
||||
+ state_table[state] = [default_state for col in range(255)]
|
||||
|
||||
# We process the transition in reverse order while updating the table.
|
||||
for i_transition in range(len(self._config.transitions) - 1, -1, -1):
|
||||
@@ -281,7 +281,7 @@ class FSMGenerateC(FSMGenerateAbstract):
|
||||
# Create the inner lists which map input characters to destination states.
|
||||
for state in self._config.states:
|
||||
transition_row = []
|
||||
- for c in xrange(0, 255):
|
||||
+ for c in range(0, 255):
|
||||
transition_row.append(' /* %06s */ %s' % (repr(chr(c)),
|
||||
state_table[state][c]))
|
||||
|
||||
@@ -306,17 +306,17 @@ class FSMGenerateC(FSMGenerateAbstract):
|
||||
def Generate(self):
|
||||
"""Returns the generated the C include statements for the statemachine."""
|
||||
|
||||
- print '\n'.join((self._CreateHeader(),
|
||||
+ print('\n'.join((self._CreateHeader(),
|
||||
self._CreateNumStates(),
|
||||
self._CreateStatesEnum(),
|
||||
self._CreateStatesExternal(),
|
||||
self._CreateStatesInternalNames(),
|
||||
- self._CreateTransitionTable()))
|
||||
+ self._CreateTransitionTable())))
|
||||
|
||||
|
||||
def main():
|
||||
if len(sys.argv) != 2:
|
||||
- print "usage: generate_fsm.py config_file"
|
||||
+ print("usage: generate_fsm.py config_file")
|
||||
sys.exit(1)
|
||||
|
||||
config = FSMConfig()
|
|
@ -25,12 +25,9 @@ lib/libctemplate_nothreads.so.3.0.0
|
|||
libdata/pkgconfig/libctemplate.pc
|
||||
libdata/pkgconfig/libctemplate_nothreads.pc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README_windows.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/auto_escape.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/designstyle.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/example.html
|
||||
|
|
Loading…
Reference in a new issue