Minor update, make xcin-2.3 to install again.
Obtained from : bento.
This commit is contained in:
parent
dbb130d43f
commit
adef956674
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=21565
3 changed files with 68 additions and 70 deletions
|
@ -1,29 +0,0 @@
|
|||
--- src/xi.c.org Thu Sep 9 17:14:05 1999
|
||||
+++ src/xi.c Thu Sep 9 17:15:53 1999
|
||||
@@ -1056,19 +1056,25 @@
|
||||
|
||||
void switch_active_client( InmdState *state, Window cli_win )
|
||||
{
|
||||
+ int refresh = 1;
|
||||
last_win = cli_win;
|
||||
|
||||
if ( ignore_cli_stat )
|
||||
ignore_cli_stat = 0;
|
||||
else
|
||||
if ( state->_CurInMethod )
|
||||
- memcpy( &inmdstate, state, sizeof( inmdstate ) );
|
||||
+ if(memcpy( &inmdstate, state, sizeof( inmdstate ) ))
|
||||
+ memcpy( &inmdstate, state, sizeof( inmdstate ) );
|
||||
+ else
|
||||
+ refresh = 0;
|
||||
|
||||
if ( hide_xcin && ( EngChi || HalfFull ) )
|
||||
Show_Xcin();
|
||||
else if ( hide_xcin && !EngChi && !HalfFull )
|
||||
XUnmapWindow( display, main_win );
|
||||
|
||||
+ if(!refresh)
|
||||
+ return;
|
||||
gotoxy( 0, MROW - 1 );
|
||||
|
||||
ClrShowArea( 0 );
|
27
chinese/xcin/files/patch-af
Normal file
27
chinese/xcin/files/patch-af
Normal file
|
@ -0,0 +1,27 @@
|
|||
--- src/Makefile.in.org Fri Sep 10 19:54:58 1999
|
||||
+++ src/Makefile.in Fri Sep 10 19:55:52 1999
|
||||
@@ -149,7 +149,7 @@
|
||||
|
||||
install_xcin: xcin $(KBMS) $(INPUT0) tsintab
|
||||
if [ ! -d $(PATH_XCIN_BIN) ]; then $(INSTALL_DIR) $(PATH_XCIN_BIN); fi
|
||||
- $(INSTALL) xcin $(PATH_XCIN_BIN)
|
||||
+ $(INSTALL_PROGRAM) xcin $(PATH_XCIN_BIN)
|
||||
echo $(PATH_XCIN_BIN)/xcin >> filelist
|
||||
|
||||
if [ ! -d $(PATH_XCIN_DIR) ]; then $(INSTALL_DIR) $(PATH_XCIN_DIR); fi
|
||||
@@ -159,13 +159,13 @@
|
||||
|
||||
install_cin2tab: cin2tab
|
||||
if [ ! -d $(PATH_XCIN_DIR) ]; then $(INSTALL_DIR) $(PATH_XCIN_DIR); fi
|
||||
- $(INSTALL) cin2tab $(PATH_XCIN_DIR)
|
||||
+ $(INSTALL_PROGRAM) cin2tab $(PATH_XCIN_DIR)
|
||||
echo $(PATH_XCIN_DIR)/cin2tab >> filelist
|
||||
|
||||
install_tsintools: tsintools
|
||||
if [ ! -d $(PATH_XCIN_DIR) ]; then $(INSTALL_DIR) $(PATH_XCIN_DIR); fi
|
||||
for f in $(TSINTOOLS); do\
|
||||
- $(INSTALL) $$f $(PATH_XCIN_DIR); echo $(PATH_XCIN_DIR)/$$f >> filelist;\
|
||||
+ $(INSTALL_PROGRAM) $$f $(PATH_XCIN_DIR); echo $(PATH_XCIN_DIR)/$$f >> filelist;\
|
||||
done
|
||||
|
||||
install_tsintabsrc:
|
|
@ -1,42 +1,42 @@
|
|||
bin/xcin
|
||||
lib/X11/xcin/cin2tab
|
||||
lib/X11/xcin/cj.cin
|
||||
lib/X11/xcin/cj.tab
|
||||
lib/X11/xcin/cj.tab.rev
|
||||
lib/X11/xcin/et.kbm
|
||||
lib/X11/xcin/et26.kbm
|
||||
lib/X11/xcin/hsu.kbm
|
||||
lib/X11/xcin/lphrase
|
||||
lib/X11/xcin/pho.sel1st
|
||||
lib/X11/xcin/pho.tab
|
||||
lib/X11/xcin/phone.cin
|
||||
lib/X11/xcin/phone.tab
|
||||
lib/X11/xcin/phone.tab.rev
|
||||
lib/X11/xcin/phs_out
|
||||
lib/X11/xcin/pin2tsin
|
||||
lib/X11/xcin/pinyin.cin
|
||||
lib/X11/xcin/pinyin.tab
|
||||
lib/X11/xcin/pinyin.tab.rev
|
||||
lib/X11/xcin/sample.phs.out
|
||||
lib/X11/xcin/tsa2d
|
||||
lib/X11/xcin/tsa2rel
|
||||
lib/X11/xcin/tsd2a
|
||||
lib/X11/xcin/tsin
|
||||
lib/X11/xcin/tsin.idx
|
||||
lib/X11/xcin/tsin.rel
|
||||
lib/X11/xcin/tsin.rel.src
|
||||
lib/X11/xcin/tsin.src
|
||||
lib/X11/xcin/tsin_pin.map
|
||||
lib/X11/xcin/voca.box
|
||||
lib/X11/xcin/zmdbosh.cin
|
||||
lib/X11/xcin/zmdbosh.tab
|
||||
lib/X11/xcin/zmdbosh.tab.rev
|
||||
lib/X11/xcin/zo.kbm
|
||||
lib/X11/xcin/docs/Boshiamy.HOWTO
|
||||
lib/X11/xcin/docs/README.xcin
|
||||
lib/X11/xcin/docs/XCIN.client.doc
|
||||
lib/X11/xcin/docs/Xfonts.HOWTO
|
||||
lib/X11/xcin/docs/cin2tab.HOWTO
|
||||
lib/X11/xcin/docs/xcin.HOWTO
|
||||
@dirrm lib/X11/xcin/docs
|
||||
@dirrm lib/X11/xcin
|
||||
lib/xcin/cin2tab
|
||||
lib/xcin/cj.cin
|
||||
lib/xcin/cj.tab
|
||||
lib/xcin/cj.tab.rev
|
||||
lib/xcin/et.kbm
|
||||
lib/xcin/et26.kbm
|
||||
lib/xcin/hsu.kbm
|
||||
lib/xcin/lphrase
|
||||
lib/xcin/pho.sel1st
|
||||
lib/xcin/pho.tab
|
||||
lib/xcin/phone.cin
|
||||
lib/xcin/phone.tab
|
||||
lib/xcin/phone.tab.rev
|
||||
lib/xcin/phs_out
|
||||
lib/xcin/pin2tsin
|
||||
lib/xcin/pinyin.cin
|
||||
lib/xcin/pinyin.tab
|
||||
lib/xcin/pinyin.tab.rev
|
||||
lib/xcin/sample.phs.out
|
||||
lib/xcin/tsa2d
|
||||
lib/xcin/tsa2rel
|
||||
lib/xcin/tsd2a
|
||||
lib/xcin/tsin
|
||||
lib/xcin/tsin.idx
|
||||
lib/xcin/tsin.rel
|
||||
lib/xcin/tsin.rel.src
|
||||
lib/xcin/tsin.src
|
||||
lib/xcin/tsin_pin.map
|
||||
lib/xcin/voca.box
|
||||
lib/xcin/zmdbosh.cin
|
||||
lib/xcin/zmdbosh.tab
|
||||
lib/xcin/zmdbosh.tab.rev
|
||||
lib/xcin/zo.kbm
|
||||
lib/xcin/docs/Boshiamy.HOWTO
|
||||
lib/xcin/docs/README.xcin
|
||||
lib/xcin/docs/XCIN.client.doc
|
||||
lib/xcin/docs/Xfonts.HOWTO
|
||||
lib/xcin/docs/cin2tab.HOWTO
|
||||
lib/xcin/docs/xcin.HOWTO
|
||||
@dirrm lib/xcin/docs
|
||||
@dirrm lib/xcin
|
||||
|
|
Loading…
Reference in a new issue